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الرحمن الرحیم بسم اللہ  

 

PREFACE 

 

Experience as a computer instructor gives me lots of knowledge and 

confidence,and on the basis of which I have written this book for students, 

beginners, professionals and especially for computer instructors. I know there are many 

experienced people. I don’t claim to be a perfect writer.But on the basis of my experience I have 

learned that there is need of a book a type of syllabus or guide line for those people who are 

relatively new in this filed and also for those who  wants to polish their knowledge through a 

quick review,and I think this will fulfill all their needs. 

I have been teaching in private institutationsfor years, now I am in a position that can 

suggest the syllabus for new comers. I understand the needs of a user very well. Also I have done 

all the hard work to provide you the latest information related to computer soft and hardware 

inclusive.  

Thebook also includes assignments related to every topic, and also frequently asked questions at 

the end.  

This is totally a different style of writing a computer book. Because  

 If you are a new computer user this is the best for you and provides you the all basic information. 

 If you are already related to computer then this book will update your knowledge.  

If you are a student from high schoolto university,this is also good for you because this will 

strengthen your knowledge of computer in very easy language English and Urdu Simultaneously. 
 If you are a professional &want to manage official work this is very good for you to sit on a chair 

and just read this book and solution is always there using easy language from this book so just 

one click or one short key will solve your problem.  

 And if you are a computer instructor this is very good guide line for you to manage your 

syllabus/lecturesof different courses. 

So this is a complete syllabus for every one,and I think as for as computer users’are concern 

they must read this particular book in order to fulfill their requirements. 

Also I have included chapters of web and internet and I think if you try those tools for just 

one month and even in your homeyou will learnt a lot. 

The best thing about this book is that it has the languages Urdu and English, pictures and 

diagrams, tools and short keys, computer hardware problems & solutions etc. 

Any mistakes pointed by you will be highly appreciated.  

 

Thank you very much. 

Wish you exhilaration & ever-increasing life. 

 

 

 

MY 



4 

 

MOON CREATIONS SCHOOL OF INFORMATION TECHNOLOGY® 

IN A GLANCE 

 

 

Welcome to the Moon Creations School of Information Technology, a hallmark for quality IT 

education. We are living in the age of rapid progress where nothing is constant, except change. 

Only those who would gain excellence in the domain of knowledge will progress ahead. In this 

race for going forward, information technology is the key tool, which we must acquire to make 

our forward journey smooth and successful. 

 

We at MCSIT aim at offering the best IT education coping with the ever changing need of the 

market.  Providing excellent teaching in better environment is our main priority. Our certificate 

and diploma programs are designed to equip our students with the latest IT skills and enabling 

them to enter the world of opportunities with flying colors and capitalize the huge IT market. 

 

At MCSIT, we believe in providing practical education using our state-of-the-art labs, thus 

enabling our students to use their IT skills to meet challenges of the market. The goal of the 

School is to become recognized as one of the top Schools of the region. To this end, we are 

making sincere efforts for attracting the best and brightest students and faculty members from the 

entire spectrum of the population. We are proud of our commitment to student achievements and 

look forward to future success. 

 

I am confident that by offering latest IT programs/courses will go a long way to enhance the 

capabilities of our local community for realizing the cherished goal of self sufficiency in the vital 

field of information technology. 

 

We invite you to join us on the exciting frontier of IT knowledge and fresh practical solutions for 

a shining future. 

 

 

Administration MCSIT 
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AUTHOR’S COMMENTS 

 

The 8th of October 2005 was really a turning point for the people of Azad 

Kashmir & especially for the people of Capital city Muzaffarabad. It was such a 

great shock for the people of entire state, that we suffer great difficulties from 

this particular disaster. And that was at times when our city was absolutely 

destroyed. But Allah SubhanWaTahAllah gives His own mercy that provides us 

the basis that we are still in procession of life again. And the people of different 

regions have become the way for this avenue. We are real thankfull to all those. 

 

After this Disaster I had experience of working with different NGO’s that made me more 

professional and efficient in computer sciences. But the real credit goes to my teachers in NICR 

(National Institute of computer Research) that provided me such a wonderful basis of 

computer skills and professionalism. Also a great experience as an instructor from PICS(Prime 

Institute of computer Sciences), Al Furqan Welfare Association andMCSIT (Moon 

Creations). I thank to my teachers. Also thank to Allah Almighty who made these people a way 

for my education. And my parents that give me great care & kindness that I have become 

educational medium for others & of course they will become the way of my absolutism to Allah 

Almighty. 

 

Message for readers: 

Although the world is progressing very rapidly, but life has become tougher. Now your 

approach must be very positive towards life, that is your Life must be beneficial for others; 

because this is your first obligation for you, for your parents & teachers. My message for you is to 

make sure that your use of computer should beneficial for you, for your parents, for teachers who 

have work hard about you, for your friends & importantly for your society. 

This is very fast period of the world & as some people are saying that world has  become 

Global Village, now you can share your knowledge, sorrow, happiness, in real quick time. So 

make a right decision about your career and profession. Because now you have to face the real 

challenges (national & international). So make sure that you are doing your job as a student as a 

professional & more importantly as a Muslim. 

Please make your way in computer field, and work hard because in the future you have to 

become one of good programmer or an engineer of computer sciences. So work hard to find your 

destination. Because we are just a little touch short in this important field of new era. 

Being a Kashmiri nation we have to perform the real good manners that the other people 

of different regions must feel & realize our moral aspects. So as a student you have to perform 

this responsibility, because this will really help us to develop as a great nation on the map of the 

world.  
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Always think about your day & what are you doing for others. And what you have done 

for himsel for the day of decision, because we have to answer about our every job every facility 

that we have in this world. So make sure that you are doing your job as Muslim again.  

 

 

 

 

I Thank To ALLAH 

For Stitching Some Beautiful People ….. 

Into The Fabric of My Life….. 

Their Colourful Patterns….. 

And Personalities…… 

Add Richness….. 

To Who i am 

 

 

Dedicated to….. 

 

My parents & teachers 

Who give me much care and knowledge… 

My friends and students 

Who give me great company, respect and honour… 

And especially to my motherland 

 

 

 

 
 

 

MMuuhhaammmmaadd  NN@@vveeeedd  

CCeellll::  0033221166771188008844  

EE--mmaaiill::nnaavveeeedd5588@@hhoottmmaaiill..ccoomm  
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CHAPTER 1:        INTRODUCTION TO COMPUTER  
(FOR BEGINNERS) 

Introduction to Computer & Its Components 

 
What is Computer? 
Computer is an electronic machine which can automatically process the input data or instructions 
(in accordance to its program of instruction i.e. OS) & provides the results in a suitable form or 
according to your desires. 
Computer is an electronic machine which can be programmed to accept data (input or 
instructions) & process it into useful information (output). 

ک مشین

 

 جو ہے کمپیوٹر ا ی ک ا یسی ا لیکٹرا ی

 

ر ا ہم کرتی ہے  پرمخصوص پرو گرا م کی مدد  سے د ی گی ہدا ی ا ت
ف
 

 

ٹ
ل
 

 

 ر ر

 

 ی ا  .عمل کرنے کے بعد ا س کا ا ٓسا ن

 کے مطابق مختلف 

 

ک مشین ہے جو د ی گی ہدا ی ا ت

 

 کی جا سکتی ہے۔کو حل کرنے کے لیےپرو گرا مڈ   Quiresکمپیوٹر ا ی ک ا یسی ا لیکٹرا ی

 یل ی ا تیں پتہ چلتی ہیں۔

 

 د

 

 تعریف سے ہمیں د ر ج

 ۔ کمپیوٹر بجلی سے چلنے و ا لی مشین ہے۔۱

   Dull & dumb۔ کمپیوٹر ا ی ک ۲

 

ر ا ہم کرتی ہے۔ یہ ا ی ک خاص پر پرمشین ہے ۔ جو صرف د ی گی ہدا ی ا ت
ف
 

 

ٹ
ل
 

 

 ہے۔و عمل کرنے کے بعد ر ر

 

  کی محتاج

 

 گرا م ی ا  کود

 :Input ہلائیں گی۔ا ٓت  کی طرف سے د ی
ک
 

 

 ٹ
پ
 

 

 ا ن

 

 گی ہدا ی ا ت

 :Output 

 

  پرکمپیوٹر ہدا ی ا ت

 

 ٹ
پ
 

 

 د ے گا و ہ ا وٓ ت

 

ہلاتی ہیںعمل کرنے کے بعد جو معلومات
ک

 ۔

 ا ی  

 

 د

 

 گرا م کی مدد  سے کمپیوٹر کی تعریف یون کریں گے۔ا ہم ا ی ک ا ٓسا ن

 
 
HISTORY OF COMPUTER 

 کر کر ر ہے  کا  حیط  ہے ہم ہاںن یدہہ یدہہتے ہوئے ا ی ک طویل عرصہ لگا ہے جو مختلف ا د و ا ر  پرکمپیوٹر کی موجود ہ شکل جو ا ٓت  کے سا منے ہے ا س کو ا س فار م میں ا ٓ

 

د

 ہیں

ا می مشین سے ہوئی جو چین میں  ABACUS۔ کمپیوٹر کی ا بتدا  1

 

 میں بنائی گئی۔ B.C 066 ی

۔ 2

 

ئ

گ

 ا و ر  و سا ئل کے سا تھ سا تھ ترقی ہوتی 

 

سا نی ضرو ر ی ا ت

 

ن
 ل  1011۔ ا س کے بعد کمپیوٹر میں و قتا فوقتاً ا 

ی
ا ر یخ میں د و سری قا

 

 ر  نے کمپیوٹر کی ی
 پ ی
ی

 

ی

 

 

میں سر جون

ا م 

 

 کر مشین بنائی جس کا ی

 

 ر کھا گیا۔  Napier Bonesد

ا م  Mechanical Compute۔ ا نیسویں صدی میں پہلا 3

 

  Charles Babbageتھا ا و ر  بنانے و ا لے تھےDifferential Engineبنا ۔ ا س کا ی

 

 ر ن

 

 کو ماد

 

ا ن

ا  ہے۔

 

ا  جای

 

 یجیٹل کمپیوٹر کا فاد ر  مای

 

 د

 ر کھا گیا۔ یہ سا   Howard Aiken میں 1336۔ پہلا بجلی سے چلنے و ا لا کمپیوٹر  4

 

ا م مار ک و ن

 

 نے بنای ا  ۔ا س کا ی

 

ز

 

پ
 ا  تھا ا س نے 

 

ز
پ 
 میں بہت 

 

 1341ا و ر  جسامت

ا م شکل ا ختیا ر  کی۔ مکملمیں 

 

 د نیا میں ست  سے تیز ر فتار  کمپیوٹر کا ی

 

ٹ
ق
 (2663کمپنی نے بنای ا  ہے۔) IBMہے ا و ر  یہ  Road Runnerا س و 
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 ہے؟

 

 کن شعبون میں کمپیوٹر کی ضرو ر ت

 ر  شعبہ
ہ
 ند گی کے تقریباً تمام شعبون میں کمپیوٹر کا ا طلاق ہو چکا ہے۔ یہی و جہ  ہے کہ 

 

 کے ترقی ی ا فتہ د و ر  میں ر

 

 ند گی سے علق  ر ھنے  و ا لا ا س کی طرف ر ا ب ا ٓج

 

 ر

 

 

 و ٹر  ا ن
 ی
می
 ہک
چ

 

ن

 سے بہت ا ہم کرد ا ر  ا د ا  کر ر ہا ہے۔ تمامہے۔ چنا

 

 ر  لحاظ
ہ
 شعبون میں 

 

 

 و غیرہ۔ا   ,صنعت و  تجار ت

 

 ر ا عت

 

 سٹری ، فزکس ، کیمسٹری ، ی ا یو، ر

 

ڈ

 

 گوئی و غیرہ۔ تعلیم سٹم۔ئنلائیرا ی

 

ن

 

 ش
ی ی

 گار  کا حصول۔موسمی 

 

 و  ر و ر

 
سک
ے ہیں کہ :چنانچہ ہم کہہ 

 

ی
 

Computer performs speed, consistency, precision, reliability & efficiency at the same time.  

  

 

ل ا عتماد  ا و ر  ی ا صلاحی ت
 
ی
ا  ہے ۔ یعنی سپیڈ، مسلسل کام، مختصر ا و ر  جامع، قا

 

 میں کری

 

ٹ
ق
 ۔کمپیوٹر ا س لیے ا ہم ہے کہ یہ بہت سا ر ے کام ا ی ک و 

 کیسے 

 

ا  ہے؟کمپیوٹر ہمار ی ی ا ت

 

 سمجھتا ہے ا و ر  حل کری

 لینے کے بعد ا س پر عمل کر کہ ہمار ے مسائل کو حل کر د یتا ہے ۔ لیکن یہ کام ا س لیے

 

ا  ہے کہ ہمار ی ہم جانتے ہیں کہ کمپیوٹر ا ی ک ا یسی مشین ہے جوہدا ی ا ت

 

 کری

  ا ستعمال کیے جاتے 

 

  ر

 

 کو سمجھنے ا و ر  حل کرنے کے لیے ا س میں کچھ خاص پرو گرا م ی ا  کود

 

 ہیں۔ہدا ی ا ت

ا  ہے جس کی بنیاد 

 

 کا مجموعہ جو کمپیوٹر سمجھ سکتا ہے۔ ا یسا پرو گرا م جو بنیاد ی طور  پر کمپیوٹر کو د ی ا  جای

 

پر و ہ بعد میں ہمار ے مسائل کو حل  پرو گرا م سے مرا د  ہے ہدا ی ا ت

و یج کا لفظ  ا ستعمال 
گ

 

 پ
لی

ا  ہے جس کے لیے کمپیوٹر پرگرا منگ 

 

ا  ہے ا س کو کمپیوٹر پرو گرا م کہا جای

 

 کرتے ہیں ۔ کری

و یج 
گ

 

 پ
لی

 کو  کمپیوٹر پرگرا منگ 

 

ا  ہے۔بنیاد ی پرو گرا م لکھنے کے لیے کچھ مخصوص پرو گرا م ا ستعمال ہوتے ہیں جن میں ا پنا پرو گرا م لکھتے ہیں ا ن

 

 کہا جای

و یج
گ

 

 پ
لی

 ا س کی تعریف یون کی جاتی ہے۔: کمپیوٹر پرگرا منگ 

 ر  ا و ر  کمپیوٹر کے د 

 

 کر "و ہ پہلا بنیاد ی پرو گرا م جو ا ی ک یور

 

ی ت  ح 

 

ل بنائے کہ ا تٓ  کمپیوٹر سے ی ا ت
 
ی
ا  ہے۔جو ا تٓ  کو ا س قا

 

 ر ا بطہ قائم کرنے کے لیے ا ستعمال ہوی

 

ر میان

 بھی حاصل کر سکیں۔

 

ٹ
ل
 

 

ک پہنچا سکیں ا و ر  بعد میں ر ر

 

 ا س ی

 

 سکیں ا و ر  ا پنی ہدا ی ا ت

و یج کی د و  ا قسام ہیں۔
گ

 

 پ
لی

 کمپیوٹر پرگرا منگ 

Low level & High Level Languages 

LOW  

 

ز
ج 
 
ن

و 
گ

 

 پ
لی

 :لیول 

  ہیں جو 

 

 ر

 

 مشین کود

 

 ی ا ن

 

 ی ا  د ر کھیں کہ کمپیوٹر کی بنیاد ی ر

 

 ر   1 ,0ا ی ک ا ہم ی ا ت
ہ
و یج میں ہمیں 

گ

 

 پ
لی

  میں لیتا ہے ۔ لو لیول 

 

 کو ا س کود

 

 ٹ
پ
 ر  ہدا 
ہ
ہیں۔ کمپیوٹر ہمار ی 

  میں کام

 

ز
ج 
 
ن

و 
گ

 

 پ
لی

 

 

 میں د ینا ہوتی ہیں جو خاصا مشکل کام ہے ا س لیے ا ن

 

  کی صور  ت

 

 ر

 

 ا نہی کود

 

 میں  ہدا ی ا ت

 

ا  ہے۔ ا ن

 

 :بہت کم کیا جای

1: Machine Language: 
2. Assembly Language: 

 :۔

 

ز
ج 
 
ن

و 
گ

 

 پ
لی

 ہائی لیول 

 کمپیوٹر کو د ینا ا یسے ہی ہو جیسے ا ی ک د و سرے سے

 

ر یب ہو ا و ر  جس میں ہدا ی ا ت
ق
 ی  کے 

 

ز
پ 
لا ا نگر

 

 مپ

 

 ی ا ن

 

سا نی ر

 

ن
و یج جو ا 

گ

 

 پ
لی

ا  ا و ر  ا پنے  ا یسی پرو گرا منگ 

 

 کری

 

 ح ی ت

 

ی ا ت

 کا 

 

 میں :خیالات

 

ا ۔ا ن

 

 ا ظہار  کری

FORTRAN: Formula Translation: It is used for mathematical problems solving. 
BASIC (Beginner’s all Purpose Symbolic Instruction Code) 
COBOL (Common Business Oriented Language) 
C and C++ Visual Basic and V.B.net and PASCAL, JAVA 

 

 کو کیسے سمجھ لیتا ہے ا س کے لیے ہائی لیول  ہم جانتے

 

 ی میں لکھی گی ہدا ی ا ت

 

ز
پ 
  کو جانتا ہے تو پھر یہ ہمار ی ا نگر

 

 ر

 

و یج میں ا ی ک ہیں کہ کمپیوٹر صرف مشین کود
گ

 

 پ
لی

 

 

 ل عمل بنا ی
ی
ا  ہے ا و ر کمپیوٹر کے قا

 

و یج  میں تبدیل کری
گ

 

 پ
لی

 کو مشین 

 

 ی کی ہدا ی ا ت

 

ز
پ 
ا  ہے جو ہمار ی ا نگر

 

ر  موجود  ہوی

 

پ ی
سل

 

ن

 ا  ہے۔ٹرا 

Main Components of computer 
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System Unit/CPU (Central Processing Unit) 

ا  ا سی کا کام ہے

 

ر ا ہم کری
ف

 

لی
 

 

 پر عمل کرنے کے بعد ر ر

 

 میں ا صل کمپیوٹر یہی ہے۔ ا ٓت  کی ہدا ی ا ت

 

 ی ا د ہ یہ کمپیوٹر کا ست  ا ہم جزو  ہے د و سرے ا لفاظ

 

ن ر
 
کلی

 

س

۔ ا س کی د و  

 د یکھنے میں ا ٓتی ہیں۔

1. Desktop Shape    2. Tower Shape 
Monitor 

 

 

 ٹ
پ
 

 

  یہ ا وٓ ت

 

ش
م

 یوا ئس ہے جس سے ا ٓت  حل شدہ موا د  کو سکرین پر د یکھتے ہیں۔ا س میں ج ڈ  ی ڈ  

 

 د

 

ر

 

پ ی
 ی ا د ہ  

 

 ی ا و ر  ٹی ا یف ٹی جو ر

 

 Slim andا ٓ چکی ہیں جیسے ا یل سی د

Smart ۔ا س کے علاہ ہیںTouch Screen   مانیٹر 

 

 بھی مار کیٹ میں ا ٓ چکے ہیں۔ر

Keyboard 

 یوا ئس ہے۔

 

 د

 

 ٹ
پ
 

 

ر ا ہم کرتے ہیں۔یہ ا ن
ف
 کمپیوٹر کو 

 

  کی مدد  سے  ا ٓت  ا پنی ہدا ی ا ت

 

 کی بور د

ا مل ہیں

 

 یٹنگ کیز، نیومیرک کیز س

 

ل کیز، ا ی لفا  نیومیرک کیز، ا ی ڈ

 

پ

 

ش
ک

 

فپ

  میں  چار  قسم کی کیز ی ا ئی جاتی ہیں۔ جن میں 

 

 ۔کی بور د

Mouse 

  بھی 

 

ر
س

 

ن

 یوا 

 

 د

 

 کو پوا ئنٹ ا ن

 

 یوا ئس ہے۔ا ن

 

 د

 

 ٹ
پ
 

 

ا  ہے۔یہ بھی ا ن

 

 کہا جای

 
Types of Computers 

ا 

 

 ے ی

 

ز
پ 
 بنیاد ی طور  پر کمپیوٹر کے تین 

پ 

 

پ

س ہیں۔

ی 

 

1. Digital Computer 

ا  ہے۔ ہمار  ے ہان ا ستعمال ہونے و ا لے کمپیوٹر ا س قسم میں ا تٓے ہیں۔ا س کی عا (0,1)ا یسے کمپیوٹر جو 

 

 سمجھتے ہیں۔ یہ ست  سے ی ا و ر  فل کمپیوٹر سمجھا جای

 

 ی ا ن

 

م کی ر

ا ل 

 

 جو ا ٓت  کے سا منے موجود  ہے۔ہیں۔ Personal Computerمپ

2. Analog Computer 

ا ل  

 

 کی بنیاد  پر کام کرتے ہیں ا س کی مپ

 

ٹ

 

پ
 ا و ر  کر

 

ج

ی 

 

لی

پمپ پر  پٹرو ل ی ا ۔ہےBilling Machineکمپیوٹر کی یہ قسم مخصو ص مقاصد کے لیے ا ستعمال ہوتی ہے۔ یہ و و 

 

 

ر

 

پ ی

 

ش
م

 ۔لگی 

3. Hybrid Computer 

ی د و نون 

 ہل
ن

لائی تحقیق و غیرہ میں ا ستعمال ہوتے ہیں۔یہ 

 

 ر کھتے ہیں۔ یہ ج

 

 د و نون کی ملی جلی صلاحی ت

 

 ا قسام سے ی ا و ر  فل ہیں چونکہ یہ ا ن

  کی بہت سیدو سری  ا قسام بھی  ہیں ہمار ے ہان ا ستعمال ہونے  و ا لی قسم کو 

 

 ہن میں ر کھیں کہ کمپیوٹر ر

 

 د

 

ا  ہے۔Personal Computer (PC)ا ی ک ی ا ت

 

 کہا جای

 
Personal Computer: 
A small single user computer based on a microprocessor has keyboard for data entry and 
monitor, has storage devices. They appeared in 1981. Made by IBM. 

I) Tower  II) Desktop 

 ر  کام کر سکتا ہے ا س کو پی سی 

 

 میں ا ی ک یور

 

ٹ
ق
 پر ا یسا کمپیوٹر جس پر ا ی ک و 

 

 یوا ئس  ہے جو ا تٓ  کی ہدا ی ا ت

 

ا  ہے۔ ا س میں ا ی ک پرو سیسر یعنی عمل کرنے و ا لی د

 

کہا جای

ا  ہے۔ یہ 

 

ر ا ہم کری
ف
 

 

ٹ
ل
 

 

ا  ہے ا و ر  پھر مین میمور ی کی مدد  سے ا ٓت  کو سکرین پر ر ر

 

ی مرتبہ متعار  ف کرو ا ی ا   1311عمل کرنے کے بعد ا  س کو حل کری

 ہل
ن

میں 

 

 

ا ت  ا ینڈ ی

 

 سک ی

 

 ا و ر ۔گیا۔ا س کی د و  ا قسام ہیں۔د

Hardware: 
All the physical components of computer are called hardware.CPU, Monitor, Keyboard, Mouse 
etc. 

ا مل ہیں۔

 

و س و غیرہ س

 

ن
  ا و ر  ما

 

، کی بور د

 

ٹ

 

پ
ہلاتے ہیں۔ جن میں مانیٹر، سٹم یو

ک
  و ئیر 

 

 کمپیوٹر کے تما م ا جزا ء ہار د

Software: 
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It is a set of an instruction that computer can understand & provides suitable results. i.e. the 
visual effects are called software. OS are examples of software. Different OS are DOS, windows, 
Linux, OS/2, etc.  

 کا ا یسا مجموعہ جس کو کمپیوٹر سمجھ سکتا

 

ے ہیں ۔ ا صل میں سا ٹ  و ئیر سے مرا د  ہدا ی ا ت

 

سکی
ا  ہے۔ ا س کو ا ٓت  سا ٹ  و ئیر بھی کہہ 

 

 ہے ا س کو کمپیوٹر پرو گرا م کہا جا ی

 ی ا قسا م ہیں۔

 

ز
پ 
 ہیں جن کو  پڑھا جا سکتا ہے۔سا ٹ  و ئیر کی د و   

 

 سکرین پر د کھائی د ینے و ا لے ا ثرا ت

1.System Software 

 ر  کے

 

بغیر کمپیوٹر پر کام ہیں  کیا جا سکتا ی ا  جو کمپیوٹر کے لیےضرو ر ی  کےہیں جن  ئیر لیے کمپیوٹر کار  ا ٓمد ہیں  و ہ سٹم وفٹ  و ا یسے تما م پرو گرا م جن کے بغیر ا ی ک یور

ا ل  ہیں۔

 

 Operating System (OS)جس کی مپ

2. Applications software 

 ر  ی ا  کمپیوٹر پر کام کرنے و ا لا ا پنی مخصوص 

 

ا  ہے۔ ا س کی ا یسے تما م پرو گرا م جو ا ی ک یور

 

 ا ینگ ی ا  کسی ا و ر  کام کے کرنے کے لیے ا ستعمال کری

 

ز
پ 
 

 

گ، د

 

 ی

 

لا ، کمپور

 

مقاصد مپ

گ ٹیوٹر، ا یم ا یس ا ٓفس ہے۔

 

 پ
پ ی

 

پ
ا 

 

ا ل ا ٓت  کا ی

 

 مپ

Introduction to Operating System (OS): 
An operating system is system software that provides an interface for the user to communicate 
with the computer in well define manner, and to find suitable solutions. The purpose of the OS is 
to organize and control hardware and software in a link. 

 یہ مین پرو گرا م ی ا  ا پٓر یٹنگ سٹم کیا ہے؟ 

 ر  کو ا ی ک ا یسا ماحول ی ا  ا نٹر فیس 

 

 لے سکتا ہے و ہ  پرو گرا م جو ا ی ک یور

 

ٹ
ل
 

 

 ر ر

 

ک پہنچانے کے بعد ا س سے ا سٓا ن

 

 کمپیوٹر ی

 

 ر  ا پنی ہدا ی ا ت

 

ا  ہے جس کی بنا ء پر یور

 

ر ا ہم کری
ف

  و ئیرا و ر  سا ٹ  و ئیر

 

ا  ہے۔ ا صل میں ا س کی مدد  سے ہار د

 

ا  ہے ۔ سمجھ لیں کہ ا س مشین کے ا ندر  ر و ج کا کام کری

 

ا  ہے ا س کو ا پٓر یٹنگ سٹم کہا جای

 

 کا علق  بنا د ی ا  جا ی

 د و نون سے ا ستفاد ہ کر سکتا ہے۔ا و ر  

 

 ر  ا ن

 

 یور

Types of OS: 
 
GUI (Graphical User Interface) OS i.e. Windows 

 د یتے ہیں یعنی جن کو ر نگون ا و ر  سکرینون کی مد د  سے د یکھا جاسکتا ہے ۔ جیسے ا تٓ  کا

 

ٹ
ل
ل ا نٹر فیس کی سہو

فی ک

  ا یسے ا پٓریٹنگ سٹم جو گرا 

 

 و ر

 

ڈ

 

  XP و ی
Command Line OS i.e. DOS (Disc Osperating System) 

  کی مدد  سے کام کیا جا سکتا ہے ۔ جیسے 

 

 ر

 

ڈ

 

 DOS (Disc OS)ا یسے ا پٓریٹنگ سٹم جن کے ا ندر  مخصوص کمای

Computer BIOS (Basic Input Output system) 

 کرنے کے بعد جو پہلا پرو گرا م ا تٓ  سکرین پر د یکھیں گے یہ ی ا ئی ا و س ہے ۔ یہ کمپیوٹر

 

ا  ہے ا س کا  ی ا  ا ٓئی سیROM کے ا ندر  ا ی ک خاص  کمپیوٹر کو ا نٓ

 

ا ل ہوی

 

شپ

 

ن
میں ا 

  د ے۔یعنی ا س کا مقصد کمپیوٹر

 

ڈ

 

 پ ک کرنے کے بعد و ر کنگ کے لیے کمای
ح
س کو 

 

ی

 

 پ
ی

 

ی

ل کمپو

 

پ

 

ش
ک

 

فپ

 کے ا ندر  لگے مقصد یہ ہے کہ کمپیوٹر کے ا ندر  لگے ہوئے مختلف 

ا   ہے۔ ا و ر  کسی 

 

 کر کہ و ر کنگ میں لای

 

ت

 

س کو  شناح

 

ی

 

 پ
ی

 

ی

 د ینا ہے۔ ہوئے کمپو

 

 میں سکرین پر معلومات

 

 میں پرا بلم کی صور ت

 

ت

 

 ی
ی

 

ی
 کمپو

ا  ہے۔یعنی  مسائلکمپیوٹر کے ا ندر  بہت سا ر ے 

 

 بھی ست  سے پہلے یہی پرو گرا م کری

 

ے ہیں۔ ا ٓت  کے ا پٓریٹنگ سٹم کی پہچان

 

سکی
ا سی پرو گرا م کی مدد  سے حل کیے جا 

ا  ہے۔ 

 

  کو و ر کنگ میں لای

 

ر
 س
ن

 یوا 

 

 د

 

 بوت

 

 
سک
 مختصرا  ً ہم کہہ 

 

 میں کام کری

 

 ی ا د ہ ا ہمیت ہے کسی کمپیوٹر میں ا س پرو گرا م میں خرا بی کی صور ت

 

ے ہیں کہ کسی بھی کمپیوٹر میں ی ا ئی ا و س پرو گرا م کی بہت ر

 

ی
ا ممکن 

 

ا  ی

ے ہیں ۔یعنی تیار ی کا عمل ۔  Booting Process ہے۔ا س کو ا تٓ  

 

سکی
 کہتے 

 

 ا ستعما ل ہوتی ہے؟  Space کمپیوٹر میں  

 

ٹ

 

پ
 سے ا کائی ی ا  یو

 

 کی پیمائش کے لیے  کون
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ٹ

 

پ
 ر  کمپیوٹر یو BITکمپیوٹر کا یو

ہ
 یوا ئس سے د و سری میں بھیجتا ہے۔ٹیبل د یکھیں۔ا و ر  

 

 کو ا ی ک د

 

 ی ا  معلومات

 

ا  سا  ٹکڑا  ہے جو ہدا ی ا ت

 

 کا ا ی ک چھوی

 

 ر  ہے۔ یہ معلومات

 

ر

 ا س کو ی ا د  ر کھے۔

Bit. (Binary Digits) 
It is a unit of computer. i.e.  
8bits=1byte implies 16bit= 2bytes(2 characters or space or symbols) 
1byte=1character. A symbol or space 
1024 bytes=1KB 
1024KB=1MB 
1024 Mb = 1 GB 
1024GB = 1 TB 

 یوا   مین کمپیوٹر کے ا ندر  

 

 سی ہے؟ئسسٹور یج د

 

  کون

 کو ا س مشین میں 

 

  مختلف ا قسام کی حامل ہے ۔ا ٓت  کی معلومات

 

ز

 

پ
 سک ۔ یہ ٹیکنالوجی و ا 

 

  د

 

 یوا ئس ہے ہار د

 

 ر ھنے  و ا لی د

 

 ,HDD, IDE,EIDEجس میں  سیو ی ا  محفوظ

SATA, ATA, PATA    میں ہے ا و ر  

 

ز

 

پ
س  سا 

سک

 

 

  د

 

 مار کیٹ میں موجود  ہیں۔ (10GB to 500 GB)مختلف ہار د

Desktop 

  ہونے کے بعد  مانیٹر

 

  لود

 

 و ر

 

ڈ

 

 ہوتے ہیں۔کمپیوٹر کی و ہ سکرین جو و ی

 

 یا ی ا  ا ٓن ہن

 

ا ر ت

 

  کے س

 

ر
ک
  پر می میں آتا ٓتی ہے جس پر مختلف پرو گرا 

ا  کیا ہو   Pentiumیہ  

 

 ؟ P3 , P4ہے پھر ا سی طرج ی

 کے بعد ا س فار م میں ا ئٓی ہے۔ تو مختلف

 

 سے ہم جانتے ہیں کہ کمپیوٹر کی موجود ہ شکل جو ہمار ے سا منےہے ا ی ک طویل ر یسرج

 

 کے لحاظ

 

 ٹ
پ
 

 

 ا د و ا ر  میں سپیڈ ا و ر  ا وٓ ت

 کی یہ مختلفا س کو 

 

 ہن میں ر کھیں کہ ا س کی ر فتار  ی ا  صلاحی ت

 

 د

 

ا  ہے۔ ا صل ی ا ت

 

 ر  کری
ہ
ا 

 

 میں ا ضافے کو ط

 

  ا و ر  صلاحی ت

 

 پ ڈ
پ ی
س
ا م ا س کی 

 

 ر  نیا ی
ہ
ا م د یے گے ۔ 

 

 ی

ا م کی ہے۔ ا س لیے چوتھی جنریشن میں جہان کمپیوٹر کی پرفار منس  CPUخصوصیت پرو سیسر ی ا  

 

 میں بہت سا ر ی تبدلیاںن ا ٓئیں ۔ ا س د عہ  ا س کے لیے ا ی ک نیا ی

یعنی ۔  Core & Dueا و ر    Dual Coreا سی طرج ا ت  پی فور  کے بعد . P1, P2, P3, P4ہے ا و ر  ا س طرج ترقی کے سا تھ سا تھ   Pentiumبھی ر کھا گیا جو 

 ل پرو سیسنگ ٹیکنالوجی
ی
 

 

 بھی مار کیٹ میں ا ٓ چکی ہیں۔ د

 
Speed Technology 

166 to 266 MHZ P1 

266 to 450 MHZ P2 

450 to 1200 MHZ (1.2GHZ) P3 

1.3 GHZ to 3.6 GHZ P4 

1.7 GHZ core to due and dual core & so on. Core & DUE 

 
What is RAM (Random Access Memory? 

 پٹس کو عار ضی طور  

 

 ی ا  ا ن

 

ا  ہے۔ پر کنٹرو ل کرتی ہے ا س کو ر یم کہاکمپیوٹر کی عار ضی میمور ی جو ہمار ی ہدا ی ا ت

 

ا  ہے سپیڈ میں ا س کا بہت کرد ا ر  ہوی

 

 ,MB 64جای

128 MB, 256 MB, 512 MB, 1 GB, 2 GB, 4 GB etc. 

 طریقے کیا ہیں؟مختلف کمپیوٹر کو ا فٓ کرنے کے 

Star – Turn off (Shut down) –Turn off (Shut down) 
or Alt +F4+U 

 ا فٓ میں

 

ر ق ہے؟ لاگ ا فٓ ا و ر  ٹرن
ف
 کیا 

ا   پڑ

 

 ہیں  کری

 

 میں ہے یعنی د و ی ا ر ہ کام کرنے کے لیے ا ٓت  کو د و ی ا ر ہ شرو ع سے سٹار ت

 

ٹ
ل
 لا گ ا ٓف سے مرا د  ہے کہ ا ٓت  کا کمپیوٹر و ر کنگ حا

 

ٹ
ل
ے گا بلکہ ا س حا

 

 

ا ر ت

 

 ا ٓف سے مرا د  Win logo+Lکی  میں صرف و ہ وف ر ہا ہے ا ٓت  ا ئٓیں ا و ر  ا س کی کی پریس کریں ا و ر  ا پنا کام شرو ع کر د یں لاگ ا ٓ ف کرنے کی س

 

ہے ۔جبکہ ٹرن

 ۔کمپیوٹر کو مکمل طور  پر بند کر د ینا ہے
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 سا  ہے ا و ر  ا س کی پرو سیسنگ سپیڈ ا و ر  ر یم کتنی ہے؟

 

 پ ک کریں کہ یہ کون
ح
 ہم ا پنے کمپیوٹر کو کیسے 

ا ت  پر موجود  

 

 سک ی

 

  سے Propertiesپر ماو س کا د ا ی ا ن کلک کریں۔ ا و ر  ا س کی    My Computerا پنے کمپیوٹر کے د

 

 د یکھ لیں ۔ی ا  کی بور د

WIN logo + Pause Breakلکھیں  

 

ڈ

 

 میں جا کر یہ کمای

 

 ر ن

 

 DXDIAGی ا  پھر سٹار ت

ا سک ی ا ر  کیا ہوتی ہے؟

 

 ی

ا  ہے۔ Startپر   جسی ا ٹم میں آت ا نٓے و ا لی ی ا ر   میں ی ا لکل  ینسکرکمپیوٹر 

 

ا سک ی ا ر  کہا جای

 

ا  ہے ا س کو ی

 

 لکھا ہوی

  کرنے کے بعد کیا کھلتا ہے؟ ئیما

 

ز ا و ر
پ 
 کمپیوٹر کو 

 سک کی سٹور 

 

  د

 

ے ہیں۔ ا و ر  ہار د

 

سکی
ے ہیں ا و ر  ا س میں ر کھا گیا تمام موا د  ا ستعمال بھی کر 

 

سکی
  ی ا  ی ا ر ٹیشنز د یکھ 

 

 ر ا یور

 

 کمپیوٹر کی تما م د

 

ا ر ت

 

ے ہیں۔ا س کی س

 

سکی
یج بھی د یکھ 

 ۔ہےWin log+Eکی 

 

 

ا  ت  کی خصوصیات

 

 یسک ی

 

 کریں؟د

 

 بیان

  کےماو س د ا 

 

 و ر

 

ڈ

 

ل مطالعہ کریں ۔جس میں و ی
ی ک

 

ی کی

 کا پر

 

ا ت  بدلنا، سکرین  ی ا ن کلک کرنے پر ہمیں جو بہت سا ر ے ا پٓشنز ملیں گے ا ن

 

 یسک ی

 

، د

 

ٹ

 

پ
تھیم ،  می، فا

  و غیرہ د یکھیں ۔یضوسیور ، سکرین ر 

 

ز
گ

 

پ

 

ی پ 
س

 لیشن،، 

 کو ا لاا س کے علاو ہ ماو س کے ا سی کلک میں د و سرے ٹولز کو بھی ہم د یکھتے ہیں۔ جس میں نیو، ا یٓکا

 

 ئنن

 

ا مل ہے پھر ر

 

ا  و غیرہ س

 

   کری
پ

ا  بھی ا ہم ہے۔یہ 

 

ٹ  فولڈر  بنای

 ر ہے۔

 

 یٹا محفوظ

 

ا  کہ ا ٓت  کا د

 

ے ہیں ی

 

سکی
  لگا 

 

 Compressed Zipمیں ا خٓری ا ٓپشن  Newا س کے لیے ا تٓ  ماو س د ا ی ا ن کلک  پھر و ہ فولڈر  ہے جس پر ا ٓت  ی ا س و ر د

Folder   ھلا ر کھنا ہے ا و ر

ک

 یٹا ا س میں کاپی کریں ا و ر  فائل میں جا کر فولڈ ر  کو 

 

کر د یں ۔د و   Add a Passwordکا ا نتخات  کریں ۔ فولڈ ر  لینے کےبعد ا پنا مطلوبہ د

ا  پڑے گا ۔

 

 کری

 

 ٹ
پ
 

 

  ا ت  د

 

 میں ا ٓت  کو د و ی ا ر ہ ی ا س و ر د

 

 ی ا ر ہ نیو فائل کی صور ت

 کریں؟

 

 بیان

 

ا سک ی ا ر  کی خصوصیات

 

 ی

ا سک ی ا ر  پر کلک

 

ا سک ینیجر  کی مدد  سے ا تٓ  کمپیوٹر کا ی

 

 ی ڈ  ا پٓشنز ہیں ۔ی

 

ر
ک
ا سک ینیجر  ا سی ی ا ر  سے تعلقہ  

 

پ ک کر Status کرنے سے ا نٓے و ا لے ٹولز ۔جس میں ی  
ح

 کتنی پرو سینگ ہو ر ہی ہے و غیرہ۔  

 

ٹ
ق
ے ہیں کہ ا س و 

 

سکی
 

 ر ا یو کے ی ا ر  ے میں ا تٓ  کیا جانتے ہیں؟

 

 ی ر و م د

 

 سی د

 ی ر و م 

 

 ر ا یو  سی د

 

 د

 

 ی   External Storage ہے جو ہمار ی ئسیوا ا ی ک ا یسی د

 

 ی و ی د

 

  کرنے کے لیے ا ستعما ل ہوتی ہے۔ ا س کے علاو ہ د

 

لانے ی ا  ر ی ڈ
 ی کو ج 

 

یعنی سی د

 ی ر ا ئیٹر  کو  ا و ر  کمبو 

 

 ی و ی د

 

  د و نو ن کام کر Supperبھی ا ستعما ل ہوتی ہیں د

 

ی ت

 

 ی کو ج لانے ا و ر  ر ا پ

 

 ی و ی د

 

 ی ، د

 

ا  ہے ۔ کیونکہ ا س میں سی د

 

 ر ا یو کہا جای

 

نے کی د

ن ہوتی ہیں۔

 

پ ی
ح

 صلا

ا سک ی ا ر  میں د ا  

 

ا ئم، و ا یم،، و غیرہ۔ئیںی

 

لًا ی

 

س
م
ٹ  آت ا نٓے و ا لے ٹولز 

 

پ
  جا

ا مل ہے۔

 

ا  س

 

پ ک کری  
ح
ا ، و ا یم، کی پرا پرٹیز 

 

 کری

 

ا ئم د ر ست

 

 ا ینڈ ی

 

 ٹ
پ
 

 

 ا س میں د

 کریں؟

 

  کی پرا پرٹیز بیان

 

 ر ا یور

 

 مائی کمپیوٹر میں کھلنے و ا لی د

 کلک کر کہ ا س 

 

 ٹ
پ
 ر ا یو پر ر ا 

 

 سک کلین ا ت  و غیرہ۔کسی بھی د

 

 ر ا یو کا سپیس، د

 

 پ ک کریں۔جس میں د
ح
  کو 

 

 می کی پرا پرٹیز میں جائیں ا و ر  مینور

 

 ا س کے علاہ کچھ لار

ا  جس میں ست  سے پہلے 

 

  پر کام کری

 

ر
ک
ا سک ی ا ر  میں ا ٓل پرو گرا 

 

 می ہیں۔  Accessoriesی

 

 ر یس ی ک و غیرہ لار

 

 پیڈ، ا ی ڈ

 

  پیڈ، نوت

 

ا  ہے۔ا س   میں پینٹ، و ر د

 

  شرو ع کری

 

ر
ک
ل کی پرو گرا 

 

 پ
ی ی

کنٹرو ل 

ا ۔کمپیوٹر 

 

 کو ج لای

 

  کے مختلف فار میٹس ا و ر  ا ن

 

 ا و ر ا ہم ٹولز کو د یکھنا ہے۔تصاو یر ا و ر  ا ٓو ا ر

 

 پیج    Application Packageخصوصیات

 

ل، ی ا و ر  پوا ئنٹ( ا ر د و  ا و ر  ا نگلش ، ا ر د و  ا ن
س
ی ک

 ، ا 

 

ا یم ا یس ا ٓفس)و ر د

  

 

 و ر

 

ڈ

 

 کٹس، ا فٓس ا و ر  و ی

 

ا ر ت

 

  موو  و غیرہ۔ ا و ر  و غیرہ۔کمپیوٹر س

 

 و  ر

 

ڈ

 

ز  کا و ی
پ ک
م

 ا ستعمال بھی۔ ی 

  کیلئے

 

 ر ر

 

س بنیاد ی طور  پر نیو یور
پ ی 
سل

ہے۔ یہ   

CHAPTER 2:        INTRODUCTION TO COMPUTER  

(FOR PROFESSIONALS) 
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LECTURE-1 

 
Computer word comes from the word compute which means to calculate. 
 
1. A computer is an electronic machine, which can automatically process the input data 

(personal instructions, in accordance to its program of instructionsOS (i.e. windows) 
install in the computer, and provides the results in a simple way or in an acceptable manner.  

2. It responds to a specific set of instructions in a well defined manner.  
3. It can execute a prerecorded list of instructions (programs).  
4. A computer is an electronic machine which process instructions or data to give desirable 

result. 

۔ فنکشنز :چنانچہ

 

 ٹ
پ
 

 

، پرو سیسنگ، سٹور یج، ا ٓو ت

 

 ٹ
پ
 

 

ا  ہے۔ا ن

 

 کمپیوٹر ہمیں یہ فنکشنز پرو ا ئیڈ کری

Evolution of computer 

 In 600 B.C china invented the first calculation machine called Abacus (Soroban). 

 In 1617 A Scottish mathematicians Sir John Napier invented the second good calculation 
machine called Napier Bones. 

 In 1642, a French mathematician Blaise Pascal invented another calculation machine 
that is called PASCAL’s calculator. It contains the no. system 0 to 9. 

 In 1671 another calculation machine was invented by a German mathematician 
GottfriedLeibnitz. that was capable of multiplying and sub. 

 In the 19th century the first mechanical computer was designed, and invented by Charles 
Babbage, called Differential engine. Charles Babbage is considered the father of modern 
digital computers 

 The first electrical computer was invented in 1930 by Howard Aiken, called Mark1.It was 
very big in size. Having 80 kilometers long wring. It got proper shape and size in 1948. 

 In 2009 the world’s fastest computer is called ROAD RUNNER made by IBM. 
 
Merits of using computers 
 
1. Business 
Marketing, organization’s products & distribution, stock exchanges, Banks, Departments, Office 
automation, Document management, message handling and quick results, networks to others. 
Etc 
2. E-Commerce 
Electronic commerce describes the buying, selling, and exchange, services, and information via, 
electronic Mail (E-Mail), Video conferencing, E-shopping, E-Banking. 
3. Industry 
Robots (an automatic machine) 
4. Research of physics, chemistry, and medical 
5. Airline system 
6. Education 
7. Weather Forecasting: etc 
So computer performs speed, consistency, precision, reliability & efficiency.  
 
Generations of computers 
Until today there are 5 generation of computers one two three four five and some of known early 
 computers are Mark I(1937-1944) ATANASOFF-BERRY (1939-42) ENIAC (1943-46) EDVAC (1946-52) the 
EDSAC (1947-49) and theUNIVAC I (1951) 
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Types of computer: 
 
1. Digital computer 

Generation(Period) 
Key hardware 
technologies 

Software 
technologies 

Characteristics Systems 

1st (1942-55) Vacuum tubes, 
electromagnetic 
relay memory 
punched cards, 
secondary storage 
etc.  

Machine & 
assembly 
languages 

 For Limited 
commercial use, 
and other 
business 
problems 

ENIAC(Electronic 
Numerical 
Integrator & 
Calculator), 
UNIVAC-
1(Universal 
Automatic 
Computer), 
IBM701 

2nd 1955-64) Transistors, 
magnetic cores 
memory, secondary 
storage 

Batch 
operating 
system high 
level 
programming. 

Faster smaller 
more reliable and 
easier to use for 
business & 
commercial 
production.  

Honey well 400 
IBM7094, IBM1400 
CDC 164 
Etc. 

3rd (1964-75) ICs with SSI and 
MSI technologies 
larger magnetic 
cores memory, 
larger data storing 
capacity,   

Timesharing 
OS with high 
level 
programming 

Faster smaller 
more reliable and 
easier to use for 
business & 
commercial 
production, and 
easier to 
upgrade than 
previous 
generation better 
futures for 
business and 
commercialism.  

IBM 360 
370, PDP-8, 
UNICAC 9000 & 
IBM 370. 

4th (1975-1989 ICS with chipsets, 
technologies, 
Pentium processors, 
semiconductor 
memory larger 
capacity of storing, 
personal computer 
with high speeds. 

OS for PCS, 
graphic user 
interface 
(GUI) 
windows OS 
UNIX OS PC 
based 
applications 
Concept of 
system 
software & 
application 
software. 

Small, 
affordable, more 
comfortable for 
use, many 
futures for 
business, and 
great for network 
and other 
functions.  
And graphic use. 

IBM PC, Apple II, 
Pentium concept 
like P1, PII. 
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A computer which understand only two codes 0(represent the OFF) & 1(represents the ON) these 
are called binary codes. PC’s are digital computers. 
2. Analog computer 
The computers in which components depends on comparison between voltage & current.  I.e. the 
billing machine.  
3. Hybrid computer 
The combination of digital & analog. These computers are used in research. 
 
Different computers: 
1. Super computer 
An extremely fast computer that can perform hundreds of millions of instructions per second.  
2. Mainframe 
A powerful multi-user computer capable of supporting many hundreds of users simultaneously.   
3. Mini computer 
Multi-user computer capable of supporting 10 to 100 users.  
4. Personal computer 
A small single user computer based on a microprocessor has keyboard for data entry and 
monitor, has storage devices. They appeared in 1981 made by IBM 

I) Tower  II) Desktop 
5. Workstation 
A power full single user computer like a personal PC but has a more powerful CPU. 
6. Laptop  7. Palmtop.  8. Pen based  9. Note Book 
 
Personal Computer 
Has four basic parts, and they are very common in these days 
System Unit, Monitor, Keyboard, Mouse etc.  
Monitor 
The output device.  
LCD (Liquid Crystal Display)or TFT 
VDD (Visual Display Device)VDU (Visual Display Units) 
Keyboard 
The data entry device. Where you give instructions to the CPU. (Input device). 
Mouse 
The input device. It is also a point in device. 
System Unit 
Also consider as CPU, one of the major component of PC, all the processing, storage and others 
functions belongs to this component. 
Parts of System unit 

 CPU or processor     

 HDD (data storage device) start form 40 GB to 500 GB and 1TB  

 RAM (random Access memory) 512 MB to 2 GB ……etc. 

 ROM (read only memory)  or IC 

 Motherboard. (Electronic circuit board) Intel chipsets are most common. 

 CD/DVD ROM (CD player) combos are most common 

 Floppy drive. Not in use now because of data traveler flash drive of 32 GB. 

 Modem (internal & USB external are both common) 
Slots, Cards (VGA (display), sound, LAN) etc. 

 

LECTURE - 2 

 
Basic Concepts 
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Input: 
Devices which give information/data to the CPU are input. I.e. keyboard, mouse, scanner, 
joystick, Web camera.  
Output: 
Devices which show or stores information are output. Monitor, Printer, headphone, speaker. 
Hardware: 
All the physical components of computer are called hardware.CPU, Monitor, keyboard, mouse 
etc.  
Software: 
It is a set of an instruction that computer can understand & provides suitable results. I.e. the set of 
instructions that you can see on the screen are called software. OS are examples of software. 
Different OS are DOS, windows, Linux, os/2, etc. i.e.  
Two Types of Software are: 
System software: OS the (GUI) windows OS was introduced by Bill Gates in 1983. 
Applications software: The programs used to accomplish some specific task i.e. Ms Office, 
Corel etc. 
Introduction to Operating System (OS): 
An operating system is system software that provides an interface for the user to communicate 
with the computer in well defines manner. And to find suitable solutions. The purpose of the OS is 
to organize and control hardware and software in a link. 
Types of OS are: 
GUI (Graphical User Interface) OS i.e. Windows 
Command Line OS i.e. DOS 
Introduction to MS DOS.(Disc Operating System): 
Dos is a ready made program that is used to operate the computer, it is also used for handling 
hard disc & other data storage devices. 
It is also called command prompt, because in this we operate with specific commands. 
There are two types of commands used in dos. 

1. Internal commands.  2. External commands. 
We shell discuss these in Hardware Section 
The Internet: 
The internet is huge network of computers in which we can share our information, can send 
emails, have very quick results of connecting with each other and can research and make your 
information available to each other. Find targets, to get entertainment and more useful results. 
What is WWW or W3: 
It is a map of text images, and other linked base files, that is use to show data and effects on the 
internet. 
Law of World Wide Web (WWW) HTTP (hyper text transfer protocol). 
And the code of HTTP is URL (Universal recourse locator). 
The format of URL is  
Type://address/Path/file.ext 
Webpage 
It is one of the main source of internet; consist of multi hyperlinks & HTML codes interpreted by 
the browser. 
ISP (internet service providers) in Pakistan 
IBM, PAKNET, DIGICOM, Brainet, Aster net, Comsat. PTCL, SCOM, WARID, ZONG, UFONE. 
Etc.  
Program 
A program is sequences of instructions given to the computer & on the basis of these instructions 
you can find desirable results. 
Computer Virus and Anti virus: 
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A computer virus is a program (software) that attaches itself with other executable files by 
modifying them so that the virus program is also loaded and executed with the execution of these 
programs. A virus performs destructive operations. Virus has this ability that makes copies of 
similar forms. 
Another definition is “A destructive program containing code that can generate copies of it with 
other programs so that it is automatically executed when those are executed”.  
Causes of Virus: 
Email, Networks, Removable storage, unregistered software, CD, etc. 
(For Details see Hardware syllabus Virus Topic) 

 

LECTURE - 3 

 
Computer Languages: 
The computer is a similar device like TV or CD player. A computer does not understand our 
instructions if they are given in any of our own language. There are some special languages that 
used to communicate with the computer. Namely: 
 

 BASIC (Beginner’s all Purpose Symbolic Instruction Code) 

 COBOL (Common Business Oriented Language) 

 FORTRAN (Formula Translation)  

 P/L (Programming Language) 
 
Bit. (Binary Digits) 
It is a unit of computer. i.e.  
8bits=1byte 
1byte=1character. A symbol or space 
1024 bytes=1KB 
1024KB=1MB 
1024 Mb = 1 GB 
1024GB = 1 TB 
Example; 
 If you have a floppy of 1.44mb and you want to know how much space it has. 
1.44 X 1024=1474.56kb 
1474.56 X 1024=1509949.44 bytes (characters) 
 
Ports of CPU 
Ps2 Ports   Keyboard, Mouse 
Serial ports   Serial keyboard, Mouse 
USB ports   USB devices(all) 
Parallel Ports   Printer etc. 
Com ports   Modem, LAN etc. 
 
 
Different computer Devices: Data traveler flash disk, Scanner, keyboard, mouse, Joystick, 
digital cameras, Modem (external), etc,.  
Printer:(Inkjet printer), Dot matrix Printer, DeskJet color printer, laser printer (color & Black white) 
Monitor:Flat Screen, LCD, TFT, Multimedia. 
Mouse:Optical laser mouse, simple mouse, pen pointer 
Speakers: Multimedia speakers set, woofers etc. 
CD-ROM:Combos, DVD Rom CD/DVD writers, Blue Ray (Dual Reading) 
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(For Details see Hardware syllabus) 
 
System specifications 
 

 
For Professionals 
Different OS (system software) for use:  
PIII: Win XP2005 (service pack 1 & 2) with direct x 9.1. etc. 
PIV and dual : Win XP (service pack 1 & 2), Vista, Win Seven(DVD version). 
 
Good editions of Application software: 
Office 2003(Win XP), office 2007 & 2010 (XP service Pack 2 or above, Os Vista etc. Corel draw 9 
to 12 for XP 2006 & above, Vista & Win 7) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

CHAPTER 3:  WORKING ON APPLICATION SOFTWARE  

Switching on Syestem Unit 

LECTURE - 4 
 

 کرتے ہیں تو ست  سے پہلے جو سکرین ا تٓ  کو آت ا ٓئے گی ا س کو

 

 :ح ت  ا ٓت  ا پنے کمپیوٹر کو ا ٓن

CPU Pentium Ram VGA card Normal HDD 

266 to 433MHZ PII 32 TO 96 MB 4 MB to 8 MB 6GB to 10 GB(user defined) 

450 to 1300MHZ 
(1.2 GHZ) 

PIII 128 to 256 MB 8 MB to 64 MB 20 GB to 80 GB (defined) 

1.3 to 3.5 PIV 256 to 1 GB 128 to above 80 GB to 250 GB (defined) 

1.7 to 3.6GHZ 
Dual Core & Core 
& Due 

Dual Core 
technolog 

512 to 4GB 652 MB to 1 
GB 

160 to 555 GB 
Optional 
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(Basic input output system)BIOS  ا گر ا تٓ  ا س ی ا ر ے میں ہیں  جانتے تو کوئی 

 

ر  سیکشن میں۔ ا س عمل کے د و ر ا ن

 

ی ی
  و 

 

ا  ہے۔تفصیل د یکھیں ہار د

 

کہا جای

 د ی ا ئیں ۔ ا س کے بعد ا تٓ  د یکھ ر ہے ہیں بٹن 

 

  ہو ر ہی ہے ا س کے بعد ا ٓت  و یلکم سکرین سے ہوتے ہوئے ا س جگہ پہنچتے ہیں جہان کہ  مت

 

  لود

 

 و ر

 

ڈ

 

ا ٓ ت  کی سکر ین پر و ی

 سے ا ٓت  

 

  کریں گے ا س سکرین کو د

 

ا  ہے۔ یسکا پنے کام کا ا غٓار

 

ا ت  کہا جای

 

  ی

ا  ہے ۔ جس پر 

 

ا سک ی ا ر  کہا جای

 

 کٹس کہتے ہیں ۔ نیچے آتا نٓے و ا لی ی ا ر  کو ی

 

ا ر ت

 

 ی ا  س

 

  کو ا ئٓیکان

 

ر

 

ی

 

 پ
پ

ا  ہے ا و ر  کسیکا  Startا س سکرین پر آت ا نٓے و ا لے 

 

پہلے  بٹن ہوی

ا ل پرو گرا م کو کھولنے کے لیے ا س پر  سے 

 

شپ

 

ن
 کلک کریں گے ا و ر  ا ٓگے پرو گرا م کو کلک کریں گے ۔ا 

ا 

 

ا  ہے و ہ ہے ی

 

 ست  سے پہلا کام جو ہم نے کری

 

پ
گ 

 

 پ
ٹ  چونکہ  سیکھناپ ی

 

پ
ا 

 

 حاصل کریں  ی

 

ٹ
ل
 

 

 کمپیوٹر کو پہنچا سکیں گے ا و ر  پھر ا س کا ر ر

 

ٹ  ہی ہم ا پنی ی ا ت

 

پ
ا  ا ٓئے گا تو 

 

کری

ا مستعماگے ۔ ا س کے لیے ہم نے ا ی ک پرو گرا م ا 

 

ا  ہے جس کا ی

 

ا  ل کری

 

 ہے ی

 

پ
گ ٹیوٹر۔ ا س پر ہم ا س کے ر و لز کے مطابق کام شرو ع کرتے ہیں۔

 

 پ
 پ ی

Starting typing tutor: At least 3 days practice is must before staring Ms Word. 
 

LECTURE - 5 

 
Starting Ms Word Processor  
MS Word processor is standard application software from Microsoft of America whose owner is 
Mr. Bill Gates a well renowned personality.  Using MS Word you can make Documents, Tables, 
books, templates, web pages, printing and many other features of daily office work. 
 
Ms Word Format 
Format means which type of application you are working on, in a specific program, i.e Doc. PPT, 
.Exe are different format. MS Word’s format is .Docx (2007-2010) 

  2006ا و ر  2003ا س سے پہلے ا تٓ  نے ا فٓس 

 

پ
 

 

ز
پ 
 کے پرو فیشنل و ر 

 

ا  ر ہا  OSکے ی ا ر ے میں سیکھا۔ یہ ا فٓس ا یکس پی  ز

 

 د نون کے سا تھ ا ستعمال ہوی

 

ہے۔ ا ن

۔ یہ ا ٓفس ا س سے پہلے تما م  2007 & 2010متعار ف کرو ا ی ا  ہے۔ تو ا س حوا لے سے ا ٓفس بھی  OS VISTA And Windows 7ٹ  نے نیا ا مائیکرو س

ا  کہ ا ٓت  ی ا لکل نیو ٹولز کو بھی سمجھ

 

ا مل کر ر ہا ہون۔ ی

 

 ہے۔  ا س لیے کور س میں ا س کو س

 

   سے بہت بہتر ا و ر  ا ٓسا ن

 

ز

 

پ
 

 

ز
پ 
ن و ر 

 
ھی

سک

ا لوگ ۔ جو 

 

ا فٓس جانتے ہیں  پرا ی

 میں

 

ا  ل کر کہ ا ستعمال کریں۔ا و ر  کسی بھی قسم کے پرا بلم کی صور ت

 

شپ

 

ن
 کے لیے میرے خیال میں ا س میں کو ئی مشکل ہیں  ہے ۔ بس ا س کو ا 

 

یہ کتات  پیش  ا ن

 ہے۔

 

ڈ مت

 

 ج

  فار میٹ ی ا  کام کرنے کی نوعیت 

 

  کے ہے۔ا  س کے Docxتو ہم شرو ع کرتے ہیں ۔ا س پرو گرا م کا سٹینڈر د

 

ز
پ 
 علاو ہ بھی بہت سا ر ے فار میٹ موجود  ہیں جو ا ٓت  سیو ا 

 کیے جا ر ہے ہیںٹیکسٹگرا م میں ہم و ٹول سے سیو کر سکیں گے۔ست  سے پہلے پر

 

 یٹنگ کے تعلق  پڑیں  گے ا کے  لیے بنیاد ی تین یکچر  بیان

 

 کو ضرو ر سمجھ   ا ی ڈ

 

ا ن

 یشن میں موجو د تھے۔

 

 ہی ہیں  ۔جو ا س سے پہلے ا ی ڈ

 

ا م ی ا د  کرنے کی ضرو ر ت

 

  کے ی

 

 لیں۔ا ت  ا تٓ  کو ی ا ر ر

ا م سے ا ی ک فا

 

 سیو کر لیں ۔ ا س کے لیے ا تٓ  پرو گرا م کھولنے کے بعد ا ٓفس بٹن پر کلک کریں ا و ر  سیو پر کلک کریں تو فائل ئلپرو گرا م کو کھولیں ا و ر  ا س میں ا پنے ی

ا کا 

 

ا م لکھنے کے بعد سیو پر کلک کر د یں ا تٓ  کی فائل ی

 

 ہے  بعد میں ا ٓت  ح ت  چاہیںئٹلی

 

ئ

گ

ا م سے سیو ہو 

 

کی مدد  سے کھول  Open(CTRL+O) ی ا ر  میں ا ٓت  کے ی

ے ہیں

 

سکی
 ۔کر د و ی ا ر  ہ کام کر 

LECTURE - 6 

 
Three Basic Lectures: 
There are four kinds of different keys on the keyboard, as a whole there will be 104 keys on the 
standard keyboard. 

1. Functional Keys like F1, F2………………F12 
2. Alphanumeric Keys A, B, C etc. 
3. Editing Keys like Home, End, delete etc. 
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4. Numeric keys like 1,2,3,…..5 

 
Text Editing: 
 
To delete one Character left from the position of cursor Backspace key 
To delete one character Right from the position of cursor Delete Key 
To delete one word left from the position of cursor  Ctrl+Backspace 
To delete one word right from the position of cursor  Ctrl+Delete 
New line       Enter key 
New Paragraph       Enter + Enter + Tab 
Word        Space 
Sentence       Full stop 
Double Distance      Tab key 
 
Cursor Movement: 
 
Movement to one character left     Left Arrow key 
Movement to one character right     Right arrow key 
Movement to one word left     Ctrl+Left arrow 
Movement to one word right     Ctrl + Right Arrow 
Move to up/Down      Up/Down arrow 
Move to beginning of line     Home key 
Move to End of line      End key 
Screen up       Page up 
Screen down       Page down 
 
Text Selection 
 
Select one character left      Shift +Left Arrow 
Select one character right     Shift + Right Arrow 
Select one word left       Ctrl + Shift + LeftArrow 
Select one word right      Ctrl + Shift+Right Arrow 
Select one Paragraph up/Down     Ctrl + Shift + Up/Down Arrow 
Select one line home to end     Shift +End key 
Select one line End to Home     Shift + Home key 
Select Whole file      Ctrl +A or Ctrl +5 
Cancel Selection      Any Arrow key 

 

 

  کے بعد ا ت  ا ٓت  پرو گرا م کے ا نٹر فیس کو سمجھیں۔ ا فٓس 

 

 کا ا نٹر فیس پہلے سے کافی مختلف ہے ۔ح ت  ا ٓت  پرو گرا م کھولیں گے تو ا ٓپکو2661-2010بیسک یکچر  ر

 ۔آت ا ٓئے گا  جیسے نیچے تصویر میں ہےا س کا ا نٹر فیس ا س طرج کا 
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 ا ٓت  کو  یکچر 

 

ا  ا و ر  ا  ٹیکسٹکے د و ر ا ن

 

ٹ  کری

 

پ
ا 

 

 صرف ٹولز کو  ہاںن  ۔ ہمہیںر و لز سمجھا د یے گے  س کے  ی

 

ا  کہ  بیان

 

ھگھر  ا ٓت  کریں گے ی

 

ی ی ی
کر بھی بعد میں ا ستعمال  

 کرسکیں۔

 

7 –LECTURE  

 

  ا ت  پر جو ی ا ر  ا ٓت  کو آت ا رٓ ہی ہے ا س کو  کی سکرین کے پرو گرا م

 

ا م Title Barی

 

ا م ، فائل کا ی

 

ا  ہے۔ا س میں پرو گرا م کا ی

 

 Extensionا و ر   کہا جای

(Format)ا مل ہیں ۔

 

 س

  ٹ  فی ا لحال ا ٓت  کو صرف تین ٹولز آتا رٓ ہے ہیں ا س  کو ئیںا س ی ا ر  کے ی ا

 

پ
ا  ہے۔ ا س میں ا تٓ  بعد میں ا پنی  Quick Access Tool Bar جا

 

کہا جای

 ا ل بھی 

 

ا مل کر مرضی کے ٹولز د

 

 ی ا د ہ ا ستعمال کرتے ہیں۔سکیں گے س

 

 ۔جو کہ ا ٓت  ر

  ا س کے پیچھے جوICON کئی  ا ٓپشن کھلیں گےجن  کو ہم ا ٓگے پڑیں  گے۔آت ا ٓ ر ر ہا ہے یہ ا ٓفس بٹن ہے ۔ ا س پر کلک کرنے سے 

  ٹ  کرنے کی بھر پور  پریکٹس کے بعد ا ت  ہم  ٹیکسٹپرو گرا م میں

 

پ
ا 

 

  کرنے بعد ا س کو  ٹیکسٹکی فار میٹنگ کرتے ہیں ی ا د  ر کھیں  ٹیکسٹی

 

کو کمپور

 میں 

 

ٹ
ل
 حا

 

ا  ہے۔تیار  ر کے بعد ا س فار میٹ یعنی خوبصور ت

 

 کیا جای

 

ٹ

 

پ
 کو پر

 کے حوا لے سے  

 

ا  ٹول ی ا ر ر

 

 ہن میں ر کھیں کہ  ی

 

  ہیں یسا ئٹلیہ د

 

 و ر
ی

 

پ ی
م

  ہیں و ہ ست  

 

 Home, Insert, Page layout ی ا ر  کے بعد نیچے جو ی ا ر ر

Menus etc   یہ ستTabs   میں 

 

 ہو ر ہی ہے۔ Displayکی صور ت

Hi! 

I AM MS. WORD 
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  و  پر

 

 ی
پ ی
م

 یل ا ٓپشن ا ٓ  ٹیکسٹح ت  ا ٓت  ہوم 

 

 د

 

 کر کہ کلک کریں تو ا س میں د ر ج

 

پ کت
پ ل
س

  گے۔ئیںکو 

 
Home Ribbon       Alt +H 

 

 :ا ہم نکتہ

  سے جانے کے لیے 

 

 کٹس ا ٓ جائیں گے۔یسا  Altکسی بھی مینو میں کی بور د

 

ا ر ت

 

  میں جانے کی س

 

 و ر
ی

 

پ ی
م

کرنے پر ا ٓت  کو  Alt +Hکی د ی ا ئیں تو ا تٓ  کے سا منے تما م 

 و  کے تما م ا پٓشنز کیز کے سا تھ ملیں گے۔
ی

 

پ ی
م

 ہو م 

 ہم شرو ع کرتے ہیں ٹولز کو۔

  میں 

 

ر

 

ی

 

 پ
پ

 

 

 کو ا ستعمال کرنے کے  Paste, Cut, copy , Format painterا ن

 

ا مل ہیں ۔ ا ن

 

س

 کریں ا و ر  ا س کے بعد ا ٓت  یا ٹیکسٹلیے ا ٓت  

 

پ کت
پ ل
س

یعنی قینچی پر کلک کریں تو ا ٓت  کا   Iconکو 

 کی   ٹیکسٹیا جائے گا ۔ ا س کا مطلب ہے کسی  ٹیکسٹ

 

ا ر ت

 

کو ا ی ک جگہ سے بطور  کاپی کاٹنا ۔ ا س کی س

Ctrl+X  کسی جگہ پر چاہیے تو ا س کے لیے پیسٹ ٹیکسٹح ت  ا ٓت  کو یہ ہے۔Icon    پر کلک کریں ی ا

Ctrl+ V   یا لیں۔ا س طرج یا سے نیچے کاپی کا ا ٓپشن کسی 

 

ا ر ت

 

کی کاپی کے لیے ا ستعمال  ٹیکسٹس

 کر کہ کاپی پر کلک کریں ی ا   ٹیکسٹہو گا ۔ 

 

پ کت
پ ل
س

Ctrl+C   میں کاپی ہو  ٹیکسٹکریں۔ تو  

 

کلپ بور د

  و ہ جگہ ہے جہان یا ی ا  کاپی شدہ  ئےجا

 

 ر ہتا ہے  ٹیکسٹگا ۔ ی ا  د  ر کھیں کلپ بور د

 

کچھ د یر کے لیے محفوظ

ے ہیں۔ ا س 

 

سکی
  کے ی ا لکل نیچے ا تٓ  لکھا ہو ا  د یکھ 

 

ر

 

ی

 

 پ
پ

 

 

تو ا ٓت  کو آت ا ٓ جائے گا۔ ا ت  ا ٓت   پر کلک کریں ۔ ا ن

  Ctrl+ Vکلک کریں ی ا   کو کسی جگہ ر کھنا چاہتے ہیں تو صرف پیسٹ پر ٹیکسٹئےا گر کاپی کیے ہو

ا  جبکہ کاپی  ٹیکسٹکریں۔چنانچہ یا سے مرا د  ہے کسی 

 

کو بطور  کاپی ا ی ک جگہ سے د و سری جگہ لے جای

 ۔جگہ بھی  یا د ھر بھی موجود  ہو ا و ر  د و سر

ر ینڈلی ٹول ہے ح ت  ا تٓ  نے ا ی ک 
ف
 ر  

 

ا  ہے ا ہم ٹول ا و ر  بہت یور

 

ہلا ی
ک
 جو فار میٹ پینٹر 

 

ز س
پ 
ا س کے بعد 

  کی فار میٹنگ ٹیکسٹ

 

ا  پڑے بلکہ ا س ٹول کی مدد   ہے کہ کر لی تو کیا ضرو ر ت

 

ا ٓت  کو ی ا ر  ی ا ر  فار میٹنگ کری

ے ہیں ۔ جس ا ی لائی  سے ا ٓت  ا ی ک فار میٹنگ کو د و سری جگہ 

 

سکی
کو فار میٹ کر لیا ہے ا س پر ا پنا  ٹیکسٹکر 

 پر کلک کریں ا و ر  جس 

 

ز س
پ 
 کر د یں ی ا   ٹیکسٹکر سر ر کھیں ۔ ا ت  

 

پ کت
پ ل
س

ا  ہے جا کر 

 

کو ا س پہلے یسا بنای

ا  

 

ا ئم کی بچت بھی مجھے بہت پسند ہے یہ ٹول۔کلک کریں تو و ہ ا س یسا ہو جائے گا ۔ ہے ی

 

 بہترین ا و ر  ی
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 می 

 

ا ٓپشن ہے جس کو ا ٓت  تصویر میں د یکھ ر ہے ہیں۔ ا س میں   Formatingہوم ر بن کا ا گلا بہت لار

 

 

ٹ

 

پ
ا م ، ہے پہلا ا ٓپشن فا

 

ر  ر کھیں تو خود  بخود  ا س ٹول کای

 

ی

 

پ

 

پ

، ا و ر  Helpح ت  ا ٓت  کسی بھی ا ٓپشن پر پوا 

 کی ا ٓجائے گی۔ ا س کو ضرو ر  سمجھیں

 

ا ر ت

 

 سے مرا د  ر  ا ا طس

 

ٹ

 

پ
۔ ا س میں بہت سے ہے  ۔ تو فا

  سٹائل موجود  ہیں ا پنی مرضی کا

 

ٹ

 

پ
 ا ستعمال کریں۔ ا س سے ا ٓگے سا  فا

 

پ
  ہے 

 

 کا سا  ٹیکسٹز

 

ز

 

پ
ے  

 

سکی
بدل 

 

 

ا ر ت

 

ہے۔ کیز کی تفصیل ا ٓت  ا ٓگے د یکھیں گے۔ ا س کے  {[+Ctrl ا و ر  ]}+Ctlہیں۔ ا س کی س

ا  کرنے کے ا و ر  د   ٹیکسٹبعد

 

 ا  ا و ر  چھوی

 

ز
پ 
ے ہیں۔ ا س کو 

 

سکی
 ی ڈ  ٹولز بھی ہیں ۔جن کی تصویر ا ٓت  د یکھ 

 

ر
ک
و  

ر کے بعد کا جو بٹن ہے ا س پر پوا 

 

ی

 

پ

 

پ

ا م سا منے ا ئٓے گا  ر کھیں

 

ا س کی مدد   Clear Formattingتو ا  س کای

 ا ہم ہے۔ کی تما م فار میٹنگ کو ختم کر سکیں گے۔یہ بھی  ٹیکسٹسے ا ٓت  

 

 ٹ
پ
  مرہ کام میں نہا

 

 ر و ر

 

ل میں نیچے کی طرف 

 

 پ
ی ی

 ر   B, I, Uتو  د یکھیںپھر ا سی 

 

ڈ

 

 سے مرا د  بولڈ ، ا ٹیلک، ا ی

 

  ہیں ۔ ا ن

 

کے لیٹرر

 کیز ئنلا

 

ا ر ت

 

 کی س

 

 ر  لا Ctrl+B, Ctrl+I, Ctrl+U ہے ا ن

 

ڈ

 

 ی ڈ  سٹائنہیں۔ا س میں ا ی

 

ر
ک
 ئل کے 

بٹن پر کلک کرکہ لیں ی ا  نیچے  Down Arrow کے سا تھ و ا لے سا ئنکے  Uبھی موجود  ہیں۔ جو ا ٓت  

ا س ٹول کی مدد  سے ا تٓ   .کا ا ٓپشن ہے Strikethroughپر کلک کریں۔ ا ٓگے د یکھیں  Fontلکھے ہوئے

 لا ٹیکسٹ

 

 ر  کرئنکے د ر میان
ہ
ا 

 

 ۔ینگے ط

 

 لکھا ہوا  

 

ٹ

 

پ
  کے نیچے ا ٓت  فا

 

ر

 

ی

 

 پ
پ

 

 

 ا ٓپشن ہے جو ا ٓت  نے ئنگے ۔ یہ ا صل میں تمام ٹولز کا کمبا د یکھیںا ن

 کی  

 

ا ر ت

 

ل میں پڑھے ہیں س

 

 پ
ی ی

 ا و ر  کچھہے۔یعنی بولڈ ا ٹیلک، فا Ctl+Dا بھی ا س 

 

ٹ

 

پ
 ی ڈ   

 

ر
ک

  ا ٓت  ئلسٹا 

 پر کلک  یکچر  

 

ٹ

 

پ
 تفصیلی د یکھیں گے ۔ ا س میں د و سرا  ٹیب ا ٓت  کو ا س کے سا تھ ملے گا ح ت  فا

 

کے د و ر ا ن

 د و سرا  ہے 

 

ٹ

 

پ
 و م ا و  ر   ٹیکسٹ۔ا س میں Character Spacingکریں تو پہلا ا ٓپشن ہے فا

 

 ر

 

ٹ

 

پ
کا پر

 کو بھی د یکھ لیں۔

 

 فاصلے موجو د  ہیں ا ن

 

 کے د ر میان

 

 ا لفاظ

LECTURE-8 
Font 

 کی مدد  سے  Supper Scriptا و ر  Subscriptیہ ٹولز 

 

ہلاتے ہیں۔ ا ن
ک

کو ی ا و ر  ا و ر  بیس میں  ٹیکسٹ

ا  ہے لکھا جا 

 

 کی  ی

 

ا ر ت

 

 =+Ctrl+shift ا و ر   +=+Ctrl۔ ا س کی س

 

 ے  حرو ف کو چھوٹے  ٹیکسٹئےکا کیس بدلنا ہے یعنی لکھے ہو ٹیکسٹا ٓگے 

 

ز
پ 
حرو ف  میں لکھ لیں ی ا  

  

 

ڈ

 

 کمای

 

ا ر ت

 

  ہیں پہلا و ا لا   Shift +F3میں ا س کی س

 

  شیڈ ہے ا و ر   ٹیکسٹہے۔ ا ٓگے  می ر

 

ڈ

 

کا بیک گرا و ی

  می ہے۔ ٹیکسٹد و سرا  

 

ٹ

 

پ
 کا فا

 

ے ہیں۔

 

سکی
گ ا ٓت  تصویر میں د یکھ 

 

س ا ینڈ نمبری

 

ی لی

س ا و ر   ٹیکسٹا ٓگے 

 

ی لی

 کر کہ مطلوبہ 

 

پ کت
پ ل
س

 کو 

  پر کلک کرنے سے ا ٓت  ا گٓے  

 

ر

 

ی

 

 پ
پ

 کے 

 

گ د ے د یں ۔ا ن

 

کا ا ٓپشن د یکھیں  Define New Bulletنمبر ی

گ گے ا س میں ا تٓ  ا پنی مرضی کی ع 

 

، تصویر، بھی بلٹ کے طور  پر لے سکیں گے۔ا س طرج نمبری

 

لامت

 کی 

 

ا ر ت

 

 کی س

 

 Alt+O+Nبھی۔ا ن

 

س ا و ر  Multilevel Listیہ ہے 

 

ی لی

گ ا و ر  ا س طر ج 

 

گ ا و ر  پھر نمبری

 

گ کے ا ندر  نمبری

 

ا  س کی مدد  سے ا تٓ  نمبری

س لگا 

 

ی لی

گ ی ا  

 

س ا و ر  پھر نمبری

 

ی لی

ے ہیںپھر 

 

سکی
 ا و ر  

 

ا ج

 

ا خیں شرو ع کریں پھر ا س کی س

 

۔ بعض د عہ  ا ی ک چیز کے س

 ی ڈ   ا س طرج

 

ر
ک

 ر  ۔ا تٓ  نے  
ہ

Enter    کرنے کے بعدTab  کی 

 

ا ر ت

 

 Alt+H+M کی د ی ا نی ہے۔ ا س کی س
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 ہیں جن میں ، ی ا ئیں،  ٹیکسٹیہ 

 

  Ctrl+R، ا ئیںد  Ctrl+Lکے ر ج

 

  Ctl+Eا و ر  د ر میان

  Ctrl+J Justfyا و ر  

 

 ی کو ا ٓگے پیچھے کرنے کے لیے ٹیکسٹا س میں پہلا ٹول ہے 

 

ز
پ 
لکھنے کے لیے کرسر کو  ۔ا ٓگے ا ر د و  ا و ر  ا نگر

ا ۔ ا و ر  بعدئیں ی ا  ی ا ئیںد ا 

 

 ی ا د ہ  ٹیکسٹمیں   لے جای

 

 و لی ی ا  صعود ی میں لکھنا ہے جو ٹیبل میں ر

 

ز

 

پ
کو ترتیب 

  ا ستعمال ہو گا۔

ا  ہے۔ یہ 

 

 کو پیرا گرا ف مار کس کہا جای

 

 ر  کریں گے جن میں  ٹیکسٹا ن
ہ
ا 

 

 ط

 

پر خاص قسم کی علامات

Enter, Tab, Space    ہیں کہ کس جگہ ا نٹر کسی جگہ کتنے سپیس و غیرہ 

 

کے لیے مختلف علامات

 میں ہیں  ا تٓے۔ لیے ہیں۔

 

ٹ

 

پ
 یہ پر

 

 کی ئنو پیسنگ  یعنی لائنیہ ہے لا

 

ا ر ت

 

 کی س

 

 فاصلے ۔ا ن

 

  Ctrl+1 and Ctrl+5ن کے د ر میان
 

  ٹیکسٹا  کے  بعد 

 

  سٹار کا شیڈ ا و ر  ی ا ر د

 

 کیئلر

 

ا ر ت

 

ا س میں ا تٓ  کو بہت سا ر ے  Alt+O+B ہیں س

 

 

  ملیں گے۔ر ی ا ر د

 

 ، ر ا  لفٹر

 

پ
 ا و ر  ا ٓت  کو ملے گا 

 

   Borders  Shadingٹ

 

  ، ر ا س پر کلک کریں تو ی ا ر د

 

ر

 

 

  سا منے ا ٓر پیج ی ا ر د

 

  ا و ر  شیڈ  میر

 

 ت  پیج فار میٹنگ میں کریں گے۔ جو ا ٓ  گے۔ئیںر

 

 و ا نس ا پٓشنز ا تٓ  کو 

 

ل کے حوا لے سے کچھ ا ی ڈ

 

 پ
ی ی

ملیں گے۔  یعنی پیرا گرا ف ٹول میں  ا ت  پھر ا س پور ے 

 ی  

 

ر
ک
 کی تفصیل ا و ر  کچھ 

 

 ا پٓشنز۔ ڈ جو ٹولز ا تٓ  نے سا منے د یکھے ہیں ا ن

9-tureLecParagraph  

 ا و ر  لا ٹیکسٹپیرا گرا ف میں فاصلے ، 

 

ا مل ہیں پہلے ئنوکا ر ج

 

 ہے  ٹیکسٹن میں فاصلے  و غیرہ س

 

کا ر ج

ا 

 

 ج ڈ ھر سے ا ٓت  ی

 

پ
  ا و ر  ا ختتام کا فاصلہ  شرو ع  ٹ  

 

 ر  پیرا گرا ف کے ا غٓار
ہ
ا  چاہتے ہیں۔ ا س کے بعد 

 

کری

 یشن ہے۔ ا و ر   بعد میں لا

 

ن میں فاصلے موجود  ہیں ا و ر  ا سی جگہ ئنوہے۔ ا س کے بعد ٹیب کی پور

 یا ا ٓگے ا ٓ پیرا گرا ف میں فاصلے

 

ا ر ت

 

 کی س

 

 گی۔ا س سے ا گٓے پیرا گرا ف ئیںبھی موجود  ہیں۔ا ن

 ہیں  Settingsکی

 ر  مینو سے تعلقہ  ا س کی 
ہ
ا ی ک پر ہے ا گر ا ٓت  

 

 ر  مینو ا ی ک ی
ہ

Alt  کیز جاننا چاہتے ہیں تو 

  سے 

 

 کی پریس کر کہ سا منے د یکھیں تو کیز ا ٓت  کے سا منے ہیں ۔ Altکی بور د

 ر  
ہ

 و 
ی

 

پ ی
م

 میں سے ا تٓ  کوئی بھی گی ئیںکی کیز ا ٓت  کے سا منے ا ٓ جا 

 

 یسپر کی پھر ا ن

 

ا ر ت

 

 کریں تو کام س

لًا ہوم کے لیے 

 

 ر  ا ی ک کے لیے ا لگ ا لگ مپ
ہ
 Alt+Hیا سے ہو جائے گا۔

 

  و غیرہ کے سٹا ہوئےکے بنے  ٹیکسٹیہ 

 

گ،  میر

 

، ہیڈی

 

ٹ

 

پ
 کریں  ٹیکسٹ ہیں صرف ئلفا

 

پ کت
پ ل
س

کو 

 کی  ئے پر کلک کرد یں تو یہ سا منے ا ٓ جائلا و ر  ا پنی مرضی کے کسی سٹا

 

ا ر ت

 

گا۔ ا س کی س

Ctrl+Shfit+Sے ہیں۔ا س کے لیےا ٓت  ئل۔ ا س میں ا ٓت  ا پنے سٹا

 

سکی
ا مل کر

 

 بھی تیار  کر کے س

Apply Style –Modify  ی ا  کا ا ٓپشن لیں۔New Style کا ا نتخات  کریں۔ 

 

 ی ڈ  سٹا ٹیکسٹ

 

ر
ک
ا مل ہے۔ی   س ئلکے 

 

ا  س

 

 کری

 

 کے مطابق ت

 

ا و ر  بنے ہوئے سٹائلز میں ا پنی ضرو ر ت

ا مل ہے۔

 

ا  س

 

 تبدلیاںن کری
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 یٹنگ کے 

 

ا مل ہیں، ر ی پلیس،  Findہیں جن میں  لیےیہ ٹولز ا ی ڈ

 

کی مدد سے ا ٓت    Findا و ر  گو ٹو س

 کی   ٹیکسٹمطلوبہ 

 

ا ر ت

 

 کریں س

 

لاس

 

کو ر ی  ٹیکسٹا س کے بعد ر ی پلیس کی مدد  سے ا تٓ  مطلوبہ   F5ی

 کیز۔ 

 

ا ر ت

 

 کی س

 

ے ہیں۔ ا ن

 

سکی
  بھی د ے 

 

ڈ

 

۔ا س  Ctrl+F, Ctrl+H, Ctlr+Gپلیس کرنے کی کمای

 ا پٓشنز ہیں جن میں 

 

پ کت
پ ل
س

 ی ا د ہ ا و بجیکٹ کو   Objectی ا  ٹیکسٹکے علاو ہ 

 

ا  ا ی ک سے ر

 

 کری

 

پ کت
پ ل
س

کو 

ا مل ہے۔

 

ا  س

 

 کری

 

پ کت
پ ل
س
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Assignments Related to Home Menu: 
On the basis of MS. Word processor 2005 edition you have just learned Text composing, 
formatting and many advanced tools. Now solve these and observe what you have learned? 
 
Assignemtn (1): Compose an application for job as a data entry operator to General Manager of 
IT Board and format it.  
 
Assignemtn (2): Write a letter to your friend for Eid greetings. 
 
Assignemtn (3): Write any 5 districts of AJK. Make them top heading and also write names of 
villages and towns for each then format it and use bullets and numbering and Multilevel Bullets as 
well. 
 
Assignemtn (4): Write any 10 main ctrl keys for Home Menu. 

 

 کی پریکٹس ہو جائے گی 

 

ٹ

 

پ
 

 

س پر ضرو ر  کام کرو ا ئیں ا س سے سٹود

 

ی

 

مپ

 

ی

 

پ

 ا سا 

 

 کی  سے  جسا نسٹرکٹر: ا ن

 

 ست   ا ٓت  کو ا ن

 

کمزو ر یون کا پتہ چل جائے گا۔ا س کے بعد ا ن

لا

 

 کا طریقہ کار  بتا د یں۔مپ

  کرنے کے لیے کسی بھی بی کام کیجات  کے لیے لیٹر کا یہ 

 

 فالو کریں۔ا س کے علاو ہ لیٹر کمپور

 

 ہن میں ر کھیں۔ا س کے ع  پیٹرن

 

 د

 

لاہ ی ک کو فالو کریں ا و ر  ا س کا پیٹرن

 ی ا د ہ ا ستعمال ہونی و ا لی ٹول ی ا ر  ہے

 

 کیز کو ا ی لائی کریں ۔ یہ بہت ر

 

ا ر ت

 

و  پر ی ا ر  ی ا ر  پریکٹس کریں، س
ی 

 

پ ی
م

 ا س 

 

 

 

 

 

 

 

MOON CREATIONS SCHOOL OF IT  
Near Girls College Madina Market, Muzaffarabad AJK. 

________________________________________________________________ 
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Dated: April 30, 2010 

 
Director General 
IT Board, 
Islamabad-Pakistan. 
 
 
Dear Sir,  
 

With reference to, the morning newspaper of April 25, 2010, I understand that you are looking for 

young graduate in computer application for your office. May I request you to consider me a as 

candidate for this position? 

 

I am interested in computer science that is why I have learned 1year Diploma in computer 

software & hardware. My CV enclosed will show you my work & experience. 

 

In addition, I have 4 years experience of teaching as a computer instructor and managing office 

work as a computer operator. 

 

Moreover, have following operating & teaching skills in computer. 

 Office Applications & DMS  

 Computer Hardware & Programming  

 Internet & Web Development  

 Designing & Multimedia etc. 

Complete details are available in my CV. 

 

In the above noted particulars I hope that my application for job will be considered accordinalgy, 

further I assure you, if I would have opportunity to serve, I will try level best to satisfy my 

superiors with my work. 

 

 

Best Regards  

 

 

XYZ 

 

 
 
 

LECTURE – 10 

Insert        Alt+N 
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  کے ٹولز کی مدد  سے ا ٓت  پرو گرا م میں کیا کیا 

 

و ر

 

 ی
پ ی
م

 

 

 کی تفصیل پشنزا ٓا نسرت

 

ا مل کر سکیں گے ا ن

 

  س

 

 یل ہے۔د ر ج

 

 د

  

 

ا ستعمال کر سکیں گے  Titleا  س کی مدد سے ا ٓت  پیج کے بنے ہوئے Cover Pageپہلا ا ٓپشن ہے ا نسرت

ے ہیں۔ ہاںن ا ٓت  کو پور ے پیج  سٹائلجس میں بہت سا ر ے 

 

سکی
موجود  ہیں ۔ ا ٓت  ا س پر کلک کرکہ لے 

 ملتا ہے ا 

 

  کی مدد   سکا ا ی ک بنا ہوا  لے ا وٓ ت

 

 ت

 

ے ہیں ی ا  پھر ا س کو ہی ا ی ڈ

 

سکی
ا ئٹل بھی بنا 

 

سے ا ٓت  ا پنا کوئی ی

 کی 

 

ا ر ت

 

 ہے۔  Ctrl +Enterکر لیں ا س کے سا تھ خالی پیج لینے کا ٹول بھی ہے۔ ا س کی س

 
ا مل ہے ا  س کو ہم تفصیل سے 

 

  ا و ر   پڑھتے ٹیبل لینے کا ٹول س

 

 ٹیبل کی مدد  سے مطوبہ ر و ر

 

ہیں۔ا نسرت

  لیں 

 

ر
م
ل

  لیں ۔ ی ا  د  ر کھیں ا ٓگے ۔کا

 

ر
م
ل

  ا و ر  کا

 

سا منے د ئیے ہوئے ٹول کے بٹن پر کلک کریں ا و ر  نمبر ا ٓف ر و ر

 کام کریں گے ح ت  ا تٓ  کے ی ا س ا ی ک ٹیبل 

 

ٹ
ق
 ہو گا ۔بنا  ا نٓے و ا لے ٹولز ا س و 

 

  ا ٓ جا   جون ہی ا تٓ  ٹیبل لیں گے تو ا تٓ  کے ی ا س د و  نئے

 

 و ر
ی

 

ی  پ 
می

و  ی ا ر  میںئیں
 
ی

 

پ ی
م

 ۔ گے ا و ر  ا و پر ٹیبل ٹولز لکھا ہوا  ہو گا د یکھیں 

 

LECTURE – 12 

 
Table Tools 

 سے ا پٓشنز ا ٓت  چاہتے ہیں ا و ر  ئلٹیبل کے مطابق جو سٹا ہوئےلیے 

 

 کون

 

 میں کون

 

 موجود  ہیں ا ن

 سے ہیں 

 

ک کا سا  کون

 

 سا  ا پٓشن ا تٓ  ئنیسا کہ ی

 

 ر  کر ر ہا ہے ۔یعنی ٹیبل کی فار میٹنگ میں کون
ہ
ا 

 

 ط

ے ہیں۔ ا سے  کو چاہیے

 

سکی
 ا ٓف کر 

 

 ا ٓن

 

 ا  ئےا  س کے علاو ہ بہت سا ر ے بنے ہو

 

ز
پ 
 

 

 کو ا ستعما ل کریں۔ا س ئنٹیبل کے د

 

 موجود  ہیں ا ن

ا  بہت ضرو ر ی ہے بنے ہوئے ٹیبل پر یہ ا ستعمال ہون گے۔ کےلیے

 

 ٹیبل کا ہوی

 

 ی  

 

ر
ک
  کے 

 

 ر ر

 

  و غیرہ کا  می ا و ر  ی ا ر د

 

  یعنی سلز، ر و ر

 

ڈ

 

 بھی موجو د  ہیں۔ا س کی ئلسٹا ڈ ٹیبل کا بیک گرا و ی

  پر کلک کریں ا و ر  لیں 

 

ر

 

ی

 

 پ
پ

 

 

 ا ٓت  کو پریکٹس کرو ا ئی جا ئے گی۔ یکچر  تفصیل ا ن

 

 کے د و ر ا ن

 

 ا ئی و غیرہ کے ا ٓپشنز ہیں کلک کرنے سے ٹیبل کے ا ندر  موجود  لائن ا و ر  لائل سٹائنلا

 

 کی ئن کی چور

 ا ئی و غیرہ کو بدلا جا سکتا ہے۔

 

  چور

 ر ا  کرنے 

 

 ر ا  کر و ا لی یہ ٹیبل د

 

گ ہے۔جس سے ا ٓت  ٹیبل ی ا  لائنز د

 

 گے۔ سکیں پنسل کا ر ی

 

 ر ا  کرنے ا و ر  

 

و  س کی مدد   ختم کرنے ا ٓگے ٹیبل د

 

ن
 کے علاو ہ ا ٓت  ما

 

کا ا ٓپشن مو جود  ہے ۔ٹیبل ا نسرت

 ر ا  ٹیبل کا بٹن لیں ا و ر  خود  بنائیں پھر ا گلا ٹول ا ٓت  کو ٹیبل کو 

 

کے کام ا ئٓے گا۔جبکہ  ختم کرنے سے د

 یلیٹ کا ا ٓپشن ا لگ 

 

  ہے۔ موجود سے د

Already discuss above 
Draw Borders 
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Design: 
 Layout 

Layout 
 ٹول سے 

 

پ کت
پ ل
س

 یٹنگ ٹولز ہیں ۔ سا منے تصویر میں 

 

 میں ٹیبل کے ا ی ڈ

 

ٹیبل لے ا وٓ ت

  لا کی مرا د  ٹیبل 

 

ا  ہے۔ ا س کے بعد گر د

 

 کری

 

پ کت
پ ل
س

 کو د یکھنا۔ یہ ئنزر و  ، سلز، کالم و غیرہ کو 

  ہوتے ہیں جو 

 

 ر ر

 

کو ترتیب میں لکھنے کے لیے سکیل کا کام د یتے ہیں ۔ لیکن  ٹیکسٹو ہ ی ا ر د

  لا

 

 کو د یکھنے کا ٹول کہ کہان پر گرد

 

ے ہیں ۔ ا ن

 

سکی
 لیے جا 

 

 میں بطور  ضرو ر ت

 

ٹ

 

پ
 پر

 

پ ی

 

پ

  لگے 

 

ر

ا مل پرہیں۔ ا س کے بعد ٹیبل کی پرا 

 

 و غیرہ بھی س

 

 ٹ
پ
 ، ہا

 

ٹیز میں ٹیبل کی سیٹنگ ا و ر  ر ج

 ہیں۔

 

 
ک
 کچھ 

 

 یلیٹ کرنے کے لیے یعنی ر و ، کالم، ٹیبل ،ر

 

ا  ح ت  سیلی ڈ  ٹولز میں د

 

 و غیرہ کو ختم کری

 کرلیں ی ا  کرسر ا س 

 

پ کت
پ ل
س

ا  چاہتے ہیں تو ا س ر و  ی ا  کالم کو 

 

ا ٓت  کسی ر و  ی ا  کالم کو ختم کری

 ی ڈ  ر و  کالم، 

 

ر
ک
ا ۔ا س کے لیے ا ٓت  کی بور سیلمیں ر کھیں۔ پھر 

 

ا مل کری

 

  سے ٹیب کی ، س

 

د

  کو 

 

ر
م
ل

ے ہیں ۔ پھر ٹیبل کے ا ندر  موجود  ر و  ی ا  کا

 

سکی
ز ا ی ک بھی ا ستعما ل کر 

پ 
ز ا 
پ 
کرنے کے  ی ا  

 کر لیں۔ ا س   Mergeلیے  

 

پ کت
پ ل
س

کا ٹول ہے ا س کو ا ستعمال کرنے سے پہلے ر و  ی ا  کالم کو 

 ٹیبل کا ٹول ہے ا سی طرج سیلز

 

پ لت
س
 ی ڈ  کے بعد ٹیبل کو ا لگ کرنے کے لیے 

 

ر
ک
 کے ا ندر  

ا مل ہے۔ کے لیےسیلز

 

 سلز کا ٹول بھی س

 

پ لت
س
  

 
ا ر مل مار جنز ہیں

 

 ا و ر  ی

 

 ٹ
پ
 Width & Heightیعنی ا ٓت  ر و  ی ا  کالم کی  ا ٓگے ر و  ی ا  کالم کی ہا

ے ہیں

 

سکی
ے۔ ا پنی مرضی سے ا ستعما ل کر بدل 

 

سکی
 و  ۔ا ٓٹو ٹ  ٹول ا ٓت  کے ٹیبل کو ہیں

 

ڈ

 

و ی

 کر د ے گا۔ی  یعنی سکرین کے مطابق س 

 

 ت

 
  کی سیل ٹیکسٹیہ ٹیبل کے ا ندر  موجود  

 

 نٹ  ہے جہان پر مطوت  ہو  ئنا لا ی ا  نمبرر

 میں ہے۔  نٹ  ہوم ر بنئنکی ا لا ٹیکسٹہے جبکہ  ا لائن نٹ  لیں۔ی ا د  ر کھیں یہ سل 

 
  ٹیکسٹندر  ٹیبل کے ا 

 

ی ت

 

ے ہیں۔ )گھما(کو ر و پ

 

سکی
 ۔ا ہم ٹول ہے یہ 

 
  سے تنا  د و ر  ہو۔ ئنر و  ی ا  کالم کی لا ٹیکسٹیعنی ا ٓت  کا . کے فاصلے و غیرہ سیلز
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 می ن ٹیبل

 

شت
پ ک

 

ی

ا ۔ 

 

 ر  کری
ہ
ا 

 

 و لی ی ا  صعود ی میں ط

 

ز

 

پ
 کر لیں Selectٹیکس کو ترتیب 

 
ے ہیں میں  ٹیکسٹکو ٹیبل ا و ر  ٹیبل کو  ٹیکسٹا س کی مدد  سے ا ٓت  

 

سکی
 ۔تبدیل کر 

 
ل میں 

س
ی ک

ٹیبل کے ا ندر  فار مولون کا ا ستعمال بھی بہت ا ہم ہے ا س کی تفصیل تو ا ٓت  ا 

لیکن کچھ ضرو ر ی فار مولے سمجھ لیں۔ا س ٹول پر کلک کریں گے تو ا تٓ  کو یہ  پڑیں  گے

 sum(above)=فار میٹ ملے گا۔

 

کلک کرنے سے ا تٓ  کے نمبر ر و  ی ا  کالم کی صور ت

 Averageکے بجائے Sum گے ۔ ا گر ا ٓت  ا و ط  چاہتے ہیں تو صرف ئیںمیں جمع ہو جا

ا 

 

ٹ  ی

 

پ
 ,Median, Mode, Maxطرج ر ہنے د یں۔ ا سی طرج کریں ی ا قی فار مولہ ا سی 

Min    چاہتے ہیں 

 

ٹ
ل
 

 

  Ctrl+F9کے بہت سا ر ے فنکشنز لے سکیں گے۔ی ا جہان پر ر ر

ا س کے بعد ا تٓ  ا س میں   ملے گا۔ئنسا {sum(above)=}  کریں۔ا ٓت  کو یہ 

 د ی ا  د یں۔ F9مطلوبہ فار مولہ لکھ کر

 
  کے ا ندر  بہت سا ر ے ا ٓپشنز موجو ہیں ۔ جس میں پہلے خانے بنے 

 

ر

 

ی

 

 پ
پ

 ٹیبل میں 

 

ا نسرت

  پر مشتمل ٹیبل ا ٓت  لے سکیں گے۔ا س کے بعد ٹیبل کو 

 

ر
م
ل

  ا و ر  کا

 

ہوئے ہیں ا تنے ہی ر و  ر

ل سے ٹیبل ا مپو
س
ی ک

ے ہیں۔ا و ر  ا 

 

سکی
 ر ا  بھی کر 

 

 ر ا  ٹول کی مدد  سے د

 

ے ہیں د

 

سکی
 بھی کر 

 

 ر ت
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ن

 

 ش
کی

یہ ٹول ہے تصویر لینے کے لیے۔ ا س پر کلک کرنے کے سا تھ ہی ا تٓ  سے لو

 ا کونٹ  میں ا ٓ جائے گی۔یعنی ئیںپوچھے گا ا ٓت  جگہ بتا

 

 ا و ر  تصویر کا ا نتخات  کریں تصویر د

 ر ا یو سے ا ٓت  تصویر لینا چاہتے ہیں لینے کے بعد

 

 سی د

 

 سک کی کون

 

  د

 

  ا لے  ٹولز ا ٓئیں گےہار د

ا ٓ جائے گا جس کا  Formatکوئی بھی تصویر لینے کے بعد ا س سے تعلقہ  ا ی ک نیا مینو 

 ا ستعمال ا سی تصویر پر ہو گا ۔

 
 ر ا 

 

 کریکٹر کتابون کے لیے د

 

 کی مدد  سے ا ٓت  کار ٹون

 

 کلپ ا رٓ ت

 

 پ
پ

   ا و ر  د و سری تصاو یر 

 

ز
گ

ے ہیں مار کیٹ میں موجود  ہے جن 

 

سکی
 ی بھی لے 

 

لے سکیں گے۔یہ ا لگ سے سی د

گ کے حوا لے سے کام ہے و ہ ا س کو ا ستعما ل کریں۔

 

 ی

 

 لوگون کا کمپور

 
 ا کونٹ  کے ا ندر   Drawingیہ 

 

 می ٹول ہے ا  س کی مدد سے ا تٓ  د

 

مرضی ا پنی کا بہت لار

ی ت  لے سکیں گے ۔ یسا کہ بٹن پر کلک کرنے سے ا ٓت  د یکھ ر ہے ہیں۔ 

 

 کی کوئی س

 
 ا ی  

 

 ا ا یہ د

 

 بنانے کے لیے ا ستعما ل ہوتے ہیں۔ا س میں چھ د

 

  ہیں ی ا  گرا م ا و ر  چار ت

 

ر
ک
گرا 

ل میں کریں گے۔ مختلف ا و ر 
س
 سک
ن

 پر کام ہم ا 

 

ا مل ہیں۔ چار ت

 

 قسم کے چار ٹس بھی س

14 –LECTURE  

 
ا  ہے۔ ا ٓت  کسی ئلیہ ٹول کسی د و سر ی فا

 

 کے سا تھ نک  بنانے کے لیے ا ستعمال ہوی

  ٹیکسٹبھی 

 

پ کت
پ ل
س

 کا ئلکہ ا س ٹول پر کلک کرد یں ا و ر  بعد میں جا کر ا س فاکر کو 
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ا  چاہتے ہیں ۔ا س کا  می بدل جا 

 

 ر یس بتا د یں جس کے سا تھ ا ٓت  نک  بنای

 

گا ۔ ا س کی  ئےا ی ڈ

 کی

 

ا ر ت

 

 Ctrl+Kس

 
 ا کونٹ  میں سے  

 

ے ہیں ۔ ا س کے لیے ا ٓت  د

 

سکی
ا س ٹول کی مدد سے ا ٓت  مطلوبہ جگہ پر جا 

 کر کہ ا س ٹول پر کلک کرد یں ی ا  کی لیں تو ا س ٹول کے ا پٓشن ا ٓ  ٹیکسٹکسی 

 

پ کت
پ ل
س

کو 

ا   جائیں

 

  کر د یں۔ د و ی ا ر ہ ح ت  ا ٓت  ا س جگہ پر جای

 

ا م د ے کر ا ی ڈ

 

گے ۔ ا تٓ  ا س کو کوئی ی

ا م پر کلک کرد یں ۔ ا س  سے ا ٓت  کو مطلوبہ 

 

 ٹیکسٹچاہتے ہیں تو ا س ٹول پر مطلوبہ ی

ا  ہیں  پڑے گا۔

 

 ی

 

ڈ

 

 ھوی

 

 د

 
س کو 

 

ی لی

  کے نمبر ی ا  

 

ز
گ

 

 پ
پ

 ا کونٹ  کے ا ندر  موجود  ہیڈ

 

ا س ٹول کی مدد  سے ا تٓ  ا پنے د

 کر سکیں گے ۔ ا س کے بعد کسی بھی نمبر پر کنٹرو ل کلک کرنے سے ا ٓت  مطلوبہ 

 

ا نسرت

گ پر پہنچ جا یں گے۔ 

 

 AlT+N+RFنمبر ی ا  ہیڈی

 ی ڈ  ر یفرینس ا س کے ی ا ر ے میں 

 

ر
ک
ت  ر یفرینس مینو میں ا ٓا س کا مقصد ہے ر یفرینس کا 

 پڑیں  گے۔

 
ا  پیج  یہ  بہت ا ہم ا پٓشن ہے ۔ ا س کی مدد  سے ا ٓت  

 

ا ت  ی ا  ی ا ٹم پر کتات  کا ی

 

ا م، ئٹلکے ی

 

 ، ی

ا مل کر سکیں

 

ا ر یخ، پیج نمبر و غیرہ س

 

گ کے حوا لے سے خالی ر کھے جاتے ی

 

 ی

 

 گے۔جو کمپور

 میں سے ا ٓت  مرضی سے ا نتخات  ئلہیں۔ ا س میں بہت سے سٹا

 

 تیار  ہیں ا ن

 Alt+V+Hکریں۔

 
کا متباد ل   Footer۔یہ ہیڈر  ا و ر    Alt+N+NUا س کی مدد  سے ا ٓت  پیج نمبر لگا سکیں گے

 فار میٹس بھی موجود  ہیں ۔ مختلف ہے ا س میں 

 
 ر ا  ٹیکسٹ

 

 ی ا کس بہت ا ہم ٹو ل ہے ا ٓت  ح ت  بھی کسی د

 

ی
گ میں 

 

 پ
ی

ا  ٹیکسٹ

 

 ی

 

پ
ا  

 

ٹ  کری

 ر ا  کر کہ 

 

ا  ٹیکسٹچاہتے ہیں تو ا س کو د

 

ٹ  ی

 

پ
ے ہیں۔بٹن پر کلک کرنے سے ا ٓت  کو 

 

سکی
 کر 

  بھی ملیں گے ۔ ا س کے علاو ہ لکھے ہوئے 

 

 کر  ٹیکسٹا س کے بہت سا ر ے ا ندا ر

 

پ کت
پ ل
س

کو 

 Alt+I+Xی ا کس میں ا جٓائے گا۔۔ ٹیکسٹکہ ا س ٹول پر کلک کریں تو یہ خود  بخود  

 
لًا 

 

 ملیں  ا س ٹول کی مدد  سے ا ٓت  بہت سا ر ے ا پٓشنز مپ

 

و ت

 

ن
کور  پیج ا س کے علاو ہ پیج لے ا ٓ

  ہے جس میں  سے  گے پھر ا س

 

ا گلا ٹول فیلڈ کا ہے ۔ فیلڈ ا صل میں ا ی ک خاص کود

  سے  یسپر F9لکھنے کے بعد   ٹیکسٹ

 

 ا ٓ جائے گا۔ ا تٓ  کی بور د

 

ٹ
ل
 

 

 Ctrl+F9 کریں تو ر ر

  ا نٹر {} ا ٓ ئے گائن کریں۔تو ا تٓ  کے سا منے یہ سا یسپر 

 

ا ت  ا س کے ا ندر  ا تٓ  فیلڈ کا کود

 ہن میں ر کھنا ہون 

 

 کے فار میٹس د

 

  ا و ر  ا ن

 

  ر

 

کریں ا س کے لیے ا ٓت  کو بہت سا ر ے کود

لًا گے۔

 

ا ر یخ کے لیے فیلڈ ا یری ا  میں مپ

 

ا ئم   , Date۔ی

 

مصنف کے لیے   Timeکے لیےی

Author و غیرہ 
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 یہ ہیڈ
 
پ

  بنانے کے لیے بنے ہو

 

ز
گ

 

پ
 ئلزسٹا ئے

پ 

 

پ

  ہیں۔کلک کر کہ ا س کے ا ندر  کو

 

شت
پ ک

 

ی

 

ا 

 

 ی

 

پ
 ٹ  کرد یں۔ ا و  کے کرنے سے ا ٓت  کی سکرین پر ا ٓ جائے گا۔

 

 

 

 
 

Word Art options 

 کریں گے تو ا ٓت  کے ی ا س ا ی ک 

 

 ی ا  تصویر ا نسرت

 

  ا رٓ ت

 

 کا ر بن ا ٓت  تصویر میں د یکھ ر ہے ہیں۔ا س کے جون ہی ا ٓت  و ر د

 

  ا رٓ ت

 

ا ضافی مینو ا ٓ جا گی ۔ یسا و ر د

 ٹول ہے جس کی مدد  سے ا ٓت  بنے ہو

 

 ٹ
پ
 

 

   ئےا ندر  پہلے نمبر پر ا ی ڈ

 

 میں ا ٓو ر د

 

  نیا ٹیکسٹر ت

 

ر
ک
ا مل کر سکیں گے۔ا س کے بعد فاصلہ ہے پھر 

 

 ئلسٹای ڈ س

 ، شیڈ، لا

 

 ر ئنہیں۔ میر

 

 ی ا و ر  ا س کے علاو ہ د

 

 ٹینگ ا ینگ   می، ھریی د

 

 کو ا ٓت   ا ی ڈ

 

ا مل ہیں۔ا ن

 

 تفصیل سے پڑیں  گے۔ یکچر   ٹولز س

 

 کے د و ر ا ن

15 –LECTURE  

 Alt+N+ RC  د ے د یں گے ۔ئلا س کی مدد  سے ا ٓت  پیج کے ا و پر کسی لیٹر کو ا ی ک خاص سٹا

 

ا  کہ ا ٓت  کو ی ا ر  ی ا ر  ہ ئل کے لیے ا ی ک سٹائنا س ٹول کی مدد  سے ا ٓت  ا ی ک تو سا 

 

ے ہیں ۔ی

 

سکی
 تیا ر  کر 

ا ئم لینے کا ٹول ہے۔

 

ا ر یخ ا و ر  ی

 

 لکھنا پڑھے۔ ا و ر  د و سرے نمبر پر ی

 

 

 

میں کھول سکیں گے ٘ ا س ٹول کی مدد سے ا تٓ  کسی د و سرے پر و گرا م کو ا ی ک ا و بجیکٹ کی صور  ت

 ر  کلک کرنے پر پرو گرا م بند ہو جائے گا لیکن ا و بجیکٹ ر ہ جا
ہ
 ئے۔ا پنا مطلوبہ ا و بجیکٹ لینے کے بعد ی ا 

 ۔AlT+I+Oگا۔

  میں

 

 کریں ا ٓت  ا یم ا یس و ر د

 

ر ص
ف

ا  چاہتے ہیں تو ا ٓت  ا و بجیکٹ کی مدد  سے جا کر ا یم 

 

ل کا کام کری
س
ی ک

 ا 

ل پر کلک کرد یں تو و ہ پرو گرا م ا ٓت  کے سا منے 
س
ی ک

   کھل جائے گا ا یس ا 

 

ل کا کام ا یم ا یس و ر د
س
ی ک

ا ت  ا تٓ  ا 

 ر  پیج پر کلک کریں تو ا ٓت  کا مطلوبہ کام
ہ
بند  ر ہ جائے گا ا و ر  پرو گرا م و ہیں  میں کریں ا و ر  مکمل ہونے پر ی ا 

 ل کلک کریں۔
ی
 

 

ا  ہو تو ا س  پر د و ی ا ر ہ د

 

 کری

 

 ت

 

یہ بہت کام کا ٹول ہے ا س ہو جائے گا ا گر پھر ا ٓت  کو ا ی ڈ

 پڑتی ہے۔

 

ل کی ضرو ر ت
س
ی ک

  میں ا 

 

ر  ا یم ا یس و ر د

 

کی
 کو ضرو ر  سمجھیں ۔ چونکہ ہمیں ا 

 

گ کر ر ہے ہون یہ  

 

 ی

 

  ی ا  فزکس کے حوا لے کمپور

 

 ت  بھی ا تٓ  ر ی ا ضی کے پیپرر
 می ٹول ہے ۔ ح

 

بہت لار

 گے تو ا ٓت  کو ی ا ر  ی ا ر  ر ی ا ضی کی بہت پیچیدہ  مساو ا تون سے و ا سطہ پڑے گا۔ ا س کے لیے یہ ٹول بہت

۔بلکہ ا س Alt+N+E گے۔ئیںا ر ے ا ٓپشن مل جاا ہم ہے۔ ا س پر کلک کرنے سے ا ُٓٓ ت  کو بہت س

 و  کے سا تھ ا ی ک پور ا 
ی

 

پ ی
م

 ۔ا ٓ جائے گا  
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Assignment: 

 

N o1: Compose your own CV, Format it using drawings, Tables etc 
 
No2. Compose a date sheet of any school using Word art for heading & Table 
 
No3. Design a Title of any book of your own choice Using shapes, shades, colours cover page & 
Text Boxes 
 
No4. Write any five mathematical equations of your own choice 
 
No5. Draw a table of 7x8 (CxR) and compose your monthly budget also use Header & footer. 
 

ا  

 

  میں ا ر د و  کا کام کری

 

 ا یم ا یس و ر د

و ئج  ست  سے پہلے ا تٓ  کو ا ر د و 
گ

 

 پ
لی

ا  ہے ا س کے بعد ا ٓت      

 

ل کری
 پ 
پ

 ا 

 

ل سا Phoneticا ن

 

 پ
ی ی

ا ل کریں گے ا س کے بعد فانٹس کو کاپی کریں ا و ر  کنٹرو ل 

 

شپ

 

ن
ٹ  و ئیر ا 

و   کرد یں ا و ر  ا س جگہ ر ل ای ا ینڈمیں موجود  فانٹس میں پیسٹ
گ

 

 پ
لی

 کی پریکٹس کریں ا و ر  ئج 

 

ل کر د یں۔ا س کے بعد ا ٓت  ا ر د و  لے ا وٓ ت
 پ 
پ

کے ا ٓپشن میں ا ر د و  ا ین ا 

ا 

 

ی ی ا ر  ی ا ر  ی
 
چ
ہ

 

ن

 ا ر د و  حرو ف 

 

پ
 کر سکیں۔ا یم ا ٓفس کے ا ندر  تمام ٹولز کو ا ٓت  ا نگلش ا و ر  ا ر د و  د و نون کے لیے ا ستعمال 

 

 کی پہچان

 

ا  کہ ا ٓت  ا لفاظ

 

ے ہیں۔ ٹ  کریں ی

 

سکی
 کر 

 

LECTURE – 15 

 
Page Layout:      Alt + P 

 لکھیں ئنکا سا  Type Equation Hereپہلے تو ا ٓت  کو 

 

 ملے گا ا س میں ا ٓت  ا پنی مطلوبہ مساو ا ت

 و  میں موجود  ہے د یکھیں۔ا ٓت  کے 
ی

 

پ ی
م

ا و ر  ا س پر جو ٹول ا تٓ  کو چاہیے ہو گا و ہ ا و پر نیو ا نٓے و ا لی 

 ا سا منے پہلا ا ٓپشن ہے جس میں پہلا مساو 

 

 موجود  ہیں  ت

 

  کیا ہو جس میں کچھ بنی ہوئی مساو ا ت

 

کا ا ندا ر

ے ہیں۔پھر ا ٓگے مساو 

 

سکی
 کو ا ٓت  لے 

 

 کو ا ا ن

 

ر کھنا ہے ی ا  پھر عام  Liner or Professionalت

 موجود  ہے فار میٹ میں ا و ر  ا ٓگے ٹول پر کلک کریں تو ا س کی سا ر ی سیٹنگ  ٹیکسٹ

 

 ر  ہے ا ٓت  کو ر ی ا ضی کی 
ہ
ا 

 

 میں ط

 

 چاہیے ہون گی تو سا منے  مختلف کسی بھی مساو ا  ت

 

علامات

 
پ 
م
س

 

 

ز
ل

( 

 

 ہو جائیں گی۔ا تٓ  کو مساو ا تیں لکھنے کے  (علامت

 

موجود  ہیں کر سر جہان ہو گا و ہان پر ا نسرت

  ، ی ا و ر  میں پھر جز ر  میں تمام ا ٓپشن موجود  ہیں ۔فار میٹس ملیں گے جس میں کسر میں لکھنامختلف لیے

 

 

  ا س کی 

 

 ا نسٹرکٹر ر

 

  ا و ر  ر ی ا ضی کی مختلف مساو ا تون کی پریکٹس کرو ا ئیں۔ئیںپور  مشق کرو ا بھرکلاس کے د و ر ا ن

 لینے کے لیے۔

 

 میں  Alt+I+sعلامات

 

 ا ٓت  کو ا لگ سے ملیں گے ا ن

 

میں  Fontsیہ علامات

Webdings ملیں گے ۔ 

 

 لیں تو ا ٓت  کو مختلف علامات

 

 ر  ہے کے یہ پور ے 
ہ
ا 

 

ا م سے ط

 

ا مل ہیں ۔ ح ت  ا تٓ   کی پور  ے پیج ،کی سیٹنگ ہے  پیجیسا کے ی

 

  و غیرہ ست  ا س میں س

 

ڈ

 

  ، بیک گرا و ی

 

 ر

 

سیٹنگ ، ی ا ر د
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 ہ ہو گا کہ یہ تنا  ا ہم ہے ۔

 

ٹ  ا ٓت  کو ا س کا ا ندا ر

 

پ
 پرو فیشنل ہو جائیں گے تو 

 
ا مل ہے۔یہ 

 

 و غیرہ س

 

ٹ

 

پ
 ا کونٹ  کا تھیم ہے جس میں پیج کا  می، فا

 

۔ا س کا Alt+P+THپور ے د

 ا کونٹ  پر ا تٓ  ا ی ک بنا ہوا  تھیم لیں ا و ر  کام جلدی نمٹا لیں پھر ا س ئدفا

 

ہ یہ ہے کہ کسی بنے ہوئے د

ے ہیں۔

 

سکی
 میں ا ٓت  تبدلیاںن بھی کر 

 

ے ہیں ی ا  ٹم ئیں، ی ا ئیںیہ پیج کے د ا 

 

سکی
ا ت  ، ی ا ٹم کے مار جنز ہیں جو ا تٓ  بنے ہوئے بھی لے 

 

، ی

 کر سکیں گے۔ ا س سے مرا د  پیج کا و ہ حصہ ہے جس میں ا ٓت  

 

ہیں   ٹیکسٹا ٓپشن میں خود  بھی سی ت

ا 

 

 ی

 

پ
ا  چاہتے۔

 

ہیں   ٹیکسٹمار جن سے مرا د  ہے پیج کا و ہ حصہ جہان پر ا ٓت  ۔ Alt+P+Mٹ  کری

ا  ہے لیکن ا ٓ ت  ا پنی مرضی سے  1لکھنا چاہتے ۔ عام طور  پر چار  و ن طرف سے 

 

ا نچ کا مار جن ہوی

ے ہیں۔

 

سکی
 کر 

 

 سی ت

 
ے ہیں ا ی ک لینڈ 

 

سکی
 ہے ا ٓت  د و نون میں سے کوئی ا ی ک لے 

 

ا س میں تین ا ٓپشن ہیں پہلا پیج کا ر ج

 ی ا د ہ تر ا ے فور  

 

 پیج لینا چاہتے ہیں ۔ر

 

ٹ
ل
 یفا

 

سا  د

 

ن
۔ د و سرا  ا ٓپشن  ہے کہ ا ٓت  کو

 

 ٹ
پ
سکیپ ا و ر  د و سر پوٹر

 ا و ر  لیٹر سا 

 

پ
ا  ہے ا و 

 

  کا ا ستعمال ہوی

 

  میں لکھنا چاہتے ہیں تو ا نتخات   ٹیکسٹر  ا س کے بعد ا ٓت  ا گر ز

 

ر
م
ل

کو کا

ا 

 

  کے لیے بہتر یہ ہے کہ ی

 

ر
م
ل

 ہو گی۔کا

 

 ا ت  میں بیان

 

 کر لیں۔ا س کی تفصیل پیج سی ت

 

پ
ٹ  کرنے سے 

 کر د یں ا س کو ا ٓت  

 

ن

 

ش

 

پ ی
م

 ا ٓسا نی ہو گی۔ سےپہلے ہی کالم 

 
کو ا ی ک جگہ سے د و سری جگہ جفت پیج پر ی ا  طا ق  ٹیکسٹئےا س سے مرا د  ہے کہ ا تٓ  ا پنے لکھے ہو

 Alt+I+Bپیج پر بھیج سکیں گے۔

 
 ر  لا
ہ
ے ہیں ا  س میں مختلف ا ٓپشن موجود  ہیں کہ ا ٓت  یہ ئنا س ٹول کی مدد  سے ا تٓ  

 

سکی
 کو نمبر د ے 

 ر  پیج کے لیے ہیں  عمل جا ر ی ر کھنا چاہتے 
ہ
 نمبر لینا چاہتے ہیں۔ نیوی ا  

 
 یش د ے د یں گے جس سے یہ  ٹیکسٹ میں جانے و ا لے ئنا س کی مدد  سے ا ٓت  د و سری لا

 

کو ا ی ک د

  د و سری لا

 

 ر  ہو گا کہ ا ی ک لفظ کے کچھ لیٹرر
ہ
ا 

 

 Alt+P+H میں ہیں۔ئنط
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 گے۔ پہلا ا ٓپشن ہے پیج کی سیٹنگ کر سکیں یہ بہت ضرو ر ی ا ٓپشن ہے۔ ا س کے ا ندر  ا ٓت  ا پنے

،ی ا ٹم،  ا ت 

 

ے ہیں کہ ا س میں ا ٓت  کے پیج کے ی

 

سکی
 کے فاصلے د یے ئیں ا و ر  ی ا د ا ئیںمار جنزا ٓت  د یکھ 

  ما ر جنز س ئےہو

 

 ی ا د ہ کر سکیں گے۔ سٹینڈر د

 

 کو کم ر

 

 ئےا منے لکھے ہوہیں۔ہاںن سے ا ٓت  ا ن

 چار و ن ا 

 

 مار جنز سے مرا د  ہے کہ ا ٓت  ا ن

 

 ہیں۔ا صل میں ا ن

 

کر  طرا ف میں ا تنا مار جن چھور

 پر ہے کہ ا تٓ  ا پنی مرضی سے ا س

 

ا  چاہتے ہیں۔ا ت  ا ٓت  کی ضرو ر ت

 

ٹ  کری

 

پ
ا 

 

ے  ی

 

سکی
 ی ا د ہ کر 

 

کو کم ر

 پر بھی آت ر کھنی ہے۔ا سی جگہ

 

 ا کونٹ  کی بناو ت

 

 ا ی ک ا پٓشن ہے ٹر  ۔ ا س ہیں ۔ لیکن ا ٓت  نے د

  سے مرا د  پیج کا ی ا 
ی

 

ی
گ حصہ ہے۔ یہ ٹول کتابون کی جلد بندی 

 

 ی

 

ڈ

 

ا س حصہ میں بھی  کام ا ئٓے گا۔میںپ

ٹ  

 

پ
ا 

 

پ

 

سی
پ ک

 

پ

 بدلنا ۔ ا ٓت  کےہیں  ہو گا۔ 

 

ہو گا کہ ا ی ک پیج کا د و  طرج کا  میں  علما گلا ا ٓپشن ہے پیج کا ر ج

 کیا جا سکتا ہے ۔ د و نون سا منے لکھے ہو

 

ا س پر کلک کر د یں۔ا گر ا تٓ   ہیں جو ا ٓت  کی مطلوبہ ہے ئےر ج

 پر

 

ٹ
ل
 یفا

 

 ت  کا پیج ا سی فار میٹ میں ھلے کلک کر د یں تو ا نٓدہہ ا ٓہاںن سے سا ر ی سیٹنگ بدلنے کے د

لا ا ٓپشن ہے پیپر کا ا نتخات  ، ا س کی مدد  سے ا ٓت  ا پنے پیج کا ا نتخا
ے ہیں کہ جس پیجگا۔ا گ

 

سکی
پر ا ٓت   ت  کر 

 ی ا د ہ تر ا ستعمال ہونے

 

 نکالیں گے۔ ا س میں ر

 

ٹ

 

پ
گ کے بعد پر

 

 ی

 

 یل ہیں۔ کمپور

 

 د

 

و ا لے پیج د ر ج  

Letter: 8.5x11 inch. 
A4: 8.27x11.69 inch 
Legal :8.5x 14 Inch 

ا  

 

 کرنے سے پہلے پیج کی سیٹنگ کری

 

ٹ

 

پ
ے ہیں۔ ی ا د  ر کھیں پر

 

سکی
ا س کے علاو ہ ا تٓ  ٹم پیج بھی تیار  کر

  

 

 ہو۔چونکہ ا س پرو گرا م میں سٹینڈر د

 

 ح ت  ا ٓت  کو ضرو ر ت

 

ٹ
ق
بہت ضرو ر ی ہے۔ لیکن ا س و 

ر  لوگ ا سی کا ا ستعمال  د سیٹنگ بھی موجو

 

کی
گ کے بعد ہوتی ہے ۔ ا 

 

 ی

 

کرتے ہیں۔ یعنی لیٹر پیج پر کمپور

 نکال لیتے ہیں۔و غیرہ۔

 

ٹ

 

پ
 ا سی پر پر

  

 

 ہے ۔ یعنی پیج کے ی ا ر د

 

ے ر ا گلا ا پٓشن لے ا وٓ ت

 

سکی
  و غیرہ۔ تو و ہ بھی ا ٓت  ہاںن ا ٓسا نی سے ا ستعمال کر 

 

ر

 کریں۔ہیں۔

 

ٹ

 

پ
 و یو میں ی ا ر  ی ا ر  د یکھیں ا و ر  پھر پر

 

ٹ

 

پ
 ا کونٹ  کو پر

 

 کرنے سے پہلے د

 

ٹ

 

پ
 پر

 

 
  میں و ا ٹر مار ک تصویر ی ا  

 

ڈ

 

ے  ٹیکسٹو ا ٹر مار ک :ا س کی مدد  سے ا ٓت  پیج کے بیک گرا و ی

 

سکی
ا مل کر 

 

س

  میں لگے ہوتے ہیں۔ہیں۔

 

ڈ

 

س کے بیک گرا و ی

 

پ ی
 فک
ی

 

پ

ا س کے نیچے پیج کا  می جو  یہ عام طور  پرسر

 ر ا و ر  شیڈ  می ا و ر  

 

  کی تفصیل ہے۔جو ہم  ٹیکسٹصرف سکرین پر ا ٓئے گا ۔ ا س کے بعد پیج کا ی ا ر د

 

 ر ر

 

ی ا ر د

 پڑھ چکے ہیں۔
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ا  ٹیکسٹپہلے 

 

 ہے ج ڈ ھر سے ا تٓ  ی

 

 کا ر ج

 

پ
 ر  
ہ
ا  چاہتے ہیں۔ ا س کے بعد 

 

ٹ  کری

  ا و ر  ا ختتام کا فاصلہ ہے۔ ا س کے بعد ٹیب کی

 

 یشن ہے۔ پیرا گرا ف کے ا غٓار

 

 پور

ن میں فاصلے موجود  ہیں ا و ر  ا سی جگہ پیرا گرا ف میں فاصلے ئنوا و ر   بعد میں لا

 یا ا ٓگے ا ئٓیں گی۔ ا ٓگے پیرا گرا ف کی سیٹنگ 

 

ا ر ت

 

 کی س

 

بھی موجود  ہیں۔ا ن

 سا ہے۔

 

 ر  بھی ہیں ا و ر  ا ن
ہ
 پیرا گرا ف کے ی ا سک میں بھی سا نے ئیڈیہ ا پٓشنز ی ا 

 تفصیل سے موجود  ہیں۔

 

 

 

 

 کی ت
 پ
 ج
ن

گ ٹول ہے ا س کی مدد  سے ا ٓت  لیے ہویہ ا و 

 

 پ
ی

 

 پ
پ
 

 

کو  بجیکٹا و  ئےا ی ڈ

سا و ر  ا ٓگے کر سکیں گے ۔ ا س کے علاو ہ مختلف ا و  پیچھےد و سرے کے 

 

 پ کی
 ج
ن

کو ا کٹھا  

 ی ا د ہ  بھی کر سکیں گے۔

 

 گرو ت  ا س کے لیے ا ٓت  ا ی ک سے ر

 

یعنی گرو ت  ا و ر  ا ن

 کریں گے ا س کے سا تھ 

 

پ کت
پ ل
س

س کو 

 

 پ کی
 ج
ن

  ہو گی   Shiftا و 

 

 کی یو ر

  میں موو  کرو ا نے کے ا پٓشنز ہیں جن کو پھر ا 

 

 ر ا ئنگ کو مختلف ا ندا ر

 

س میں کسی د

 ا و ر  ا لا ٹیکسٹ

 

ی ت

 

ا  مل ہیں ئنکے سا تھ ا ستعما ل کیا جاسکتا ہے۔ پھر ر و پ

 

 بھی س

 یشن کا ٹول ہے کہ کسی تصویر کو 

 

کی کس  ٹیکسٹ۔ا س میں پہلے نمبر پر پور

 یشن پر ر کھنا ہے ۔

 

 ا ٓپشن ہیں کلک کریں توپور

 

 ا ٓت  کو پتہ چل ا س میں سی ت

 جائے گا۔

 

 
Assignments: 
 
No1. Using Theme, A4 page settings, landscape page, page color, and watermark prepare a 
stylish document 
 
No2. How can you group three different objects of insert shapes? 
 
No3. Write a paragraph and format it also give it indent and space margins? 
 

_____________________ 
 
 

 

 

 

LECTURE – 17 
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References Ribbon:                                                                             Alt+S 

 ے پیچیدہ ہیں 

 

 ر ا  غور  سے سمجھیں کیونکہ ا س کے بعض ٹولز تھور

 

 و  کو د
ی

 

پ ی
م

 ۔ا س 

LECTURE – 18 

 

ا  ہے ا س کے 

 

ا م ا و ر  ا س کے پیج نمبر کے لیے کتابون میں ا ستعمال ہوی

 

ا ی ک کے ی

 

 ر  پیج پر موجود  کسی ی
ہ
یہ ا ٓپشن 

گ پر کلک کر د یں تو 

 

ا  ہوتو صرف ا تٓ  ا س ہیڈی

 

ا ی ک پر جای

 

ت  و ہان پہنچ جا یں گے۔ا س ا ٓبعد ح ت  ا ٓت  کو ا س ی

ا ت  ہیڈ

 

 کے لیے ا ٓت  ا پنے پیج کی ی
 
پ

  

 

 و  میں موجود  ٹول ا ی ڈ
ی

 

پ ی
م

 کر کہ ا س 

 

پ کت
پ ل
س

  کو 

 

ز
گ

 

پ
پر کلک کرد یں  ٹیکسٹ

 ر  ا ی ک کے لیول بتا تے جا
ہ
  ۔بعد میں جہان پر ا ٓت  کو یہ ٹیبل یعنی ہیڈز ک کا ٹیبل چاہیے ا تٓ  ئیںا و ر  

Table of contents  

 

   Table of Contentsپر موجود  ا نسرت

 

پر کلک کرد یں تو ا ٓت   کے ی ا س ا ن

 سا ر ی ہیڈ
 
پ

 
گ

 

پ
 

 

گ پرکنٹرو ل  کلک کر د یں تو ا تٓ   ز

 

 میں سے کسی ہیڈی

 

کا ا ی ک ٹیبل ا ٓ جائے گا ا س کے بعد ا ٓت  ا ن

 ی ا  ا سباق کی 

 

ا ت

 

 ر  کتات  کا حصہ ہے جس میں تمام عنوا ی
ہ
خود  بخود  و ہان پہنچ جایں گے۔ا س کے علاو ہ یہ 

 ہوتی ہے ۔ا 

 

 ی ا ٓسا نی سے بنا سکیں گے۔فہرست

 

ز
پ 
ا و ر  ا س  سے ا ٓگے لیولز کے س کو ا ٓت  ا س ٹول کی مدد  سے 

 Table ofکا ٹول ہے ا گر ا ٓت  نے بعد میں کتات  میں ا ضافہ کیا تو ا ت  د و ی ا ر ہ Update Tableبعد  

contents  ہیں  صرف جا کر 

 

پر کلک کریں ۔ ا س کے لیے ا تٓ    Update Tableبنانے کی ضرو ر ت

 ا کونٹ  

 

ا  چاہیے۔کے د

 

 میں پیج نمبر لگے ہوی

Lec-18 

 ا کونٹ  کے ا ندر  کسی بھی 

 

کا ر یفرینس پیج  ٹیکسٹیہ بھی ا ی ک ر یفرینس ٹول ہے ا س کی مدد  سے ا تٓ  ا پنے د

 ر  کر سکیں گے۔ ا س کے لیے ا ٓت  جس 
ہ
ا 

 

کے تعلق  ر یفرینس د ینا چاہتے ہیں  ٹیکسٹی ا  سیکشن کے ا خٓر میں ط

 ا کونٹ  کے ا خٓر میں ا ی ک چھوٹی سی لاین ا ٓ جائےگی ا و ر  

 

 کر کہ ا س ٹو ل پر کلک کر د یں تو د

 

پ کت
پ ل
س

ا س کو 

 شدہ 

 

پ کت
پ ل
س

 ٹیکسٹسے تعلق  کوئی معنی ی ا  کوئی ا و ر   ٹیکسٹپر نمبر لکھا ہوا  ملے گا ۔ ا ت  ا ٓت  ا س  ٹیکسٹ

ٹ  ا س لائن کے نیچے 

 

پ
ا 

 

ا  ہے ۔ کر د یں۔یہ  ی

 

ر  کتابون میں ا ستعمال ہوی

 

کی
 ا 

 

 ا کونٹ  کے ا خٓر میں

 

ر یفرینس د  ے سکیں گے۔ ا س کے   یہ ٹول بھی ا سی طرج کا ہے ا س کی مدد  سے ا تٓ  د

 پر جا

 

 ا و ر  علاو ہ ا لے  ٹول کی مدد  سے ا ٓت  مختلف ٹ  نوٹس کو د یکھ بھی سکیں گے ا و ر  ا ن

 

 سکیں گے۔ٹ  نوت

 بنیاد ی طو ر پر

 

 پیج کے ا خٓرمیں جبکہ ا ینڈ نوت

 

  ا ی ک ہی کام کرتے ہیں لیکن ٹ  نوت

 

کتات  کے ا خٓر  ا ینڈ نوت

 میں حوا لہ د یتا ہے۔

 

 و  کا علق  ر یفرینس کے سا تھ ہے ا س لیے یہ ا ی ک ا و ر  ر یفرینس کا ی ا و ر  فل ٹول ہے ا س کی 
ی

 

پ ی
م

ا  س پور ی 

ا ر یخ کے حوا لے سے ر یفرینس د ے سکیں گے ۔ 

 

 ا کونٹ  ی ا  پیرا گرا ف کے سا تھ ا س کا ی

 

مدد  سے ا ٓت  کسی د

ا ر یخ، کتات  ی ا  کسی د و سر

 

 نقل کی ہے کا جیسے مصنف، ی

 

ے حوا لے سے جہان سے ا تٓ  نے یہ ی ا ت

 ا نٹر کریں گے  Manage Soursesر یفرینس د ے سکیں گے۔ پہلے ا ٓت  

 

کی مدد  سے ا ٓت  تعلقہ  معلومات

 کر سکیں گے ی ا   Biblographyا س کے بعد ا ٓت  و ہ ر یفرینس

 

کی مد  Insert citationکی مد د سے ا نسرت
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ا  سا  حوا لہ  د  سے

 

 کر  ا س کا چھوی

 

 MLA & APAا س کا سٹائل بھی موجود  ہے ا س میں سکیں گے۔ا نسرت

ا  ہے ۔

 

 ی ا د ہ ا ستعمال ہوی

 

 ا تٓ  کسی د و سری جگہ نقل ر

 

 کی کوئی ی ا ت

 

یہ کتابون میں حوا لے ی ا  جیسے ا خبار ا ت

 

 

 کہان پر ، کب ، کس نے کی ی ا  ا ٓت  یہ ی ا ت

 

کرر  ہے ہیں تو ا خٓر میں ا ٓت  ا س کا ر یفرینس د یں گے کہ یہ ی ا ت

 

م

ا  ہے پھر ا ٓت  کہان کس کتات  ی ا  

 

  کیا جای

 

 کو پہلے ا ی ڈ

 

 ہیں ا ن

 

 ین سے لے  ر ہے ہیں۔جو حوا لاجات

 

ز
پ گ

Biblography  کر سکیں گے۔ 

 

 ٹول کی مدد  سے مختلف فار میٹس میں ا نسرت

 

  کا ر یفرینس د ے سکیں گے۔

 

ز
گ

 

 پ
پ

 ر ا 

 

 table1, Fig 1 ا ی ک ا و ر  ر یفرینس ٹول ا س کی مدد  سے ا تٓ  تصاو یر ، د

, Dg2 کا ٹیبل جیسے ا ٓت  نے ا و پر پڑھا ہے بھی تیا ر  کر سکیں گے۔ 

 

ا  ا  س کے بعد ا ٓت  ا ن

 

ر  کتابون میں ہوی

 

کی
ا 

 فلان 

 

  Fig1ہے کہ ا س کی و ضاحت

 

ا  ہ پڑے بلکہ جہان بنی ہیں۔  Figsمیں ہے تو ا ٓت  کو ی ا ر  ی ا ر  ا ن

 

کو بنای

 سمجھ جائے گا۔

 

ے و ا لا بھی ی ا ت

 

ھی
 ہوجائے گا ا و ر  پڑ

 

 پر ا ٓت  ا س کا ر یفرینس بتا د یں تو ا ٓت  کا کام ا ٓسا ن

 

 ضرو ر ت

 کا ا لگ سے بھی  Tablesی ا   Figsپھر ا ٓت  کے ی ا س ا گر بہت سا ر ے 

 

ے ہیں یسا بنا  Tableہیں تو ا ٓت  ا ن

 

سکی

 میں د یکھا ۔ Table of contentsہم نے 

ہے ا  س کی مدد  سے ا ٓت  ا ی ک ر یفرینس کا د و سرے کے سا تھ بھی  Cross Referenceا س  کےنیچے 

ا  ضرو ر ی ہے جن کو ا تٓ  

 

ے ہیں ا س کے لیے ا تٓ  کے ی ا س پہلے سے مختلف ر یفرینس کا ہوی

 

سکی
ر یفرینس د ے 

 پرھ 

 

 سکتی ہے۔نک  کر یں گے ۔ ا س کی بھی ضرو ر ت

 

 

 ٹولز کی مدد  سےا تٓ  

 

 کو   Table of Contentsی ا  ہیڈز ک کے  ٹیکسٹا ن

 

تیا ر  کر سکیں گے ا و ر  بعد میں ا ن

 کر سکیں گے۔مار ک 

 

کے لیے    Citationکی مد د  سے ا ٓت   Citation  پہلے ٹولز کی مدد  سے ا ٓت  ا نسرت

 ا نٹر کر سکیں گے۔ ٹیکسٹ

 
Assignments: 
 
No1. Using your Document make table of contents for five Headings and then insert it on page 
NO0. 
 
No2. Apply these tools on your document footnote, Endnote, citation etc? 

__________ 

 

LECTURE – 19 

Mailings:                                 Alt+M 

 
INTRODUCTION TO MAIL MERGE: 
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  و غیرہ 

 

 یٹا بیس ا پٓشن ہے ا س کی مدد  سے ا تٓ  ا ی ک ہی لیٹر ی ا  ا ی میل ی ا  کوئی کار د

 

 ا ی ک بہت ی ا و ر  د

 

ے ہیں ی ا  ا یسا  مختلفمیل مرج

 

سکی
 بھی کر 

 

ٹ

 

پ
ا مون سے پر

 

 ٹیکسٹی

 ی کاجس 

 

ے ہیں۔ ٹیکسٹی ا د

 

سکی
ے ہیں ا و ر  ا ی میل بھی کر 

 

سکی
 بھی کر 

 

ٹ

 

پ
 ر یس مختلف ہو ۔ ا س ٹول کی مدد  سے ا تٓ  و ہ پر

 

ا م ی ا  ا ی ڈ

 

 و غیرہ تو ا ی ک ہی ہو لیکن صرف ی

 کر سکیں

 

ٹ

 

پ
ا مون سے پر

 

 ی ا ٓسا نی سے تیار  کرنے کے بعد مختلف ی

 

ز
پ 
   

 

 کار د

 

ٹ
ل
 

 

ہاںن پر ہم ا ی ک  گے۔ ا س ٹول کی مدد  سےا ٓت  لیٹر، ا ی میل، خط کا لفافہ، لیبل ا و ر  ر ر

  

 

 کار د

 

ٹ
ل
 

 

 کو ا پنالیتے ر ر

 

 یل ا قدا ما ت

 

 د

 

 ۔ئیںہیں۔ا س کے لیے د ر ج

۱  

 

 کار د

 

ٹ
ل
 

 

ت  سے پہلے کوئی خط ی ا  ر ر
لًا۔بنائیں۔ س

 

 ۔مپ

 

Moon creation school of IT 
Muzaffarabad AJK 

 
Result Card 

Name:   
Roll No:   
Class:   
RegdNo:   
 

Subjects Total Marks Obt. Marks Remarks 

English 100 52 Pass 

Urdu 100 53 Pass 

S.Study 100 57 Pass 

Math 100 61 Pass 

Physics 100 74 Pass 

Chemistry 100 59 Pass 

Bio 100 69 Pass 

Islamic study 100 70 Pass 

 
Principal _______________________   

  ی ا ۲

 

س کی مدد  سے بنا ۔ پھر ا ٓت  ا ی ک د و سرا  ٹیبل ا ہم ا یس و ر د

ش
ی ک

ل ی ا  ا 
س
ی ک

ر ا د  ی ا  طلبا کے لیے ا ٓت  نے یہ پر، ئیںا 
ف
  کرنے ہیںجن ا 

 

ٹ

 

پ
 

Name Roll NO Class Regd. No 

Muhammad Ali 100 10th PPS-220 

Nasir khan 101 10th PPS-225 

Shakoor Ahmed 102 10th PPS-226 

Kamran Ahmed 103 10th PPS-227 

Ghafoor Ali 104 10th PPS228 

Zubair 105 10th PPS-229 

 ا کونٹ  کے فیلڈ ا و ر  ا س ٹیبل کے تمام فیلڈ ا ی ک ہی ہون۔جیسے ا و پر ہیں۔ ئے۔ ی ا  د  ر کھیں ا ٓت  کے بنے ہو۳

 

 د

 و  میں موجود  ۴
ی

 

پ ی
م

  کو فالو کریں۔ Step by step mail mergeخری ٹول ا ٓمیں   Start Mail Merge۔ ا ت  ا تٓ  

 

 ا ر د

 

 پر کلک کر د یں۔ا و ر  و ر

  میں موجود  لیٹر پر کلک کر د یں ا و ر  ا خٓری ٹول ۵

 

 ا ر د

 

 پر کلک کریں۔ Next :starting document۔ا س و ر

 پر کلک کریں۔ Select recipientsپر کلک کریں ا و ر  پھر  Use the current document۔ا س میں  ۶

 تما م ا و ر  ا  س ٹیبل کا کریں پر کلک   Browseپر کلک کرنے کے بعد Use an existing list۔ا ت  ۷

 

 ر یس د یں جو ا تٓ  نے پہلے بنا ی ا  تھا۔ یعنی جس کے ا ندر  ا ن

 

 ا ی ڈ

 یٹا سیو ہے۔ا س کے بعد  

 

ر ا د  کا د
ف
س میں بھی ہو سکتا ہے ۔ پر کلک  Write Your Letterا 

ش
ی ک

ل ی ا  ا 
س
ی ک

  ہی میں بنا ی ا  ہے ا 

 

 کریں ا س ٹیبل کو ہم نے و ر د

لًا۔ ۸

 

  مپ

 

 فیلڈر

 

 کرتے جا نےا منے ا پنا کرسر ر کھ د یں ا و ر  ی ا ر ی ی ا ر ی ا ٓکے س Name, Roll No, Class etc۔ا ت  ا تٓ  ا ن

 

ا م ا نسرت

 

 ۔ئیںو ا لی لسٹ کے ی
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    Complete the merge۔ ا س کے بعد ا ٓگے جاتے ہوئے۹

 

ٹ

 

پ
ا  ہے تو پر

 

 کری

 

ٹ

 

پ
پر کلک کر د یں ا و ر  ا نٓے و ا لی لسٹ میں ا لٓ پر کلک کرد یں۔ا و ر  ا س میں ا گر پر

 کریں۔ کو کلکEdit individual itemsپر کلک کرد یں ی ا  

  ا ٓ چکے ہیں۔   Preview the letters۔ ا س کے بعد ۱۱

 

ر ا د  کے لیےا لگ ا لگ کار د
ف
 تمام ا 

 

 د یکھیں ۔ا ٓت  کے ی ا س ا ن

 

ٹ
ل
 

 

 پر کلک کر کہ ر ر

 ا س ا پٓشن سے ا و ر  بھی بہت سا  کام لیا جا سکتا ہے ۔

Assignment: 

A). Compose a Wedding invitation card، using Mail merge send it to 10 different friends۔ 

 

LECTURE – 20 

 
 Review Ribbon:      Alt +R 

   

 ی  ئےا س ٹول کی مد د  سے ا تٓ  لکھے ہو

 

ز
پ 
پ ک کر سکیں گے۔ا س کے  ٹیکسٹا نگر  

ح
کے سپیلنگ 

و لیے ا ٓت  ما

 

ن
ے ہیں ۔ یعنی غلط لفظ پر ر ا 

 

سکی
 س بھی ا ستعمال کر 

 

پ
 کلک کریں تو ا ٓت  کو ا پٓشنز مل 

 

ٹ

 کر د یں۔ Alt+f7د یں تو لسٹ کو فالو کریں۔ ی ا    کر  گے۔ ی ا  پھر ا س ٹول پر کلکئیںجا 

 

 ٹولز کی مد د 

 

 ا کو نٹ  کا جاسے ا ٓا ن

 

 ت  ا پنے د

 

ز

 

پ
 ی ا  

 

 Thesaurus andہ لیں گے۔ ر یسرج

Translate    ٹولز کی مدد  سے ا ٓت 

 

پر تحقیق کر یں گے ۔ ا س کے  ٹیکسٹSelectedا ن

 بھی کر سکیں گے

 

 ا کونٹ  میں ا نسرت

 

 کو ا پنے د

 

 سکیں گے۔ا و ر  ا ن

 

۔ا سی جگہ مترا د ف جان

 کے تعلق  ٹو ل بھی ملیں گے۔

 

 ی ا ن

 

 ا و ر  ر

 

ٹ

 

پ
  کاو 

 

 کی تعدا د  ا ٓت  کو و ر د

 

جن سے ا ٓت  ا لفاظ

 سکیں گے پیرا گرا ف ا و ر 

 

 جان

 

 ۔معلوما ت

 

 د یں سکیں گے۔ ا ی ک سے  ٹیکسٹا س ٹول کی مدد  سے ا تٓ  کسی 

 

ت

 

می
ک
کے ی ا ر ے میں کوئی 

 پڑنے  پر د یکھ سکیں گے ا و ر  ا ٓگے پیچھے بھی کر سکیں گے۔

 

 کو ضرو ر ت

 

 ی ا د ہ بھی پھر ا ن

 

یعنی ا ی ک ر

  پر جا سکیں گے پھر 

 

 میں ا ن

 

 ہونے کی صور ت

 

ت

 

می
ک
 ی ا د ہ 

 

کا ا ٓپشن بھی موجود   Deleteسے ر

 سے ا تٓ  

 

 یلیٹ کریں گے۔ Selected commentsہے ا ن

 

 کو د

 

 ا کونٹ  کے ا ندر  کی 

 

 ٹول کی مدد  سے ا ٓت  د

 

 ا ن

 

ئ

گ

لا ا ی ک  

 

 ہ لے سکیں گے۔ مپ

 

ز

 

پ
 و ن کا جا

ی لی
تبد

 ا کونٹ  تیار  ہونے کے بعد ح ت  ا س پر ٹری ک 

 

 کر د یتے ہیں۔ ا ت  ا ٓت  ا س میں سے  چینجد

 

ا ٓن

 تبدیل 

 

ٹ

 

پ
لا بولڈ ی ا  فا

 

  کریں،فار میٹ کے ٹولز مپ

 

س ا ی ڈ

 

ی

 

مپ
ک

 کریں، 

 

 یلیٹ کریں ، ا نسرت

 

ا گر د

ا ئم کو 

 

ا ر یخ ا و ر  کس ی

 

 ر  نے کس ی

 

سا  کام کس یور

 

ن
  ا ٓت  کو ملے گا کہ کو

 

 ست  کا ر یکار د

 

کریں و غیرہ ا ن

و ن کو قبول ی ا  ر د  
ی 
ی ل
 تبد

 

ے ہیں یہ تمام ٹولز سا منے موجود   ہیں ۔یہ کیا۔ ا س کے بعد ا تٓ  ا ن

 

سکی
کر 
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س  میں کام کرنے 

ک

 

 پ
ی ی

 و ر کس جیسے ا ٓفس ا و ر  

 

ی ت

 

ٹول بہت ا نٹرسٹنگ ہے۔ا س کے علاو ہ پ

  کے لیے بہت ا ہم ہے۔

 

 منسٹریٹر ر

 

 و ا لے ا ی ڈ

 ا کونٹ  

 

ا  کہ د و سرا  ا ٓت  کے د

 

ے ہیں ی

 

سکی
  د ے 

 

 ا کونٹ  کو ی ا س و ر د

 

ا س کی مدد  سے ا ٓت  ا پنے  د

 یٹنگ ہ کر کے 

 

  ۔میں ا ی ڈ

 

 ہو جائےگا۔د ینے سے صرف ی ا س و ر د

 

پ کت

 

پ
 ا کونٹ  پرو 

 

 یعنیا ٓت  کا د

 ٖ فائل بن جائے گی۔ Read Onlyا ٓت  کی فائل 

 

 
Assignment: 
 
No1. Using Review Ribbon review your document using spelling & grammar, research, track 
changes & protect document۔ 

 

LECTURE – 21 

View: Alt+W 

 

 

 

پ ی
م

  یہ 
ی

  بدلنے

 

 ا ٓف کرنے میں کام ا ٓتی ہے۔ و  سکرین کے مختلف و یور

 

  ا ٓن

 

 ا و ر  ٹول ی ا ر ر

  ہیں جن

 

 ا کونٹ  کے مختلف و یور

 

 ہے ۔ جو ا تٓ   میں مختلف ا س میں پہلے ی ا نچ بٹن د

 

 لے ا وٓ ت

 

ٹ

 

پ
  و یو پر

 

گ کے سٹینڈر د

 

پ

 

پ
مقاصد کے کام کیا جا سکتا ہے ۔ جس میں پر

ا  پڑتی۔

 

 ی ا د ہ محنت ہیں  کری

 

 ر

 

ٹ
ق
 کرتے و 

 

ٹ

 

پ
 ا ستعمال کیا کریں۔ ا س میں پر

ا  ہے۔ا ٓگے

 

 ا ٓف کری

 

  ر و ر  ا ٓن

ا ت  ہیڈ ا گٓے ا س کے

 

 ا کونٹ  کی ی

 

 ا کونٹ  میپ ہے جو ا ٓت  کو د

 

 ا ی ک ا و ر  ٹول د
 
پ

  د کھا 

 

ز
گ

 

پ
گ پر ا ٓت  کلک کریں ئے

 

 گے و ہان پہنچا د ے گا۔ گا۔ جس ہیڈی

 ا گلا ٹول ا ٓت  کو پیج و 

 

پ
  و یو د ے گا۔ا 

 

 ز

 ا کونٹ  کو پیج و 

 

 ا س کے بعد ا ی ک ا یسا و یو ہے جس میں ا ٓت  د

 

ز

 

پ
ے ہیں۔ ا 

 

سکی
ا  ہے  Thumbnailsا س کو د یکھ 

 

 کہا جای

ے ہیں۔

 

سکی
 ی ا د ہ کر 

 

 و م کم ر

 

 و م ہے ا س کی مدد  سے ا ٓت  سکرین کا ر

 

 ا  س کے بعد ر

 ہے ا س کے بعد ا تٓ  سکرین پر جتنے پیج د یکھنا چاہتے ہیں بتا د یں۔ 100و یو  Actualپھر

ے

 

سکی
 ا ٓف کر 

 

 و  کی سیٹنگ ہے جو ا ٓت  ا پنی مرضی سے ا ٓن

 

ڈ

 

 کو ا ر ینج کر سکیں ہیں۔ پھر سکرین و ی

 

ے ہیں ا و ر  ا ن

 

سکی
  یعنی سکرینز لے 

 

 و ر

 

ڈ

 

 ی ا د ہ و ی

 

ا س میں ا ٓت  ا ی ک سے ر

 کا ٹول ہے۔  Splitگے۔پھر ا ی ک سکرین کو د و  حصون میں کرنے کے لیے 

 
پ 
م

  نیو 

 

ے ہیں۔ ا ٓت  ا  س بٹن پر کر کلک کر کہ ا س میں ر یکار د

 

سکی
گ کر 

 

 ی

 

ز و  ٹول ہے ۔ ا س کی مدد  سے ا تٓ  ر یکار د
پ ک
م

 کی ر کھ ا خٓر میں 

 

ا ر ت

 

ز و  پر کلک کریں ا و ر  ا ی ک س
ک

ا  ٹیکسٹکر د یں۔ ا س کے بعد ا ٓت  جو  Assignد یں ا و ر   

 

 ی

 

پ
  ہو جا

 

ا س کے گا۔ ئےخود  بخو د  ا ٓ جا ٹیکسٹگا ۔ بعد میں ا ٓت  و ہ کی پرس کریں تو  ئےٹ  کریں گے و ہ ر یکار د

  کر سکتا ہے ۔

 

ا ر ٹس ا و ر  کی سٹرو کس بھی ر یکا ر  د

 

 علاو ہ یہ ٹول ا ٓت  کےسکرین س

 

LECTURE – 22 

 ۔ا ت  ہم ا ٓفس بٹن کی طرف چلتے ہیں
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ا س بٹن میں ٹولز ا تٓ  سا منے تصویر میں د یکھ ر ہے ہیں۔ا ٓفس بٹن کے سا تھ جو ٹولز ہیں 

 کو ہم بعد میں د یکھتے ہیں۔پہلے نیچے چلیں۔

 

 ا ن

 کی 

 

ا ر ت

 

 ا کونٹ  لینا ا س کی س

 

 ا کونٹ  ہے یعنی پرو گرا م میں ی ا لکل نیا د

 

نیو سے مرا د  نیا د

Ctrl+N ا کونٹ  لینا  ئے ۔ ا س پر کلک کرنے پر ا ٓت  کے ی ا س ا ٓپشن ا ٓ جاہے 

 

گا کہ ا تٓ  نیا د

 کو لے کر بھی ا ٓت   ہوئےچاہتے ہیں ی ا  پہلے سے بنے 

 

پ لت
 م
ی

 

پ

 کو لینا چاہتے ہیں۔

 

پ لت
 م
ی

 

پ

ے ہیں۔

 

سکی
 ا کونٹ  ا پنی مرضی کے فار میٹ میں سیو کر 

 

ا س کے علاہ ا ٓت  ا پنے کسی ا چھے د

ے ہیں۔ Tampleteا د ھرکی مد د  سے  Save Asکو بھی 

 

سکی
 میں سیو کر 

  کے فار میٹس کی فا

 

 کو پرو گرا م ئلزا س کےبعد ا و پن ہے ا  س کی مدد  سے ا ٓت  ا یم ا یس و ر د

 کی  

 

ا ر ت

 

 ہے۔ Ctrl+Oمیں کھو ل سکیں گے۔ا  س کی س

Convert جو ا س سے پہلے ئلٹو ل کی مدد  سے ا تٓ  ا یم ا یس ا ٓفس کی کھلی فا 

Compatibility Mode   2616میں کھلی ہے کو ا فٓس  

 

کے فار میٹ میں کنور ت

ے ہیں۔

 

سکی
 Alt+F+Vکر 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Ctrl+Sکو سیو کریں گے۔  ٹیکسٹ کو سیو کریں گے ا و ر  بعد میں ئلفانیو سیو کی مدد  سے ا ٓت  

  کی مدد  سے ا ی ک تو ا ٓت  فا

 

ز
پ 
ا م ی ا  جگہ ی ا  فار میٹ بھی بدل  کی کایائلسیو ا 

 

ن تیار  کر سکیں گے ۔ ا س کے علاو ہ ی

ے ہیں۔

 

سکی
F12لا ا ٓفس ئلیعنی ا ٓت  ا پنی فا۔

 

ا  چاہیں  2663 کو کسی ا و ر  فار میٹ مپ

 

فار میٹ میں سیو کری

 تو ا س ٹول کو ا ستعمال کریں۔

 کر نے کے بعد پیج بتا

 

پ کت
پ ل
س

 کر سکیں گے۔ پرنٹر 

 

ٹ

 

پ
 ا کونٹ  پر

 

 کی مد د  سے ا ٓت  د

 

ٹ

 

پ
 ا و ر  ا و کے کر یں ئیںپر

.Ctrl+P 

Prepare ے ہیں ۔

 

سکی
 ا کونٹ  کی پرا پرٹیز د یکھ 

 

ا س کے بعد ا ی ک ا و ر  ا ہم ٹول ہے ٹول کی مد سے ا ٓت  د

 یعنی جو ا ٓت  کی فا

 

پ کت
ش

 

ن

 سے یجر  ٹول لیے گے ہیں۔ئلا 

 

 کون

 

  میں بتائے گا کون

Encrypt ے ہیں۔ا س کے علاو ہ فائلکی مدد  سے ا ٓت  پور ی فا

 

سکی
  د ے 

 

 ئل پر ی ا س و ر د

 

 لی  کو ر ی ڈ

 

بنا  بھی ا ٓن

 یٹنگ پر فار م ہ ہو

 

 ی ڈ  کوئی ا ی ڈ

 

ر
ک
ا  کہ ا ٓت  کی فائل پر 

 

ے ہیں ی

 

سکی
  فا ۔

 

ز
پ 
 کی مدد  سے کر ئنلا س سے ا ٓگے مار ک ا 

 لی سکیں گے۔

 

  ا ٓن

 

ک ا س کو ختم ہیں  کریں گے۔ ر ی ڈ

 

 کے بعد فائل پر کوئی ٹول کام ہیں  کرے گا ح ت  ی

 Alt+F4ا و ر  پرو گرا م بند کرنے کے لیے  Ctrl+W بند کر نے کے لیے ئلفا
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ا مل کر سکیں گے۔یعنی   Quick Access Tool Barیہ 

 

 می ٹولز سکرین پر س

 

ہے۔ا س کی مد د  سے ا ٓت  لار

  کو

 

ز
گ

 

پ

 

پ ی
س

  میں ی ا  بہت   Customizeا  س کی مد د  سے ا ٓت  

 

و ر

 

 ی
پ ی
م

کر سکیں گے۔یعنی ا یسے ٹولز جو د و سرے 

ر 
ف
 کو ا ٓت  

 

 د و ر  ہیں ا ن

 

ٹ

 

پ
  میں 

 

 ر

 

ڈ

 

ے ہیں۔ صرف بٹن پر کلک کریں ا و ر  مو ر کمای

 

سکی
ے پر لا 

 

سکی
 جا کر ا س کو لے 

 ہیں۔

 

 پر ا ٓت  کلک کر د یں تو و ہ ا و پر ا ٓ جا

 

ا مل ہیں ا ن

 

ا  ئیںا س ی ا ر  میں کچھ ٹولز س

 

 گے۔ا گر کسی بھی ٹول کو سا منے لای

 ی ڈ  کے لیے ا ٓت  کو  ئیںچاہتے ہیں کچھ سا منے و ا لے تو ا ٓ ہی جا

 

ر
ک
ا   More commands گے لیکن 

 

۔میں جای

  ا پٓشن

 

  کی ا ی ک نئی د نیا ا و پن  ا یس  ا س پر کلک کرنے سے ا یم ۔ہو گا۔ ا س کے علاہ ا گٓے ا ی ک ا پٓشن ہے و ر د

 

و ر د

 

 

 ے  یں  پڑہو جاتی ہے ا س کو ا ٓت  کلاس کے د و ر ا ن

 

ز
پ 
گے ۔ ا س کو ا پنے طور  پر ضرو ر  د یکھیں ا س میں کچھ 

کو ہیں  پڑھاتے۔ ا س لیے ا ٓت  خود  ا س پر محنت کریں۔ا و ر  ٹیچر کام کی چیزیں ہیں عام طور  پر ا نسٹر کٹر ا س 

 ہیں  پڑتی۔ سے وفا ل پوچھ لیں۔

 

 عام طور  پر ا ٓفس میں کام کرنے و ا لون کی ا س کی ضرو ر ت

 

 
Status Bar 

 

  

 

 و م ا و ر  سکرین کے و یور

 

  د ا ئیںا س ی ا ر  میں ر

 

 ہیں جو ا ٓت  کام کے د و ر ا ن

 

 کشنری ا پٓشن، ا و ر  ی ا قی معلومات

 

ی ا ر  ی ا ر  د یکھیں گے۔ا س کے علاو ہ  طرف ہیں۔ ا س کے علاو ہ د

 کلک کریں ا و ر  لے لیں۔

 

 ٹ
پ
س ا ٓت  جاننا چاہتے ہیں ا س  ی ا ر  پر ر ا 

 

پ ی

 

سی

 ا و ر  ا پٓشنز جن کا 

Reviews of MS Word 

ا  سیکھا۔ 

 

 ا کونٹ  بنای

 

  ا س پرو گرا م کی مدد سے ا تٓ  نے د

 

ز
پ 
 

 

 ا کونٹ  ، ٹیبل ، د

 

ا ا ئنیعنی ا فٓس د

 

 ا و ر  بہت کچھ۔ ا سی پرو گرا م کی مدد سے ا ٓت  ا پنی ئٹل، خط، کتات  کے ی

  ا ی ک بہت ی ا و ر  فل پرگرا م ہے۔ ا ٓت  کھبی یہ ہ سمجھیں 

 

ے ہیں۔ ی ا د  ر کھیں ا یم ا یس و ر د

 

سکی
  کر 

 

کہ جتنا ا ٓت  کو پڑھا د ی ا  ا تنا ہی سی و ی ، فار م ا و ر  بہت کچھ ا ٓسا نی سے کمپور

 کے لیے ا س کے ا ندر  بہت کچھ ی ا قی ہے۔ ہے 

 

 بلکہ ا ٓت  کی ر یسرج

 ٹولز پر عبو ر  ر کھتے ہیں تو ا ٓت  ا ی ک ا چھے و ا ت  ہم پر

 

 ر ا تے ہیں۔یہ و ہ ٹولز ہیں ا گر ا ٓت  ا ن
ہ
ے ہیں۔   Office Professionalگرا م کے کچھ خاص ٹولز کو د و 

 

سکی
 بن 

 ا کونٹ  کے ا ندر  

 

ی چیز ہے د

 ہل
ن

ا  ۔ ا پنی سپیڈ ٹیکسٹتو 

 

ٹ  کری

 

پ
ا 

 

ا  سمجھیں۔ ا س کے بعد  ا و ر بنانے کی کوشش کریں ۔  بہتر   کوی

 

 یٹنگ کری

 

 ا کونٹ  کے ا ندر  ا ی ڈ

 

د

ا  ہے۔ سا منے سکرین پر موجود  فار میٹنگ ٹولز کی مد د  سے ا تٓ  

 

 تمام چیزو ن کو مد آت ر کھا جای

 

 ا ن

 

 ا کونٹ  کو ا پنی  فار میٹنگ کی طرف ا ئٓیں ۔ کور س کے د و ر ا ن

 

د

 )ہوم ر بن(۔ فار میٹ مینو کا ا ستعما ل کریںمرضی سے فار میٹ کریں۔تفصیل کے لیے

 و  ، یا ، کاپی، پیسٹ پر مکمل عبو ر حاصل

 

 و  ا و ر  ر ی د

 

ڈ

 

 و یو د یکھیں۔ا ی

 

ٹ

 

پ
 ر  گز ہ بھولیں۔ ا و ر  ی ا ر  ی ا ر  پر

ہ
ا  

 

 ا کونٹ  کو سیو کری

 

 یا  ا س کے بعد د

 

ا ر ت

 

 کی س

 

کریں ا و ر  ا ن

ت  کچھ ی ا ر  ی ا ر  پڑھتے ہیں لیکن
 ا ٓت  یہ س

 

ا  ہے۔ٹیبل بنانے کے لیے   کیز ی ا د  ر کھیں۔ کور س کے د و ر ا ن

 

ا ر  پر مکمل کی ٹول ی   Tables & Bordersا ت  عمل کری

 و م عبور  حاصل کریں ۔ جو 

 

  ر

 

 و م ا پنی مرضی کا ر کھا کریں۔ا س کے لیے سٹینڈر د

 

س بھی کی گی ہے ا و ر  ا ٓت  نے تفصیل سے پڑھی بھی ہے۔سکرین کا ر

سک

 

 

 ہے۔ 166د

 ر ا 

 

  د
ی

 

ی
 ا 

 

ز
پ 
 

 

گ ی ا ر  کی مدد  سے ا ٓت  نے د

 

 پ

 

ی
 

ی  پ 

 

س

گ سیکھی ۔ 

 

 پ
ی

ی ت  پر ٹیکسٹ ٹیکسٹس کا ا ستعمال کریں۔ 

 

 ی ا  د ہ ا ستعمال کریں۔ا س کے علاو ہ کسی س

 

 ی ا د ہ سے ر

 

 ی ا کس کا ر

ا  ا و ر  تصویر و غیرہ  کا ا ستعمال کریں۔

 

 ر ا  کری

 

 ی ا کس د

گ لا

 

 ی

 

 کمپور

 

پ ی

 

پ

  سے بتائے گے ا ٓپشن ا ستعمال کریں۔

 

  کے لیے کی بور د

 

 ر ا  کریں۔ر

 

 سے لائن د

 

 جس میں فل سٹات  ی ا  د و سری علامات
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 نوٹس میں موجود  ہیں۔  ,Page setup, Save as, Printفائل میں 

 

 و غیرہ بہت ا ہم ٹولز ہیں۔جو کور س میں ا و ر  ا ن

ا ،  ٹیکسٹپھر یا، کاپی، پیسٹ، پیسٹ سپیشل کی مدد سے ا ر د و  

 

 می ہے۔ ا س کے علاو ہ فار میٹنگ کلیر کری

 

  کا ا ستعمال بہت لار

 

ا ،ا ٓفس کلپ بور د

 

  میں لای

 

 ٹیکسٹکو و ر د

ا  ا و 

 

 کری

 

لاس

 

 کٹس و غیرہ۔ی

 

ا ر ت

 

 کی س

 

 ر  ا ن

Header & Footer کا ا ستعمال، ا و بجیکٹ، ی ک مار ک و غیرہ۔ 

 

 ، ر یفرینس کے ٹولز، علامت

 

 کے سا ر ے ٹولز ، فیلڈر

 ر ا ت  کیپ، ٹیکسٹ

 

   ا و ر   پھر د

 

ز و  ر
پ ک
م

گ و غیرہ۔سپیلنگ، ا و ر  سکیور ٹی کے ٹولز ، 

 

، نمبری

 

ٹ

 

پ
  Customizeکا کیس بدلنا، فا

ا 

 

ٹ  پرو گرا م میں ا ر د و  ی

 

پ
  طریقہ ا ٓت  کو کرنے کا 

 

 سکھا ی ا  جائے گا۔ یکچر ر

 

 کے د و ر ا ن

There are huge numbers of Short keys; you will never find these in any other book. 

The 10 most useful shortcut keys in Word   

  

F5 Displays the (Edit > GoTo) dialog box  

F9 Updates all the field codes in the selection 

Shift + Enter Enters a line break (Soft break) 

Ctrl + 1 Adjusts the line spacing to Single for the current selection 

Ctrl + R Right aligns the current selection 

Ctrl + Enter Enters a normal page break 

Ctrl + Alt + 1 Applies the Heading 1 style to the selection 

Ctrl + Shift + N Applies the Normal style to the selection 

Alt + Ctrl + N Displays the active document in Normal view 

Alt + 5 Selects the whole table (5 on Numerical keypad) 
 

Function Keys   

  

F1 Displays the Office Assistant or (Help > Microsoft Word 

Help) 

F2 Moves text ?? 

F3 Replaces an AutoText entry from the preceeding word  

F4 Repeats the last document action (Edit > Repeat) 

F5 Displays the (Edit > GoTo) dialog box  

F6 Moves to the next pane in a document (if the window is 

split)  

F7 Displays the (Tools > Spelling) dialog box  

F8 Toggles whether to extend a selection with the arrow 

keys 

F9 Updates all the field codes in the current selection  

F10 Toggles the activation of the Menu Bar / Subscript ???  

F11 Moves to the next Field 
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F12 Displays the (File > Save As) dialog box  
 

  Shift + Function   

  

Shift + F1 Activates the context sensitive Whats this ? prompt 

(Help > Whats This) 

Shift + F2 Copies ?  

Shift + F3 Toggles between lowercase, mixedcase and uppercase 

on the selection 

Shift + F4 Repeats the last Find, the same as (Edit > Find Next) 

Shift + F5 Moves to the previous revision \ Goto Previous insertion 

point when document was last opened 

Shift + F6 Moves to the previous pane in a document (if the window 

is split) 

Shift + F7 Displays the (Tools > Language > Thesaurus) dialog 

box 

Shift + F8 Shrink / reduce selection  

Shift + F9 Toggles between displaying field codes and field results 

Shift + F10 Displays the (Shortcut) menu for the selected item 

Shift + F11 Moves to the previous Field 

Shift + F12 Saves, Displays the (File > Save As) dialog box if a new 

document 
 

  

  Ctrl + Function   

  

Ctrl + F2 Displays the Print Preview (same as File > Print 

Preview) 

Ctrl + F3 Spike / cut to spike (multiple cuts to clipboard) 

Ctrl + F4 Closes the active document or window (File >Close) 

Ctrl + F5 Restores the size of the active document or window 

Ctrl + F6 Moves to the next open document or window 

Ctrl + F7 Activates the Move window command 

Ctrl + F8 Activates the Resize window command 

Ctrl + F9 Inserts a blank Field containing two curly brackets  

Ctrl + F10 Maximise the active document or window 

Ctrl + F11 Locks a Field code 

Ctrl + F12 Displays the (File > Open) dialog box  
 

  

  Other + Function   



45 

 

  

Alt + F2 Displays the (File > Save As) dialog box 

Alt + F3 Create an AutoText entry for the current selection 

Alt + F4 Closes the active document (saving first) and exits Word 

(File > Exit) 

Alt + F5 Restores the size of the active window?? 

Alt + F6 Toggles between all the documents that are currently 

open 

Alt + F7 next spoll ? Similar to right mouse click ?? Move to the 

next misspelling ?? 

Alt + F8 Displays the (Tools > Macros > Macro) dialog box 

Alt + F9 Toggles between displaying field codes and field results 

Alt + F10 Maximise the active window 

Alt + F11 Toggles between the Visual Basic Editor window and 

the Word window 

Alt + F12 Activate Print Preview ?? 

Alt + Shift + F2 Displays the (File > Save As) dialog box 

Alt + Shift + F4 Closes the active document (saving first) and exits Word 

(File > Exit) 

Alt + Shift + F10 Displays the drop-down menu for the corresponding 

smart tag 

Alt + Ctrl + F2 Displays the (File > Open) dialog box  

Ctrl + Shift + F3 Unspike / paste the spike contents 

Ctrl + Shift + F5 Displays the (Insert > Bookmark) dialog box 

Ctrl + Shift + F6 Moves to the previous open document or window 

Ctrl + Shift + F7 Updates Selection ?? 

Ctrl + Shift + F8 Allows you to vertically select text / Selects a column in a 

table 

Ctrl + Shift + F9 Unlinks a Field code 

Ctrl + Shift + F11 Unlocks a Field code 

Ctrl + Shift + F12 Displays the (File > Print) dialog box 
 

  

  Ctrl + Numbers   

  

Ctrl + 1 Adjusts the line spacing to Single for the current 

selection 

Ctrl + 2 Adjusts the line spacing to Double for the current 

selection 
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Ctrl + 5 Adjusts the line spacing to 1.5 for the current selection 

Ctrl + 0 Toggles adding a 12 point line spacing before the current 

selection 

Ctrl + Shift + 8 Toggles the display of paragraph formatting (non 

printable characters) 

Alt + Ctrl + 1 Applies the built-in Heading 1 style to the current 

selection 

Alt + Ctrl + 2 Applies the built-in Heading 2 style to the current 

selection 

Alt + Ctrl + 3 Applies the built-in Heading 3 style to the current 

selection 
 

  Ctrl + Letters   

  

Ctrl + A Selects all the text in the active document 

Ctrl + B Toggles bold on the current selection 

Ctrl + C Copies the current selection to the clipboard (Edit > 

Copy) 

Ctrl + D Display the (Format > Font) dialog box 

Ctrl + E Centre aligns the current selection 

Ctrl + F Displays the (Edit > Find) dialog box 

Ctrl + G Displays the (Edit > GoTo) dialog box / unhand an 

indent ?? 

Ctrl + H Displays the (Edit > Replace) dialog box / toggles 

hidden text ?? 

Ctrl + I Toggles italics on the current selection 

Ctrl + J Justifies the current selection / ie full paragraph 

justification 

Ctrl + K Inserts hyperlink / Toggles between (smallcaps / 

lowercase) ??? 

Ctrl + L Left aligns the current selection 

Ctrl + M Indents the paragraph / Un Nest / left indent, increase 

indent ?? 

Ctrl + N Creates a new document based on Normal.dot template 

Ctrl + O Displays the (File > Open) dialog box 

Ctrl + P Displays the (File > Print) dialog box 

Ctrl + Q Resets the formatting back to the original paragraph 

style. Removes character formatting from the selection 
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Ctrl + R Right aligns the current selection 

Ctrl + S Saves, Displays the (File > Save As) dialog if new 

document 

Ctrl + T Inserts a Hanging Indent 

Ctrl + U Toggles (continuous) underlying on the current selection 

Ctrl + V Pastes the entry from the clipboard (Edit > Paste) 

Ctrl + W Closes the active document or window (File >Close) 

Ctrl + X Cuts the current selection to the clipboard (Edit > Cut) 

Ctrl + Y Repeats the last document action (Edit > Repeat) 

Ctrl + Z Undo the last document action (Edit > Undo) 
 

  Others + Letters   

  

Ctrl + Shift + A Toggles between Capitals and Lowercase on the 

selection 

Ctrl + Shift + C Copies only the formatting from the current selection 

Ctrl + Shift + D Toggles (double) underlining on the selection 

Ctrl + Shift + F Activates the Font drop-down list on the Formatting 

toolbar 

Ctrl + Shift + H Toggles whether to make the current selection hidden 

Ctrl + Shift + K Toggles smallcaps on the selection 

Ctrl + Shift + L Applies the built-in List Bullet style to the selection 

Ctrl + Shift + M Unindents the paragraph, decreases indent ?? 

Ctrl + Shift + N Applies the built-in Normal style to the selection 

Ctrl + Shift + P Activates the Point drop-down list on the Formatting 

toolbar 

Ctrl + Shift + Q Applies the Symbol format / Changes the selection to 

symbol font ?? 

Ctrl + Shift + S Activates the Style drop-down list on the Formatting 

toolbar 

Ctrl + Shift + T Reduces / removes a hanging indent 

Ctrl + Shift + V Pastes only the formatting. Used in conjunction with (Ctrl 

+ Shift + C) 

Ctrl + Shift + W Toggles underlining on the selection (words only not 

spaces) 

Alt + A Displays the (Table) menu 

Alt + E Displays the (Edit) menu 
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Alt + F Displays the (File) menu 

Alt + H Displays the (Help) menu 

Alt + O Displays the (Format) menu 

Alt + T Displays the (Tools) menu 

Alt + V Displays the (View) menu 

Alt + W Displays the (Window) menu 

Alt + Shift + D Insert Date field with current Date (format ??) 

Alt + Shift + E Edit Merge data source ?? 

Alt + Shift + F Insert Merge field 

Alt + Shift + N Merge to a new document ?? 

Alt + Shift + M Merge to a printer ?? 

Alt + Shift + P Insert Page field with current Page 

Alt + Shift + T Insert Time field with current Time 

Alt + Ctrl + A All in capitals 

Alt + Ctrl + C Enters the Copyright symbol (©) 

Alt + Ctrl + D Enters the current date as a field. Format "mm/dd/yy" 

Alt + Ctrl + E Enters an Endnote 

Alt + Ctrl + F Enters an Footnote 

Alt + Ctrl + I Displays the Print Preview (same as File > Print Preview) 

Alt + Ctrl + K Start Autoformat ??? 

Alt + Ctrl + N Displays the active document in Normal view 

Alt + Ctrl + P Displays the active document in Page Layout view 

Alt + Ctrl + R Enters the Registered symbol (®) 

Alt + Ctrl + T Enters the Trademark symbol (™) 

Alt + Ctrl + V Replaces an AutoText entry from the preceeding word 

Alt + Ctrl + Y Goto the top of the next page?? 

Alt + Ctrl + Z Goto the previous Insertion point?? 
 

  Entering Data   

  

Enter Enters a new paragraph 

Ctrl + Enter Enters a normal page break 

Shift + Enter Enters a line break (Soft break) 

Ctrl + Shift + Enter Enters a column break or splits the table 

Delete Deletes the selection or one character to the right 
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Backspace Deletes the selection or one character to the left 

Ctrl + - Enters an En Dash (number pad) (shorter) basically a 

hyphen ?? 

Alt + Ctrl + - Enters an Em Dash (number pad) (longer) 

Alt + 0152 Enters the ?? symbol 

Alt + 0175 Enters the ?? symbol 

Ctrl + Tab Enters a tab in a table cell 

Ctrl + Shift + Spacebar Enters a non breaking space / hard space, ie prevents 

word wrap at undesirable places ?? 
 

  
 

Extending Data 
  

  

Shift + Home Extends the selection to the beginning of the line 

Shift + End Extends the selection to the end of the line 

Shift + Up Arrow Extends the selection one line up 

Shift + Down Arrow Extends the selection one line down 

Shift + Left Arrow Extends the selection one character to the left 

Shift + Right Arrow Extends the selection one character to the right 

Ctrl + Shift + Home Extends the selection to the beginning of the document 

Ctrl + Shift + End Extends the selection to the end of the document 
 

  

  Selecting Data   

  

Ctrl + Shift + Up Arrow Selects to the beginning of the current paragraph 

Ctrl + Shift + Down Arrow Selects to the end of the current paragraph 

Ctrl + Shift + Left Arrow Selects the beginning of the current word 

Ctrl + Shift + Right Arrow Selects the end of the current word 

Ctrl + Shift + Home Selects to the beginning of the document 

Ctrl + Shift + End Selects to the end of the document 

Shift + Page Up Selects to the top of the previous screen 

Shift + Page Down Selects to the bottom of the next screen 

F8, F8 Selects the current sentence?? 

F8, F8, F8 Selects the current word?? 

Ctrl + Backspace Deletes one word to the left of the cursor 

Ctrl + Delete Deletes one word to the right of the cursor 
 

  

  Formatting Data   
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Ctrl + ] Increases the font size of the current selection by 1 point 

Ctrl + [ Decreases the font size of the current selection by 1 

point 

Ctrl + Shift + ] Increases the font size of the current selection by 1 point 

Ctrl + Shift + [ Decreases the font size of the current selection by 1 

point 

Ctrl + Shift + > Increases the font size to the next size in the font drop-

down list 

Ctrl + Shift + < Decreases the font size to the previous size in the font 

drop-down list 

Ctrl + Shift + - Inserts a non breaking hyphen (ie grammer note 2 

hyphens = 1 dash) 

Ctrl + = Applies Subscript to the selection (automatic spacing??) 

Ctrl + Shift + = Applies Superscript to the selection 

Ctrl + Spacebar Resets the formatting back to the original style (removes 

any manual formatting) 

Alt + Shift + Right Arrow Demotes the paragraph to the previous heading style 

Alt + Shift + Left Arrow Promotes the paragraph to the next heading style 
 

  

    Manouvering   

  

Arrow Keys Moves one character in the corresponding direction 

Tab Moves to the next cell in a table (or inserts a normal tab) 

Home Moves to the beginning of the line 

End Moves to the end of the line 

Page Up Moves to the previous screen 

Page Down Moves to the next screen 

Ctrl + Home Moves to the beginning of the document 

Ctrl + End Moves to the end of the document 

Ctrl + Up Arrow Moves to the beginning of the paragraph or the previous 
paragraph 

Ctrl + Down Arrow Moves to the end of the paragraph or the next paragraph 

Ctrl + Left Arrow Moves one word at a time to the left 

Ctrl + Right Arrow Moves one word at a time to the right 

Ctrl + Page Up Moves to the top of the previous page (paragraph / end 
of column) ?? 

Ctrl + Page Down Moves to the top of the next page 

Alt + Ctrl + Page Up Moves to the top of the current window 

Alt + Ctrl + Page Down Moves to the bottom of the current window 
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  Other   

  

Alt + Ctrl + Home Activates the Document Browser 

Alt + Enter Repeats the last action (Edit > Repeat)?? 

Shift + Delete Cuts the selection to the clipboard 

Ctrl + Insert Copies the selection to the clipboard 

Shift + Insert Pastes the entry from the clipboard 

Alt + Tab Toggles between all your open applications 

Alt + Shift + Tab Toggles backwards between all your open applications 

Alt + Print Screen Copies just the active window / application to the 
clipboard?? 

Alt + Spacebar Activates the Control Box in the top left hand corner 

Alt + Backspace Undo the last action (Edit > Undo)?? 

Ctrl + Escape Activates the Windows Start menu 

Alt + Escape Toggles between all your open applications on the 
taskbar 

Ctrl + Spacebar Resets the formatting back to the original paragraph 
style. Removes character formatting from the selection 

Ctrl + Up Arrow + F9 Converts a field to text?? 

Esc Cancels the action or closes the dialog box 
 

 
Assignments: 
 
No1. What do know about MS Word please explain in 5 lines? 
No 2: Write an application for job & Print it out? 
No 3: Composing your matric‘s result card & Print it out? 
No 4: Pasting inpage‘s text into word and print it out? 
No 5: Composing an Admission form of your Institute & Print it out? 
No 6: Compose a district wise population table with chart & print it? 
No 7: Composing a Book title of your own choice? 
No 8: Using text boxes Word art & drawing? 
No 9: Using Object tool & working on MS Equation editor? 
No 10: Using data base options & Mail Merge? 

 

  جوا ٓت  کا پہلا پرو گرا م ختم ہوا ۔ 

 

ا  ضرو ر  ی ہے۔ ا یم ا یس ا ٓفس و ر د

 

 س کس کری

 

 د

 

 ی ڈ   ا س کے بعد ہم ا ر د و  کی طرف جا ر ہے ہیں۔ ا ی ک ی ا ت

 

ر
ک
میرے خیال میں ا ت  

 جار ی ر کھیں تو ا ٓت  ا و ر  بھی بہت کچھ سیکھ ی ا یں گے۔یعنی جو

 

 ہو چکا ہے، ا ٓت  نے سیکھا ا ت  ا س میں ا پنی ر یسرج

 

 ا ٓت  نے پڑھا ہے ا س کے علاو ہ بھی بہت کچھ ا ٓسا ن

کو پڑھا ر ہا ہون میں بہت کچھ  جو ا ٓت  خود  سے کریں گے۔بس کوشش ا تٓ  کی ہو گی ا و ر  پھل تو ضرو ر  ہی ملتا ہے ا س کی د لیل میں خود  ہون ۔ میں جو ا ٓت   ہے

 سے سیکھا ۔ لیکن بنیاد  یعنی ٹیچر کا و یو ہمیشہ سا تھ ر ہتا ہے۔

 

 کور س کے بعد ا پنی ر یسرج
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Inpage3.5 
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 ا  پرو گرا م ہے ا و ر  ا س میں ہمار ے میں ہم نے ا ر د و   

 

ز
پ 
  چونکہ ا ی ک 

 

  میں بھی کام کیا ہے ا و ر  ا یم ا یس و ر د

 

 ی ا د ہ ا پٓشن ہیں ا س  ا یم ا یس و ر د

 

ی ا س ر

 پیج

 

  میں کریں لیکن جات  کے حوا لے سے ا تٓ  کو ا ن

 

 ی ا د ہ تر کام ا یم ا یس و ر د

 

 بھی پڑ سکتی ہے ا س لیے کوشش کریں ا تٓ  ا پنا ر

 

 کی ضرو ر ت

ا مل کر ر ہا ہون ۔لیے ا س کو بھی کور س میں

 

  س

 

 

 

 

 

 

 

CHAPTER 4:        INPAGE 

 

LECTURE- 23 

 

F12 

 
ا ئلفار میٹنگ سٹا

 

تیار   Format –Style Sheet۔ جو سٹائل ا ٓت   تیار  کری

 کریں گے و ہ ا س میں ا ٓ جائے گا ۔

 

     
 English font style 

 

  Ctrl+F9,Ctrl+F10  

 کا سا   ٹیکسٹ

 

ز

 

پ
ا  

 

 ی ا د ہ کری

 

 کم ر

 

 

Character spacing 

 

Text alignments Ctrl+Alt+L, Ctrl+Alt+E, Ctrl+R
  

 
 فاصلہ

 

 لا یٔنون کے د ر میان

 
 سٹا

 

ٹ

 

پ
 ئلا ر د و  فا

 

Text Colour 
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 ر  ٹیکسٹ

 

ڈ

 

ا   لائنا ی

 

 کری

 
 و م ٹیکسٹ

 

 ر

 

ٹ

 

پ
 پر

 

 

 

 

 

 

 

 

 

 

 

LECTURE-24 

Tool bar 

 

 

 ا پٓشن کسی بھی ا و بجیکٹ کو  پہلاا س میں 

 

پ کت
پ ل
س

  

 

  میں جانے کے لیے ا ستعماا ئپنگکرنے کے علاو ہ ی

 

ا  ہے۔ ماد

 

ل ہوی  

 یٹنگ ٹول جو ا ی ک ہاتھ کا سا 

 

  میں لانے کے لیے ٹیکسٹ ہے ا ی ک تو ئند و سرا  ا ی ڈ

 

 جسٹ ماد

 

  کرنے لیے ہے۔ا س کے علاو ہ تصویر ا ی ڈ

ا  ٹیکسٹا ٓگے د و نون 

 

کے لیے ا ٓت  ر بن کا ا ستعمال کریں گے  فار میٹ کرنے  ہے۔د و نون کو و غیرہ کے لیےئٹلی ا کس موجود  ہیں ا ی ک پیرا گرا ف ا و ر  د و سرا  ی
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گا۔ ئےپر کلک کرنے کے بعد ا و پر ا ٓ جا ا و بجیکٹجو   

 ی ا د ہ 

 

 کی مدد سے ا تٓ  ا ی ک سے ر

 

ی ا کس مکمل  ٹیکسٹہ یہ ہو گا کہ ا ٓت  ا ی ک ئدی ا کسز کو نک  کر سکیں گے۔۔ ا س کا فا ٹیکسٹا س سے ا ٓگے نک  ٹولز ہیں ا ن

گا۔  ئےی ا کس میں ج لا جا ٹیکسٹیعنی نک  شدہ ہونے پر کر سر خود  بخود  د و سرے   

 یٹنگ ٹول کی

 

ر یم تصویر لینے کے لیے ہیں۔ ا س کو لینے کے بعد ا تٓ  ہاتھ ا ی ڈ
ف
 کریں گے تو ا ی ک ا و ر  ر بن ا ٓ  ا س سے ا ٓگے تین ا پٓشن 

 

کی ت
پ ل
س
مدد  سے ا س کو 

 جسٹ کر سکیں گے۔ ئےجا

 

گا ا س کی مدد  سے ا ٓت  تصویر کو ا ی ڈ  

 کے ا ندر   ٹیکسٹئےہیں جو لکھے ہوا  س سے ا ٓگے تین ا و بجیکٹ 

 

 ر ا  ہوتے ہیں لیکن ا ن

 

 کو صرف لکھے ہوہیں  ٹیکسٹکے ا و پر د

 

ا ۔ ا ن

 

 کے ٹیکسٹئے لکھا جای

 ر ا  کریں ۔ ا س کے علاو ہ یہ سکرین

 

  ا و پر د

 

 غایپنگا  سے ی

 

  کے د و ر ا ن

 

پ
 میں یہ ضرو ر  ا ٓ

 

ٹ

 

پ
ر ی ہینڈ ٹول بھی ہے ا و ر   ئیںٹ  ہو جاتے ہیں لیکن پر

ف
گے۔ ا ٓگے ا ی ک 

ا مل ہے بھی ئنلا

 

۔س  
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Menu bar 

 

 

Important tools in File Menu: 
Place: 

 

 

 ا کونٹ  میں کسی تصو یر کو س

 

ے ہیں۔ ا س ا س ٹول کی مدد  سے ا ٓت  ا پنے د

 

سکی
ا مل کر 

 ر ا 

 

  میں جا ینگکے لیے پہلے ا ٓت  د

 

م کرے گا۔ گے پھر یہ ٹول کائیں ماد  

Import: 

ی ا کس میں  لا سکیں گے۔ تصویرا س ٹول کی مدد  سے ا ٓت    

Export: 

 ا کونٹ  کو تصو

 

 می ٹول ہے ا س کی مدد  سے ا ٓت  ا پنے ا ر د و  د

 

یر کے طور  پر یہ بہت لار

۔ گےسیو کر سکیں گے ا و ر  کسی د و سرے پرو گرا م میں کھول بھی سکیں  

 ہوئے ہیں( ی ا قی ٹولز 

 

 میں بیان

 

تقریباً و ہی ہیں )ا یم ا یس و ر د  
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Edit Menu 

 

 

 و  کا ٹول ہے 

 

ڈ

 

ا ...ا ی

 

ا   کسی ا و بجیکٹ کی کاپی کری

 

کسی مخصوص مقصد کے ...ا و ر  یا کری

ا 

 

یا ی ا  کاپی شدہ ٹیکسٹ کو پیسٹ ...لیے کسی د و سرے فار میٹ میں پیسٹ کری

ا 

 

ا  ۔...کری

 

 کسی ا و بجیکٹ کی کاپی کری

ا  

 

ا  ...ٹیکسٹفار میٹنگ  کلیر کری

 

ا  ا و ر  تبدیل کری

 

 کری

 

لاس

 

کو ا ٓگے  کسی ا و بجیکٹ...ی

ا 

 

 …پیچھے کری

 

 ٹ
پ
ا  ...کہانی سکر

 

   کی سیٹنگ  ہےپھر ...پیج کو ختم کری

 

ا  کے  ا ٓگے کی بور د

 مینو میں کچھ تو و ہی ٹولز ہیں ...غیرہ ہیںپور ے پرو گرا م کی سیٹنگ ، یونٹس و 

 

 ت

 

ا ی ڈ

 و  ، کاپی ، پیسٹ، پیسٹ سپیشل۔

 

ڈ

 

 جو ا ٓت  پہلے سمجھ چکے ہیں یسا کہ یا، ا ی

 سے مرا د  کسی ا 

 

 کی ت
ی لپ
 و 

 

ا  ہے ۔د

 

 شدہ ...و بجیکٹ کی کاپی کری

 

کی ت
پ ل
س
کلیر سے مرا د  

ا  ہے۔ا و بجیکٹ ی ا   ٹیکسٹ

 

 کو ختم کری

 ٹولز کی مدد  سے ا تٓ  ا ی ک 

 

۔ ا ن

 

ٹ

 

پ
ر 
ف
گ ٹو 

 

ز ی
پ 
ا س میں ا ہم ا ٓپشن ہے سینڈ ٹو بیک ا و ر  

 کو د و سرے کے ا و پر ا و ر  بیک میں کر سکیں گے۔ بجیکٹا و 

 یٹر یہ

 

 کہانی و غیرہ لکھنے کے لیے ا س کے علاو ہ ا س میں ا ی ک ا و ر  ا ٓپشن سٹور ی ا ی ڈ

 و غیرہ ا لگ ہیں جو ا ٓت  ا سی مینو کے ا خر میں ا سی 

 

ٹ

 

پ
ا  ہے ۔ا س کے فا

 

ما ل ہوی
مع

 

سی

ا 

 ا ٓپشن کی مدد  سے ا ستعمال کر سکیں گے۔

  کی مدد  سے ا ٓت  ا پنے پر

 

ر
س

 

ی ی

ر 
ف
گرا م کی سیٹنگ تبدیل کر سکیں گے و ا س کے علاو ہ پری 

 کا ا ستعما

 

  ی ا  لے ا وٓ ت

 

ل بھی ا سی ا ٓپشن کی مدد  سے کریں ۔ا  س کے علاو ہ ا پنے کی بور د

 گے۔

View     Alt+V 
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ا  

 

 ا ٓف کری

 

  ا ٓن

 

  بدلنا ا و ر  ی ا ر ر

 

 سکرین کے و یور

 
سک
  سے ہیں جن کو بدل 

 

ے ہیں ا و ر  ا پنے مرضی کےو یو مینو میں سکرین کے کچھ و یور

 

ی
و یو  

 یا کیز مینو میں موجو

 

ا ر ت

 

  و یو میں کام کر سکیں گے ۔ ا س میں س

 

د  ہیں۔سٹینڈر ر

 ہے۔166

 

 کی ا یف سیون

 

ا ر ت

 

ہے۔ا س کی س  

ا  بھی ا سی ٹول ی  

 

 ا فٓ کری

 

 ا ٓن

 

لاو ہ سکرین سے ٹولز ی ا ر ر
ا مل ہےا س کے ع

 

ا ر  میں س  

 

 

 

 

 

Insert 

ا  

 

 مینو ا ٓتی ہے ا س میں ست  سے پہلا ا ٓپشن پیج نمبر کا ہے تو ا ٓت  چھوی

 

 ر ا  کر کہ ا س ٹو ل پر کلک کر د یں تو نمبر خود  بخوی ا کس ٹیکسٹا س مینو کے بعد ا نسرت

 

د   د

گا۔ ئےلگ جا  

 
ق
ا ر یخ ا و ر  و 

 

 ا س کے بعد ی

 

ے ہیں۔ ٹ

 

سکی
 کر 

 

ا نسرت  

ا مل ہے۔

 

 ا و ر  ا س کے بعد تصویر لینے کا ٹول بھی س

 کریں گے ۔ی ا د  ر کھیں ٹیبل

 

ل ا نسرت
 پ 
ی

 

ی

 کا ہے ۔ ا  س کی مد د  سے ا ٓت  

 

ا  سا  بہت ا س کے بعد بہت ا ہم ٹول ٹیبل ا نسرت

 

ر ے مقاصد کے لیے ا ستعمال ہوی

 ل کیا جا ل ی ا  ا شعار  و غیرہ لکھنے کے لیے بھی ٹیبل کو ا ستعماکو ترتیب میں لکھنے کے لیے بھی ٹیبل لیتے ہیں ا س کے علاو ہ نظم، غز ٹیکسٹہے۔ بعض د عہ  ہم 

 سکتا ہے۔

 ر  ہو
ہ
ا 

 

 یہ ہے کہ ح ت  ا ٓت  ٹیبل لیں گےتو سا منے سکرین پر ط

 

 ر نے و ا لی چیز جو ا ٓت  کو ی  ا س میں ی ا  د ر ھنے  کی ی ا ت

 

 میں آت ا ٓ ر ہی ہو گی۔ا ر د

 

  کی صور ت

 

لیکن  ر

  لا

 

  ہیں  ہیں۔بلکہ یہ گرد

 

 ر ر

 

ے ہیں۔ا گر ا ٓت  ٹیبلئنزو ہ حقیقت میں ی ا ر د

 

سکی
 میں د کھا 

 

ٹ

 

پ
 کو ا تٓ  ح ت  چاہیں پر

 

ا  چاہتے ہیں تو ا ٓت   ہیں۔ ا ن

 

 کو فار میٹ کری

 کے ا ٓپشن

 

 مینو میں ٹیبل فار میٹ ا و ر  ٹیبل لے ا وٓ ت

 

 کے تعلقہ  ا ٓت  کور س میں فار مت

 

  سمجھ چکے ہیں۔ا ستعمال کریں گے ۔ ا ن

 

LECTURE – 27 
Format Menu 
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 ٹولز کو تفصیل ا یس و  چونکہ ا ٓت  ا یم 

 

  میں ا ر د و  پر بھی تما م کام کر چکے ہیں ا س لیے ا ن

 

ر د

 سے ہیں  لیا گیا۔ 

Character  ے ہیں۔ا ٓپشن کی مد د  سے ا ٓت  ٹیکسٹ کو ا ی ک ہی جگہ سے فار میٹ کر

 

سکی
 

Paragrpahمیں ٹیکسٹ کی ا لائن نٹ  ا و ر  د یگر ٹولز ہیں ۔ 

  ٹیکسٹ

 

 ر ر

 

 کریں ا و ر  تعلقہ  ٹول پر کلک کر کہ  ی ا ر د

 

پ کت
پ ل
س

ا مل ہے ٹیکسٹ کو 

 

د ینا س

  کا سٹائل د یں۔

 

 ر

 

 ی ا ر د

Tabs کی مدد  سےTab کریں۔کہ ٹیب پریس کرنے پر ٹیکس تنا  ا ٓگے 

 

کی کا فاصلہ سی ت

 منتقل ہو۔

Text Wrap  ا ٓف کریں۔کی مدد 

 

 میں ا ٓن

 

ٹ

 

پ
 سے ٹیکسٹ ی ا کس کو سکرین ا و ر  پر

ٹیبل سے تعلق  ہیں ا س کے لیے پہلے ا ٓت  Table Format & Table Layouا ٓگے 

Insert ے ہیں۔

 

سکی
  کر 

 

 ٹولز کو یور

 

 کرکہ ا ن

 

پ کت
پ ل
س

 میں جا کر ٹیبل لیں پھر ٹیبل کو 

 کریں۔ Objectپھر 

 

 کے لیے کوئی بھی ٹیکسٹ ی ا کس ی ا  تصویر ا نسرت

Document  ، ا ت  ہے جس کی مدد   سے ا ٓت  پیج کے مار جنز 

 

میں پیج سی ت

Orientation  ا و ر  پیج کا ا نتخات  کریں گے ۔ ح ت  ا ٓت ،File-New پر کلک کرتے ہیں تو

 کر لینا بہتر ہے ۔

 

 سی ت

 

ٹ
ق
ا  ہے ا س کو ا سی و 

 

 یہ ا ٓپشن پہلے ہی ا ٓ جای

Style Sheet   ے ہیں ا س کو کی مدد  سے ا ٓت  ا ی ک طرج کا فار میٹنگ سٹائل تیار

 

سکی
کر 

 پڑنے پر ا س 

 

  ہو جائے گا ا و ر  بعد میں ا ٓت  ضرو ر ت

 

سیو کرنے پر یہ ا ٓت  کے ر بن میں ا ی ڈ

ے ہیں۔ 

 

سکی
 کو ا ستعمال کر 

ا  

 

 ی ڈ  ر نگون کا ا نتخات  کری

 

ر
ک

 

 
What you have learned? 

 نکالنا۔

 

ٹ

 

پ
ا  سیکھا ا و ر  ا س کا پر

 

 ا کونٹ  بنا ی

 

 ا س پرو گرا م کی مدد سے ا ٓت  نے ا ر د و  د

ا  ۔ GIFا ر د و ٹیکس فائل کو کسی بھی 

 

 فار میٹ میں سیو کری

 ٹول کا ا ستعما ٹیکسٹا ر د و  

 

ا  ا و ر  ا سے کسی د و سرے پرو گرا م میں بھیجنے کے لیے فائل مینو سے ا یکسپور ت

 

ل۔سیو کری  

سا و ر  ا و  ٹیکسٹر بن ی ا ر  کی مدد  سے 

 

 پ کی
 ج
ن

ا ۔ 

 

کو فار میٹ کری  

ا  ا و ر  ا نگلش ا ر د و  

 

گ سٹائل تیا ر  کری

 

 ی ا نون کا ا کٹھا ا ستعمال۔ا و ر  عربی  مختلف ہیڈی

 

ر  

ا  ا و ر  ا ر د و  

 

ا  ٹیبل کو فار میٹ کرنے کے لیے فار میٹ مینو میں ٹیبل کے ٹولز ا ستعما ٹیکسٹٹیبل بنای

 

ا مل کری

 

ل کیے۔س  

 ٹول کی مدد  سے سیکھا

 

ی ت

 

ا  ا ٓت  نے فار میٹ میں سٹائل س

 

 کے لیے ا ی ک ہی طرج کا فار میٹنگ سٹائل تیا ر  کری

 

ی ت

 

۔پور ی س  

 

 

ا ر ت

 

 پیج سے تعلقہ  س

 

۔ا گٓے ا ٓ ر ہی ہے یا کیز کی تفصیل ا ن  

 پیج میں:۔ ٖ 

 

ا ن Assignments: 

  A4۔ ا پنی جات  کے لیے ا ی ک ۱

 

ٹ  پیج پر ا ی ک د ر خوا ست

 

پ
ا 

 

ا ت  ا و ر  ی ا ٹم سے  ی

 

 کریں ی

 

ٹ

 

پ
  سے ا ٓد ھے ا نچ کا فاصلہ ئیں ی ا  ئیںا نچ کا فاصلہ ا و ر  د ا  1کریں ا و ر  ا س کو پر

 ۔ر کھیں
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  ا و ر  ۲

 

 ر و ر

 

  پر مشتمل ا ی ک ٹیبل تیا ۸۔ سا ت

 

ر
م
ل

ا مل کریںکا

 

 یٹا س

 

۔ر  کریں جس میں ا پنی مرضی کا د  

  لا۳

 

 پیج میں ٹیبل گرد

 

ٹ  ا ی ک نظم ی ا  غزل  ئے کا ا ستعمال کرتے ہوئنز۔ ا ن

 

پ
ا 

 

۔کریں ا س کو فار میٹ کریں  ی  

ا  ئےی ا کسز کا ا ستعما ل کرتے ہو ٹیکسٹ۔ ۴

 

 سا  ی

 

  تیار  کریںئٹلا ی ک خوبصور ت

و  پر۵

 

 ی
پ ی
م

 

 

 پیج کے تما م ٹولز میں سے ا پنے فیور ت

 

 کریں ۔ ا ن

 

 ا پٓشنز کی و ضاحت

 

۔کام کریں ا و ر  ا ن  

ٹ  ۔ ا ی ک نظم ی ا  غزل ۶

 

پ
ا 

 

  میں کھولیں (GIF)یرکرنے کے بعد ا  سکو تصو ی

 

 ۔کے فار میٹ میں سیو کریں ا و ر  و ر د

 ۔ ا پنی سپیڈ کا لفظ پر نٹ  جا۷

 

پ
 ہ لیں 

 

۔ز  

 یا 

 

ا ر ت

 

          stucaoh  daebyeK:س

File Operations 
Create a New Document  Ctrl+N       

Save Document   Ctrl+S   

Save As Document  Ctrl+Alt+S  

Print Document   Ctrl+P 

Import Picture    Double Click on Picture Box 

Open an Existing Document  Ctrl+O 

Print Setup   Ctrl+Alt+P 

Import Text or Picture  Ctrl+Y 

Export Text or Picture  Ctrl+Alt+Y 

Close Document   Ctrl+F4 

 

 
 
 

KEYBOARD SHOTRCUTS 

 
 
 
 
 
 

 
 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 

 

 

 

 

 

 

 

Caret movement and Text Selection 

Previous Character  Left Arrow 

Next Character   Right Arrow 

Previous Word   Ctrl+Left Arrow 

Next Word   Ctrl+Right Arrow 

Previous Line   Up Arrow  

Next Line   Down Arrow 

Top of Previous Textbox  Alt+Up Arrow  

Top of Next Textbox  Alt+Down Arrow 

Top of Paragraph   Ctrl+Up Arrow  

Top of Next Paragraph  Ctrl+Down 

Arrow  

Beginning of Line   Home 

End of Line   End 

Beginning of Story  Ctrl+Home 

End of Story   Ctrl+End 

Select Word   Double Click  

Select Paragraph   Triple Click 

Text Formatting 

Bold    Ctrl+B 

Italics    Ctrl+I 

Left Alignment   Ctrl+Alt+L 

Right Alignment   Ctrl+Alt+R 

Center Alignment   Ctrl+Alt+C 

Text Editing 

Toggle English and Urdu Ctrl+Space 

Delete Previous Character Backspace 

Delete Previous Word  Ctrl+Backspace 

Delete Next Character  Del 

Delete Next Word  Ctrl+Del 

Cut   Ctrl+X, Shift+Del 

Copy   Ctrl+C, Ctrl+Insert 

Paste   Ctrl+V, Shift+Insert 

Undo Previous Operation Alt+Backspace,  

   Ctrl+Z 

Select All   Ctrl+A 

Find Text   Ctrl+F 

Replace Text   Ctrl+R 

Scroll Page Up by One Line

 Shift+Page Up 

Scroll Page Down by One Line

 Shift+Page Down 
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CHAPTER 5:         PRESENTATION PROGRAM  
 

POWER POINT 2010 

 

LECTURE – 28 

 
Introduction to PowerPoint: 
Power point is program (application software) which is ued to represent our information in the 
form of slides. 
The format of power point 2010 is PPTX. In which you can make wonderful presentation and also 
video & audio effect can be shown in presentation using power point slide show format. 
PowerPoint 2010 offers you advanced web and picture editing tools also. 
Power point also has similar type of Bars that you have already learned in MS word.  
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 جو د ا  

 

لائیڈ  لیں گے۔ تو ی ا د  ر کھیں سلائیڈ لے ا وٓ ت
ا سک ن    میں ھلے گا۔ و ہان سے ا پنی کائیںح ت  ا ٓت  نیو س

 

 کا ا نتخات  ئیڈم کی نوعیت کے مطابق سلا طرف ی

ا مل ہیں۔ا ی ک سلائیڈ کے بنیاد ی طور  پر د و  حصے ٹیکسٹکریں۔ ا س میں 

 

 یو ا و ر  گرا ف و غیرہ ست  س

 

 یو ، و د

 

ا ئٹل ، ا و ر  د و سرا  ، تصاو یر، ٹیبل، ا ٓد

 

 ہوتے ہیں۔ ا ی ک ی

 یٹا ا نٹر کریں۔

 

ا ئٹل۔ا سی کے مطابق ا پنا د

 

 ست  ی

  میں پڑھے ہیں ۔ ہاںن پر ہم صرف نیو  Menusی ا و ر  پوا ئنٹ میں

 

 ٹولز کو د یکھیں گے۔ و ہی ہیں جو ا ٓت  نے پہلے ا یم ا یس و ر د

ا 

 

ا ئٹلجون ہی ا ٓت  پرو گرا م کھولیں گے تو ا ٓت  کو ا و پر د ی ہوئی تصویر ملے گی۔ ا س میں ی

 

 د و  ا ٓپشن ہیں ۔کیونکہ ا تٓ  کے پرو کٹ    کے ا ندر  د و  ا ہم ا پٓشنز ئٹل ا و ر  ست  ی

 یٹا ا نٹر کرنے کے بعد ا ٓت  نے ا س کو فار میٹ کر

 

ے ہیں۔ جو ا ٓت  د یکھ ر ہے ہیں۔ ا س میں د

 

سکی
ا  ہے ۔ ا س کے لیے ا ٓت   ہو 

 

ر بن ا ستعمال کریں گے جو ا ٓت   Homeی

 کو ہم د یکھتے ہیں۔

 

  میں سیکھا ہے۔ جو نیو ٹولز ہیں ا ن

 

 نے پہلے ا یم ا یس و ر د

 بھی ملے گا جس میں   لے سکیں گے۔ ا س کے سا تھ ا ٓت  کو لےئیڈسلاا س ٹو ل کی مدد  سے ا ٓت  نیو

 

ا وٓ ت

 Ctrl+Mسے ا ٓت  ا پنی مرضی کا ا نتخات  کریں گے۔

ا  ہو ا سی طرج کا فار میٹ لیں گے تو 

 

  بنای

 

ڈ

 

 پ
پ
ا  پڑےی ا د  ر کھیں جس نوعیت کی سلا

 

  ا ٓت  کو بہت کم محنت کری

 گی۔ 

 

  ی ا قی فانٹس و غیرہ ا ٓت  کو پہلے سے ا تٓے ہیں۔

ے ہیں

 

سکی
 بدل 

 

ا  .ٹیکسٹ کا ر ج

 

 کری

 

ی ت

 

 یعنی ر و پ
 

ے ہیں۔ ٹیکسٹ

 

سکی
ا ت  ی ا  ی ا ٹم و غیرہ میں کر 

 

کو ی ا کس میں ی   

 ا ی  

 

 کی مدد  سے ا ٓت  مختلف د

 

 گرا م بنا سکیں گے۔ی ا و ر  پوا ا ا ن

 

ی
 میں ا س ٹول کا بہت ا ستعمال ہے ا س 

 

ت

 

 ی
ی

Visula Aid  ا  ہے

 

 ا ی   Presentationبھی کہا جای

 

ر  ہمیں کسی چیز کو د

 

کی
گرا م کی مدد  سے ا کے ا ندر  ا 

ا  ہے تو ا س ٹول کی مدد  سے 

 

ا  پڑی

 

 ا ٓت  کو ا سٓا نی سے ا ٓ جائے گا۔سمجھای

 

PowerPoint 

Screen 
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 ر ا 

 

 یہ د

 

ی
 کو ترتیب

 

  لے سکیں گے ا و ر  ا ن

 

ز
گ

 

 پ
پ

 ر ا 

 

گ ٹول ہے ا س کی مدد  سے ا ٓت  د

 

 پ
ی

  بھی د ے سکیں گے۔
 

 ٹول ہے ا س کی مدد  سے ا تٓ  

 

ز د ست
پ 
 

 

 بنا سکیں ٹیکسٹیہ بہت ر

 

 گے۔ ا س میں بٹن کو خوبصور ت

  ی سٹا۳ ، ئلسٹا

 

ا مل ہیں ئلد

 

 سٹا لکھنے کے بعد ا ٓت  ی ا کس سمیت ا س ٹیکسٹ س

 

ےئلکو ا ن

 

سکی
  یسا کر 

 ہیں۔

 

گ  می، جس میں تصاو یر ، 

 

 ر ا ینگ کے لیے فلپ

 

ا مل ہیں۔ ا س کے 2لی گی د

 

  و غیرہ س

 

  میر

 

 ، پیٹرن

 

 میر

ا مل ہیں۔ ٹیکسٹ سٹالز  ا و ر  ئنعلاو ہ لا

 

 بھی س

 

 مینو ہے۔ جس 

 

  ہیں۔ ا س کے علاو ہ تصاو یر کے لیے ا لبم ہے۔ ا س کے بعد ا نسرت

 

ز
گ

 

 پ
پ

 ر ا 

 

 ی ا د ہ تر د

 

میں ر

  میں سیکھ چکے ہیں۔ا س کے علاو ہ ا خٓر میں د و  نیو 

 

 ، ا و بجیکٹ ٹول جو ا ٓت  ا یم ا یس و ر د

 

ا س کے علاو ہ علامات

 ا ئیڈٹولز ہیں ۔موو ی کی مدد  سے ا ٓت  سلا

 

 یو کو د

 

 میں کسی و ی ڈ

 

پ
لا سکیں گے۔ ا س کے لیے ا ٓت  

ز یکٹ ج 

 یو کے لیے بھی ٹول ہے۔ا س ٹول پر 

 

 بتا د یں۔ ا س کے بعد ا ٓد

 

ن

 

 ش
کی

ا س کو بھی کلک کرنے بعد جا کر لو

 ا ٓت  ا سی طرج لے سکیں گے۔

 

 

 

 

 

 

 

 

 

 

LECTURE – 29 

 

Design       Alt+G 

 

 
 ر  ہے
ہ
ا 

 

ا م سے ط

 

  کی سیٹنگ جو کے ی

 

 ٹولز کی مدد  سے ا ٓت  سلای ڈ

 

جس  کر سکیں گے۔ا ن

  کا و یو ہے  کہ ا ٓت  ا سکو

 

 ا ت  تھا ا س سے ا گٓے سلای ڈ

 

 Portrait  or طرج پیج سی ت

Landscape   میں  کر سکیں گے 

 
  تیا ر  کرنے کے

 

 بعد ا س کو ا ی ک ا ھا یہ بہت ا ہم ٹول ہے ی ا و ر  پوا ینٹ میں کوئی سلای ڈ

 ہو جاے گی۔ا  کے  بعد

 

  خوبصور ت

 

 ا ین د یں ا س سے ا ٓت  کی سلای ڈ

 

ز
پ 
 

 

  ا و ر  د

 

 ا س کے  میر
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LECTURE – 31 

  میں پڑھ چکے ہیں۔  Reviewا ٓگے 

 

ر  ٹولز ا ٓت  ا یم ا یس و ر د

 

کی
 ا و ر  و یو مینو ہیں جن کے ا 

Powerpoint ا  ہے: میں

 

 ا ی ک پرو کٹ   کیسے بنا ی

ا   لیں ۔ئیڈسلا ۔ ست  سے پہلے ا ی ک نیو۱

 

ا ئٹلا س کے بعد ا س کے ی

 

ا م ا و ر  ست  ی

 

 کوئی ٹیکسٹلکھیں۔ ا ٓت   ٹیکسٹ میں تعلقہ  ئٹل میں ی

 

، ا و بجیکٹ، ٹیبل ، چار ت

( 

 

ے ہیں۔ ا س کے بعد ا ن

 

سکی
 ر ا ینگ کے لیے ا خٓر میں ا نٓے  بن کا  (فار میٹ کریں۔ ا س کے لیے ہوم ر ی ا  ا و بجیکٹ کو ٹیکسٹبھی چیز لے 

 

ا ستعما ل کریں ی ا  تصاو یر ، د

 ا ئیڈمینو فار میٹ کی مدد  سے کریں۔ ا س کے بعد سلا و ا لی نئی

 

ز
پ 
 

 

 سا  د

 

  ئین کو خوبصور ت
پ
  د یں۔ا س کے بعد ا گر ا و ر  سلا

 

  لینی ہیں تو و ہ بھی ا سی طرج لے لیں۔ ا س پ

 

 ر

 

ڈ

 پر

 

   Animationد یں۔ ٹم  Animationکے بعد ا ن
سک
  و غیرہ بھی لے 

 

ڈ

 

 یشن لے لیں۔ ا س کے سا تھ سا و ی

 

ز

 

پ
  ٹرا 

 

ے ہیں۔ ی ا  سلای ڈ

 

سکی
ے ہیں۔ ا س کے بھی د ے 

 

ی

  کی سیٹنگ بتا د یں۔ پھر F5بعد سیو کریں۔ پھر   

 

  ر

 

 ا ت  میں جا کر سلای ڈ

 

 Rehearseکی مدد  سے ا تٓ  ا س کو فل سکرین شو میں ی ا ر ی ا ر  د یکھیں۔ا س کے بعد سی ت

  کے ٹولز بھی موجود  ہیں۔

 

  فار  سلای ڈ

 

ڈ

 

 بیک گرا و ی

 

LECTURE – 30 

Animation      Alt+A 

 

 
 ی ا و ر  پوا 

 

ی
 میں کوئی سلا

 

ت

 

 ی
د ے سکیں Animation بنانے کے بعد ا تٓ  ا س میں ئیڈی

 مدد  سے ا ٓت  بنے گے۔ ا س کے لیے ا ٓت  کے ی ا س یہ ٹول موجود  ہے ۔ پہلے ٹول کی

ے ہیں۔ ا س کے علاو ہ ٹم  ئےہو

 

سکی
 لے 

 

پ کت
ن ف
کوی ا  Animation کا بہت ا ہم ٹو ل  

 کر ی ا  ٹیکسٹہے جس میں چا ر  ا ٓپشن ہیں۔ ا س کے لیے ا تٓ  پہلے 

 

پ کت
پ ل
س

یں ا و بجیکٹ کو 

 پر کلک کریں ا و ر  

 

پ کت
ن ف
   Advanced Effectsا  س کے بعد ا س میں موجود  کسی ا 

 
ک
 میں جا کر 

 

 بھی بتا سکیں گے۔ر

 

پ کت
ن ف
ی ڈ  ا   

 
  
پ
 کی مدد  سے ا ٓت  کسی سلا

 

 یشن ہیں ۔ ا ن

 

ز

 

پ
  ٹرا 

 

 یہ سلای ڈ

 

  میں تبدیلی کا سٹاپ

 

 لا سکیں ئلڈ

  
پ
 گے جس سے ا ٓت  کی سلا

 

 ہو جاپ

 

  بہت خوبصور ت

 

  میں صرف ئیڈگی۔بعض سلا ئےڈ

 

ر

  
پ
 سلا

 

ز د ست
پ 
 

 

 یشن لگا کر بہت ر

 

ز

 

پ
 ٹرا 

 

لا تصاو یر و غیرہ میں ۔پ

 

  بنائی جاتی ہیں مپ

 

 ر

 

 ڈ

 

 یشن کی سپیڈ کیا ہو ا و ر  

 

ز

 

پ
 بھی ہے۔کہ ٹرا 

 

پ کت
ن ف
  ا 

 

ڈ

 

ا س میں ا س کی سپیڈ ا و ر  سا تھ سا و ی

  کا ا ٓپشن 

 

ڈ

 

  و غیرہ ا ٓت  کے کمپیوٹر میں موجود  ا لگ سے کوئی سا و ی

 

 Otherسا تھ کوئی ا وٓ ا ر

Sound یشن کی سپیڈ بھی موجود بھی موجود  ہے۔ 

 

ز

 

پ
ہے ۔ پھر ا تٓ   پھر ا سی جگہ ٹرا 

Effetsپر چاہتے ہیں ی ا  صرف ا ی ک پر ۔  

 

 کا ٹول ہے۔ Apply to Allپور ی سلائیڈر
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Timings   کریں جتنی د یر ا ٓت  سلا 

 

ا ئم سی ت

 

ا  چاہتے ہیں۔پھر ا تٓ   ئیڈکی مدد  سے ا ٓت  ی

 

   PowerPoint Showکی مدد  سے جا کر ا س کو  Save As کو ج لای

 فار میٹ میں سیو کریں۔

 Power point ۔ئیںمیں ا ی ک فوٹو ا لبم کیسے بنا: 

ے ہیں

 

سکی
 نکلوا  

 

ٹ

 

پ
ے ہیں ا و ر  پر

 

سکی
 بھی کر 

 

 ت

 

 کو ا س پرو گرا م کی مدد  سے ا ی ڈ

 

  یعنی ی ا و ر پوا ا ٓت  کے ی ا س ا گر تصاو یر ہیں تو ا ٓت  ا ن

 

ی
 یٹنگ ٹول کا کا

 

ز  ا ی ڈ
ج 
 پ ک
پ

 ا ی ک 

 

ت

 

 ی
م ی

  میں د کھا بھی سکیں گے۔

 

 بھی کر سکتا ہے۔ا و ر  پرو گرا م میں ا چھے ا ندا ر

Insert مدد  سے نیو فوٹو ا لبم ٹول پر کلک کریں۔ کی  

ے ہیں۔ یعنی ر و شنی ا و ر  کنٹر

 

سکی
 بھی کر 

 

 ٹ
پ
 

 

 کو ا ی ڈ

 

 کریں۔ا س کے بعد ا پنی مرضی کاا س کے بعد ا س میں جا کر فایل کی مدد  سے تصاو یر بتا د یں۔ ا ن

 

 بھی سی ت

 

 ا ست

 کر لیں تو

 

 بھی بتایں۔ح ت  ا تٓ  تمام تصاو یر کو سی ت

 

ے ہیں  Createلے ا وٓ ت

 

سکی
 کر 

 

 ت

 

۔ ا  س کے لیے ا ٓنے کر د یں۔ا س کے بعد ا ٓ نے و ا لی تصاو یرو ن کو ا ٓت  ا ی ڈ

 س

 

 ہت
ن
ل کلک کریں ا و ر  ا نٓے و ا لے ا پٓشنز کی مدد  سے ا تٓ  تصاو یر کو 

 
ی
 

 

Stylsihو ا لی تصاو یر پر د ا  چاہتے ہیں تو سیو ا لگ سیو کر کر سکیں گے۔ ا گر ا ٓت  کسی تصویر کو

 

ی

 میں سے کو

 

  کی مدد  سے ا تٓ  ا سکا فار میٹ ا  ن

 

ز
پ 
ر کھ کر کر د یں۔ ئیا   GIF, JPEG, BMP, PNG etc. 

  کو و یب پیج کے لیے بھی 

 

  ر

 

HTMLا س کے علاہ ا ٓت  ا پنی سلای ڈ ے ہیں ۔ا و ر  بعد میں و یب میں ا ستعمال کر سکیں 

 

سکی
  گے۔فار میٹ میں سیو کر 

 

 

 ا و ر  ا س کے بعد ا ٓت  ا ن

 

پ کت
ن ف
 یشن ا 

 

ز

 

پ
تصاو یر پر ٹرا  Animation  ی طرج سیو بھی کریں ۔

 ہل
ن

 بھی د یں ا و ر  پرو کٹ   کو 

  میں ا ی ک نیو مینو 

 

 و د
ی

 

پ ی
م

 .ہے ا س کے کچھ ٹولز د یکھیںSlide Showا و پر 

Alt+S 

  پہلے ٹول کی مدد  سے ا تٓ  شو کو شرو ع سے ج لا سکیں گے ۔ ا و ر  د و سرا  ا ٓ

 

پشن ہے کہ ا تٓ  جس سلای ڈ

  ی ا ر  ی ا ر  ہ د یکھنا

 

 ر

 

ی سلای ڈ

 ہل
ن

ا  کہ ا ٓت  کو 

 

  پڑیں۔ پر ہیں و ہیں سے شو چل پڑے ی

 

  کے 

 

 ر

 

  کی صوا س ٹو ل کی مدد  سے ا ٓت  مختلف سلای ڈ

 

 میں سیو ر کر سکیں گرو ت  ا لگ ا لگ شور

 

ر  ت

 گے ا س میں پہلے نیو کی مدد  سے گے ا و ر  بعد میں ا سی ٹول کی مدد  سے جا کر شو بٹن سے ج لا سکیں

 کو ج لایں۔

 

  کریں ا و ر  پھر ا ن

 

 شو ا ی ڈ

 

  ہیں ا س پر کلک کرنے

 

ز
گ

 

پ

 

پ ی
س

سے ا ٓت  کے سا منے ا ی ک  بہت ا ہم ا ٓپشن ہے ا س میں بہت سا ر ی 

 ا 

 

پ  د

 

پ
لاگ ی ا کس ا ٓ جائے گا ۔  

 

ا  چاہتے ہیں۔ جس

 

  ج لای

 

 ر

 

 میں پہلا ا لٓ ہے ی ا  پھر جس میں پہلا ٹول ہے کہ ا ٓت  شو میں کتنی سلای ڈ

5to 5 or 10 to 15ا ٓت  بتا د یں کہ   ا مل کرتے ہوئے 

 

ی کو س

 ہل
ن

  

 

 ر  سلای ڈ
ہ
ا ٓگے  ا س میں 

ے ہیں کہ فل سکر

 

سکی
 کر 

 

 و  میں پھر ین شو چلےجائے گی۔پھر ا س میں ا ٓت  سی ت

 

ڈ

 

 ی ا  کہ چھوٹی و ی

 ی ڈ  سیٹنگ ہیں جن کو ا ٓت  

 

ر
ک

  کر ھ کرپڑ

 

ے ہیں  یور

 

سکی
۔  
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  شو میں ہیں  ج لانی تو ا س کو ہائید کر د یں ۔

 

 ا گر کوئی سلای ڈ

 

 ہو ر ہا ہے  Narrationپہلا ٹول ہے 

 

ا  ہے ا س کا مقصد ہے جو بیان

 

  ہو  یہ ٹو ل کیا کری

 

و ہ ر یکار د

 ا و ر  سپیکر د و نون چاہیں ا پنے سپیکر

 

  ج لا د یں جائے ا س کے لیے ا ٓت  کو ہیڈ فون

 

 سے ا ٓت  کو ئی ا وٓ ا ر

 کر کہ ا س ٹول پر کلک

 

 کو سی ت

 

 ا لے پیغام کے بعد سیو کریں کریں ا  س کے بعد ا ٓنے و ا و ر  ہیڈ فون

  ہو جا

 

  کے سا تھ ر یکار د

 

 ر

 

  سپیکر پر چل ر ہی تھی و ہ ا ٓت  کی سلای ڈ

 

ئے گی۔ تو جو ا وٓ ا ر  

ا  ہے ا س ٹول پر کلک کر

 

 کری

 

ا ئم کے سا تھ سی ت

 

یںپھر ا س میں شو کو ی   

 پرئیڈا پنی تمام سلاپہلے ا ٓت  

 

 کر لیں ا ن

 

  کو سی ت

 

ر Animation  ا ل 

 

 و غیرہ د

 

پ کت
ن ف
د یں  ا و ر  تمام ا 

 

 

ا ئم ا ٓت  ر کھیں گے ا تنا ہی ا و ر  ا س ٹول کلک کرنے سے ا تٓ  کا شو ا ت  ا ٓٹو میٹک ہو جائے گا جتنا ی

ا ئم ا ٓت  کی سلا

 

شو ج لا د یں ۔  شو میں چلے گی ا س کے بعد ا س کو سیو کرد یں ا و ر ئیڈی  

Rehearse Timings 

 لیشن، ہے ا و ر  پھر پرجیکٹر کی سیٹنگ بھی ہیں

 

   ۔یہ سکرین کو ر یور

 
Assignment: 
 
No1. Make five slides project with pictures using insert album tool, format it, edit it, apply 
animations, transition and save these in PowerPoint show? Use your own name and any title 
style for 1st slide. 

:

 

 کام کی ی ا ت

 

 

 میں بتانے جا ر ہا ہون صرف ا ن

 

ا  جانتے ہیں ا و ر  ا س پرئنٹکے لیے جو ی ا و ر   پوا   Studentsا ت  جو ی ا ت

 

 و  مقاصد جانتے ہیں۔ گرا م کے ا غرو  کے ا ندر  کام کری

 

ا ص

۔۔یعنی پرو گرا م مکمل کر چکے ہیں۔   

ا سکئیں میں نیو پر کلک کریں گے تو ا تٓ  کے ی ا س د ا ئلح ت  ا ٓت  فا

 

ا    ن   کہا  طرف ا ی ک ی ا ر  ھلے گی جس کو ا ٓت  جانتے ہیں کہ ی

 

ہے۔ جای  

 ا  س میں بنے ہو

 

  ی

 

سکی
 میں سے ا ٓت  ا پنی مرضی کا ا نتخات  کر 

 

 کی تفصیلپرو کٹ   ہیں ا ن

 

میں سیکھی۔  ا ٓت  نے کور سے ہیں۔ ا ن  

 می ا ٓپشن بتا د یتا ہون۔

 

 میں ہاںن پر ا ی ک لار

New  ج لا  

 

 ا ر د

 

۔یہ ا صل میں ا ٓت  کے کام سے تعلقہ  ئیںپر کلک کریں ا و ر  ا ٓگے و ر From Auto Content Wizard  ی ا ر میں  

  کامختلف پر

 

ے ہیں۔یعنی سلای ڈ

 

سکی
 سے لے   و کٹ   موجو د  ہیں جن کو ا ٓت  ملاظہ  کر 

 

 ، سٹار ت

 

کر پور ا  لے ا وٓ ت Finish  ک۔ ا کے  بعد ا تٓ  پرکٹ   کر ا نتخا

 

ت  کریں ی

 ، کمرشل و غیرہ کے ا ٓپشن موجود  ہیں۔ ا س کے مطا بق ا گٓے چلیں۔ 

 

، سیمینار ، شور

 

  بن کہ ا ٓ گیا س کے بعد ا ٓت  د یکھیںجس میں تجار ت

 

 ر

 

۔ا ت  صرف ہیں  گے سلای ڈ

 یٹا لکھیں تو ا ٓت  کا پرو کٹ   ا پنی نوعیت

 

 ا فٓس  گا۔ا س کی پریکٹس ضرو ر  کریں۔  ئے مکمل ہو جاکا د

 

ٹ
ل
  میں ہے۔جبکہ ا فٓس 2660یہ سہو

 

ز

 

پ
 

 

ز
پ 
 سے پہلے کے و ر 

2007 -2010  کہ ہے و ہ ا س طرج کہ ا ٓت  ح ت  نیو پر کلک کریں گے تو ا تٓ  کے ی ا س ا ی ک  

 

 ا  سا  ہ ت

 

ا ٓئےگا ا س میں ی ا ئیں  Dialoge Boxمیں یہ ا پٓشن تھور

  Installed Tamplets ا ی ک ا پٓشن ہے طرف بہت سا ر ے ا ٓپشن ہیں ا س میں
س
 کر 

 

 ت

 

 کی مد د  سے بھی ا ٓت  بنے ہوئے فار میٹ لے کر ا ی ڈ

 

ے ہیں ۔ یعنی ا ن

 

کی

 کو سمجھیں کہ کیا چیز کیسے

 

 ہو جائے ۔ ضرو ر  د یکھیں ا و ر  ا ن

 

ا  کہ ہمار ا  کام ا ٓسا ن

 

ے ہیں ی

 

سکی
 کو ا پنی نوعیت کا بنا 

 

لی گئی ہے۔  ا ن  

 

 

 د

 

یل ہیںی ا و ر  پوا ینٹ سے تعلقہ  کیز د ر ج  
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The 10 most useful shortcut keys in PowerPoint   

  

F5 Runs the presentation (View > Slide Show) 

Shift + F3 Toggles between lowercase, mixedcase and uppercase on the 

selection 

Shift + F9 Toggles the display of Guide Lines 

Shift + Enter Enters a line break (Soft break) 

Ctrl + A Selects all the objects on the active slide 

Ctrl + T Displays the (Format > Font) dialog box 

Ctrl + Shift + Tab Toggle between the Slides and Outlines tabs (Normal view) 

Ctrl + Shift + G Group the currently selected objects / shapes 

Ctrl + Shift + H Ungroups the currently selected object / shape 

Alt + Shift + F4 Closes all the presentations (saving first) and exits PowerPoint 

(File > Exit) 
 

Essential   

  

1 + Enter Goto slide number 1 

2 + Enter Goto slide number 2 

Escape Stops the slide show 
 

  

  Letters   

  

A Show or hide arrow pointer 

B Toggles the display of a black screen 

E Erase any on screen annotations 

H Displays the next hidden slide 

M Use the mouse click to move to the next slide 

N Move to the next slide or perform the next animation 

O Use the original timings while you are rehearsing 

P Move to the previous slide or perform the previous animation 
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S Stop or restart the slide show 

T Set new timings while you are rehearsing 

W Toggles the display of a white screen 
 

  Ctrl + Letters   

  

Ctrl + A Redisplay the hidden pointer and/or change the pointer to an 

arrow 

Ctrl + H Hide the pointer and navigation buttons immediately 

Ctrl + M Toggle the display of the ink markup 

Ctrl + P Redisplay the hidden pointer and/or change the pointer to a pen 

Ctrl + S Display the All Slides dialog box 

Ctrl + T Display the task bar 

Ctrl + U Hide the pointer and navigation buttons in 15 seconds 
 

  

  Manoeuvring   

  

Spacebar Move to the next slide or perform the next animation 

Enter Move to the next slide or perform the next animation 

Page Down Move to the next slide or perform the next animation 

Right Arrow Key Move to the next slide or perform the next animation 

Page Up Move to the previous slide or perform the previous animation 

Left Arrow Key Move to the previous slide or perform the previous animation 

Up Arrow Move to the previous slide or perform the previous animation 

Backspace Move to the previous slide or perform the previous animation 

1 + Enter Goto slide number 1 

2 + Enter Goto slide number 2 
 

  

  Other   

  

= Show or hide arrow pointer 

. Toggles the display of a black screen 
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, Toggles the display of a white screen 

+ Stop or restarts the slide show 

Esc Stop the slide show 

Ctrl + Break Stop the slide show 

Hyphen Stop the slide show 

Shift + F10 Display the shortcut menu 

Tab Move to the first or next hyperlink on the slide 

Shift + Tab Move to the last or previous hyperlink on the slide 
 

Function Keys   

  

F1 Display Help or the Office Assistant 

F2 Select the text box containing an object or text 

F4 Repeats the last presentation action (Edit > Repeat) (not 

Format Autoshape dialog) 

F5 Runs the presentation (View > Slide Show) 

F6 Moves to the next pane in the presentation (clockwise) 

F7 Displays the (Tools > Spelling) dialog box 

F10 Toggles the activation of the Menu Bar 

F12 Displays the (File > Save As) dialog box 
 

  

 

  Shift + Function   

  

Shift + F1 Activates the context sensitive Whats this ?prompt (Help > 

Whats This) 

Shift + F3 Toggles between lowercase, mixedcase and uppercase on the 

selection 

Shift + F4 Repeat the last Find, the same as (Edit > Find Next) 

Shift + F6 Moves to the previous pane in the presentation (anti-clockwise) 
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Shift + F9 Toggles the display of Guide Lines 

Shift + F10 Display the (Shortcut) menu for the selected item 

Shift + F12 Saves, Displays the (File > Save As) dialog box if a new 

presentation 
 

  Ctrl + Function   

  

Ctrl + F4 Closes the active presentation or window (File > Close) 

Ctrl + F5 Restore the size of the active presentation or window 

Ctrl + F6 Moves to the next presentation window 

Ctrl + F7 Activates the Move window command 

Ctrl + F8 Activates the Resize window command 

Ctrl + F9 Minimises the size of the active presentation or window 

Ctrl + F10 Maximise the size of the active presentation or window 

Ctrl + F12 Displays the (File > Open) dialog box 
 

  

  Other + Function   

  

Alt + F2 Displays the (File > Save As) dialog box 

Alt + F4 Closes the active presentation (saving first) and exits 

PowerPoint (File > Exit) 

Alt + F5 Restore the program window size 

Alt + F7 Find next mispelt word - continue (Tools > Spelling) ?? 

Alt + F8 Displays the (Tools > Macros > Macro) dialog box 

Alt + F9 Toggles the display of the Grid 

Alt + F10 Maximise the program window 

Alt + F11 Toggles between the Visual Basic Editor window and the 

PowerPoint window 

Alt + Shift + F2 Displays the (File > Save As) dialog box 

Alt + Shift + F4 Closes the active presentation (saving first) and exits 
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PowerPoint (File > Exit) 

Alt + Shift + F10 Displays the drop-down menu for the corresponding smart tag 

Ctrl + Shift + F10 Activates the Menu Bar or displays the (View > Toolbars) 

dialog box 

Ctrl + Shift + F12 Displays the (File > Print) dialog box 
 

  Ctrl + Numbers   

  

Alt + Shift + 1 Show Heading 1 (Outline view) 

Alt + Shift + 9 Expands all text in the presentation (Outline view) 
 

  

  Ctrl + Letters   

  

Ctrl + A Selects all the objects on the active slide 

Ctrl + B Toggles bold on the current selection 

Ctrl + C Copies the current selection to the clipboard (Edit > Copy) 

Ctrl + D Make a duplicate of the selected slide (Edit > Duplicate) 

Ctrl + E Centre aligns the current selection 

Ctrl + F Displays the (Edit > Find) dialog box 

Ctrl + G Displays the (View > Grid and Guides) dialog box 

Ctrl + H Displays the (Edit > Replace) dialog box 

Ctrl + I Toggles italics on the current selection 

Ctrl + J Justifies the current selection 

Ctrl + K Displays the (Insert > Hyperlink) dialog box (in a textbox) 

Ctrl + L Left aligns the current selection 

Ctrl + M Inserts a new slide (Insert > New Slide) 

Ctrl + N Creates a new presentation (File > New) 

Ctrl + O Displays the (File > Open) dialog box 

Ctrl + P Displays the (File > Print) dialog box 

Ctrl + R Right aligns the current selection 
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Ctrl + S Saves, Displays the (File > Save As) dialog box if a new 

presentation 

Ctrl + T Displays the (Format > Font) dialog box 

Ctrl + U Toggles (continuous) underlying of the selection 

Ctrl + V Pastes the entry from the clipboard (Edit >Paste) 

Ctrl + W Closes the active presentation or window (File > Close) 

Ctrl + X Cuts the current selection to the clipboard (Edit > Cut) 

Ctrl + Y Repeats the last presentation action (Edit > Repeat) 

Ctrl + Z Undo the last presentation action (Edit > Undo) 
 

  Others + Letters   

  

Ctrl + Shift + B Opens the Outlook Address Book 

Ctrl + Shift + C Copies the formatting attributes from the current selection to the 

clipboard 

Ctrl + Shift + F Activates the Font Names drop-down on the Formatting toolbar 

Ctrl + Shift + G Group the currently selected objects / shapes 

Ctrl + Shift + H Ungroups the currently selected object / shape 

Ctrl + Shift + P Activates the Font Size drop-down on the Formatting toolbar 

Ctrl + Shift + V Pastes the formatting attributes from the clipboard on to the 

selection 

Alt + D Displays the (Slide Show) menu 

Alt + E Displays the (Edit) menu 

Alt + F Displays the (File) menu 

Alt + H Displays the (Help) menu 

Alt + I Displays the (Insert) menu 

Alt + K Checks the names in the To, Cc and Bcc lines against the 

Address Book 
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Alt + O Displays the (Format) menu 

Alt + S Displays an e-mail message containing the active presentation 

Alt + T Displays the (Tools) menu 

Alt + U Displays the AutoShapes drop-down menu on the Drawing 

toolbar 

Alt + V Displays the (View) menu 

Alt + W Displays the (Window) menu 

Alt + Shift + A Show all or collapse all text or headings (Outline view) 
 

  Entering Data   

  

Enter Enters a new paragraph 

Shift + Enter Enters a line break (Soft break) 

Ctrl + Tab Inserts a tab in a table cell 
 

  

  Extending Data   

  

Shift + Home Extends the selection to the beginning of the line 

Shift + End Extends the selection to the end of the line 

Shift + Up Arrow Extends the selection one line up 

Shift + Down Arrow Extends the selection one line down 

Shift + Left Arrow Extends the selection one character to the left 

Shift + Right Arrow Extends the selection one character to the right 

Ctrl + Shift + Home Extends the selection to the beginning of the textbox 

Ctrl + Shift + End Extends the selection to the end of the textbox 
 

  

  Selecting Data   

  

Ctrl + Shift + Up Arrow Selects to the line above 

Ctrl + Shift + Down Arrow Selects to the line below 

Ctrl + Shift + Left Arrow Selects to the beginning of the word 

Ctrl + Shift + Right Arrow Selects to the end of the word 
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Delete Deletes one character to the right 

Backspace Deletes one character to the left 

Ctrl + Delete Deletes one word to the right 

Ctrl + Backspace Deletes one word to the left 
 

  Formatting Data   

  

Ctrl + ] Increases the font size to the next size in the drop-down list 

Ctrl + [ Decreases the font size to the next size in the drop-down list 

Ctrl + Shift + > Increases the font size to the next size in the drop-down list 

Ctrl + Shift + < Decreases the font size to the next size in the drop-down list 

Ctrl + = Toggles Subscript on the selection 

Ctrl + Shift + = Toggles Superscript on the selection 
 

  

  Maneuvering   

  

Arrow Keys Moves one character or line in the given direction 

Tab Moves to the first or next hyperlink / object / cell 

Shift + Tab Moves to the last or previous hyperlink / object / cell 

Home Moves to the beginning of the line 

End Moves to the end of the line 

Page Up Moves to the previous slide 

Page Down Moves to the next slide 

Shift + Page Up Moves to the previous slide 

Shift + Page Down Moves to the next slide 

Ctrl + Home Moves to the beginning of the text box 

Ctrl + End Moves to the end of the text box 

Ctrl + Up Arrow Moves up one paragraph 

Ctrl + Down Arrow Moves down one paragraph 

Ctrl + Left Arrow Moves one word to the left 
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Ctrl + Right Arrow Moves one word to the right 

Ctrl + Enter Moves to the next title or body text placeholder 
 

 

  

 

 

Other 

  

  

Alt + Tab Toggles between all your open applications 

Alt + Shift + Tab Toggles backwards between all your open applications 

Ctrl + Shift + Tab Toggles between the Outline tab and the Slides tab in Normal 

view. 

Ctrl + Spacebar Remove manual character formatting returning the text back to 

its default 

Esc Cancels the action or closes the dialog box 

Alt + Shift + Left Arrow Promotes a paragraph (Outline view) 

Alt + Shift + Right Arrow Demotes a paragraph (Outline view) 

Alt + Shift + Up Arrow Moves the selected paragraphs up (Outline view) 

Alt + Shift + Down Arrow Moves the selected paragraphs down (Outline view) 

Alt + Shift + + Expands the text below a heading (Outline view) 

Alt + Shift + - Collapses the text below a heading (Outline view) 

/ Turn character formatting on or off (numeric keypad) 

Alt + Escape Switches to the next program 

Ctrl + Escape Displays the Start Menu 

Print Screen Copies a picture of the whole screen to the clipboard 

Alt + Print Screen Copies a picture of just the active window to the clipboard 
 

  

  Redundant Shortcut Keys   

  

Ctrl + Shift + F6 Move to the previous presentation window ?? 

Alt + S Send presentation as an email ?? 
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Alt + K Check the names in email against the address book ?? 
 

 

What you have learned? 
There are two parts of a slide a title & subtitle. 
In this program you have learned about making a decorated presentation and starting its show in 
full screen. 
Making presentation & formatting it. 
Using animations including simple animation & custom animation also called advanced 
animation. 
Copying urdu text in a slide using paste special tool for this purpose. 
Using media clips, like inserting sound, video, and adding your own voice as well, form insert 
menu in movies & sounds. 
Arranging slides & starting it show using slide show menu that is discuss above. 
Saving your slide as picture using save as tool in file menu using GIF & JPEG format. 
Start presentation directly using save as button in file menu & format must be power point show. 

 

__________________ 

 

ھا  ہون جو ا پنی تعریف خود  کرتے ہیں۔ حالانکہ و ہ خود  بھی جانتے ہیں کہ یہ کوئی 

 

ی کی

 کی آت سے د 

 

 ی حیرت

 

ز
پ 
 ہیں  میں بہت سا ر ے ا یسے لوگون کو 

 

ا چھی ی ا ت

ٹ  ہے کہ ا تٓ  کی تعریف کوئی د و سرا  کرے۔ ا س کے علاو ہ میں ا یسے لوگون کو د ل سے بہت کمزو ر  ا و ر  بے عقل 

 

پ
 تو 

 

 مگر ہان ا  ہون۔سمجھتا ہے۔ ی ا ت

 

  ن

 

کو خوس

 کرنے کے لیے ا 

 

ا  کہ ا کی تعریف  ن

 

ا  ہون ی

 

 ھ چڑھ کر کری

 

ز
پ 
 کاا و ر  

 

 شو ق پور ا  ہو۔ ن

ا م

 

 کے ی

 

، لالچ ا و ر  تعریف کے کام کرتے ہیں۔ یعنی و ہ کام کرتے ہیں لیکن د نیا ا ن

 

 لوگون سے متاثر ہون جو بغیر کسی عزت

 

ن ہوتی  مگر میں و ا قعی ا ن
 
ی
 
ہ

 

ن

سے و ا قف 

 کے کام کی 

 

 د یں۔ لیکن ی ا  لیکن ا ن

 

 ٹ
پ
 

 

 کو ا س کا کری ڈ

 

  ھ کر ا ن

 

ڈ

 

 ھوی

 

 کو د

 

 کو ضرو ر  د ا د  د یں۔ ا و ر  ا ن

 

 ر  جگہ ہوتی ہے۔ میں ا ٓت  سے صرف یہ کہون گا ۔ کہ ا ن
ہ
 

 

ی ا ت

  
ہ
 ی ا د ہ ہو گی جو 

 

 سے ر

 

 ا ن

 

 کی عزت

 

 ر  گز ا ھا خیا ل ہیں  کریں گے۔ تو سمجھ لیں یہی لوگ کامیات  ہیں ا و ر  معاشرے میں ا ن
ہ
 ا د ر کھیں و ہ ا س کو 

 

ٹ
ق
پنے تعریف ر  و 

 کی تعریف ہو۔

 

 خو د  کرتے ہیں ا و ر  ا س کوشش میں ہوتے ہیں کہ ا ن

ک کو د یکھا  ا س آت سے کہ یہ کہان جا 

 

ک ی

 

 کی قدر  کریں کھبی کھبی ا پنی گھڑی کی ی

 

ٹ
ق
 ندگی سے یار  کریں یہ صرف ا ی ک ی ا ر  ہی ملتی ہے۔ و 

 

ر ہی ہے ہان میری ا و ر  ر

 

 

ک ی

 

 ۔ کھبی ا س ی

 

 ۔ک کو غور  سے د یکھیں یہ مجھ سے ا و ر  ا ٓت  سے کوئی وفا ل بھی کرتی ہے ا و ر  و ہ وفا ل کیا ہے؟وفچنا ضرو ر ا ٓت  کی منزل ا ی ک ہے و ہ ہے موت

______________ 
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CHAPTER 6:         MS. EXCEL 2010 
 

LECTURE – 32 
MS Excel: 
Ms Excel is spread sheet software, which provide you the facilities of arranging and storing large 
amount of data (text and numbers), performs calculations, analyze information, draw charts and 
Diagrams and also can be used for creating small data base as well.  
Using Ms Excel you can make large spread sheets and can use functions that provide you more 
smooth results of your data and your tables become more accurate. 
The format of MS Excel is .XLSx & others.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ا  ضرو ر ی ہیں۔ 

 

 س کس کری

 

 می چیزیں د

 

 کچھ لار

ل میں کیون 
س
ی ک

  کے بجائے ا 

 

 ہےکہ ہم کوئی ٹیبل و ر د

 

ی ی ا ت

 ہل
ن

ا  ا ٓت  ا چھی طرج سمجھ چکے ہیں۔ لیکن ح ت  ا ی ک ٹیبل  بنائیں

 

  میں ٹیبل بنا ی

 

گے۔ تو ی ا د  ر کھیں و ر د

  میں کنٹرو  ل ہیں  کر سکیں

 

 سے کرا س کر جائے گا تو پھر ا ٓت  ا س ٹیبل کو و ر د

 

مت
ل
 مینو میں ا و بجیکٹ ٹول موجود  ا ی ک 

 

 ہے کہ ا ٓت  کے ی ا س ا نسرت

 

 گے۔ و ہ ا لگ ی ا ت

ے ہیں۔

 

سکی
  میں کھول کر ا پنا تعلقہ  کام کر 

 

ل کو و ر د
س
ی ک

 ہے جس کی مدد  سے ا ٓت  ا 

ا  ہو ا س کے

 

  میں ہینڈل کری

 

 یٹا کو سکرین پر بھی بہتر ا ندا ر

 

ا  ہو ا س کے علاو ہ د

 

 ے پیمانے پر حسات  کتات  کری

 

ز
پ 
ا  لیکن ح ت  ا ٓت  نے 

 

 علاو ہ فار مولون کا ا ستعمال بھی کری

 ہو جا

 

ل کا ا نتخا ت  کریں۔ا س سے ا ٓت  کا کام بہت ا ٓسا ن
س
ی ک

ا  ہے ۔جو  ئےہو تو ا س کے لیے ا ٓت  ا 

 

ر ا ہم کری
ف
 بھی 

 

ٹ
ل
 یٹا بیس کی سہو

 

ل ا تٓ  کو د
س
ی ک

گا۔ ا س کے علاو ہ ا 

ے ہیں۔

 

سکی
ل سے گزا ر ا  کر 

س
ی ک

س میں کام ہیں  جانتے تو و ہ ا 

سی 
ی ک

 لوگ ا یم ا یس ا 

ل کے ا ندر  ح ت  ا ٓت  نیو پر کلک کرتے ہیں تو ا ٓت  کے ی ا س نیو و ر ک ی ک ا جٓاتی ہے۔ ا س کے ا ندر  ا 
س
ی ک
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No of Sheets = 0-255 
No of page per sheet = 0-255 
Every worksheet has columns (A – XFD) and 1758401 rows. 
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Default sheets in new book=3 
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There can be 3200 characters can be write in cell but according to rules 255 
One formula can hold up to 3200 letters.etc 

ل میں ر و  ا و ر  کا
س
ی ک

 د و نون جگہ ا نٹر ہو گا۔ ا س کے علاو ہ سیل ر یفرینس)ا 

 

ی ت

 

 یٹا فار مولا ی ا ر  ا و ر  س

 

 یٹا ا نٹر کریں گے تو ا ٓت  کا د

 

 یٹا ا نٹر ح ت  ا ٓت  د

 

ا  ح ت  ا ٓت  د

 

لم  کا کمبائن ہوی

 کیا   5کریں گے تو ا ی ک طرف سے ر و  ا و ر  د و سرا  کالم میں ا نٹر ہو گا تو جیسے ا تٓ  نے لکھا 

 

ر ص
ف
 تو یہ 

 ر یس ہے۔میں 

 

 A1 لکھا گیا تو یہ ا س کا سیل ر یفرینس ی ا  ا ی ڈ

 یٹا ا نٹر کریں گے تو ا گر نمبر  

 

ل میں ح ت  د
س
ی ک

ٹ  ا ٓت  ا 

 

پ
ا 

 

  ی

 

ت

 

 ی
ے ہیں۔ا ی ک  ی ا ئیںکی  ٹیکسٹہو گی ا و ر   د ا ئیںکریں گے تو ا س کی ا لاین می

 

سکی
۔ ا س کے بعد ا تٓ  بدل بھی 

ے ہیں لیکن 255سیل کے ا ندر  ا صولی طور  پر 

 

سکی
  لکھے جا 

 

ٹ  کریکٹر  3266 ا صل میں ا ٓت  لیٹرر

 

پ
ا 

 

ے ہیں۔  ی

 

سکی
 کر 

 ا یریکٹ بھی 

 

 یٹا ا نٹر کرنے کے لیے ا ٓت  د

 

ٹ  ا س کے بعد کچھ ا و ر  ا ہم چیزیں د

 

پ
ا 

 

 کر کہ بھی  ی

 

کی ت
پ ل
س
ے ہیں ا و ر  

 

سکی
ٹ  کر 

 

پ
ا 

 

 کیا ا ٓت  نے کافی جگہ  ی

 

ر  ص
ف
ے ہیں۔ 

 

سکی
کر 

 کر 

 

پ کت
پ ل
س

ک چاہتے ہیں 

 

ا  ہے تو ا ٓت  جہان ی

 

 یٹا ا نٹر کری

 

  سے ا یفا ی ک طرج کا د

 

 یٹا ا ی ک سیل میں لکھیں ا س کے بعد کی بور د

 

ا و ر   کنٹرو ل ا نٹر کریں  ی ا ئیںد   2لیں۔ د

ا  ہے۔

 

 ۔ پھر د یکھ لیں کیا ہوی

 کور س میں سیکھیں گے۔ا ٓت    Techniquesا سی طرج کی ا و ر 

  کے کچھ ا ہم ا پٓشنز کو د یکھتے ہیں۔

 

 ا ت  ہم مینور

ل میں
س
ی ک

  و ہی ہیں جو ا ٓت  نے پہلے پڑھی ہیں ا 

 

 ۔کچھ نیو ا پٓشنز۔کچھ مینور

 س کس ہوا  یہ بہت ضرو ر ی ہے۔

 

۔جو کور س میں د  ا ت 

 

 فایل مینو میں پیج سی ت

 : 

 

 مینو میں ا ٓفس کلپ بور د

 

 ت

 

 ا ی ڈ

ے ہیں ا 

 

سکی
 ا یریکٹ بھی کر 

 

ل کا کام د
س
ی ک

  کے ا ندر  ا یم ا 

 

  میں فار مولون کو ہم نے تفصیل سے ہیں  پڑھا۔ چونکہ ہم ا یم ا یس و ر د

 

بھی کر و ر  کاپی کر کہ پیسٹ ا یم ا یس و ر د

ا  ہے۔

 

 یٹا ا ی ک ا فٓس پرگرا م سے د و سرے میں ٹریول کر ی

 

  ا ٓت  کا د

 

 سکیں گے۔ تو ا فٓس کلپ بور د

ل د و نون
س
ی ک

  ا و ر  ا 

 

 ہے۔ ا س کو ا ٓت  و ر د

 

ا  ہے جس کے ا ندر  کچھ فار مولے جیسے جمع، تفریق، ضرت  و غیرہ کی ضرو ر ت

 

 کیا ا ٓت  نے ا ی ک ٹیبل بنای

 

ر ص
ف

ے  

 

سکی
میں بنا 

ا  ہے تو

 

  میں بنای

 

  ٹیبل مکمل کرنے کے بعد جہان پر ا ٓت  کو جوا ت  چاہیے و ہان پر ا پنا کرسر ر کھیں ا و ر  ٹیبل مینو میں فار مولہ پر کلک کریں ا و ر  فار مولہ بتاہیں۔ ا گر و ر د

لًا۔

 

س
م
 د یں۔ 

=sum(above), =average(above), max(above), product(above) etc. 

 د و سرا  طریقہ:جہان پر جوا ت  چاہیے کر سر ر کھیں۔

Then press Ctrl +F9 and type your formula in given brackets. Like. 
{=sum(above}, {=average(above)} etc then pres F9 

 مینو میں فیلڈ پر کلک کریں ا و ر  و ہان سے فار مولہ کا ا نتخات  کریں۔ و غیرہ۔

 

 تیسرا  طریقہ:ا نسرت
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ل کی طرف ۔ی ا د  ر کھیں ح ت  ہم ا ٓفس میں کام کرتے ہیں
س
ی ک

  ا ت  ا تٓے ہیں ا 

 

 ا کٹھی بھی پڑھ سکتی ہے۔ا س کے لیے ا ٓت  ا نسر ت

 

ل کی ضرو ر ت
س
ی ک

  ا و ر  ا 

 

تو ہمیں و ر د

ے ہیں۔

 

سکی
 میں ا و بجیکٹ کی مدد  سے د و سرے پرو گرا م کو مطلوبہ پرو گرا م میں کھول 

  میں ر ہتے 

 

ا  چاہتے ہیں تو ا ٓت  و ر د

 

ل میں بنا ی
س
ی ک

ل ہوئےجیسے ا ٓت  یہی ٹیبل ا 
س
ی ک

 سے ا و بجیکٹ پر کلک کریں ا و ر  ا 

 

کر بطور  ا و بجیکٹ کھول لیں۔ ا س میں ا پنا  ا نسرت

  میں ا ٓ جا بنائیںٹیبل 

 

ل سے و ر د
س
ی ک

 ر  کلک کریں تو ا ٓت  کا ٹیبل ا 
ہ
  کی گا یہی کام ا تٓ  ا ٓفس کلپ ئےا س کے بعد مطلوبہ فار مولے ۔ا و ر  بعد میں ٹیبل کے ی ا 

 

 بور د

ے ہیں۔

 

سکی
 مدد سے کاپی کر کہ بھی کر 

 مینو میں ا ی ک ا و ر  ا ٓپشن ہے پیسٹ 

 

 ت

 

 سپیشل ا س کے ا ندر  بھی بہت ا ہم ا پٓشنز ہیں۔ا ی ڈ

 
ف 
ے ہیں۔ا س کے علاو ہ 

 

سکی
ر ق ر کھ کر کھینچ 

ف
  کو ا پنی مرضی کا 

 

ا ر یخ ا و ر  نمبر ر

 

 ل ٹول بھی بہت ا ہم ہے ا س کی مدد  سے ا تٓ  د نون کو ، ی

 ا س کے علاہ فاینڈ بھی ضرو ر ی ہے۔

 ا ت  میں پڑھائلفٹر کے ی ا ر ے میں ا ٓت  نے فا  Headerو یو میں 

 

 ۔ پیج سی ت

 میں نیو

 

 کی کیز ا ٓگے ا ٓ ر ہی ہیں۔ ا نسرت

 

 لینے کے ا ہم ا ٓپشن ہیں ۔ ا ن

 

ی ت

 

 ر و  ، کالم، سیل، س

 کی 

 

ا ر ت

 

 بنانے کا طریقہ بھی ا ٓت  نے کور س میں سیکھا۔ ا س کی س

 

 Alt+F1ا س کے علاو ہ چار ت

 ا سی مینو میں ا ی ک ا پٓشن ہے و ہ ہے نیم یہ ا ی ک بہت ی ا و ر  فل ٹو ل ہے ا س کی مدد سے ا ٓت  

 یفاین کر د یں۔ ا س کی بعد صرف و ہنیچر ل فا

 

 د

 

ن

 

ش

 

فکی

 کریں ا و ر  جا کر نیم 

 

پ کت
پ ل
س

 یٹا کو 

 

نیم فنکشن بتایں ا و ر   ر مولے بنا سکیں گے۔ ا س کا طریقہ کار  یہ ہے کہ ا ٓت  ا پنا د

 بنای ا  جا سکتا ہے۔تفصیل ا ٓت   تما م فار مولون کو نیم فنکشن کی مدد سے ہوئےگا۔نیچے د یے  ےد ینا پڑ  ہیں ا ٓت  کو لمبا ر یفرینس فار مولہ بتا د یں۔ ا سطرج

 

ا ٓسا ن

 کور س میں سیکھیں گے۔

 میں فار مولون یعنی فنکشنز  کو د یکھتے ہیں۔فار مولون میں جہان 

 

 ا س کے علاو ہ کوئی ر یفرینس ہے تو ا س سے مرا د  سیل ر یفرینس ہے۔ A1ا ت  ہم ا نسرت

  کو لیتے ہیں۔

 

 و ر
ی

 

پ ی
م

  ا و ر  

 

 ا ت  ہم ی ا ر ر

 س کس نیوجہان پر 

 

 کو د

 

 پڑھ چکے ہیں۔ٹولز ہیں صرف ا ن

 

  میں ا و ر  کلاس کے د و ر ا ن

 

 کیا گیا ہے۔ی ا قی ا ٓت  و ر د
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 یٹا سیل میں کہان ا لاین ہو لیکن نیچے کونسی ا لاین نٹ   

 

ست  سے پہلے سیل ا لاین نٹ  ہے کہ ا ٓت  کا د

ٹ  ا ٓت   ٹیکسٹہے ۔ نیچے بھی 

 

پ
 تبدیل کریں گے تو 

 

 ٹ
پ
ا لاین نٹ  ہے لیکن ح ت  ا ٓت  ا پنے سیل  کی ہا

 میں ٹیکسٹکو ا گر ا پنے 

 

ا  ہے تو ا ٓت  د و نون جگہ ا لا کو ی ا لکل د ر میان

 

 کریں گے ۔ئنکری

 

   د ر میان

 کر کہ لکھنے کا ٹول بھی ہے۔ا ٓگے د ا   ٹیکسٹپھر ا س طرج ا ٓگے 

 

ی ت

 

 سے ئیں ی ا  ی ا ئیںکو سیل کے ا ندر  ر و پ

 ئنکو ی ا لترتیب ا ٓگے ی ا  پیچھے کرنے کا ا ٓپشن ا لا ٹیکسٹلکھنے کا ا ٓپشن ہے۔پھر 
م
   
 ٹولز ا ٓگے موجود  ہے۔ی

 

ت

 

 ی

کو ا تٓ  چاہتے ہیں کہ و ہ نیچے منتقل ہو جائے ی ا  ا ٓگے د و سرے سل کی طرف ج لا  ٹیکسٹپہلا ا ٓپشن ہے  

 ی ا د ہ سلز مختلفجائے ۔ا و ر  ا گلا ٹول ہے 

 

ا  یعنی د و  ی ا  د و  سے ر

 

 کری

 

 کر کہ ا ی ک میں سیلز کو مرج

 

بدلنا  کو مرج

 ی لا

 

ز
پ 
 لیے ا ہم ہے ۔  لکھنے کےئنیہ ٹول 

 یٹا ا نٹر کرنے کے  

 

ا ٓت  ا نٹر کر  ٹیکسٹفار میٹ ہیں جن میں پہلا جنزل فار میٹ ہے کہ یسا  مختلفیہ د

ر ہے ہیں ا س میں کوئی فار میٹنگ ہ ہو۔ لیکن ا س میں ا ٓگے بہت سا ر ے فار میٹ ا ہم ہیں یسا ح ت  
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ا ر یخ

 

و نٹس سے تعلق  کام کر  کرلکھنا چاہتے ہیں تو ا س میں جا ا ٓت  ی

 

ن
 فار میٹ د یں پھر ا گر ا ُٓٓ ت  ا کا

 

 ٹ
پ
 

 

د

ا  چاہتے 

 

ت  ا ٓت  د و ی ا ر ہ سا د ہ فار میٹ میں ا ٓی
 ر  نوعیت کے مطابق فار میٹ موجود  ہیں لیکن ح 

ہ
ر ہے ہیں تو 

 ہیں تو د و ی ا ر ہ جنر ل فار میٹ بتا د یں۔

 ا سی ٹول میں نیچے کرنسی ا و  ر  د و سرے فار میٹس 

 

د یے گے ہیں۔یہ تمام  ٹولز ا تٓ  کو کلاس کے د و ر ا ن

 جائیں گے۔  ئےبہت ا چھی طرج سمجھا

typicalا س کو ا تٓ      

 

ا م سے ا تٓ  جان

 

ے ہیں۔ا س کے ی

 

سکی
ل ٹول کہہ 

س
ی ک

گے ہون گے کہ  ا یم ا یس ا 

  ٹیکسٹسے مرا د    Formattingکنڈیشنل فار میٹنگ کیا ہے۔ 

 

  کو فار میٹ کری

 

 ی ا  ی ا  نمبرر

 

ا  ی ا  خوبصور ت

ا  ہے۔ لیکن ا س ٹول کی مدد سے ا ٓت  ا پنے 

 

  کو ٹیکسٹا ٓت  کےکام کا بنای

 

سکی
ے خاص قسم کی فار میٹنگ د ے   

 ہیں۔

  میں فار میٹ کریں گے کہ فلان  ٹیکسٹا س کی مد د  سے ا ٓت  

 

کا  می یہ ہو۔ ا گر و ہ کسی  ٹیکسٹکو ا س ا ندا ر

   Criteriaخاص  

 

 ر  ا  س کا شیڈ  می و غیرہ ۔ا س کو ا ٓت  ا س بٹن کے مختلف پر پور ا  ا تری

 

ا  ہو۔ ا س کا ی ا ر د

  بھی د ی جا سکتی ہیں۔مطلب یہ کہ ا ٓت  کہتے ہیں 

 

ر

 

 س
ن

 ر یعے ا ستعمال کر سکیں گے۔ا و ر  نیو کنڈ

 

ا پٓشنز کے د

  

 

ن ہیں جیسے ی ا س ، فیل، گری ڈ

 

پ ی
ع

 یٹا کی مختلف نو

 

 بنائی ہے تو ا ت  ا س میں د

 

ی ت

 

 س

 

ٹ
ل
 

 

کہ ا ٓت  نے ا ی ک ر ر

 فیل ہے ا س کی فار میٹنگ ا و ر  ہو ا و ر  جو ی ا س ہے ا س کی ا و ر  ا و ر  و غیرہ۔

 

ٹ

 

پ
 

 

ا ت  ا ٓت  کہتے ہیں کو جو سٹود

ر  لوگ ا س کو فضول 

 

کی
 کی ا و ر  ۔ تو ا س مقصد کے لیے یہ ٹول بہت ا ہم ہے ا و ر  ا 

 

  ا ے ہے ا ن

 

جن کا گری ڈ

  د یتے ہیں حالانکہ یہ بہت ا ہم ہے۔

 

 ت  نے ا س میں ا گٓے بہت سا ر ے ر و لز ہیں جن کو ا ٓ کہہ کر چھور

ا مل ہیں ۔

 

 ی ڈ  س

 

ر
ک
 د یکھنا ہے ۔ جس میں گریٹر د ین ، لس د ین  ا و ر  

 فار میٹس کی مدد  سے ا ھا بنا  

 

ا س کی مدد  سے ا ٓت  بنے ہوئے ٹیبل لے سکیں گے۔ا و ر  ا پنے ٹیبلز کو ا ن

ے ہیں۔

 

سکی
 فار میٹس میں سے ا ٓت  کے 

 

 کریں ا و ر  ر ینج د یں تو و ہ ا ن

 

پ کت
پ ل
س

کسی بھی بنے ہوئے ٹیبل کو 

ا و ر  پھر ا س کے تعلقہ  ا ی ک ا و ر  مینو بھی ا ٓ جائے گی جس کو بتائے ہوئے فار میٹ میں بدل جائے گا۔ 

 ا ٓت  ا پنی مرضی سے ہینڈل کریں گے۔

 کنڈیشنل فار میٹنگ 

 

ا ن

 

 کر سکیں گے۔یعنی جو پہلے ا س کی مدد  سے بھی ا ٓت  بنے ہوئی کنڈیشنل ا و ر  ی

ے ہیں۔

 

سکی
 کو بھی لے 

 

  ہیں ا ن

 

ر

 

 س
ن

  کا سٹائل بتا سکیں گے۔ا و ر  سلز میں فار میٹنگ سے موجود  کنڈ

 یہ  

 

ی ت

 

 یلیٹ ا و ر  نیو لے س

 

 کی مدد  سے ا تٓ  سل کو ر و  ی ا  کالم کو د

 

  ہیں ا ن

 

ر

 

ی

 

 س
ن

  سکیں گے۔ ا س کےعلاو ہ ا پٓر

 ا ئی ۔ پھر کسی 

 

 ، چور

 

 ٹ
پ
 کی ہا

 

  Selectedفار میٹ میں ا ن

 

 کری

 

ا  ا و ر  د و ی ا ر ہ ا ٓن

 

 ر و  ی ا  کالم کو چھپای

 

ی ت

 

ا  ۔ س

ا  ا ی ک جگہ سے د و سری

 

 کی کاپی کری

 

ی ت

 

ا م بدلنا ی ا  س

 

  کا ی

 

ا  ۔جگہ منتقل کری  
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 ہو گی۔ یہ فنکشنز سے تعلقہ  ہے ۔ 

 

ا س کے بعد و ا لے ٹول کی مدد  سےا ٓت   پہلے ٹول پر ا ٓگے تفصیلی ی ا ت

ٹ  

 

پ
ا 

 

  کے مطابق فل کرسکیں گے۔ یسا ی

 

ر

 

 س
ن

 یٹا کو ا ٓگے کنڈ

 

ا ر یخ و ا سر یل شدہ د

 

  نمبر ی ا  گرو ت  ی ا  ی

 

ز

 

پ
فل  

ا  ا ٓپنے

 

ہے۔  سیکھا کری  

 کسی بھیکلیر کر سکیں گے۔  ا خٓر پر کلیر فار میٹنگ ٹول ہے جس کی مدد  سےا ٓت  فار میٹنگا س کے بعد

 فار میٹنگ کو کنڈیشنل کو بھی ۔

 

 و لی ی ا  صعود ی میں ٹیکسٹپہلے ٹول کی مدد  سے 

 

ز

 

پ
  کو ترتیب 

 

ی  ی ا  نمبرر

 

  لکھ سکیں گے۔ ا س کے بعد س

 

ت

ا مل ہے۔

 

ا  س

 

 کری

 

پ کت
پ ل
س

ا  ا و ر  

 

 کری

 

لاس

 

 یٹا ی

 

 میں د

 

ت  کو گی یہ ا ٓ ئےح ت  ا ٓت  ا سی ہوم ر بن کے نیچے بنی ہوئے نمبر ا ٓپشن پر کلک کریں گے تو یہ لسٹ کھل جا

ی ا   ٹیکسٹا ٓپشن ہے ا س کی مدد  سے ا ٓت   Numberگی۔ پہلے نمبر پر  د ےا و ر  بھی بہت سا ر ے ا ٓپشنز 

  کریں گے۔ ئلنمبر فار میٹنگ سٹا

 

  یو  General چور

 

ز
پ 
  فار میٹنگ ا 

 

فار میٹ سے مرا د  ہے کہ سٹینڈر د

ٹ  

 

پ
ا 

 

  میں   Number۔ د و سرے نمبر پر ی

 

فار میٹ ہے ا س کی مدد  سے ا ٓت  نمبر فار میٹ یعنی نمبرر

Decimal  پوا ینٹ کا بتا سکیں گے ۔ا ٓگےCurrency  بھی لے 

 

کی مدد  سے ا تٓ  سا تھ کر نسی کی علامت

ل کہا جا سکتا ہے۔ 

 

پ

 

 ش
ن

 ر  فار میٹ کا ا پنا کرد ا  ر  ا و ر  نوعیت ہے ا س کو ا ٓ
ہ
 سکیں گے۔ا سی طرج 

LECTURE – 34 

 

 

 

 یٹا جو ا ی ک خاص ترتیب میں

 

 شدہ د

 

پ کت
پ ل
س

ل کا ا ی ک بہت ا ہم ٹول ہے ا س کی مدد  سے ا ٓت  کسی بھی 
س
ی ک

  ا یم ا یس ا 

 

 ہو گا ا و ر  ہو گا بھی ر و لز کے مطابق ا  س کا چار ت

ے ہیں ا س پر 

 

سکی
 ا ٓت  بنا 

 

 کرتے ہیں ۔ ا س کے لیے ا ٓت  ا ی ک ٹیبل بنائیں جو یہ ہے تفصیلی  چار ت

 

ی ا ت  

 

Overs Runs Rate 

1 12 12 

2 7 8.7 

3 6 7.7 

4 5 6.5 

5 8 9.5 

6 9 9 

 

 

ٹ  کے چار ت

 

پ
ا 

 

 و ا نس ی

 

ل میں بہت ا ی ڈ
س
ی ک

ا ل ہے حالانکہ ا ٓت  ا 

 

  بنایہ ا ی ک بہت سا د ہ سی مپ

 

پ لکت
س
ل میں بنای ا  ہے 

س
ی ک

ے ہیں۔ ا ت  ا ٓت  ا س ٹیبل کو جو ا ٓت  نے ا 

 

سکی

0

2

4

6

8

10

12

14

1 2 3 4 5 6

Overs

Runs

Rate
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  سے پرس کریں

 

 ا ٓت   کے سا منے ہے۔Alt+F1کرلیں ا و ر  کی بور د

 

 ۔ تو ا ٓت  کامطلوبہ چار ت

Design, Layout, Foramt 

 کا 

 

 ہیں ا ن

 

ئ

گ

  میں ا ضافہ ہو گیا ہے۔ جس میں تین نیو مینو جو سا منے لکھی گئی ہیں ا ٓ

 

و ر

 

 ی
ی

 

 پ
می

 لیا ہے ا ٓت  کے سا منے 

 

 کے سا تھ جون ہی ا ٓت  نے چار ت

 

ا ستعمال چار ت

 کے 

 

 ا ین تو چار ت

 

ز
پ 
 

 

 ا  مختلفہو گا۔جس میں د

 

ز
پ 
 

 

 میئند

 

 یٹنگ ہے ا و ر  بہت لار

 

 میں ا س کی ا ی ڈ

 

 ی ڈ    ا و ر  فار میٹس پر بنی  ہے۔ لے ا وٓ ت

 

ر
ک
ا پٓشنز ہیں ا و ر  فار میٹ میں 

ےہیں ا و ر  پھر ٹیکسٹسٹائلز ا ٓف 

 

سکی
 کر 

 

 ا و پر بتائے گے طریقہ سے ا نسرت

 

 پر کام کر سکیں گے لیکن ا ت  کسی بھی نوعیت کا چار ت

 

 ہم ا ن

 

 موجود  ہیں کلاس کے د و ر ا ن

ے ہیں ۔ لیکن 

 

سکی
  ی ا  ی ا و ر  پوا ینٹ میں بھی لے جا

 

 بنانے سے پہلے ا س کو ہاںن سے کاپی کر کہ ا یم ا یس و ر د

 

ا  بہت ضرو ر ی ہے  ٹیکسٹچار ت

 

 ا نٹر کری

 

 یٹا کو د ر ست

 

ی ا  د

ے ہیں۔ 

 

سکی
 کو بعد میں د و سرے میں بھی بدل 

 

 غلط ہو جائے گا ۔ چار ٹس میں ا ٓت  کسی ا ی ک طرج کے بنے ہوئے چار ت

 

 و ر ہ چار ت

LECTURE – 36 – 37  

 
 کو بھی ا پنے کام کے مطابق لے

 

  بھی ا ہم ہیں ا ن

 

ر
ک
 ا یگرا 

 

 یعنی د

 

 ا رٓ ت

 

ے ہیں  سمار ت

 

سکی
 

ر  ا پٓشنز کا پتہ چل چکا 

 

کی
  میں ا 

 

 ی ڈ  یہ بھی بہت ا ہم و یسے تو ا ٓت  کو ا ہم ا یس و ر د

 

ر
ک
 ہے لیکن ا س میں کچھ 

 ہی لیں گے۔۔ 

 

 کو ہم کلا س کے د و ر ا ن

 

 ا پٓشنز ہیں ا ن

Formulas of Ms Excel 

 ہون ۔ چونکہ سل ر یفرینس کی مدد  سے ا ٓت  ا سٓا نی سے فار مولہ فار مولون 

 

کو ا ستعمال کرنے سے پہلے ا ٓت  کو سیل ر یفرینس کے ی ا ر ے میں مکمل معلوما ت

 ا 

 

 فار مولون میں د

 

 ا ستعمال کر سکیں گے۔میں ا ن

 

پ
ا  کہ ا ٓت  کو سمجھنے میں ا ٓسا نی ہو۔

 

 ر یس د ے ر ہا ہون ی

 

 ز یکٹ سل ا ی ڈ

Sum 
 ر قمون کو جمع کرنے کے مختلف فنکشن

=sum (a1:a5)     

=a1+a2+a3 
=45+78+56   
=Sum(name)  

 ی ا د ہ ا ستعمال ہونے و ا لے فنکشنز

 

 ا و ر  ر

 

 جمع کرنے کے ا ٓسا ن

=a1+b1+c1+d1+…….. 
ا 

 

  کو جمع کری

 

ر
م
ل

 ی ا د ہ کا

 

 ا ی ک سے ر

=Sum(a1:a10;b1:b10)  
 کا ا ستعمال

 

ن

ک

 

فپ

ا م 

 

 جمع کرنے کے لیے ی

=sumif(a2:a10;”Ali”;c2:c10) 
ر ا د  کیجمع 

ف
ا  مخصوص ا 

 

  سیل پر فاس  جانناکے سا تھ کنڈیشن و ضع کری

Average 
 ا و ط  لینا

=average (a1:a10) 
  

=average(a1:a10;b1;b10)  
  کا ا و ط  لینا

 

ر
م
ل

 ی ا د ہ کا

 

 ا ی ک سے ر

Maximum or Minimum 
 ی مقدا ر  جاننا

 

ز
پ 
 چھوٹی ا و ر  

=Max(a1:a7) 
=Min(a1:a10) 

 ی مقدا ر  کا تعین 

 

ز
پ 
ا  چھوٹی ا و ر  

 

کری  

Count 
 ر قم گننا

=Count(a1:a10)  
 

=Count blank(a1:a30)  
 خالی سیل کی مقدا ر  جاننا

=CountA(a1:a10) 
  کی تعدا د  جاننافل شدہ سیلز

LECTURE – 38 
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=countif(a1:A10; “=200”) 

 
 سکیں گے

 

۔ا ٓت  سیلز کے ا ندر  کوئی خاص مقدا ر یں جان  

Product 
ا 

 

 ضرت  کری

=Product(a1:a6) یا     
=45*89 یا     
=a1*a2*a3 یا     

 

 

Subtraction 
ا 

 

 تفریق کری

=a1-a2 
=50-60 

 

 

Dividing 
ا 

 

 تقسیم کری

=a1/a2 
=45/  

LECTURE – 39 
Statistical Functions 

Stdev(Standard Deviation)  Used to define the variation of Data. 
=stdev(a1:a9) 
=Var(a1:a10)  

Linest The slope of line 
=Linest(a1:a5;b1:b5) 
  

Trend Forecasting 
=Trend(a1:a5;b1:b5) 
 

ا  

 

 میں کام ا ٓی

 

یہ فار مولہ ا تٓ  کو مستقبل کے ی ا ر ے میں تجار تی معاملات

 کے لیے

 

 ہے ا ن

 

 ہے جن لوگون کا یہ مضمون

Growth The Growth of a company in a new year 

=Growth(a1:a5;b1:b5) 
 

 

Median 
 کسی بھی 

 

ا  د

 

یٹا میں د ر میانی مقدا ر  کا تعین کری  

=median(a1:a5) 
=mode(a1:a5)  

Correlation The strength of relationship in two 
variables or attributes 

=correl(a1:a5;b1:b5)  

LECTURE – 40 

LogicalTest 

 تمام فنکشنز میں سیمی کالن کا ا ستعمال کر ر ہا 

 

 ر  میں ا ن
ہ
 فالو کریں گے ا و ر  

 

ٹ
ق
ٹ  کرتے و 

 

پ
ا 

 

ا  ہے جو ا ٓت  فار مولہ ی

 

ہون لیکن بعض د عہ  ا س کی جگہ کاما بھی ا ستعمال ہوی

 ا س کے فار میٹ میں یہ چیز ا ٓ جاتی ہے، کہ کاما د ینا ہے ی ا  سیمی کالن۔

 

ٹ
ق
ٹ  کرتے و 

 

پ
ا 

 

 فار مولہ ی

If : 
=if(a1=5;10;20)  
and 
=if(a1>100;200;300 

ا  یعنی ا گر د ی ہو ئید و سرے سیل میں کو     

 

 ر  کری
ہ
ا 

 

سل  ئےخاص مقدا ر  ط

 ر  ہو و ر ہ  16ہو تو ا لے  سل میں  5میں 
ہ
ا 

 

 26ط

Pass/Fail Test 

 
 می 

 

 کو ی ا ر  ی ا ر  فنکشنز یہ بہت لار

 

 ا ی لائی کریں۔ہیں ا ن
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=if(a1>=33; “pass”; fail”) 

 
 

 

ٹ

 

پ
 

 

 نمبر لے ر ہا ہے تو ی ا س و ر ہ فیل 33ا گر ا ی ک سٹود

=if(Average(B4:D4)>=40;”Pass”;”Fail”) 

 
 ہے تو ی ا س و ر ہ فیل 46ا گر ا س کی ا و ط  

=If(sum(a1:b1)>=66;”Pass”;”Fail”) 
 

ل 

 

ی
  کا ٹو

 

ر
م
ل

 ہے تو ی ا س و ر ہ فیل 00ا گر د و نون کا

=if(a1>50; “True”; “False”) 
 

 ی ا د ہ ہے 56ا گر نمبر 

 

 Fallseو ر ہ  True تو  سے ر

=if(a1=2; “Move” ; “Stop”) 
 

  Stopو ر ہ  Moveہے تو  2ا گر 

 
 

 

  مرہ معاملات

 

ے ہیں۔ جو ر و ر

 

سکی
  بنائے جا 

 

ر

 

ی

 

س
فک

ا س طرج کے بے شمار  

 میں ا ستعمال ہوتے ہیں۔

LECTURE – 41 

Grading 

ا 

 

  معلوم کری

 

 طلباء کے گری ڈ

=If(a1>89;”A”;if(a1>79;”B”;if(a1>69;”C”;if(a1>59;”D”;”
F”)))) 

 

=if(a1<=59; “c”; if(a1<45; “d”)  

=if(a1<=32; “fail”; if(a1<=45; “d” ;if(a1<=59; “c”)))  

=if(a1>=85 “a+”;if(a1>=75; “a”;if(a1>=60; “b” ; 
if(a1>=50; “c”; if(a1>=33; “d”))))) 

 

=if(average(B2:E4)>=40; “Pass”;”Fail”)  

 فنکشنز کا ا  فار مولون کے لیے ا سی نوعیت کا ا ی ک ٹیبل چاہیے جو نیچے د ی ا  گیا ہے ا س میںم ا و پر تما 

 

 ۔ل کیا گیا ہےستعماا ن

Computer Class Test for 8th   Test #2 conduct on 20-06-2010 

S# 
Roll 
NO Name 

Obt. 
Marks T.Marks 

Pass/Fai
l Condition Remarks Grade 

1st  1 Moazzam 36 100 Pass Poor Satisfactory D 

2nd  2 Gulzar 40 100 Pass Good Good D 

3rd  3 Shadab 22 100 Fail Poor Good F 

4th  4 Faizan 29 100 Fail Poor Satisfactory F 

5th  5 Adil 46 100 Pass Good Satisfactory D 

6th  6 Asif 67.5 100 Pass Better Satisfactory B 

7th  7 Qasim 65 100 Pass Better Good B 

8th  8 Arif 34 100 Pass Poor Satisfactory D 

9th  9 Tariq 21 100 Fail Poor Satisfactory F 

10th  10 Asharaf 21 100 Fail Poor Satisfactory F 

11th  11 Javed 60 100 Pass Good Good B 

12th  12 Naseem 11 100 Fail Poor Satisfactory F 

13th  13 Waqas 57 100 Pass Good Satisfactory C 

Computer Class Test for10th   Test #2 conduct on 08-06-2010 

S# 
Roll 
NO Name 

Obt. 
Marks T.Marks Pass/Fail Condition Lab Grade 

1st  1 M. Zaman 46 100 Pass Good Satisfactory D 

2nd  2 Atiq  55 100 Pass Good Good C 

3rd  3 Atiq Bag  25 100 Fail Poor Satisfactory F 

4th  4 Ishtiaq 27 100 Fail Poor Poor F 

5th  5 Ajza Absent 100 0 FALSE Poor FALSE 

6th  6 Tnaveer 58 100 Pass Good Good C 

7th  7 Ajaz 61 100 Pass Better Better B 
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Balooch 

8th  8 Ali 66.5 100 Pass Better Better B 

Computer Class Test for 9th   Test #2 conduct on 08-06-2010 

S# 
Roll 
NO Name 

Obt. 
Marks T.Marks Pass/Fail Condition Lab Grade 

1st  1 Naveed 22 100 Fail Poor Poor F 

2nd  2 Faisel 64 100 Pass Better Better B 

3rd  3 Mumtaz 42.5 100 Pass Good Good D 

4th  4 Sajawal 19 100 Fail Poor Poor F 

5th  5 Zahoor 69 100 Pass Better Better B 

6th  6 Rasalat 35 100 Pass Poor Good D 

7th  7 Ali Shan 33 100 Pass Poor Good D 

8th  8 Rasalat 23.5 100 Fail Poor Good F 

9th  9 Ali Shan 34 100 Pass Poor Good D 

6th  6 Rasalat 35 100 Pass Poor Good D 

7th  7 Ali Shan 33 100 Pass Poor Good D 

8th  8 Rasalat 23.5 100 Fail Poor Good F 

9th  9 Ali Shan 34 100 Pass Poor Good D 

=if(a1>=33; “pass”; fail”) 
 

 نیچے ی ا س فیل کے فیلڈ میں تعلقہ  فار مولہ لکھیں۔

=if(a1<=39;”Fair”;if(a1<=49;”Satisfactory”; if(a1<=59;”Good”; 
if(a1<=79;”Very good”; if(a1<=89; “excellent”; if(a1<=99; 
“exceptional”)))))) 

 کنڈیشن کے لیے ا س کا تعلقہ  فار مولہ موجود  ہے۔

=if(a1<=39;”Fair”;if(a1<=49;”Satisfactory”; if(a1<=59;”Good”; 
if(a1<=79;”Very good”; if(a1<=89; “excellent”; if(a1<=99; 
“exceptional”)))))) 

پھر ر یمار کس جہان ا س ٹیبل میں لیب ہے ا س کا تعلقہ  

 فار مولہ د یں۔

=if(a1<=39; “F”;if(a1<=49; “D” ; if(a1<=59; “c”;if(a1<=79; “b” 
;if(a1<=89; “a”; if(a1<=99; “a+”)))))) 

  کے لیے و ہ فار مولہ د یں

 

 ا و ر  گری ڈ

42 – LECTURE 

Reference Formulas 

  کسی بھی جگہ پر جمع ، تفریق ی ا  ا و ر  د و سرے فنکشنز ا ستعمال کر سکیں گے۔

 

س کا ر یکار د

 

پ ی

 

س

 ی ا د ہ 

 

 کی مدد  سے ا ٓت  ا ی ک سے ر

 

 ا ن

=SUM(Sheet1:Sheet2!A1:F12) 
=average(Sheet1:Sheet3!A1:F12) 
=max(Sheet1:Sheet2!A1:F12) 
=counta(Sheet1:Sheet2!A1:F12) 
=product(Sheet1:Sheet2!A1:F12) 
=var(Sheet1:Sheet2!A1:F12) 
=count(Sheet1:Sheet2!A1:F12) 
 
 
These are called 3d formulas. 

 ی ا د ہ پر ہے  سا منے لکھا گیا فار مولہ کیا کرے گا۔ د یکھیں ا گر ا ٓت  

 

س پر یہ د و سے ر

 

پ ی

 

س

 یٹا د و  

 

کا د

لا۔ 

 

ے ہیں مپ

 

سکی
تو ا س طرج کا فار مولہ لینے سے ا ٓت  کسی بھی جگہ ا پنا مطلوبہ ہدف لے 

 

 

ی ت

 

  1سا منے لکھا فار مولہ س

 

ی ت

 

  کو جمع کر د یتا ہے جس میں  2ا و ر  س

 

کے لکھے گے ر یکار د

ا  ہے ۔ ا س

 

کے لیے ا ٓت  ا سی  ا ی ک خاص فار میٹ سے فار مولہ د ی ا  گیا ہے ا س کوفالو کری

ے ہیں۔

 

سکی
 ا و ر  سلز د ے 

 

ی ت

 

 ی ا د ہ س

 

 ترتیب میں ا ی ک سے ر

و ی ا  پھر ما

 

ن
 

 

ٹ  کریں مپ

 

پ
ا 

 

لًا س لیں ۔ ا ٓت  نے جو کام سرا نجام د ینا ہے و ہ ی  

=Sum( 

  سے شفٹ د ی ا تے

 

 پر کلک کریں پھر کی بور د

 

ی ت

 

ی س

 ہل
ن

س پر کلک  ا ت  ا ٓت  

 

پ ی

 

س

ہوئے ا گلی 

ا مل ہو جاد یں ، ا خٓری پر ا س سے پیچھے و ا لی خود  بخود  

 

پ ک  گی۔ ا س کےئیںس
پ ل
س

 یٹا کو 

 

  بعد د

 

ت

 

 

ز یکٹ بند کرنے کے بعد ا نٹر د ی ا  د یں۔ ا ی ک ی ا ت
پ 
س پر کریں ۔ ا و ر  

 

پ ی

 

س

 ی ا د  ر کھ لیں کہ ا گلی 

 پر ہے ۔سا منے

 

ی ت

 

ی س

 ہل
ن

 یٹا ا سی ر یفرینس پر ہو ۔ جس طرج 

 

ا س طرج کے کچھ  بھی د

 فار مولہ د ے ر ہا ہون ۔ 
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LECTURE – 43 

Data Menue 

 
 یٹا 

 

  میں و ا قف ہیں  ہیں ۔ سا منے د ی ا  گیا ٹول ا ٓت  کو د

 

و  ہے جس سے ا ٓت  پہلے یعنی ا ہم ا یس و ر د

 

 ی
پ ی
م

یہ ا ی ک ی ا لکل نیو 

 

 

س، و یب ی ا  کسی د و سری فائل جس کا فار میٹ ا سی نوعیت کا ہو۔ ا صل میں ا ن

ش
ی ک

 ر  سے لانے میں کام ا ٓئے گا جیسے ا 
ہ
ی ا 

 لاٹولز

 

ے ہیں ا و ر  پھر ئن کی مدد  سے ا تٓ  ا ٓن

 

سکی
ک ر سا ئی حاصل کر

 

 یٹا بیس ی

 

و یج ہے کی   My SQL  د
گ

 

 پ
لی

 یٹا بیس 

 

جو ا ی ک د

 ٹولز کو ہم ا ٓفس میں ا ستعمال ہیں  کرتے۔

 

ے ہیں ۔ عموما ا ن

 

سکی
 مدد  سے ٹیبل بنا 

 
 
 

Sort  لًا  ٹیکسٹا ہم ٹو ل ہے ا س کی مدد  سے ا تٓ  کسی

 

  کو ترتیب مپ

 

  ا و ر  پھر ا ی ک سے ا ٓگے ی ا  د س سے  ی ا  نمبر ر

 

 ی ڈ

 

ا ے ٹو ر

 ر  کر سکیں گے۔
ہ
ا 

 

 کے مطابق ا پٓشن پر کلک کر د یں۔ ٹیکسٹپیچھے ط

 

 کر کہ ا س ٹول پر کلک کریں ا و ر  ا پنی ضرو ر ت

 

پ کت
پ ل
س

 

 
 یٹا کو  

 

 ے ٹیبلز میں د

 

ز
پ 
  میں ا ر ینج کریں گے۔ ح ت  ا ٓ ت  کسی خاص ا ٓ٘ فلٹر ٹول ا س کی مدد  سے ا ٓت  

 

یٹم کو مختلف ا ندا ر

 کے

 

 ی ا ٓسا نی سے ا ی ک ا ی ک کر کہ ا و ر  پھر ا س کے ا ندر  سا ر ت

 

ز
پ 
ا  چاہیں گے تو فلٹر لگا کر ا تٓ  

 

 کری

 

لاس

 

 یٹا کو  ی

 

ٹول سے د

 کر سکیں گے۔

 

 سرج

 
لا ا ٓت   مختلف کو  ٹیکسٹا س ٹول کی مد د  سے ا ٓت  ا ی ک ہی کالم میں لکھے ہوئے 

 

 ر  کر سکیں گے۔ مپ
ہ
ا 

 

  میں ا لگ ا لگ ط

 

ر
م
ل

کا

  کو ا لگ کالم میں ٹیکسٹتو یہ ٹول ا تٓ  کو ۔نے لکھا ہے 

 

 MZD-120-JKL کر د ے گا ا و ر  نمبر ر

 

 
=obt.marks/total.marks*100 

ے ہیں ا س کا فار مو

 

سکی
لہ سا منے ہے۔پھر ا س میں ا تٓ  ا و ط  کے کالم کا ا ضافہ کر  

 

 

 

LECTURE – 44 

Reference Formulas 

 ا و ر  غلط کا ا ستعمال

 

 د ر ست

=and(5<a1;a1<100) 
=and(5<a2;a2<100)    

 ہونے پر ٹرو  ا و ر  غلط ہونے پر 

 

 د ے گا۔  Falseیہ فار مولہ ا تٓ  کو کنڈیشن د ر ست

 
 پڑ لیا س ٹول کی مدد  سے ا ٓت  کسی بھی ر و  ی ا  کالم میں ی ا ر  ی ا ر  ا نٓے و ا 

 

  کو ضرو ر ت

 

 و  ر
ی لی
نے پر ختم کرسکیں گے۔و   

 

ل پر عبور   نے یہ بہت ا ہم ا ٓپشن ہے خاص کر ح ت  ا ٓت  
س
ی ک

 یٹا ا گر ا 

 

ل میں ا ی ک پور ی د
س
ی ک

حاصل کر لیا ہے ا و ر  ا ٓت  ا 

 یٹا پر 

 

ا  چاہتے ہیں ا س ٹول کو ضرو ر  سمجھیں ا س میں ہم د

 

لا ہم کہتے  مختلفبیس کنٹرو ل کری

 

ی ا بندی ا  ن لگا د یتے ہیں مپ

 ی ا د ہ نمبر ہ ا نٹر ہو ا و ر  ا گر ہو تو کمپیوٹر یہ ا یرر  

 

پھر ا س شو کرے۔   Messageہیں کہ فلان ٹیبل میں ا س نمبر سے ر

س بھی بنا سکیں گے 

 

سی
ل

 .میں ا ٓت  
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Truefalse 

OR 

 
ا ل کے لیے ا ستعمال

 

ا  ہے۔ یہ فنکشن کسی خاص کنڈیشن کی پڑی

 

ہوی  

=if(or(average(a1:D1)>=80;E1<2) 
“Pass”; “Fail”) 

 

Absolute Number 
 قیمت

 

 عدد  کی د ر ست

=abs(a1) 

 
ا صلی قیمتکسی بھی عدد  کی   

SQRT 
 ر  لینا

 

 ج ڈ

=Sqrt(a1) 
=a1^b1 

 ر  لینا

 

 ج ڈ

Dollar 
 ا ر  کا سا یٔن ٹیکسٹ

 

کے سا  تھ د  

=Dollar (a1;2)  

Factorial  

=Factorial (a1) 

ک حاصل ضرت   1کسی بھی مقدا ر  کا ا س سے پیچھے 

 

ی  

Power  

=Power (a1;b1) 

72=49 

Trigonometric functions: 
=sin(a1)    
=tan(b1)   
=cos(v1) 

 فار مولے

 

 تکونیات

=proper(a1) 
=rept(a1,3)   

=lower(a1) 
=upper(a1) 

کا کیس بدلنے کے مختلف فار مولے۔ ٹیکسٹ  
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More Complicated Functions 

 
=sum (a1:a4;100) 

ا 

 

ا  لیکن سا تھ مقدا ر  کا ا ضافہ کری

 

 جمع کری

=sum(a1: a6; b1:b6) 
  کی مقدا ر و ن 

 

ر
م
ل

ا مختلف کا

 

 کو جمع کری

=countif(a1:a4; “>200”)  
 ی ا د ہ ہے جاننا 266ا یسی مقدا ر  جو 

 

 سے ر

=countif(a1:a4; “>200”)  
 ی ا د ہ ہے جاننا 266ا یسی مقدا ر  جو 

 

 سے ر

=countif(a1:a4;<> “100”) 
ز  ہیں  ہے۔ 166جو 

پ 
ز ا 
پ 
 کے 

=Round(A1;2)  
ک

 

ا  کسی فکس پوا ءینٹ ی

 

  کری

 

ڈ

 

  کو ر ا و ی

 

 نمبرر

=Round(a1;0) 
ا 

 

 فکس کری

=int(a1) 
ا 

 

 کسی مقدا ر  سے ا عشار یہ ختم کری

=Mod(a1;b1)  
 1 = 5 ÷ 16:| .ی ا قی جاننا

=PV(10 %;5;1000) 
 حالیہ مقدا ر  جاننا
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=FV(a1;a2;-b3;1) 
=PV(Rate; no of periods, payment, future value, type) 
Rate=11%   Time=35 
 Deposits=2000 
=Pmt(B1;b2;b2) 
=NPER(a1;a2;a3) 

     

 

  تفصیل طلب ہیں جو ا خٓر میں

 

ر

 

ی

 

س
فک

  ہیں۔یکھتےد  کچھ 

 مستقبل کی مقدا ر  جاننا

=Value(A1)  
میں بدلنا ٹیکسٹکسی نمبر کو   

=Value(“40205”) 
 

=Text(a1) 
ا  ٹیکسٹکسی 

 

 کو نمبر بنای

=Dollar(a1) 
 

 

 کسی مقدا ر  کے سا تھ کرنسی کی علامت

=Rept(“*”;4) 
 

 

ا  کسی علامت

 

 کو د کھای

=Len(a1) 
 لاگ لینا

=Choose(a1; “one”; “Two” ; “Three”) 
 کسی خاص مقدا ر  کا ا نتخات  

=Sign(a1) 
  د یکھنائنکسی مقدا ر  کے سا تھ سا 

=Vlookup(c1;a1;b4;2) 
 

=Hlookup(d4;a1;d2;2) 
 

=lookup(b7;e1;e5;b1;b5) 
 

=index(d3;g5;a2;a3) 
 

=length(a1) = 5. 
 

The Length of text or number   

=Match(20, a1:d1) 
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Text Formulas 

ل میں کسی 
س
ی ک

 ی ا ئیں ہو گی ا و ر  نمبر کی د ا ئیں۔ ٹیکسٹی ا د  ر کھیں ا 

 

ت

 

می

 

پ ی
کی ا لا  

=BAHTTEXT (a1)     موجو د  ہو گی ٹیکسٹیہ نمبر کو 

 

 ی ا ن

 

 کر د ے گا جو ر

 

میں کنور ت  

=CHAR (A1)     د ے گا کسی نمبر ی ا  

 

 کے حوا لے سے کود

 

ل کریکٹر سی ت
س
ی ک

کا  ٹیکسٹا   

=CLEAN (A1)   Remove nonprintable character from text 

=CODE (a1)      د ے گا  کسی ٹیکسٹ  

 

ی ا  نمبر کا کود ASCII 

=CONTENCATE (a1)       ی ا  

 

۔ کرے گائنکو کمبا ٹیکسٹمختلف نمبرر  

=DOLLAR(A1)     کے  

 

 د ے گا۔نمبر ر

 

سا تھ ا عشار یہ ا و ر  کرنسی کی علامت  

=Exact(a1) ی ا  پھر 

 

 ا و ر  غلط کا ا ٓپشن د ے گا۔ جیسے سیلز میں ا ی ک جیسے نمبر ہون تو د ر ست

 

 ر  د ر ست
ہ
 ہونے 

 

 د ے گا  Falseیہ کسی کنڈیشن کے د ر ست

=Fixed(a1)و  لیٹر پر فکس کرتے ہیں
پ لک
ک

  کرے گا جیسے ا ٓت  

 

ڈ

 

 کسی بھی نمبر کو ر ا و ی

=Len(a1)کی تعدا  بتا ٹیکسٹ  

 

 گا۔ ئےکے کیریکٹرر
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=Rept(a1;5) ا ئمکو نمبر ا ٓف  ٹیکسٹکسی

 

 ر ا  ی
ہ
 گا۔ ئےد 

ا  ہے۔جیسے ہم نے 

 

 ر  کے گا کہ یہ ا یٓٹم کہان کس نمبر پر ا ٓی
ہ
ا 

 

 کے ی ا ر  ے میں پوھا ہے ۲۱یہ فنکشن د ی ہوی ر ینج کے مطابق یہ ط

Apply this useful function:(Related to Banks) 

Down payment=No 
Interest Rate = 18% 
Term (Months) = 360  
Loan Amount   = 800000 
Use suitable function? 
 

Down paymnet Nil

Interest Rate 10%

Term(Month) 360

Loan 800000

Rs80,000.00- 800000  

pmt(b1;b2;b3)=فار مولہ  لینے پر  166666یعنی یہ فار مولہ ہمیں ا ی ک سا ل کے  

 

ر ص
ق
 ر ہا فی صد وفد  پر ہمیں جو د ینا ہو گا ا س کا بتا 16ر و پے بنک سے 

 ہے۔

Some complicated formulas for professionals: 
1. Function FV (future Value) : 

ک کسی مخصوص شرج سے حل کرنے کے بعد سرمائے کی جو لگائے یہ فنکشن 

 

 ی

 

  شکل ا تٓی ہے ا س کو بتائے گا۔گے سرمائے کی کسی بھی مدت

Format of this function is: 
=Fv(rate, number of periods, payment, present value, type) 
For example: 
Rate=11%  years= 35  deposits= 2000 
=fv(b1,b2,-b3,,1) =fv(11%,35,-2000,,1) 
=758,328.81 

 ینٹ

 

 سے مرا د  مدتی ا د ا ئیگی ہے۔ا و ر  پرر

 

ت

 

 ی
 ا و ر  پے می

 

  سے مرا د  مدت

 

 کی شرج مرا د  ہے، پری ڈ

 

ٹ

 

پ
 سکاءو 

 

 ہے و ہان د

 

 ٹ
پ
 چیز جو ا تٓ  و یلو سے مرا د  ا یسی جہان لفظ ر 

۔خود   ر کھیں گے  

2.PMT(payment) 

 

 

 ر  کیا جای
ہ
ا 

 

 لی گئی ر قم کو کسی خاص ا د ا ئیگی سے سا لاہ کسی خاص شرج سے حل کرنے کے لیے ط

 

ر ص
ق
ا  ۔یہ فنکشن   

=PMT(rate, number of periods, present value, future value, type) 

Rate:  
 

ٹ

 

پ
 سکاءو 

 

 ا ٓف د

 

 ٹ
پ
 ر 

Number of periods: will be time period 
Present value:  current value 
Future value, type your choice. 
Rate=0.92%  Months=300  Loan= 100000 
=pmt(b1,b2,b3) =pmt(0.92,300,100000) 
=983 
3. NPER(number of periods): 

ا 

 

 کو حاصل کرنے کے لیے ا ستعمال ہوی

 

 لی ہوئی ر قم کی جملہ مدت

 

ر ص
ق
۔ہے یہ فنکشن کوئی   

=Nper(rate, payment, present value) 
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Rate=0.92%  months=1200  loan= 100000 
=nper(A1,-a2,a3)  =159 
4. Rate: 

  فنکشن کسی قدر  کی ا د ا ءگی  کی سا لاہ ی ا  ماہاہ شرج کو حاصل کرے گا۔یہ

=rate(number of periods, payment, present value, future value, type, guess) 
Year=5   payment= 1000  cost= 3000 
=rate(a1,a2,-a3) =0.1986% 
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 ا  

 

ز
پ 
ل بہت 

س
ی ک

 ر  کے لیے بنیاد ی ٹولز ہاںن پر  ا 

 

 پرو گرا م ہے لیکن ا ی ک یور

 

  کے لیے ا ٓت  کیے گے ہیں بیان

 

 کر ر ہا ہون ، ا نٹر و یو ر

 

 ی ڈ  ٹولز ا و ر  ا پٓشنز میں ہاںن بیان

 

ر
ک
۔کچھ 

ے

 

سکی
 سے ر ہنمائی لے 

 

 ہیں۔ ا ن

Data Base Options: 

 

 

 یٹا بیس کہتے ہیں۔ جیسے ہمار ی د

 

 ا نفار میشن کے کسی بھی مجموعہ کو د

 

پ
 یٹا بیس کیا 

 

  بھی د

 

 ر یکار د

 

 یٹا بیس کے حصے:ز ی میں محفو ظ

 

ا ل ہے۔د

 

  ا ی ک مپ

  میں سنبھالنے و ا لا۔

 

  کو کالمون ا و ر  ر و ر

 

 یٹا ی ا  ر یکار د

 

 ٹیبل: د

 : ٹیبل میں ا ی ک ر و  

 

 ہون۔کسی شخص جگہ جس میں ر یکار د

 

ی ا  کمپنی کے تعلق  معلومات  

ا ر یخ و غیرہ

 

ا م، ر و ل نمبر، کلاس، ی

 

لًا۔ ی

 

س
م
گ ۔ 

 

ا ت  ہیڈی

 

 یٹا سے تعلقہ  ی

 

 فیلڈ: د

Some main tools are discussed below: 
Sort: 

 و لی ا و ر  صعود ی۔ا س کی مدد سے ا ٓت  کسی بھی

 

ز

 

پ
 ر  کرنے میں مدد  د ے گا۔یعنی ترتیب 

ہ
ا 

 

 یٹا کو ترتیب میں ط

 

 یٹایہ ٹول ا ٓت  کو د

 

ا  د

 

ا ر یخ، ی

 

ا مون کو ترتیب میں ئم ، ی

 

، ی

ے ہیں۔ 

 

سکی
 د کھا 

Filter: 

  میں د یکھ سکیں

 

 کو بہت مناست  ا ندا ر

 

 یٹا بیس کے ا ندر  معلو مات

 

 ی ا  د

 

ی ت

 

 می ٹول ہے جس کی مدد  سے ا تٓ  ا پنی س

 

  کے سا تھ ا ی ک بٹنیہ بہت لار

 

  گے۔یہ ا تٓ  کے فیلڈ ر

  میں د یکھ سکیں گے۔کو بہتر ا پٓشنز شو کرے گا ا س پر کلک کرنے سے ا ٓ ت  مختلف

 

  ا ندا ر

Form: 

  لکھنے 

 

 یٹا بیس میں نیا ر یکار د

 

  کییہ ٹول د

 

ر ا ہم کرے گا۔ا س کے لیے پہلے ا ٓت  ا پنے فیلڈر
ف
 

 

ٹ
ل
 کر کہ فار م پر کلک بہت ا چھی سہو

 

پ کت
پ ل
س

 کو 

 

 ا نٹر کریں ا س کے بعد ا ن

ا  

 

 یٹا ا س فار م کری

 

ٹ  کریں ا و ر  ا نٹر کرکریں ا و ر  ا و  کے کریں ا س کے بعد ا پنا د

 

پ
ا 

 

 ی

 

ٹ
ل
 یٹا بیس یں۔یہ سہو

 

  میں د

 

  ی ا ر  میں بھی موجود  ہے۔ا یم ا یس و ر د

Subtotals: 

لًا۔

 

ا  ضرو ر ی ہے۔ مپ

 

 یٹا ا ی ک خاص فار م کا ہوی

 

و  لیٹ کر کہ د ے گا۔ا س کے لیے د
پ لک
ک

 یہ ٹول منتخب شدہ نمبرو ن کو 

 

 

Category Rs 

Food 45 

Food 12 

Food 56 

Food 78 

Food 12 

Entertainment 220 
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Entertainment 150 

Entertainment 200 

Entertainment 330 

Entertainment 225 

 

 کا گرینڈ ٹو

 

ل چاہیے ا و ر  پھر ا ن

 

ی
 کا ا لگ ا لگ ٹو

 

ت

 

 ی
  ا و ر  ا نٹر ٹین می

 

 یٹا ہے ا ت  ا س میں ا گر ا ٓت  کو فود

 

  میں لکھا ہوا  د

 

ل چاہیے تو یہ ٹول ا ٓت  کا یہ کام یہ ا ی ک خاص ا ندا ر

 

ی

 کے لیے ، د و سرے حسابی فار مولے ا ستعمال کر سکیں گے۔ ا ٓسا نی سے کر د ے گا۔ا س

 

ے ہیں۔ ا و ر  ا ن

 

سکی
ا مل کر 

 

ا س میں ٹیبل کو ا ی ک کے علاو ہ ا ٓت  ا و ر  ا ٓیٹمز بھی س

ل لے سکیں گے۔ 

 

ی
  ، ا و ط  ا و ر  ست  ٹو

 

 و ر
ی لی
ل، نمبر ا ٓف و 

 

ی
ا  بہت ضرو ر ی ہے ۔پھر ا ٓت  ا س ٹیبل میں جمع، تفریق، گرینڈ ٹو

 

  میں بنای

 

 خاص ا ندا ر

Validation: 

 یٹا پر خاص قسم کی شر

 

 یٹا بیس کے ا ندر  ا پنے بٹن بھی بنا سکیں گے۔ا س کی تفصیل ا ٓت  کور س  ا ئطا س ٹول کی مدد  سے ا ٓت  ا پنے د

 

لگا سکیں گے ۔ ا س کے علاو ہ ا ٓت  د

 ئیںمیں پڑیں  گے۔ ا س ٹول کی مدد  سے ا ٓت  بٹن بنا

 

ٹ
ق
ا  ہے۔۔د ے گا ا ی ک ا ٓپشن منتخب کرنے میں مد د  میں گے جو ا ٓت  کو ا ی ک و 

 

  میں ہوی

 

ر
ک
 جس طرج فار 

Table: 

لًا۔

 

 حل کر د ے گا۔ مپ

 

 کے بہت سا ر ے معاملات

 

 یہ ٹول ا ٓت  کو فنانس ا و ر  تجار ت

و  لیٹ کر کہ د ے گاا ئیگیہم فنانس ٹیبل کی تخلیق کرتے ہیں جو قسط و ا ر  ا د 
پ لک
ک

 کو 

 

 کے ایای ا  جات

 

ر ص
ق
 ، وفد  کی شرج، ا و ر  

Function is 
=abs(pmt(c3/12,c4,-c5) 

 
Text To columns: 

لًا۔ ہوئےا س ٹول کی مدد  سے ا ٓت  ا ی ک ہی سیل میں لکھے 

 

ا یٹمز کو ا لگ ا لگ سیلز میں د کھا سکیں گے۔ مپ  

MCSIT-120-450-360 

ا  چاہتے ہیں تو یہ ٹول ا ستعمال کریں۔ 

 

 کو ا لگ ا لگ سیلز میں د کھای

 

 ا گر ا ٓت  ا ن

Pivot Table Reports: 
This tool will allow you to create your pivot table for getting your desirable solutions. 

 کو ا سکرین پر 

 

 یٹا ی ا  معلومات

 

لا ً مختلفیہ ٹول د

 

ا  ہے۔ مپ

 

  میں د کھانے کے لیے ا ستعما ل ہوی

 

 ا ندا ر

 

 پر ا گر ا ٓت  نے ا ی ک س

 

  ا نٹر کیے ہیں مختلف ی ت

 

  ر

 

 ا و ر  نوعیت کے ر یکار د

ا  چاہتے ہیں

 

ل، کری

 

ی
 کے گرو پس کے سا تھ ٹو

 

۔ تو یہ ٹول موجود  ہے ا ت  ا ٓت  ا ن  

Chart Producing: 

 کیا

 

 کیا ہے پھر ا س لیے بیان

 

 بنانے کے لیےپہلے ا ٓت  کسی بھی نوعیتجار ہا ہے کہ ا ٓت  کی پریکٹس ا چھی ہو جائے۔تو د یکھیں میں نے ا س کو پہلے بھی بیا ن

 

کا   چار ت

ا 

 

 یٹا ا ی ک خاص فار میٹ میں ی

 

 د

 

پ
ٹ  کریں  

 

 

 

  2008 2009 2010 

PAK 3.70  $         8.50$    5.50 $        

IND 5.60  $        3.20  $        9.50 $ 

IRAN  5.60 $   8.50 $   8.60 $   

  سے 

 

 کریں ا و ر  کی بور د

 

پ کت
پ ل
س

 یٹا لکھنے کے بعد ا س کو 

 

 یہ د



91 

 

ے ہیں 

 

سکی
 سا منے ہو گا ا س کو ا ٓت  بعد میں خود  فار میٹ کر 

 

۔پریس کریں چار ت Alt+F1 

 

LECTURE – 48 

Summary 
 
What you have learned? (Important features) 
Office clipboard: 

 یٹا کو ا ی ک ا ٓفس پرو گرا م سے د و سر

 

 ے میں لے جا سکیں گے۔یہ ٹول ا ٓت  کو ہوم مینو کے پہلے ا پٓشنز کے نیچے کی طرف ملے گا۔ ا س کی مدد  سے ا تٓ  یا ی ا  کاپی شدہ د

Fill: 

  کو ا پنی مرضی سے 

 

 تیا ر  کر سکیں گے۔ seriesئے فل کرتے ہوا ٓت  نمبر ر

Name: 

  کو ا پنی مرضی

 

ا  سیکھا۔ یعنی ا ٓت  نمبرر

 

ا  ا و ر  ا ستعمال کری

 

  میں بنای

 

ا م د ے کر بعد میں بہت ی ا و ر  فل ٹول ہے ا س کی مدد  سے ا ٓت  نے فار مولون کو ا ی ک نیو ا ندا ر

 

 کا ی

لًا۔

 

ے ہیں۔مپ

 

سکی
 sum(sales=فار مولے میں ا ستعمال کر 

Chart & diagram: 

  میں ی ا  ی ا و ر پوا  

 

 ا یگرا م ا س پرو گرا م میں بنانے کے بعد ا ٓت  ا س کو ا یم ا یس و ر د

 

 ی ا  د

 

 چار ت

 

ی
 کر 

 

پ کت
پ ل
س

 یٹا د ینے کے بعد 

 

ے ہیں۔ ا س کے لیے ا ٓت  د

 

سکی
 میں لے جا 

 

ت

 

 ی
ی

ے ہیں

 

سکی
 ر ا  کر 

 

 د

 

 ۔ کہ چار ت

Object: 

کر د یں گے۔  لینے کے بعد ا س کو بندا س ٹول کی مدد  سے ا ٓت  کسی د و سرے  پرو گرا م کو کھول کر ا س میں سے تعلقہ  ا و بجیکٹ  

Formatting: 

ا  جس میں بنے

 

 یٹا کو فار میٹ کری

 

 می ٹول ہیں۔ ہوئے سٹائل، کنڈیشنل فار میٹنگ بہتد

 

لار  

Security: 

 

 

  د ینا ی ا  پ

 

 کو ی ا س و ر د

 

ی ت

 

 سکیور ٹی کا ا ستعمال ۔س

 

گ کے د و ر ا ن

 

 و ر ک پر شیری

 

ی ت  

Formula Auditing: 

 و  ہیں۔ا س کی مدد  سے ا ٓت  نے فار مولون سے تعلقہ 

 

ڈ

 

 و ی

 

  ا ہم ا ٓپشن د یکھے ۔ جس میں ٹریس ا و ر و ا ج

Using Functions: 

 می فار مولے سیکھے۔

 

 ہو گیا۔ا ٓت  نے بہت لار

 

 فنکشن ا و ر  فار مولے جس کی و جہ سے ا ٓت  کا ا کاو نٹنگ کا کام بہت ا ٓسا ن

Printing: 

ا  سیکھا۔

 

 کری

 

ٹ

 

پ
 پر

Data Operations: 

 یٹا بیس کے کچھ ا ہم ٹولز ا ٓت  کو 

 

 یٹا ر بن میں سکھاپھر د

 

گے۔ ئےد  

Conclusion: 
As a whole I can only say that you have learned some exciting features of data base & keeping 
your record smooth & accurate as well. This will help you to become a successful professional of 
DMS (document management system), and to find your goals as well. I hope so. 
 
Excel Short Keys: 

Down Arrow) Move to the same field in the next record 

(Up Arrow) Move to the same field in the previous record 
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(Tab) Move to the next field you can edit in the record 

(Shift + Tab) Move to the previous field you can edit in the record 

(Enter) Move to the first field in the next record 

(Shift + Enter) Move to the first field in the previous record 

(Page Down) Move to the same field 10 records forward 

(Ctrl + Page Down) Move to a new record 

(Page Up) Move to the same field 10 records back 

(Ctrl + Page Up) Move to the first record 

(Home) Move to the beginning of a field 

(End) Move to the end of a field 

(Shift + Home) Extend the selection to the beginning of the field 

(Shift + End) Extend the selection to the end of the field 

Function Keys   

  

F1 Displays the Office Assistant or (Help > Microsoft Excel Help) 

F2 Edits the active cell, putting the cursor at the end* 

F3 Displays the (Insert > Name > Paste) dialog box 

F4 Repeats the last worksheet action (Edit > Repeat) 

F5 Displays the (Edit > GoTo) dialog box 

F6 Moves to the next pane in a workbook (if the window is split) 

F7 Displays the (Tools > Spelling) dialog box 

F8 Toggles whether to extend a selection with the arrow keys 

F9 Calculates All the worksheets in All the open workbooks 

F10 Toggles the activation of the Menu Bar 

F11 Displays the (Insert > Chart) dialog box that creates a chart 

(on a chart sheet) using the highlighted range 

F12 Displays the (File > Save As) dialog box 
 

  

  Note: *This is only available with (Tools > Options, Edit tab, Edit directly in cell).   
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  Shift + Function   

  

Shift + F1 Activates the context sensitive Whats this ? prompt (Help > 

Whats This) 

Shift + F2 Inserts or edits a cell comment (Insert > Comment) 

Shift + F3 Displays the (Insert > Function) dialog box 

Shift + F4 Repeats the last Find, the same as (Edit > Find Next) 

Shift + F5 Displays the (Edit > Find) dialog box 

Shift + F6 Moves to the previous pane in a workbook (if the window is 

split) 

Shift + F8 Toggles between switching Add Mode on or off* 

Shift + F9 Calculates just the active worksheet 

Shift + F10 Displays the (Shortcut) menu for the selected item 

Shift + F11 Inserts a new worksheet (before the active sheet) into the 

active workbook (Insert > Worksheet) 

Shift + F12 Saves, Displays the (File > Save As) dialog box if a new 

workbook 
 

  

    

 Ctrl + Function   

  

Ctrl + F1 Closes and reopens the current task pane 

Ctrl + F3 Displays the (Insert > Name > Define) dialog box 

Ctrl + F4 Closes the selected workbook window 

Ctrl + F5 Restores the size of the active workbook or window 

Ctrl + F6 Moves to the next open workbook or window  

Ctrl + F7 Activates the Move window command 

Ctrl + F8 Activates the Resize window command 

Ctrl + F9 Minimises the size of the active workbook or window 

Ctrl + F10 Maximises the size of the active workbook or window 
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Ctrl + F12 Displays the (File > Open) dialog box 
 

  Other + Function   

  

Alt + F1 Creates a chart (on a chart sheet) using the highlighted range 

Alt + F2 Displays the (File > Save As) dialog box 

Alt + F4 Closes all the workbooks (saving first) and exits Excel (File > 

Exit) 

Alt + F8 Displays the (Tools > Macro > Macros) dialog box 

Alt + F11 Toggles between the Visual Basic Editor window and the 

Excel window 

Alt + Ctrl + F9 Calculates All cells on All worksheets in All workbooks 

Alt + Shift + F1 Inserts a new worksheet (before the active sheet) into the 

active workbook (Insert > Worksheet) 

Alt + Shift + F2 Displays the (File > Save As) dialog box 

Alt + Shift + F4 Closes all the workbooks (saving first) and exits Excel (File > 

Exit) 

Alt + Shift + F10 Displays the drop-down menu for the corresponding smart tag 

Alt + Shift + F11 Activates the Microsoft Script Editor window 

Ctrl + Shift + F3 Displays the (Insert > Name > Create) dialog box 

Ctrl + Shift + F6 Moves to the previous open workbook or window 

Ctrl + Shift + F10 Activates the Menu Bar or Displays the (View > Toolbars) 

dialog box 

Ctrl + Shift + F12 Displays the (File > Print) dialog box 

Insert + F4 Read spelling errors and suggestions ?? 
 

  

  Ctrl + Numbers   

  

Ctrl + 0 Hides the columns in the current selection (Format > Column 

> Hide) 

Ctrl + 1 Displays the (Format > Cells) dialog box 
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Ctrl + 2 Toggles bold on the current selection 

Ctrl + 3 Toggles italics on the current selection 

Ctrl + 4 Toggles underlying on the current selection 

Ctrl + 5 Toggles the strikethrough of text on the current selection 

Ctrl + 6 Toggles between hiding, displaying or displaying just 

placeholders (objects) 

Ctrl + 7 Toggles the display of the Standard toolbar 

Ctrl + 8 Toggles the display of Outline symbols on the active worksheet 

Ctrl + 9 Hides the rows in the current selection (Format > Row > Hide) 

Ctrl + Shift + 0 Unhides the columns in the current selection 

Ctrl + Shift + 2 Enters the value from the cell directly above into the active cell 

Ctrl + Shift + 8 Selects the current region (surrounded by blank rows and 

columns) 

Ctrl + Shift + 9 Unhides the rows in the current selection 
 

  Ctrl + Letters   

  

Ctrl + A Displays the formula palette given a function name or selects 

the whole worksheet 

Ctrl + B Toggles bold on the current selection 

Ctrl + C Copies the current selection to the clipboard (Edit > Copy) 

Ctrl + D Copies the first cell in the selection downwards (Edit > Fill > 

Down) 

Ctrl + E Goto current Error ?? 

Ctrl + F Displays the (Edit > Find) dialog box 

Ctrl + G Displays the (Edit > GoTo) dialog box 

Ctrl + H Displays the (Edit > Replace) dialog box 

Ctrl + I Toggles italics on the current selection 
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Ctrl + J Toggles calculation between Manual and Automatic ?? 

Ctrl + K Displays the (Insert > Hyperlink) dialog box 

Ctrl + L (Added in 2003) Displays the Create List dialog box 

Ctrl + N Creates a new workbook (File > New) 

Ctrl + O Displays the (File > Open) dialog box 

Ctrl + P Displays the (File > Print) dialog box 

Ctrl + R Copies the leftmost cell in the selection to the right (Edit > Fill > 

Right) 

Ctrl + S Saves, Displays the (File > Save As) dialog box if a new 

workbook 

Ctrl + U Toggles underlining on the current selection 

Ctrl + V Pastes the entry from the clipboard (Edit > Paste) 

Ctrl + W Closes the active workbook or window (File > Close) 

Ctrl + X Cuts the current selection to the clipboard (Edit > Cut) 

Ctrl + Y Repeats the last workbook action (Edit > Repeat) 

Ctrl + Z Undo the last workbook action (Edit > Undo) 
 

  Other + Letters   

  

Alt + C Move the selected field into the Column area (Pivot Table) 

Alt + D Displays the (Data) menu 

Alt + E Displays the (Edit) menu 

Alt + F Displays the (File) menu 

Alt + H Displays the (Help) menu 

Alt + I Displays the (Insert) menu 

Alt + L Displays the Pivot Table Field dialog box ?? 

Alt + O Displays the (Format) menu 

Alt + P Move the selected field into the Page area (Pivot Table) 
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Alt + R Move the selected field into the Row area (Pivot Table) 

Alt + T Displays the (Tools) menu 

Alt + U Activates the AutoShapes submenu on the Drawing toolbar* 

Alt + V Displays the (View) menu 

Alt + W Displays the (Window) menu 

Alt + Shift + B Report on the cell borders ?? 

Alt + Shift + G Report the gridline status ?? 

Ctrl + Shift + A Inserts argument names given a function in the formula bar. 

Ctrl + Shift + C List cells in current column ??? 

Ctrl + Shift + F Activates the Font Name drop-down list on the Formatting 

toolbar 

Ctrl + Shift + H Selects all the hyperlinks ?? where 

Ctrl + Shift + O Selects all the cells with comments 

Ctrl + Shift + P Activates the Font Size drop-down list on the Formatting 

toolbar 

Ctrl + Shift + R List cells in the current row ??? 

Ctrl + Shift + S List all the worksheets ?? 
 

  Note: *This assumes that the Drawing toolbar is visible.   

 

  Entering Data   

  

Enter Enters the contents of the active cell and moves to the cell 

below (by default) 

Shift + Enter Enters the contents of the active cell and moves to the cell 

above (by default) 

Tab Enters the contents of the active cell and moves one cell to the 

right 

Shift + Tab Enters the contents of the active cell and moves one cell to the 
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left 

Alt + = Enters the SUM() function (AutoSum) to sum the adjacent block 

of cells 

Alt + 0128 Enters the euro symbol (€) (using Number keypad) 

Alt + 0162 Enters the cent symbol (¢) (using Number keypad) 

Alt + 0163 Enters the pound sign symbol (£) (using Number keypad) 

Alt + 0165 Enters the yen symbol (¥) (using Number keypad) 

Alt + Enter Enters a new line (or carriage return) into a cell 

Ctrl + ' Enters the formula from the cell directly above into the active 

cell 

Ctrl + Shift + 2 Enters the value from the cell directly above into the active cell 

Ctrl + ; Enters the current date into the active cell 

Ctrl + Enter Enters the contents of the active cell to the selected region 

Ctrl + Shift + ; Enters the current time into the active cell 

Ctrl + Shift + Enter Enters the formula as an Array Formula 

Shift + Insert Enters the data from the clipboard 

Alt + Down Arrow Displays the Pick From List drop-down list 

Esc Cancels the cell entry and restores the original contents 
 

 

  Editing Data   

  

Delete Deletes the selection or one character to the right 

Backspace Deletes the selection or one character to the left 

Shift + Delete Cuts the selection to the clipboard 

Ctrl + Delete Deletes text to the end of the line 

Ctrl + - Displays the (Edit > Delete) dialog box 

Ctrl + Shift + = Displays the (Insert > Cells) dialog box 
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  Selecting Data   

  

Ctrl + \ Selects the cells in a selected row that do not match the value 

in the active cell 

Ctrl + Shift + \ Selects the cells in a selected column that do not match the 

value in the active cell 

Ctrl + / Selects the array containing the active cell ?? 

Alt + ; Selects the visible cells in the current selection 

Ctrl + Enter Selects the first object / chart ?? 

Ctrl + Shift + (8 or *) Selects the current region (surrounded by blank rows and 

columns) 

Ctrl + * Selects the current region (using the * on the number keyboard) 

Ctrl + [ Selects all the cells that are directly referred to by the formula in 

the active cell (precedents) 

Ctrl + Shift + [ Selects all the cells that are directly (or indirectly) referred to by 

the formula in the active cell 

Ctrl + ] Selects all the cells that directly refer to the active cell 

(dependents) 

Ctrl + Shift + ] Selects all the cells that directly (or indirectly) refer to the active 

cell 

Ctrl + Shift + Page Down Selects the active worksheet and the one after it 

Ctrl + Shift + Page Up Selects the active worksheet and the one before it 

Ctrl + Shift + Spacebar Selects all the objects on the worksheet when an object is 

selected or selects the whole worksheet 

Ctrl + Backspace Selects the current active cell (scrolling if necessary) 

Ctrl + Spacebar Selects the current column 

Shift + Arrow keys Selects the active cell and the cell in the given direction 

Shift + Backspace Selects the active cell when multiple cells are selected 
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Shift + Spacebar Selects the current row 
 

  Extending Data   

  

Ctrl + Shift + Arrow Key Extends the selection to the next cell adjacent to a blank cell in 

that direction 

Ctrl + Shift + End Extends the selection to the last used cell on the worksheet 

Ctrl + Shift + Home Extends the selection to the beginning of the worksheet 

Shift + Arrow Keys Extends the selection by one cell in that direction 

Shift + Home Extends the selection to the first column 

Shift + Page Down Extends the selection down one screen 

Shift + Page Up Extends the selection up one screen 

End, Shift + Arrow Keys Extends the selection to the next non-blank cell in that direction 

End, Shift + End Extends the selection to the last cell in the current row* 

End, Shift + Home Extends the selection to last used cell on the worksheet 
 

  

  Note: *This is only available with (Tools > Options, Transition tab, Transition Navigation Keys).   

  Formatting Data   

  

Alt + ' Displays the (Format > Style) dialog box 

Ctrl + Shift + ( ' or ¬) Applies the Time format "hh:mm" to the selection 

Ctrl + Shift + (1 or !) Applies the Comma separated format "#,##0.00" to the 

selection 

Ctrl + Shift + (4 or $) Applies the Currency format "£#,##0.00" to the selection 

Ctrl + Shift + (5 or %) Applies the Percentage format "0%" to the selection 

Ctrl + Shift + (6 or ^) Applies the Exponential format "#,##E+02" to the selection 

Ctrl + Shift + (# or ~) Applies the General format to the selection 

Ctrl + (# or ~) Applies the Custom Date format "dd-mmm-yy" to the selection 

Ctrl + Shift + (7 or &) Applies the outline border to the selection 

Ctrl + Shift + (- or _ ) Removes all the borders from the selection 
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  Manoeuvring   

  

Arrow Keys Moves to the next cell in that direction 

Ctrl + Tab Moves to the next open workbook or window 

Alt + Tab Moves to the next application open on your computer 

Alt + Shift + Tab Moves to the previous application open on your computer 

Enter Moves to the cell directly below 

Tab Moves to the next cell on the right (or unprotected cell) 

Home Moves to the first column in the current row 

End, Arrow Keys Moves to the next non empty cell in that direction 

End, Enter Moves to the last cell in the current row that is not blank 

End + Home Moves to the last used cell on the active worksheet* 

End, Home Moves to the last used cell on the active worksheet* 

Page Down Moves to the next screen of rows down 

Page Up Moves to the previous screen of rows up 

Shift + Enter Moves to the cell directly above (opposite direction to Enter) 

Shift + Tab Moves to the cell directly to the left (opposite direction to Tab) 

Alt + Page Down Moves you one screen of columns to the right 

Alt + Page Up Moves you one screen of columns to the left 

Ctrl + Home Moves to cell "A1" on the active sheet 

Ctrl + End Moves to the last used cell on the active worksheet* 

Ctrl + Up Arrow Moves to the first row in the current region 

Ctrl + Down Arrow Moves to the last row in the current region 

Ctrl + Left Arrow Moves to the first column in the current region 

Ctrl + Right Arrow Moves to the last column in the current region 

Ctrl + Page Up Moves to the previous worksheet in the workbook 

Ctrl + Page Down Moves to the next worksheet in the workbook 
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Ctrl + Shift + Tab Moves to the previous open workbook or window 

Ctrl + Backspace Moves to the display the active cell 

Scroll Lock + Arrow Keys Moves the workbook or window one cell the corresponding 

direction 
 

  Note: *This is only updated when the workbook is closed.   

 

  Manoeuvring (within a selection)   

  

Enter Moves from top to bottom within a selection 

Tab Moves from left to right within a selection 

Ctrl + . Moves clockwise to the next corner within a selection 

Shift + Tab Moves from right to left within a selection (opposite direction to 

Tab) 

Alt + Ctrl + Left Arrow Moves to the left between non adjacent cells in a selection 

Alt + Ctrl + Right Arrow Moves to the right between non adjacent cells in a selection 
 

  

  Other   

  

= Starts a Formula 

Ctrl + ` Toggles between the value layer and the formula layer 

Ctrl + Delete Deletes to the end of the line 

Ctrl + Insert Copies the current selection to the clipboard 

Ctrl + Shift + ( Unhides any hidden rows within the selection 

Ctrl + Shift + ) Unhides any hidden columns within the selection 

Ctrl + Shift + / Copy value from cell above / select the array ?? 

Ctrl + Shift + \ Select unequal cells 

Alt Toggles the activation of the Menu Bar 

Alt + Shift + Left Arrow Displays the (Data > Group and Outline > UnGroup) dialog 

box 

Alt + Shift + Right Arrow Displays the (Data > Group and Outline > Group) dialog box 
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Alt + Backspace Undo the last action (Edit > Undo) ?? 

Alt + Spacebar Activates the Control Box in the top left hand corner 

Alt + - Displays the Excel application control menu 

End Toggles between switching End Mode on or off 

Scroll Lock Toggles between switching Scroll Lock on or off 

Shift + Insert Pastes the entry from the clipboard 
 

 

 

 

 

 

 

 

 

 

 

 

 

CHAPTER 7:          COREL DRAW 12 
 

LECTURE – 49 
A Touch of Graphic Designing  

 ا ٓت  ا س کے کچھ بیسک ٹولز سیکھیں گے 

 

  پرو گرا  م ہے ۔ا س کور س کے د و ر ا ن

 

 ا ینگ کے لیے ا ی ک بہت سٹینڈر د

 

ز
پ 
 

 

 ر ا  د

 

ہاںن پر ا س کو پڑھانے کا مقصد ا ٓت  ۔کور ل د

 ا 

 

ز
پ 
 

 

 کی د

 

ی
گ کی بنیاد ی ضرو ر تیں پور ی 

 

 پ
ی

ا  ہے۔جو ا ٓت  کی محنت پر

 

 ہیں۔ منحصر  کری

ا یٹل ی ا ر  

 

 ی

 

 مینو ی ا ر  

 

  ٹول ی ا ر  

 

 سٹینڈر د
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 ئلفا نیو ی ا  نیو کی مدد سے ا ٓت  ا ٓت  نیو فائل جس کے لیے ہاںن گرا فک لفظ ا ستعمال ہو گا لیں گے  پرو گرا م کھلتے ہی ا ٓت  کو ا ی ک و یلکم سکرین ملے گی۔ ا س کی مدد  سے 

 سیو کی جاسکتی ئلو ہ ا و ر  بہت سا ر ے فار میٹس میں بھی فاہے جس میں ا ٓت  فایل کو سیو کر سکیں گے ا س کے علا Graphicلیں ا س پرو گرا م کا فار میٹ   

 کے بعد ا نٓے و ا لے تمام نیو و ر  16ہے۔کور ل 

 

ز

 

پ
 

 

ز
پ 

ا  مشکل ہیں ۔ 

 

 میں سے کسی ا ی ک کو ا گر ا ٓت  سمجھ لیں تو ی ا قی پر کام کری

 

 تقریبا ا ی ک طرج کے ہیں ا ن

  ٹول ی ا ر :

 

 سٹینڈر د

ا م پر ماو س پو

 

 کے ی

 

ر  ٹولز سے ا ٓت  و ا قف ہیں ا ن

 

کی
  ہ ہو جاا س میں ا 

 

 گا۔ ئےا ینٹر ر ھنے  سے ا ٓت  کوا  س کا ا ندا ر

 کی مدد سے ا تٓ  ہاںن سے کوئی پر  Import & Exportد و  نیو ٹولز 

 

 کی مدد سے ا ٓت  کسی تصویر کو کور ل میں لا سکیں گے ۔ ا و ر  ا یکسپور ت

 

کٹ   ا ہیں۔ تو ا مپور ت

 ر  بھیج سکیں گے۔جو بہت ضرو ر ی ہے۔ مختلفبنانے کے بعد
ہ
 فار میٹس میں ی ا 

 ا ینر کہہ سکیں گے۔ہم 

 

ز
پ 
 

 

ک گرا فک د

 

 لیتے ہیں ٹول ی ا کس جو ا س پرو گرا م کی مین ی ا ر  ہے ا س کو سمجھنے کے بعد ا ٓت  ا پنے ا تٓ  کو کسی حد ی
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پ کت
پ ل
س

 ر  ہے کہ ا تٓ  کسی بھی ا و بجیکٹ کو لینے کے سا تھ سا تھ 
ہ
ا 

 

ا م سے ط

 

ی ک ٹول ی

 ا سی سے کریں Modifyا و ر   

 

ی ت  ٹول ہے ا س کی 

 

بٹن پر کلک کرنے سے ا ٓپکوا ی ک لسٹ ملے گے جس میں پہلا س

 ت  گول ی ا  بدل سکیں گے ا س کے لیے ا ٓت   ئےمدد سے ا تٓ  لیے ہو
ی

 

ا و بجیکٹ کی س

و س کی مدد سے کونون کو ماکو کلک کرنے کے بعد ا س ٹول پر کلک کریں ا و ر   بجیکٹا و 

 ر ی گ کریں۔

 

 ے  د

 

ز
پ 
 ٹولز کو بہت تفصیل سے ہیں  لیا جاسکتا کیونکہ یہ سا ر ے ٹولز 

 

ا ن

Tenhnical  ہیں ۔جس کے لیے ا چھی خاصی پریکٹس چاہیے۔ 

 

 سکیں گے

 

 ۔ سیدھا کانے  کے لیےا س ٹول کی مدد  سے ا ٓت  کسی بھی ا و بجیکٹ کو کات

ر ماو س کو 
ف

 تے ہوی 

 

کلک کریں۔  ئےچھور  

 

س کو کسی کار نر سے صاف کر

 

 پ کی
 ج
ن

 ر  کی مدد سے ا تٓ  ا و 

 

ز
پ 
  ا یر

 

سکیں گے ی ا  پھر د ر میان

 ر  کریں گے۔
ہ
ا 

 

 میں کٹا ہوا  ط

 

 ٹولز کے لیے ا تٓ  پہلے کو

 

 کے  ا و بجیکٹ لینے کے بعد ئیا ن

 

 پر کلک کریں ا و ر  ا ن

 

ا ن

 کے کونے جھری د ا ر  بنا

 

ا  شرو ع کریں تو ا ن

 

 ی

 

ز
گ
 شرو ع ہون کونون پر ماو س کو ر 

 ر  کریں گے۔ سٹائلگے۔جس سے ا ٓت  خوبصور تی ی ا  
ہ
ا 

 

ط  

 

، 

 

ی ت

 

ر ی ر و پ
ف
ر ی ہینڈ ٹول کی مدد  سے ا ٓت  

ف
ر و ٹیشن کر سکیں  سکیو ا و ر  ا ینگل پر 

 میں سے ٹو

 

 ر  د عہ  پرا پرٹی ی ا ر  ا ٓتی ہے ا ن
ہ
ل کے ا ٓپشن ضرو ر  گے۔تمام ٹولز میں 

 کریں۔

 

پ کت
پ ل
س

 ر  ٹول پر کلک کرنے کے بعد ا ٓت  کی
ہ
تی   فار میٹنگ ٹول ی ا ر  بدل جایعنی 

 

 

 ر  
ہ
 ر  ٹول کی فار میٹنگ کر سکیں گے۔نئےپرا پرٹی ی ا ر :یہ ا ٓت  کو 

ہ
  ٹول کے سا تھ نیو ملے گی۔ 

 

ٹ  ٹول ی ا کس ہے۔ئیںی ا ا و ر  

 

پ
  جا
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 ہے جو ا و پر ا ٓ  جاتی ہے ۔

 و م ماو س کی

 

 و م ٹول ہے ا و ر  ہینڈ ٹول کی مدد  سے ا ٓت  سکرین کا ر

 

 کر  یہ ر

 

مدد  سے سی ت

 ا س کا ی ا ر  ی ا ر  ا ستعمال ہو گا ۔ ا س کی

 

ٹ
ق
 و م ٹوسکیں گے۔کام کرتے و 

 

  پرا پرٹی میں سے ر

 کی پریکٹس ضرو ر  کریں۔

 

  ہے۔ ا ن

 

 پیج سٹینڈر د
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  ٹولز ہیں۔ جس میں سے ا ٓت  کو

 

ڈ
 

 

 پ
ر ی ہ ی
ف
و ل لینے یہ تما م 

 

 ی
ی

 

ی
ماو س کے  کے بعد  بعد

ے ہیں ی ا  

 

سکی
 ر ا  کر 

 

 ر ا  کر سکیں گے۔ پہلا پنسل ٹول ہے ا س کی مدد سے ا ٓت  لاین د

 

سا تھ د

 پھر ا ٓت  ہینڈ ر ا یٹنگ کا کام کر سکیں گے۔

ا و بجیکٹ لے سکیں گے۔ ا س کے بعد  Curveپھربیزیر ٹول ہے ا س کی مدد  سے ا ٓت   

Artistic Media طا طی کر سکیں گے۔  کا بہت

 

ا ہم ٹول ہے ا س کی مد د  سے ا ٓت  ح

  کریں۔ ا س کے علاو ہ کسی لی ہو

 

 میں سے چور

 

 موجود  ہیں ا ن

 

ز س
پ 
ی ت  کو  ئیمختلف 

 

س

ز شز میں کسی پر
پ 
 

 

  کلک کریں تو لینے کے بعد ا ٓت  ا ن

 

ز س
پ 
ی ت  ا س 

 

میں  سٹائلو ہ س

 د ے گا ۔

 

ٹ
ل
 

 

 بہت ا ھا ر ر

ر ی ہینڈ ہیں 
ف
لاو ہ ی ا قی تمام ٹولز بھی 

۔ا س کے ع  

 

س لینے کے لیے ا ستعمال ہوتے ہیں جن میں ی ا کس،  م یہ تما

پ ی 

 

س

ٹولز مختلف گرا فکس 

 د ا 

 

پ
 ز ہ، ا و ر  ٹیبل و غیرہ ہیں۔

 

 ر ا  کرنے کا طریقہ ا ٓت  

 

 کے د

 

س جن کو ا ٓت  ی ا ر  ی ا ر  لیں گے ۔ ا ن

پ ی 

 

س

بہت سے گرا فکس 

  میں 

 

 پر کلک کرنےسیکھا یم ا یس و ر د

 

سا تھ ہی ا و پر پرا پرٹی ی ا ر  میں  کے   چکے ہیں۔ا  ن

 گی ۔ ا س میں سے مطلوبہ ا و بجیکٹ لیں۔ ئےا س کی تفصیل ا ٓ جا

 

ی ت  پر ٹیکسٹ 

 

 ر ا  کریں ی ا  کسی س

 

ٹ  ٹیکسٹ ٹول ا  س کی مدد  سے ا ٓت  ٹیکسٹ ی ا کس  د

 

پ
ا 

 

 ی

 و غیرہ 

 

ٹ

 

پ
 ر ا  کریں ا و ر  پرا پرٹی میں سے فا

 

کریں۔ ی ا  پیرا  گرا ف کے لیے ی ا کس د

 جسٹ کریں۔

 

ی ت  کو لینے کے بعد ا ٓت  ا س پر ٹیکسٹ کا ٹول لے  ا ی ڈ

 

ا س کے علاہ کسی س

ٹ  کر سکیں گے ۔

 

پ
ا 

 

  میں ٹیکسٹ کو ی

 

 کر جائیں ا و ر  مختلف ا ندا ر

 

ا س میں پہلا بلینڈ ٹول ہے۔ا س کا ا ستعمال کرنے کے لیے پہلے ا ٓت  کسی بھی ا و بجیکٹ 

 و ن فاصلے پر ر کھ د یں۔ا س ٹول پر کلک کر کہ یر  کے کی کاپی

 

 کریں ا و ر  ا س کو ا ی ک مور

ک ا ٓ ئنسا 

 

 ر  ی
ہ
 کو فالو کریں ا و ر  کلک کرد یں۔ تو ا ٓت  د یکھیں گے کہ ا س ٹیکسٹ کا شیڈ ی ا 

  د ے سکیں گے۔ بعد میں  3dگیا ہے۔ ا س ٹول کی مدد  سے ا ٓت  ا و بجیکٹ کو  

 

کا ا ندا ر

 

 

 ت

 

 بھی کریں۔ا ٓت  پرا پرٹی ی ا ر   کی مدد  سے ا ی ڈ

 سا 

 

 ا س کے بعد کنٹور  ٹول کسی ا و بجیکٹ کو ا ن

 

 پ
پ

  سٹا

 

 د ے گا۔ ا س کے لیے ا س پر ئلڈ

 کلک کریں ا و ر  ماو س کو ا ندر  کی کی طرف کلک کریں۔
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  میں 

 

ا س ٹول کی مد د  سے ا ٓت  کسی کور ل ا و بجیکٹ ی ا  ٹیکسٹ کو ا ی ک خاص ا ندا ر

 

 

  د یتا ہے۔ئلسٹربنگ سٹاد

 

  د یں گے۔ یہ ٹیکسٹ کو ا ی ک نیا ا ندا ر
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ی ت  کرتے 

 

ی ت  کو ر ی س

 

 نیوہوئےبہت ا ہم ٹول ہے ۔ ا س کی مدد  سے ا ٓت  کسی س

ی ت  بنا

 

ا ئیںس

 

ا  ہے۔ کسی ٹیکسٹ پر ی ا  ئیٹلز گے۔ کتابون کےی

 

 ی ا د ہ ا ستعمال ہوی

 

 میں ر

کار نر پر جو نیو  ا و بجیکٹ پر کلک کریں ا و ر  ا س ٹول کو لیں ۔ ا س کے بعد ا ٓت  کے ی ا س

 پوا 

 

ن

 

ش
پ ک
پ ل
س

 

 

ی

س ا ٓ

 

ی

 

 پ
ی

 ر ی گ کریں تو ا ٓت  ا پنی مرضی ئیں

 

 کی مدد  سے کلک کر کہ د

 

 گے ا ن

ی ت  میں 

 

ی ت  کو نیو س

 

کر سکیں گے۔ ا سی طرج ٹیکسٹ کو بھی تیار  کر سکیں  تبدیلسے س

 گے۔

 

 د ے سکیں گے۔ ا س سے 

 

پ کت
ن ف
ا س ٹول کی مد د  سے ا ٓت  ٹیکسٹ ی ا  ا و بجیکٹ کو بیول ا 

 ر ا ینگ  

 

بن جاتی ہے۔ ا س کے لیے پہلے ا ٓت  ٹیکسٹ ی ا  ا و بجیکٹ کو  3Dا ٓت  کی د

 ر ی گ کریں ۔ ا س کے بعد ا س کی 

 

 ا سے د

 

 کریں ا و ر  ا س ٹول کی مدد سے تھور

 

پ کت
پ ل
س

 جسٹمنٹ کریں۔

 

ے ہیں  Bevelا س کو ا ٓت  پرا پرٹی کی مدد  سے ا ی ڈ

 

سکی
 ٹول کہہ 

 

ی بہت شیڈ ی ا  ٹرا نس

س

 

ی ی

ا ہم ٹول ہے ٹیکسٹ ی ا  ا و بجیکٹ کو شیڈ د ے گا ا و ر  د و سرا  ٹول  پر

 ر 
پ ی
ش

 

ن

ا مل ہے۔ ینٹ می کو ٹرا 

 

 یعنی ہلکا کرے گا۔ ا س میں تصویر بھی س

 

 ہے۔ ا س کی مدد  سے ا ٓت  کسی بھی ا و بجیکٹ ی ا  تصویر میں eye dropperپہلا ٹول 

 کریں گے ا و ر  پھر ا لے  فل ٹول کی مدد  سے مطلوبہ ا و بجیکٹ 

 

ت

 

لیے گے  می کی شناح

 میں فل کر سکیں گے۔ 

 

 لاین ٹول ہے۔ ا س میں پہلے ا ٓپشن ا تٓ  کے ی ا س ا ی ک ی ا کس کھولے گا۔ ا س 

 

یہ ا وٓ ت

 کی لاین ،  می

 

ج کت
ن 

 میں سے ا ٓت  ا و 

 

لاو ہ لاین کے ی ا قی  ا ئی، ا و ر  چور
بتا سکیں گے۔ ا س کے ع

ق ا پٓشن  سٹائل

لع

 

مپ

ی ا  فار میٹ بھی لے سکیں گے۔ا س پور  ی لسٹ میں لاین ہی کے 

 ہیں ۔

Lec53 

 کی مدد  سے ا ٓت  کسی ٹیکسٹ)ا ر د و  ی ا  ا نگلش ( ا و بجیکٹ 

 

گ ٹول ہیں ا ن

 

یہ سا ر ے فلپ

 

 

 ٹ
پ
  کرنے ا و ر  ا س کو لا

 

گ  می کر سکیں گے۔ا س میں پہلا ا پٓشن کسی  می کو چور

 

میں فلپ

 می ہے ا س کی مدد  سے ا ٓت  کسی ا و بجیکٹ

 

 ا ر ک کرے گا۔ د و سرا  بہت لار

 

 میں ا ی ک ی ا  د

 

 

 ٹ
پ
  لینا۔ ا س کے بعد 

 

 ی ا د ہ  می لے سکیں گے۔ یعنی ا ی ک ا و بجیکٹ میں ا کٹھے  میر

 

سے ر

  موجود  ہیں سٹائلزمیپ 

 

  میر

 

 ا و ر  د و سرے خوبصور  ت
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 ی ا د ہ ا ستعمال ہونے و ا لی ی ا ر  ہم نے 

 

 ر ا  میں ست  سے ر

 

 ٹولز کے ا ی ک کور ل د

 

س کی۔ ی ا د  ر کھیں ا و پر ہم نے ا س کو بہت مختصر لیاہے۔ ا س کے علاو ہ ا ن

سک

 

 

ً  ا و پر د مختصرا 

 ی ا د ہ ا ستعمال بھی ہیں۔ جن کو ا ٓت  ا ٓگے چل کر

 

 ۔د یکھیں گےسے ر

 ا و ر  و یو سے تعلقہ  بہت سا ر ے ٹولز ا ٓ 

 

 ت

 

 می ا پٓشنز د یکھتے ہیں۔جس میں فایل ا ی ڈ

 

  کے کچھ لار

 

 و ر
ی

 

پ ی
م

ت  پہلے سے جانتے ہیں۔ ا س کور ل میں  ا ت  ہم 

 سے کچھ ٹول ہیں جس میں نیا پیج لینا  Layoutکے علاو ہ  

 

 ے ا ٓسا ن

 

ز
پ 
و  میں 

 

 ی
پ ی
م

ا  ,

 

 یلیٹ کری

 

   می۔ جو میرے خیا ل میں ا تنے  ,د

 

ڈ

 

ا ۔ ا و ر  پیج کا بیک گرا و ی

 

ر ی نیم کری

 ۔ہیےکور س کے بعد ا ٓت  کو ضرو ر  خود  د یکھنے چا

 کو 

 

ا  ہون ا ن

 

 می چیزیں بتای

 

 ضرو ر  سمجھیں۔ میں ا ٓت  کچھ لار

 پیج کھولیں ا و ر  و ہان ٹیکسٹ کو ٹیکسٹ ی ا کس میں ر کھیں ا و ر  کور ل میں لا کر پیسٹ کر 

 

د یں ۔ ا ت  ا ٓت  ا س پر پرو گرا م میں ا ر د و  ٹیکسٹ لانے کے لیے ا ٓت  پہلے ا  ن

 ا 

 

ز
پ 
 

 

 و ہ تمام د

 

ی
ے ہیں ۔ جو کور ل میں موجود  ہے 

 

سکی
گ کر 

 

 پ
ی

 ۔

  ٹول ی ا ر  میں ا ی ک ٹول ہے  ۱

 

ا مل کرسکیں گے ۔ ا س IMPORT۔ سٹینڈر د

 

 کی مدد سے ا ٓت  کسی تصویر کو پرو گرا م میں س

ا یٹل کو ٹیکسٹ کو چاہے ا ر د و  ہو ی ا  ا نگلش ہو۔ ا س  EXPORT۔ ا س سے ا گٓے ۲

 

ٹول ہے۔ ی ا د  ر کھیں بہت ا ہم ہے۔ ا س کی مدد  سے ا تٓ  کور ل میں تیار  کرد ہ کسی ی

ا یٹل ہوئےکو تصویر کے طور  پر سیو کر سکیں گے۔ ا س کے پہلے ا ٓت  بنے 

 

 کر کہ پہلے ا س کو ی

 

پ کت
پ ل
س

گرو ت  کریں گے ا س کے بعد ا س ٹول کی مدد  سے ا ٓت  ا س کو  کو 

میں سے کسی ا ی ک میں کسی فولڈر  میں سیو کریں گے ۔ ا و ر  بعد میں کسی بھی پرگرا م میں تصویر   JPEG, (GIF, BMP, TIFF, PNG)تصویر کے فار میٹ )

 کے طور  پر کھول سکیں گے۔

 ا ٓت  کور ل ا و بجیکٹ کو کسی د و سرے فار میٹ میں سیو کرنے کے لیے ا ستعمال کریں گے۔ بھی Save As۔فایل میں ۳

ا س کی مدد  سے ا ٓت  کسی تصویر کو سکینر کی مدد  سے پرو گرا م میں سکین کر سکیں گے۔ ا و ر  بعد  Acquire Image۔ا س کے علاو ہ ا سی مینو میں ا ی ک ا پٓشن ہے ۴

 کر سکیں گے۔

 

 ت

 

 میں ا ی ڈ

  سے لا Publish to PDF۔ ۵

 

 کر سکیں گے۔  PDFٹیکسٹ ی ا  ا و بجیکٹ کو ئےہو ئےبہت ا ہم ٹول ہے ا س کی مدد  سے ا ٓت  کور ل ی ا  و ر د

 

 ت

 

 فار میٹ میں کنور

 ی ا د ہ ا ستعمال ہونے و ا لے ٹولز  Arrange Menu۔ پھر ۶

 

 گرو ت  ا لٓ بہت ر

 

  گرو ت  ، ا ن

 

میں بہت سا ر ے نیو ٹولز ہیں جس میں ا لاین منٹس ا و ر  گرو ت  ، ا نَ

 سیکھیں گے۔

 

 نے کے لیے ہیں۔ا س  کی تفصیل ا ٓت  کلاس کے د و ر ا ن

 

 پیج کے ٹیکسٹ کو تور

 

 لینا۔ Ungroup Allا ن

  ٹولز   Shaping۔ ا سی مینو میں ۷

 

 ی ڈ

 

ر
ک
 می ہیں۔میں بہت سا ر ے 

 

گ  و غیرہ بہت لار

 

 ہیں جن میں و یلڈی

ے ہیں۔ا س کے بعد بہت سا ر   Affect۔ ۷

 

سکی
 یٹنگ کر 

 

ے ٹولز مینو میں پہلے تما م ا پٓشنز تصاو یر کے لیے ہیں کسی تصویر کو لے کر ا ٓت  ا س میں ا پنی مرضی کی ا ی ڈ

ا س کی مدد  سے ا ٓت  کسی بھی تصویر سے کوئی بھی ا یٓٹم ی ا  پور ی ل ہے ۔ بہت ی ا و ر  فل ٹو LENSا ٓت  نیچے ٹول ی ا ر  میں پڑھ چکے ہیں۔ا س میں ا ی ک نیا ٹول ہے 

ی ت  میں حاصل کرسکیں گے ا س کے لیے پہلے ا ٓت  ا پنی مطلوبہ تصویر لیں پھر 

 

پر کلک کریں ا و ر  ا ٓنے و ا لے  Lensمینو میں جا کر  Affectتصویر کسی ا لگ  می ی ا  س

 لائی کر د یں ۔ ا ت  ا ٓت  کا  Fish Eyeہے  ا پٓشنز میں سے ا پنا مطلوبہ لے لیں ا س میں ا ی ک ا ٓپشن
یہ ست  سے بہتر ہے ا س کو لیں ا و ر  نیچے د یے گئے ٹول کی مدد  سے ا ی

ے ہیں ا س کے علاہ ا س 

 

سکی
ے ہیں۔ Lensنیا ا و بجیکٹ تیار  ہے ا ٓت  ا س کو ا لگ سے سیو بھی کر 

 

سکی
 ی ڈ  شفاف بھی بنا 

 

ر
ک
 کی مدد  سے ا ٓت  کسی بھی ا و بجیکٹ کو 

 میپ مینو میں

 

 ٹ
پ

 کریں پھر ا س مینو کے ی ا قی ا ٓپشن ا ی لائی ہون گے جس  Bitmapر ے ا پٓشنز ہیں پہلے ا ٓت  کسی بھی لیے گے ا و بجیکٹ کو بہت سا  

 

میں کنور ت

 کرنے کے بعد  Bitmapا و بجیکٹ کو ا ٓت  

 

پ کت
پ ل
س

ا  چاہتے ہیں ا س کو 

 

 کری

 

پر کلک کریں  Convert to Bitmapمینو میں موجود  پہلا ٹول  Bimapمیں کنور ت

ے ہیں۔ ا و ر  د ی گئی

 

سکی
 پرا پرٹیز کو فالو کریں ۔ ا س کے بعد ا تٓ  ا س ا و بجیکٹ پر ا س مینو کے ی ا قی تمام ٹولز ا ی لائی کر 

 کر سکیں گے۔و کی مدد  سے ا تٓ  بہت سا ر ے ا شکال پر  Insert Characterمیں  مینو TEXTا س کے علاو ہ  

 

 ت

 

ا مل کرنے کے بعد ا ی ڈ

 

 گرا م میں س

 

عام علامات

 پیج ا و پن ہونے پر  Webdingsکے لیے ا ٓت  ا س میں سے 

 

 لیں ا و ر  ا ن

 

ٹ

 

پ
 ا ئن ملیں گے  Zhakrifفا

 

ز
پ 
 

 

 میں ا ٓت  کو بہت سا ر ے ا ر د و  کے د

 

ٹ

 

پ
ا س مینو میں  فا
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Fit Text to path  کرنے 

 

پ کت
پ ل
س

ی ت  ا و ر  ٹیکسٹ کو ا کٹھا 

 

ی ت  پر ٹ  کر سکیں گے ۔ ا س کے لیے ا س س

 

بعد ا س ٹول پر کے کی مدد  سے ا تٓ  کسی ٹیکسٹ کو کسی س

 ہ۔و غیرکلک کر د یں۔

More Shortcuts 

Ctrl +A           Select all  Ctrl + B  Bold text  

Ctrl + C   copy text or folder or object Ctrl + D  Font List 

Ctrl + E Center alignment Ctrl + F  Find text  

Ctrl + G  Go to text Ctrl + H  replace text  

Ctrl + I italic text  Ctrl + J  justify text 

Ctrl + K create hyperlink Ctrl + L  left alignment 

Ctrl + M increase indent Ctrl + N  new document 

Ctrl + O open list of files Ctrl + P  Print  

Ctrl + R right alignment Ctrl + S  save text 

Ctrl + U underline text Ctrl + v  Paste text 

Ctrl + W close file Ctrl + X  cut text or folder 

Ctrl + Y redo Ctrl + z  undo 

Ctrl + shift + D double underline Ctrl + shift + +/= superscript 

Ctrl +}]  increase text size Ctrl + {[  decrease text size 

Shift +F3  change case Ctrl +home  home of file 

Ctrl +end  end of file Alt + F4  close applications 

Alt +Tab go to previous program Print screen sys Rq to take picture of 
current screen 

F2  to edit in Ms excel cell F5   refresh 

Alt +5  new folder Ctrl + Alt + Delete end task 

Esc  cancels any list Ctrl + enter  new page 

Ctrl +F9 Decrease size in (Inpage) Ctrl + F10 Increase size in (Inpage) 

Ctrl + space bar key   To change lang. Alt + insert new page in Inpage 

Alt + del delete page in Inpage F12  Go to ribbon in inpage 

Ctrl+Alt+Del  End task Alt +F+A  Save as 

F7 Spelling check Alt+F7 Direct Spelling check 

F1 Help F2 Editing in MS excel cell. 

Corel Draw Short Cuts: 

F1 Help F10 shape tool 

Z Zoom Tool F6 Rectangle 

F7 Oval Y Polygon 

F8 Text Editing G Interactive Fill toll 

Ctrl +I Import Ctrl +E Export 

Ctrl +D Duplicate Ctrl +Z Undo 

Ctrl+shift +Z Redo Ctrl +R Repeat 

F9 Full screen Ctrl +G Group 

Ctrl +U Ungroup Ctrl +Q Convert to curve 

Ctrl+F9 Contour Ctrl+F7 Envelope 

Alt +F3 Lens Ctrl+T Format Text 

Ctrl+ F11 Insert symbols   

 

57  –55  – LECTURE 
Starting Accessories OS ‘s Important Application: 
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You will learn about some extra Applications. Including Printing, Virus Scanning, Data traveling, 
Disk properties CD writing, System properties, Different Concepts of daily usage. Etc. 
Summary: 
In this little course you have learned about English composing, Tables, Book Titles & Design 
Templates, Using Office tools, (MS. Word), Urdu composing, Tables, Design (Using Inpage2.4), 
Making Presentation, Showing Charts, Diagrams, Professional Presentations with Animations, 
Audio/Video effects (PowerPoint), Working on spreadsheet, Making large Tables, More effective 
tools, formulas & functions, data base management(Using MS Excel including), Designing, Art & 
design, book titles, visiting cards, eid cards, handouts, working on pictures (Using Corel Draw, 
And saving your assignment as a bitmap picture, Using GIF and JPEG Format.  
Accessories, software installation, using Antivirus, Control Panel & OS XP, introduction to Internet 
& Some extra applications, and other office handling tools. 
These applications allow you to become a good professional official person. Our prayers of 
success will always with you. 

 
Golden Tips: 

 I trust you is better complement than I love you because you may not always trust the 
person you love, but you can always Love the person you trust. 

 A rain drop looks very small to eyes but somewhere a thirsty land waits for it. 

 Care should be in heart not in words, & anger should be in words not in heart. 
 
 
 

CHAPTER 8:         SLYBUS OF COMPUTER HARDWARE  
 

LECTURE – 01 

 

 ر  کے لیے بہت ضرو ر ی ہے۔ ا س لیے کہ :ا س

 

 ر  کمپیوٹر یور
ہ
ر  کا جاننا 

 

ی ی
  و 

 

ر  کے سا تھ سا تھ ہار د

 

ی ی
 ٹ  و 

 ہے ۔ کہ ۔ا و ر  میں یہ سمجھتا ہونکے ۔ و ہ ا پنا کمپیوٹر خود  ٹھیک کر1

 

ت  سے ا ہم ی ا ت
 یہ س

 ی ا  ر شتہ د ا ر  کا  ا گر ۔ ا س کے علاو ہ۲

 

 کم ا س مسئلے کمپیوٹرکسی د و ست

 

 یوا گر پرا بلم کر ر ہا ہے تو ا ٓت  کم ا ر

 

  تبدیل کر سکیں۔ئس کو ٹریس کرلیں ا و ر  ا س کی تعلقہ  د

 ا ٓت  کے کمپیوٹر میں ا گر کوئی مسئلہ۳

 

ا  ہے تو ا ٓت  خود  ا س کو ٹریس کر۔ ا ٓفس میں جات  کے د و ر ا ن

 

 ۔سکیں ا ٓی

ر  کے سا تھ سا تھ یہ ا ی ک پلس پوا ا  ی ا س س۔ کسی بھی جات  کے لیے ا ٓت  کے ۴

 

ی ی
 ٹ  و 

 

ی
 ہے ۔

 

ت

 

 ی
 ی

ر  تو ا ۔ س۵

 

ی ی
کٹ  و 

 

 ر  لیول ی

 

 ی ا د ہ تر لوگ یور

 

  کرے گا۔  تقریباً ر

 

ر  ا ٓت  کو د و سرو ن سے ممتار

 

ی ی
  و 

 

 جانتے ہیں لیکن کمپیوٹر ہار د

ر  کور س کے بعد ا ٓت  کمپیوٹر کی بنیاد و ن کو سمجھنے0

 

ی ی
  و 

 

   لگتے ہیں ا و ر  ا ٓت  ا س فیلڈ میں  ۔ ہار د

 

ر
ک

ے ہیں۔ ی ڈ 

 

سکی
 کر 

 

 ر یسرج

  و ئیر کور س کے بعد ا ٓت  کمپیوٹر فیلڈ میں ٹیچنگ کر سکیں گے۔1

 

 ۔ ہار د

ا  چنانچہ میں 

 

ھپ
 
چ
س

ا مل کر ر ہاہون 

 

 ر  ا ی ک لیے ضرو ر ی ہے ا س لیے میں ا س کو ا س کتا ت  میں س
ہ
ر  

 

ی ی
  و 

 

 ۔ہون کہ ہار د

Introduction to Hardware 
Definition of Computer: 
1. A computer is an electronic machine, which can automatically processthe inputdata (Data refer 
to a collection of facts usually collected as the result) (personal instructions), in accordance to its 
program of instructions OS(i.e. windows) install in the computer, and provides the results in a 
simple way or in an acceptable manner.  
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2. A computer is machine that can be used programmed to accept data (input) and process into 
useful information (output) and also safe for later reuse. 
3. It responds to a specific set of instructions (input) in a well defined manner.  
4. A computer is an electronic machine which process instructions or data to give desirable result. 
5. A computer is machine that can be programmed to accept input(data) & process it into output 
(information). 

 
 
Difference Between Hardware & Software. 

 
Hardware:  
All the physical components of computer are called hardware. Handling system devices &hard 
driveis also included in this process. 
 
Software:  
It is a set of instruction that computer can understand & on the basis of these it can provides 
suitableresults. i.e. the affects that you can see on the screen are called software. OS are 
examples of software. Different OS are DOS,Windows, Linux, OS/2, MS. Word, MS. Excel are 
another example of softwares. 
 
Two types of softwares are 
System software: 
 System software provides the interface to user for controlling operations like saving data printing 
document and other useful solutions of daily use. i.e. OS’s  
Application software:  
These are used to accomplish tasks specified by the user. I.e. Ms Office, Corel etc. 

The main purpose of an OS is to control and manage the hardware and software in a link, 

and software can be some given instruction of a user to accomplish a specifictask. 

We will discuss about OS in next lectures. 

 
What are Machines? 
Machines are devices which perform a useful work. Computer is also a machine. 
*Simple machines  *Automatic Machines  *Digital Machines 
*Analog Machines  
 

The Under line words will be discussed briefely in lectures 
 
Computer Languages: 
The computer is a similar device like TV or CD player. A computer does not understand our 
instructions if they are given in any of our own language. There are some special languages that 
used to communicate with the computer.  
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Types of Languages: 

i) Low Level Languages ii) High Level Languages 
 
i) Low Level Languages: 
The low level language requires the programmer to have a detailed knowledge of the internal 
structure of the computer hardware that is how these components works with 0 and 1. 
 
There are two low level languages: 

1) Machine languages  2)Assembly Languages 
 
1. Machine languages: 
The only language that computer can understand that is machine language, ie 1 and 0. This is 
only language that directly understood by the computer, machine language represents data and 
programinstructions into 0 and 1 two digital codes. 
 
2. Assembly Language: 
Many people doesn’t like machine language that is 1and 0, solution was provided in 1952 which 
uses nemonic codes (abbreviations) such as A for add and C for compare MP for multiply and so 
on. Assembly language uses assembler to change assembly language’s codes into machine 
languages that is 1 & 0. 
 
High level programming languages: 
In this language we use English to write any program and after a translator is needed to convert 
this into machine language. Some main high level languages are: 
FORTRAN: Formula Translation: It is used for mathematical problems solving. 
BASIC (Beginner’s all purpose Symbolic Instruction Code) 
COBOL (Common Business Oriented Language) 
C and C++ Visual Basic and V.B.net and PASCAL, JAVA 
 
Types of Computer: 
Digital Computer: A computer which understand only two codes i.e. the two machine codes 
0(represent the off) & 1(represents the on) these are called binary codes. PC’s are digital 
computers. 
Analog Computer: The computers in which components depends on comparison between 
voltage & current.  i.e. the billing machine.  
 
Hybrid computer: The combination of digital & analog. These computers are used in research 
fields. 
Our course just belongs to Digital Computers. 

 
PHYSICAL DEVICES OF COMPUTER (PC) 

 
LECTURE – 02 

 

 کہ کمپیوٹر کے بہت سا ر ی ا قسام ہیں۔ جن کے ی ا ر ے میں ا ٓت  پہلے کور س میں پڑھ چکے ہیں۔ یہ کور س پی سی سے تعلقہ  ہے۔ یعنی ہاںن پر تماما ٓت  جانتے ہیں 

 ل شوٹنگ، ہینڈلینگ و غیرہ۔
ی
، ٹر

 

ٹ

 

پ
 پی سی سے تعلقہ  ہو گی۔ا سی کے کمپو

 

 ی ا ت

PC (Personal Computer): 
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 ر   1311یہ ست  سے پہلے ا ٓئی بی ا یم کمپنی نے 
ہ
 ر  گھر ، 
ہ
 تو یہ 

 

 یرا ئی ملی۔ ا و ر  ا ٓج

 

 ے ہی عرصہ میں ا سے پور ی د نیا میں بہت ی ڈ

 

میں متعار ف کرو ا ی ا ۔ لیکن بہت تھور

 

 

ن ہیں جو: بن چکا  د فتر، سکول، کالج ا و ر  یونیور سٹی کی ا ہم ضرو ر ت
 
کلی

 

س

 ہے۔ ا سکی د و  

There are two types of PC.    
  i) Desktop    ii) Tower 

 

ہیں پھر ہم ا س کے ا ندر  کی طرف چلیں گے۔  سمجھتےحصون کو بیرو نیہم ا س کے ست  سے پہلے   

ر  
ف
 پی سی کا 

 

ٹ

 

پ
ل  

 

 پ
ی ی

 ی :

 

ل/سی د

 

 پ
ی ی

 

 

ت

 

 لاپ ی

 

ٹ

 

پ
ر 
ف
 بٹن، 

 

 ، ی ا و ر  بٹن، ر ی سٹار ت

 

  پور ت

 

ڈ

 

و ی

 

ن
 ی، یو ا یس بی، سا 

 

 ی و ی د

 

ا  ہے ۔ د

 

پر مشتمل ہوی  

ل:ا س میں ست  سے 

 

 پ
ی ی

پور ٹس ہیں۔ پہلےبیک   

Ports of System Unit (Called CPU): 

 

 

 

 
 
PS2 ports, USB 
(universal serial Bus), Comp ports, Parallel ports, Serial Ports, VGA port, game and sound 
portsetc. 

 کو شکلون کے حسات  سے 

 

 ، یو ا یس بی، مانیٹر لگانے کی پریکٹس کریںسمجھیںا ن

 

و س ا و ر  کی بور د

 

ن
 میں ما

 

 ا ن

 

ٹ

 

پ
 

 

 .۔پھر سٹود

 
LECTURE – 03 

 
The Physical Devices of the system unit: 

 
1. Motherboard: 
 

It is an electronic circuit board. 
The circuit where the processing, 
storage& different functional 
devices take place consists 
number of silicon chips. And each 
chip has many of transistors and 
ices. (Integrated (built in or fixed) 
Circuit) 
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  ہے۔ جہان پر تمام 

 

یہ بجلی سے چلنے و ا لا سریا بور د

  لگتی ہیں۔ ا س کی مختلف ا قسام ہیں۔پہلے ہم کچھ 

 

ر
 س
ن

 یوا 

 

د

 ہ سمجھتے  ی ا ر ٹس کو 

 

ز

 

پ
ہیں پھر ا ٓگے ہم تفصیل سے ا س کا جا

  د کھا ی ا  گیا  مدر  کا ا ی ک 4لیں گے۔نیچے شکل میں  پی 

 

بور د

 ۔ہے
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LECTURE – 04 

The Chipsets 
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A chipset is referred to aggregate of different 
ices or chips that are designed to work 
together. Or the chipsets are aggregate of 
several ices (integrated circuits) in two or 1 
IC. The north bridge and the Southbridge.  

 کا جا

 

ت

 

  کی سا ح

 

 ہ لینے کے بعد ا ت  ہم ا س کو تفصیلبور د

 

ز

 

پ
 سے لیتے ہیں۔ ی ا د  

 کے ی ا ر ے میں جاننا بہت 

 

 کے حوا لے سے ح ت  ست

 

  کی پہچان

 

ر کھیں بور د

 کی تعریف د ی گئی ہے۔ا صل میں 

 

ضرو ر ی ہے۔ تو د یکھیں ا و پر ح ت  ست

 د و  ا ٓئی سیز پر مشتمل ا ی ک

 

ا  ہے جس میں  ح ت  ست

 

پور ے سر یا کو کہا جای

 کر د ی ا  گیا ہے۔ ا و ر  

 

بہت سا ر ے ا ٓئی سیز کے کام کو صرف د و  میں کنور ت

ا ل ا ٓت  

 

 کر د ی ا  گیا ہے ۔ جس کی مپ

 

کت

 

 کے سا تھ ی ا ہم کپ

 

  کو ا ن

 

ر
 س
ن

 یوا 

 

تمام د

 

 

  د

 

ے ہیں۔بور د

 

سکی
 ا و پر تصویر میں د یکھ 

 

ز
پ 

 کو 

 

 ح ت  ست

 

 ا ن

 

ٹ
ق
ا ین کرتے و 

 کو بہت ترجیح بہت ترجیح د ی جاتی ہے ا و ر  ہار 

 

  و ئیر جاننے و ا لے بھی ا ن

 

د

  کو سا منے 

 

د یتے ہیں۔سا منے تصویر میں ا تٓ  د یکھ ر ہے ہیں ۔ پور ے بور د

 

 

ر کھیں ا و ر  د یکھیں ا س میں د و  مین ا ئٓی سیز ہیں ۔ یہی ا ٓت  کے ح ت  ست

ا ر تھ ا و ر  

 

 پر ا نحصار  کرتے ہیں۔ا ی ک کو ی

 

 ا ن

 

ت

 

 ی
ی

 

ی
ہیں۔ ی ا قی تمام کمپو

ا  

 

ز یج کہا جای
پ 
ہے۔ہم جانتے ہیں کہ کمپیوٹر میں د و سرے کو سا و تھ 

ا  ہے۔ ا ت  بنیاد ی طور  پر یہ پرو سیسنگ

 

ا  ہوی

 

 کا سا ر ا  کام سی پی یو نے کری

 

 

کت

 

 کہیں گے، یہ سی پی یو سے کپ

 

د و نون ا ٓئی سیز جن کو ا ت  ہم ح ت  ست

ک پہنچتے ہیں

 

 ا ٓئی سیز کی مدد  سے ا ٓگے سی پی یو ی

 

س ا ن

 

پ ی

 

پ

 ۔ہیں ی ا قی تمام کمپو 

 

 

Northbridge  
Links the CPU to very high-speed devices, 
especially main memory and graphics 
controllers,  

 ے ر یم ا و ر  گرا فک 

 

  پر لگے ہوئے د و  ا ہم پرر

 

ز یج کی مدد  سے بور د
پ 
ا ر تھ 

 

ی

 ہوتے ہیں۔

 

کت

 

 کنٹرو ر  سی پی یو سے کپ

Southbridge  
Connects to lower-speed peripheral buses (such 
as PCI or ISA). In many modern chipsets, the 
Southbridge actually contains some on-chip 
Integrated peripherals, such as Ethernet, USB, 
and audio devices. A chipset is usually designed 
to work with a specific family of 
microprocessors. Because it controls 
communications between the processor and 
external devices, the chipset  
plays a crucial role in determining system 
performance. 

س جن کا ا بھی صرف ا تٓ  کو تعار ف کرو ا ی ا  گیا ہے سا و تھ 

 

پ ی

 

پ

ا ت  ی ا قی تما م کمپو

 ہوتے ہیں

 

کت

 

ک کپ

 

ز یج کی مد د  سے سی پی یو ی
پ 

 ۔

 لز 

 

 ماد

 

 :ح ت  ست
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  یعنیا ت  ی ا ت

 

  کرتے  ہیں فلان بور د

 

 کی تو ح ت  ہم یہ لفظ یور

 

  کی پہچان

 

 ا گٓئی بور د

Intel 815, intel 810،Intel 845, Intel 945  etc.  

 

 

 لز ح ت  ست

 

 کریں کہ کے تو یہی ماد

 

  کی پہچان

 

ا  ہے۔ا س کو و ہان سے د یکھیں ا و ر  بور د

 

  کے مین ا ٓئی سی پر لکھا ہوی

 

ا م ا تٓ  پکار تے ہیں یہ بور د

 

   ہیں ا ت  یہ جو ی

 

سا  بور د

 

ن
کو

 بنائے ہیں لیکن

 

 ست  سے ا چھے مانے جاتے ہیں Intelہے۔مختلف کمپنیون نے مختلف ح ت  ست

 

ا  ہے ۔ کے ح ت  ست

 

بعض د عہ  ا ئٓی سیز پر ا ی ک ہیٹ سنک لگا ہوی

  
پ
 میں کسی کار نر پر ی ا  سا 

 

 ا س صور ت

 

ا  ہے۔پ

 

 ل لکھا ہوی

 

 ماد

 

  پر ح ت  ست

 

 ڈ

 کی شنا:لی ب ورک 

 

  کے ح ت  ست

 

 کریںا پنی لیب میں لگے کمپیوٹرر

 

 کی پہچان

 

 کریں ا پنے گھر کے کمپیوٹر کے ح ت  ست

 

ت

 

 ۔ح

 

LECTURE – 05 
Different Components of Board 

 
Ports are already discus.  
Slots: 
Different slots. 
 

 

 

  و غیرہ۔ سا تھ سا تھ ا ن

 

 ر

 

لا ر یم، کار د

 

  لگاتے ہیں۔مپ

 

ر
 س
ن

 یوا 

 

ل د

 

پ

 

ش
ک

 

فپ

سلاٹس جہان پر ا ٓت  مختلف 

  کا تعار ف بھی سا تھ کرو ا  د یںکو د یکھیں ا و ر  

 

 ر

 

 کار د

Types of Slots: 
PCIslots (peripheral component 
interconnect) sound, VGA modem 
etc.  
 

 

 

 

 

 

 

 ی ا د ہ 

 

  پر تعدا د  میں ست  سے ر

 

 کا ی ا ئی جانے و ا لی سلاٹسیہ بور د

 

ا  ہے ا ن

 

 ی ا د ہ تر سفید ہوی

 

گ ر

 

 ر ی

AGP (Accelerated Graphic Port) 
sound VGA, TV card etc.  

 

 

  یعنی و ی جے ا و ر  ٹی و ی 

 

 س پلے کار د

 

 ا ر ک گرے  می میں ہوتی ہے ا ی ک ی ا  د و  کی تعدا د  میں یہ د

 

د

 ی ا د ہ ا ستعمال ہوتی ہے

 

  کے لیے ر

 

 ۔ کار د

 

 

3. AMR(Audio  Media riser) 
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4. ISA (industrial standard 
architecture) Slot 

 ی ا د ہ تھیں لیکن P2یہ 

 

  میں تو ر

 

ر
م

 

شی
س

 P3   ی ا د ہ ہیں 2میں ا س کی تعدا د 

 

ر  نیو  سے ر

 

کی
ہوتی ا و ر  ا 

 پر لگنے و ا لے 

 

  میں ی ا لکل ہیں  ہے چونکہ ا س کے متباد ل سلاٹس موجو ہیں۔ا س سلات

 

 ر

 

بور د

  

 

 ر

 

    ISAکار د

 

 ر

 

  بھی عام کار د

 

 کی ا وٓ ا ر

 

 ی ا د ہ مشہور  ہیں ا و ر  ا ن

 

  ر

 

 ر

 

  کار د

 

ڈ

 

ا  ہے ا س کے سا و ی

 

  کہا جای

 

 ر

 

کار د

 ی ا د ہ ہے۔

 

 سے ر

Ram Slots 
SIMM (Single in line memory 
Module) slot (P1) 
 

ر  مسائل کا علق  

 

کی
لاٹس کے ی ا ر ے میں جاننا بہت ضرو ر ی بھی ہے ، کیونکہ کمپیوٹر کے ا 

ر یم کی س

 سے ہو سکتا ہے ی ا  پھر ر یم سے تو ا س ی ا ر ے میں ا ٓ ت  کو ا گر پور ا  علم ہو گا تو ا تٓ  کسی بھی مسلے 

 

ا ن

 کا حل جلدی کر سکیں گے۔

 پیو

 

 کو  ا کے بور  ن

 

  پر لگی ہوئی ر یم سلات

 

 ر

 

 د

 

 سلات

 

 میں ر یم کی مناسی ت

 

ا  ہے ، ا س سلات

 

کہا جای

ا  ہے ۔ سا 

 

 سے سنگل یا ہوی

 

پ
  

 

 ی سی چھوٹی ہے ۔ی ا د  ر کھیں ر یم ا لٹی لگانے سے بور د

 

  میں تھور

 

ز

 جل سکتا ہے ا س لیے ا حتیاظ ضرو ر ی ہے۔

 
 
 
DIMM (Dual in line memory 
Module) slot (PII, PIII)SDR RAM 
 

 

 

 

 

 

 
 م ر یم

 

 سے  د و  یا ہوتے   P3 & P4د

 

 میں ر یم کی مناسی ت

 

د و نون میں ا ٓئی ہے ، ا س سلات

 ہیں ا و ر  سا 

 

پ
 ہے

 

 ی ہے۔ یہ ر یم لگانے میں ا ٓسا ن

 

ز
پ 
 ی سے 

 

  میں بھی تھور

 

 ۔ز

DDR (Double Data Ram) slot (PIII, 
PIV) 
 

 

 

 

 

 ی ا د ہ تر 

 

 ی ا رٓ  ر

 

 ی د

 

 یعنی د

 

ا  ہے۔ ا س کے  P4یہ سلات

 

 سے سنگل یا ہوی

 

  میں ا ئٓی ہے ۔ ا س میں ر یم کی مناسی ت

 

 یو کمپیوٹرر

 

 یول کور  ا و ر  کور  ٹو د

 

ا و ر  ا س کے بعد د

  چل پڑی ہے و ہ ہے 

 

ز
پ 
  .…DDR1,DDR2 بعد ا س کی ا ی ک خاص سیر

 

 

 
ن

  پر 

 

 ر

 

 کے نیو ا نٓے و ا لے بور د

 

  ا سا ئن کی گئی ہے۔ ا ٓ ج

 

ز
پ 
 لگی ہوتی ہے۔یعنی ا ت  سپیڈ کے حسات  سے ا س کو ا ی ک خاص سر

 

ی سلات

ہہ
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LECTURE – 06 
Test 

ل کریں۔
ی ک

 

ی کی

 نٹس کا ٹیسٹ لیں ا و ر  پچھلے ہفتے کا سا ر ا  کام پر

 

 ر ا ہیں، ا و ر  سٹود
ہ
  کو د 

 

 پہلے تمام یکچر ر

CPU/Processor 
Slots 

 

 

 

 

 

 

 

 

Socket (ZIF) zero insertion Force 
processor slot  
 
 
 
 
Slot processor  

 

 یہ د و  طرج کی ہے ا ی ک تو تو ہم سلاٹس پڑھ 

 

ر ہے تھے۔ ا ٓگے ا رٓ ہی ہے پرو سیسر سلات

، سپیڈ، ا و ر  سا 

 

 تصویر میں د یکھ ر ہے ہیں نیو ٹیکنالوجی کے سا تھ سا تھ ا س کی جسامت

 

ز

 

پ
 

ا  ہے ا و ر  ا س کا

 

ت  ی ا  سا یا کہا جای
 کو ح 

 

 ہے۔ا و پر و ا لی سلات

 

ئ

گ

 ر  چیز بدل 
ہ

پرو سیسر بھی  

ا  ہے۔Pentium Chip سا یا 

 

ہلای
ک
 ی ا  

 ہوتی ہے۔ نیو ا ٓنے

 

  پر یہی سلات

 

 ر

 

  و ا لے تمام بور د

 

 

 کی طرج لمبی یہ سلات

 

  پر تھی ا و ر  ا ت  تقریبا ً ختم ہو P3د و سری تھی سلات

 

 ر

 

کے بور د

 پر لگنے و ا لے پرو سیسر کی ا خٓری سپیڈ تھی۔

 

 ہے۔ا س سلات

 

ئ

گ

1000 MHZ  

Some concepts about electronic 
components 
 

 

Conductor, insulator, Semiconductor, 
Transistor,  
Capacitors, Diode & IC. 
 

 ر  بجلی سے 
ہ
 ے بھی موجود  ہیں جو 

 

  پر بہت سا ر ے ا یسے پرر

 

و ا لی مشین پر  چلنے بور د

 کو بھی سمجھ لیتے ہیں۔

 

 ہوتے ہیں ہم ا س کور س میں ا ن

Conductor 
 کو

 

 ا ٓسا نی سے گز ر  کے  ا ن

 

ٹ

 

پ
ا  ہے  کہا موصل ی ا  کنڈکٹر و ہ ا شیاء جن میں سے کر

 

جای

لًالوہا، سلور ، ی ا نی

 

 مپ

Insulator, 
ا   

 

 کو ا نسولیٹر ی ا  غیر موصل کہا جای

 

 ہیں  گزر  سکتا ا ن

 

ٹ

 

پ
ا یسی ا شیا جن میں سے کر

 ،خشک لکڑی

 

ز
پ 
لًا ر 

 

 ہے۔مپ

Semiconductor 
 کے ا ندر  د و نون کنڈکٹر 

 

 گزر  ے لیکن بہت د ر میاہ، یعنی ا ن

 

ٹ

 

پ
ا یسی ا شیاٍ جن میں کر

 موجود  ہون۔ 

 

 ا و ر  ا نسولیٹر کی خصوصیات
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Transistor,  

ز ی ا  کیا۔
پ 
لات  
ق

 

ن
 ا س کی ا یجاد  نے کمپیوٹر کی د نیا میں ا 

 

ر ، د و سرے کو بیس، ا و ر  تیسرے کو کولیکٹر کہتے ہیں۔ یہ  ا ینٹ یہ تین ٹرمینل وفئچ ہے ا س کے ا ی ک پو

 

 می
ن

میں ا یجاد  ہوا  ا س کا ا یجاد  کرنے و ا لے و یم،  1341کو ا 

 ھانے ا و ر  کم کرنے کا

 

ز
پ 
 کو 

 

ٹ

 

پ
 یوا یس ہے جو کر

 

  بھی ملا۔بنیاد ی طور  پر یہ ا ی ک سیمی کنڈکٹر د

 

ز

 

پ
 ل پرا 
ی
 کو نو

 

 ین تھے ا ن

 

 ی ا ر د

 

ا کلے ا و ر  جار ج

 

ا  ہے۔ ا و ر  س

 

 کام کری

پ لائی 
س

ا  ہے۔ 

 

پ لایفائی کرنے کا کام بھی کری
 م
ن

 کو ا 

 

ٹ

 

پ
ا  ہے۔یہ کر

 

ک مشین میں ا س کا بہت ا ہم ر و ل ہوی

 

ا  ہے کسی بھی ا لیکٹرا ی

 

 ہ کریں کہ کا کام بھی کری

 

ا ٓت  ا ندا ر

  ہو تے ہیں۔  P3ا ی ک

 

 سٹر ر

 

ز

 

پ
 و ن ٹرا 

 

 پرو سیسر میں کرو ر

Capacitors 

 کو سٹو ر  کرنے بعض فلٹر ا

 

ٹ

 

پ
 کرنے کا کام کرتے ہیں۔ س کی بہت سا ر ی ا قسام ہیں بعض کر

Diode  

 یوا   ٹرمینلٹو

 

ز ۔ ئسد
پ 
ز ا 
پ 
ا  ہے بلکہ ہ ہونےکے 

 

 گزا ر ی

 

ٹ

 

پ
 کو ا ٓسا نی سے گزر نے د یتا ہے جبکہ ا س کی خالف  مت  میں ا نتائی کم کر

 

ٹ

 

پ
 جو صرف ا ی ک مت  میں کر

ا  ہے۔ا س کی بھی بہت سا ر ی ا قسا

 

 کری

 

 میں کنور ت

 

ٹ

 

پ
 ی سی کر

 

 کو د

 

ٹ

 

پ
 م ہیں۔ا س کی علاو ہ سریا میں ا ے سی کر

 ر  مشین
ہ
 کو 

 

ٹ

 

پ
 پر چلتی ہیں ا س لیے ا نٓے و ا لے کر

 

ٹ

 

پ
 ی سی کر

 

  د

 

ر
 س
ن

 یوا 

 

 ی ا د ہ تر د

 

 ا ے سی ہے چونکہ ر

 

ٹ

 

پ
ک ا نٓے و ا لا کر

 

ر  ی

 

پ ی
م

:ا ٓت  کے 

 

ٹ

 

پ
 میں لگے ا ے سی کر

شفا ر مر ہے جو یہ کام کر

 

ن
پ لائی میں بھی ا ی ک ٹرا 

س
 کرتے ہیں ا ٓت  کے کمپیوٹر میں لگی ی ا و ر  

 

 ی سی میں کنور ت

 

  د

 

شفا ر مرر

 

ن
  کے سریا میں ٹرا 

 

ا  ہے ۔ لیکن ا گٓے بور د

 

ی

ا  ہے۔

 

 ر یعے یہ کام کیا جای

 

  کے د

 

 ر

 

 ا یود

 

 د

IC.(ROM) 
These are ROM (Read only Memory) 
ICES (integrated Circuits) An integrated 
circuit (IC), sometimes called a chip or 
microchip, is a semiconductor wafer on 
which thousands or millions of tiny 
resistors, capacitors, and transistors are 
fabricated. An IC can function as an 
amplifier, 

 

 

 چھوٹے سا 

 

 ٹ
پ
 ا ٓئی سی کے ا ندر  نہا

 

پ
 

ک

 کرنے و ا لا(

 

مت
ح
 ا 

 

ر
ک
لاف 

 

 کے ج

 

ٹ

 

پ
 سٹر)کر

 

ا  ہے۔ یعنی ر ر

 

  میں ا ی ک پور ا  سریا ہوی

 

 ز

 

 ا یود

 

ر ، د

 

 سی
 پ ی
ی

  لگے ہوتے  

 

 سٹرر

 

ز

 

پ
ا و ر  ٹرا 

 سٹر کا ا ی  

 

ز

 

پ
 ہوتی ہے۔ا صل میں یہ بہت سا ر ے ٹرا 

 

 کی ضرو ر ت

 

ج

ی 

 

لی

 و و 

 

 ٹ
پ
 

 

 ا وٓ ت

 

 ٹ
پ
 

 

ک مجموعہ ہے کمپیوٹر کے حوا لے سے ا س ہیں۔ ا س کو کام کرنے کے لیے ا ن

 کو بہت سا ر ی ا قسام میں ر کھا گیا ہے۔

LECTURE – 08 
Chip and Slot Processor 

The CPU (central Processing Unit) refers 
to the brain of the computer. The primary 
work of the CPU is to convert data from 
input, process the data (instructions) and 
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out put in useful information that can be 
use by the user of other computer 
programs. The definition of computer 
also referred to CPU as well. It is one of 
the complex units of the computer. Has 
three basic parts. 
All the operations & calculations are 
basically depends on this device. CPU 
receives & transfers the signals which we 
send to it.  Different processors holding a 
code i.e.8088, 80286, 80386, 80486, 
Pentium, pentium11…..the greater codes 
denotes the amount of highest speed. 
Different Processors from companies are 
Intel, Intel’s Celeron, AMD (advanced 
Micro Devices)’s ATHLON, Motorola, 
DUO core, VIA, Cyrix etc. 
 

 

 

 

 

 

 

 

 

CPU has three basic parts i.e.  
Control unit:  It controls all the activities 
of a computer with the help of given 
instructions. I.e. decides what kind of 
action is to be taken. The CU consists of 
circuitry that generates signals to direct 
the entire computer system to carry out 
or execute the programs. It also controls 
the flow of information through the 
processor. 
Arithmetic logic unit (ALU):  
Solves the mathematical and decision 
making problems and produce the 
results. I.e. add subtract, divide and 
multiply and other logical solutions. 
Addition, subtraction, multiplication, 
Division, logical operations (if, and less or 
greater). 
Memory Unit (MU):  
It is used to store data temporarily & 
permanently. 
I.e. with the help of given instructions 
CPU has to decide what to do and how to 
do. 

 ہے یعنی سی پی یو جس کی و جہ سے ہم تما م پرو سینگ پرفار م کرتے 

 

یہ کمپیوٹر کا د ماع

ہیں۔یہ کمپیوٹر کا ست  سے پیچیدہ حصہ ہے بنیاد ی طور  پر یہ بھی ا ی ک سریا ہے ح ت  

  پر ا ٓت  ا س کو د یکھیں گے یسا کہ ا و پر تصویر میں تو یہ

 

 سٹر ر

 

ز

 

پ
 و ن ٹرا 

 

 ا ٓئی سی ا و ر  کرو ر

 مشتمل ا ی ک سر یا ہے۔ ا س کی پرو سینگ سپیڈ

MHZ and GHZ 

لًا 

 

  ی ا  1666میں ہوتی ہے۔ مپ

 

ز

 

پ
 ر 
ہ
 مار کیٹ میں ست  سے 1میگا 

 

ٹ
ق
  ا س و 

 

 ر ٹرر
ہ
گی گا  

 ی ا د ہ حد 

 

 سیکھیں  گے۔ 3066ر

 

 ا ٓت  کلاس کے د و ر ا ن

 

پ لات
فص

 

ن

  ہے۔ی ا قی 

 

ز

 

پ
 ر 
ہ
میگا 

 

 

  حضرا ت

 

ر

 

کی
 کے  مختلفا نسٹر

 

ت

 

 پر لکھے سا ح

 

 نٹس کو د کھائیں ا و ر  ا ن

 

پرو سیسر سٹود

  پر ٹ  کرنے کا 

 

  ا و ر  پرا پرٹیز کو بھی سمجھائیں، ا س کے علاہ پرو سیسر کو بور د

 

 ر

 

ہوئے کود

 ر ا ئیں۔
ہ
 طریقہ ی ا ر  ی ا ر  د 

 

Bit. (Binary Digits) 
It is a unit of computer. i.e.  
8bits=1byte implies 16bit= 2bytes(2 characters or space or symbols) 
1byte=1character. A symbol or space 
1024 bytes=1kb 
1024kb=1mb 
1024 mb = 1 GB 
1024GB = 1 TB 
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 ا ٓف کمپیوٹر:

 

ٹ

 

پ
 یو

 

Buses (Data Cables):  
These are internals used to transfer data 
from one device to another. 
Types of buses are. 
 
 Address bus:  
Address bus carries address information. 
It only connects CPU and memory. 
 
Control Bus: 
It carries control information from the 
control unit to the other units ALU and 
MU 

 یوا 

 

  جن کی مدد  سے ہم ا ی ک د

 

ز
 پ ل
کی

 تے ہیں۔ئسو ہ 

 

 سک ا و ر   کو د و سرے سے جور

 

  د

 

ہار د

 ی ر ا م کی

 

 سے یہ  سی د

 

ٹ  کی حامل ہیں۔ Ata , SaTaمناسی ت

 

پ
ا 

 

 ی

LECTURE – 09 
Cards 

 اقسام
: 

 

ر
 س
ن

 یوا 

 

ل د

 

پ

 

ش
ک

 

فپ

 مختلف 

 ا ٓپشن ی ا  تو ہ ہو ی ا  ا تٓ  ا س  

 

 لگائے جاتے ہیں ح ت  ا ٓت  کا کوئی بلٹ ا ن

 

ٹ
ق
  ا س و 

 

 ر

 

یہ کار د

 س پلے 

 

لا ا ٓ ت  کے کمپیوٹر کا د

 

ا  چاہیں مپ

 

ا   121ا یم بی ہے تو ا ٓت   04کی جگہ ا ھا لگای

 

کری

 س 

 

ا  ہو گا ا و ر  پہلے و ا لے کو صرف ی ا ئی ا و س سے جا کر د

 

  لگای

 

چاہتے ہیں تو ا ٓت  کو نیا کار د

ل کر
 پ 
پ

ا  ہوگا۔ا 

 

 ا گر و ہ ا نٹرنل ہے ۔ی

1. VGA CARD (Video Graphic Array) 
PCI & AGP (Peripheral Component 
Interconnect) & Accelerated Graphic 
port) 
It is a monitor input (where we detect the 
monitor’s cable). The display of 
computer. Now days the 64 Mb VGA 
card is most common. AGP and PCI 
VGA are most common in these days. 
Different VGA cards drivers names: ATI, 
Intel, S3, AMD, SIS, Different Chipsets 
(intel 810 E, 815, 845, 865) Triton, XL etc 

 

 

 سے ہے ا و ر  ا س کا

 

 ا س کی سلات

 

  کی پہچان

 

 ر  کار د
ہ
لاٹس پہلے پڑھ چکے ہیں ا ت  

  پر ا ی ک مین ا ئٓی سی ہے جس سے ا س کے ہم س

 

 ر  کار د
ہ
 سے ہے۔

 

ا م بھی ا سی مناسی ت

 

 ی

 

 

ٹ  ح ت  سی ت

 

پ
ا 

 

 مختلف ی

 

ر  کا پتہ بھی ہاںن سے چلے گا ۔ا نسٹرکٹر حضرا ت

 

ی ی
 ر ا یور  ی ا  سا ٹ  و 

 

 ل کا ہے ا س کے علاہ ا س کے د

 

 کا پتہ چلتا ہے کہ کس کمپنی ا و ر  کس ماد

ا  ا و ر  

 

  پر لگای

 

  کو بور د

 

 ر

 

 کار د

 

 ل کی مدد  سے ا ن

 

 نٹس کو بتائیں۔ماد

 

ے کا طریقہ سٹود

 

ھی
ا م پڑ

 

  کے ی

 

 ر ا یور ر

 

 کے د

 

 ا ن
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Sound card 

It is a sound of computer & contains 
the speakers input. PCI and 
AGP.Different Sound cards drivers 
names: 
Audio Excel, Creative, Trident, 
Mvision, Dream, Crystal, Neomagic, 
sound pro series, Yamaha, Zlotrix, C-
Media, Soundmax,  
 

 

  خود  ٹ  کر لیں 

 

ل کریں ا و ر  ا س کی جگہ ا ی ک نیا کار د
 پ 
پ

 س ا 

 

  خرا ت  ہے تو ا تٓ  ی ا ئی ا و س میں جا کر ا س کو د

 

  کار د

 

ڈ

 

و ی

 

ن
  کا سا 

 

و ہ ا ٓٹو ہے تو ٹھیک و ر ہ ا گر ا گر ا ٓت  کے بور د

 ل د یکھ کر ا س کا مطلوبہ س

 

 ٹ  و ئیر د یں۔ا ا س کا ماد

  

 

 کر لیں ، و ندو ر

 

کت

 

  و ئیر کو پرا پرلی کپ

 

ا ل کرنے کا طریقہ :پہلے کسی بھی ہار د

 

شپ

 

ن
  ا 

 

 ر ا یور

 

 کر  XPد

 

ت

 

 کوئی بھی ا پٓریٹنگ سٹم ا س کو خود  شناح

 

 ٹ
پ
 

 

ی ا  ا س سے ا ت  د

ا ل ہو جائے  New Hardware Foundگا د ے  Messageلےگا ا و ر  ا ٓت  کا کمپیوٹر ا ٓت  کو

 

شپ

 

ن
 ی د یر کے بعد خود  بخود  ا س کو سا ٹ  و ئیر ا 

 

ا گر و ہ ا ٓٹو ہوا  تو تھور

 ر ا یور  ہیں  ہوا ۔  Messageگا ۔ و ر ہ ا ٓت  کو 

 

 مل جائےگا کہ د

 ل ا و ر  

 

 یوا ئس کا ماد

 

 میں ا ٓت  نے بتائے گے طریقہ کے مطابق کسی بھی د

 

 سے لیںICا س صور  ت

 

ی ت

 

 ر ا یور  پ

 

 ی سے لے کر ۔ ا ٓت  نمبر د یکھ کر د

 

 My ی ا  کسی سی د

computer   پر ماو س کا د ا ی ا ن کلک کریں ا و رProperties میں جا کرHardware  پر کلک کریں ا س میں ا ٓت  کے کمپیوٹر میں لگے تمامFunctional 

Components  جس پر 

 

ت

 

ی

 

) می ی ا  کسی ا و ر   می میں  Yellowکی لسٹ ا ٓت  کے سا منے ا ٓ جائے گی ۔ا س میں و ہ کمپوپ

 

ا ن

 

س

 

ن
 یوا ئس ?وفا لیہ 

 

( لگا ہو تو سمجھ لیں و ہ د

 کلک کرکہ 

 

 ٹ
پ
ر  ہیں  چل ر ہا تو ا ت  ا ٓت  نے ا س پر ر ا 

 

ی ی
 لگی ہوئی ہے لیکن ا س کا سا ٹ  و 

 

ا  ہے ا و ر  ا ٓگے جا ر کر سا ٹ  و ئیر کی  Updateد ر ست

 

 ر ا یو ر  کری

 

د

ا ل ہو جائے گا ۔و ر ہ 

 

شپ

 

ن
 د ینی ہے ا گر و ہ سا ٹ  و ئیر ا  س کا ہے تو و ہ ا 

 

ن

 

 ش
کی

 ا ٓ جائے گا ۔Errorلو

TV Tuner Card 

  بھی کہتے ہیں  Captuareکمپیوٹر میں ٹی و ی ج لانے کے لیے ا س کو 

 

 کار د

 

 
 Modem:  
 

 

 یو

 

ی ت

 

ا  ہے۔ گھریلو ا نٹرپ

 

 ی ا د ہ تر پی سی ا ٓئی ہوی

 

ا  ۔ ر

 

 ہیں  ہوی

 

ک ر سا ئی حاصل کرتے ہیں ی ا د  ر کھیں یہ بلٹ ا ن

 

 ی

 

ی ت

 

  کے لیے یہ بہت ا س کی مدد  سے ا ٓت  ا نٹرپ

 

 ر ر

 

ر

 ا ہم ہے ۔ا س کی ا قسام۔

 :جو ا و پر تصویر میں د کھای ا  گیا ہے سٹم کے ا ندر  لگتا ہے۔ا نٹرنل

ا  ہے۔ا یکسٹرنل

 

 ج لانے کے لیے ا ستعمال ہوی

 

ی ت

 

 و ر کس پر پ

 

ی ت

 

 ی ا د ہ تر پ

 

 ی ا د ہ ہے ر

 

ا  ہے ا س کی سپیڈ پہلے و ا لے سے ر

 

 ر  ر کھا جای
ہ
 :جو سٹم سے ی ا 

 و  

 

پ
 ا 

ل 

ا پس و غیرہ میں لگا ہوسز  

 

ا  ر  کے بغیر :لیپ ی

 

ا  ہے ۔:ی

 

  بھی ا ٓ گی ہیں جیسے ی

 

ر
 س
ن

 یوا 

 

 EVO (PTCL)ا ت  یو ا یس بی  د
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LAN Card: (local area Network):  
LAN connects the computers in a small unit 
in office or in any department or in 
buildings situated near each other. 
 

 

Wan: Wide area Network: 
It can be spread over different countries & 
has several LANs connected together. 

 

 

 

LECTURE – 10 
Power Supply 

Power supply is a reference to a source of 
electrical power. A device or system that 
supplies electrical or other types of energy 
to an output load or group of loads is called 
a power supply unit or PSU. The term is 
most commonly applied to electrical energy 
supplies, less often to mechanical ones, 
and rarely to others. It is an electronic part 
of computer that provides the electricity to 
your PC. A computer usually uses a 5V 
(1.5A), 12 V (2.5A) volts of electricity 
A modern computer power supply is a 
switched-mode supply designed to convert 
110-240 V AC power from the mains 
supply, to several output both positive (and 
historically negative) DC voltages in the 
range 12V to 3.3V. The first computer 
power supplies were linear devices, but as 
cost became a driving factor, and weight 
became important, switched mode supplies 
are almost universal. The diverse collection 
of output voltages also have widely varying 
current draw requirements, which are 
difficult to all be supplied from the same 
switched-mode source. Consequently most 
modern computer power supplies actually 
consist of several different switched mode 
supplies, each producing just one voltage 
component and each able to vary its output 
based on component power requirements, 
and all are linked together to shut down as 
a group in the event of a fault condition. 

 

پ لائی کو کھول کر ا س کے 
س

  جو  مختلف

 

ر ر

 

 سی
پ ی
ک

  ا و ر  د و  ا ہم 

 

  ہ لیں پھر فیور

 

ز

 

پ
ی ا ر ٹس کا جا

 

 

 کو تبدیل کرنے کا طریقہ بتائیں۔ا س کے علاہ کسی بور

 

د  پر عموماً جل جاتے ہیں ا ن

پ لائی کو ٹ  کرنے کا طریقہ
س

 

ا  ہے ا ی ک تو پی 4ا و ر   3پی 

 

ر ق ہوی
ف
پ لائی میں 

س
  کم  3کی 

 

پ لائی کے کن ا یکٹرر
س
کی 

  4ہوتے ہیں جبکہ پی 
ی ک
 ی ا د ہ ہیں جبکہ ی ا و ر  کے د و  مین پوکے کن ا 

 

  ر

 

 ر

 

ر

 

ی
س 

 

ی

 

 پ
پ

ہوتے  ا 

 کرو ا ئیں۔

 

ت

 

 کی شناح

 

 ہیں ا ن
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LECTURE – 10 
 

The memoriesof computer  a re two type 
 

Primary (Internal) 
Secondary (External) 

 کمپیو

 

  ا ن

 

ر
 س
ن

 یوا 

 

 ٹر:سٹور یج د

Secondary (External) 
Hard DRIVE/hard disc: 
HDD are used to permanently store 
information in the computers, and can be 
used any time for other purposeless, now a 
days a typical computer has HDD of 
capacity of more than 80GB. Data is stores 
in HDD in form of files & folders.(A file is 
simply a named collection of bytes).  
 
 
 
Some main concepts of HDD: 
A typical HDD consists of a sealed metallic 
box with controller circuit on one side; the 
controller is responsible for read/write 
mechanism of HDD. 
DATA RATE: The data rate is the number 
of bytes per second the the HDD can 
deliver to the CPU, rates between 5 and 40 
MB are common. 
Seek time: 
The time used to move the HDD to the 
appropriate track after reading the address 
is called the seek time. 
Types of HDD are: 
IDE (Integrated development environment) 
EIDE (Enhanced integrated development 
environment) 
ATA (Advanced technology attachment) 
SATA (SerialAdvanced technology 
attachment) 
PATA (Parallel Advanced technology 
attachment) 
SCSI (Small computer system interface) 
 
Parts will be discussed in lectures with 
practical 
Settings of HDD: 
Master or slave: Will be discussed in 
lectures in details using different HDDs. 
 

Settings of HDD: 
Master or slave: Will be discussed in 
lectures in details using different HDDs. 

 

 

 

 

 

 

 

 

 

  

http://upload.wikimedia.org/wikipedia/commons/5/52/Hard_drive-en.svg
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CD (Compact Disk): It is a made of plastic, 
has nearly 5 inch diameter. Can store data 
more than 600 – 700 Mb other are 
DVD(digital versatile Disc) can store data 
up to 8 GB. 
 

 

CD Rom/writer/DVD/Combo 

 

 

Flash Drive (Flash Memory):  
These are the devices that can be used to 
transfer the data from one pc to the other.  
If Floppy has the size of 1.44 MBi.e. It can 
save your 1509376 characters. The other 
device is Flash drive it can store your data 
from 1GB to 32 GB.  

 

 

LECTURE – 12 
The Priamary Memories (Internal) 

A). RAM (Random Access Memory): 
 It holds the inputs or instructions that we 
give to the computer temporarily. When we 
switch off the computer these inputs are 
removed. 
SIMM (Ram) single in line memory module) 
4 Mb 8MB 16 Mb 32 Mb 64 MB. 
DIMM (Dual in line memory module) 128 
MB & 256 DDR (double data Ram 
256mb512 Mb 1 GB 
 

 

b). ROM (Read Only Memory): 
A permanent memory i.e. 
Ices.(Integrated(built in or fixed) Circuits), it 
holds the data after making computer off. 
At the time of making a computer some 
programs are stored in ROM. Whenever 
the computer is switched on these 
programs are automatically executed. 
These programs are never removed even 
when the computer is off. The user can 
only use these programs but can not edit or 
delete these. 
 
 

 

http://images.google.com.pk/imgres?imgurl=http://www.yamahamultimedia.com/yec/tech/images/sample_cd.jpg&imgrefurl=http://club.cdfreaks.com/f59/copying-disc-t-2d-cds-mass-copying-61601/&usg=__okQI1uweP_qawTYeVKHY65w27kI=&h=407&w=400&sz=39&hl=en&start=4&um=1&tbnid=-ZRqznb5ofpFWM:&tbnh=125&tbnw=123&prev=/images?q=CD&um=1&hl=en&sa=N
http://www.google.com.pk/imgres?imgurl=http://upload.wikimedia.org/wikipedia/commons/e/ef/SDR_SDRAM_133MHz.jpg&imgrefurl=http://commons.wikimedia.org/wiki/File:SDR_SDRAM_133MHz.jpg&h=568&w=2066&sz=1322&tbnid=4WEjg0imYM_riM::&tbnh=41&tbnw=150&prev=/images?q=SDR+RAM&hl=en&usg=__yEHQ9Fz5jyTA6_S248EjJBpwUaQ=&sa=X&oi=image_result&resnum=2&ct=image&cd=1
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Types of ROM: 
PROM: 
Programmable ROM: 
In programmable ROM a user can also 
write his own program, but cannot make 
any further changes. 
 
EPROM: 
The erasable Programmable Rom provides 
us both writing & erasing facilities. 
 
EEPROM: 
Electrically Erasable Programmable Read 
only Memory is permanent memory on 
which user can write and erase his 
programs 
 
HEAT SINK 
A heat sink (or heat sink) is an environment 
or object that absorbs and Dissipates heat 
from another object using thermal contact 
(either direct or Radiant). Heat sinks are 
used in a wide range of applications 
wherever efficient Heat dissipation is 
required; major examples include 
refrigeration, heat engines, cooling 
electronic devices and lasers.  
 
PROCESSOR FAN 
A set of 4 industry standard 80 mm fans, 
most commonly used in personal 
computers. A computer fan can be any fan 
inside a computer case used for cooling 
purposes, and may refer to fans that draw 
cooler air into the case from the outside, 
expel warm air from inside, or move air 
across a heat sink to cool a particular 
component. 
 
 
BUS Speed: 
The ability of the chipsets to transfer 
instructions and data from device to 
another device.100 MHz, 133 MHz, 266 
MHz 566 MHz, 800 MHz are common Bus 
speeds. A bus is simply a circuit that 
connects one part of the motherboard to 
another. The data that a bus can handle at 
one time, faster it & allows information to 
travel. The speed of the bus, measured in 

 

 

 

 

 

 

 

 

 

 

 

 یٹا ی ا  ا نسٹر 

 

ا ر  یعنی ا ی ک کیبل کی و ہ سپیڈ جس کی بنا پر و ہ د

 

بس سے مرا د  ہے کیبل ی ا  ی

 یوا یس سے 

 

 ٹریول کرے گی۔ ا س کی بھی ا ی ک خاص کشن ا ی ک د

 

د و سری کے د ر میان

 ہن میں ر کھ لیں۔ا ی ک تو یہی بس سپیڈ۔د و سرا :

 

 ہے ۔ ا ٓت  د و  چیزیں د

 

ی ت

 

 ا جی

 یوا 

 

  کی و ہ سپیڈ جس پر و ہ مشین ئسکلاک سپیڈ: کسی بھی د

 

لا ر یم، پرو سیسر، بور د

 

 مپ

 پر

 

 عمل پرو سینگ پرفار م کرتی ہے۔ یعنی ا س کی و ہ سپیڈ جس کی مدد  سے و ہ ہدا ی ا ت

 

 

 ی ا د ہ ہدا ی ا ت

 

 یوا یس ا تنی ر

 

 ی ا د ہ ہو گی و ہ د

 

ر ا ہم کرتی ہے۔ یہ سپیڈ جتنی ر
ف
 

 

ٹ
ل
 

 

کر کہ ر ر

 د ے گی۔

 

ٹ
ل
 

 

 کو حل کر کہ ر ر

ر  جاننے و ا لون کے 

 

ی ی
  و 

 

ا ل لیتے ہیں ر یم کی د و  چیزیں ہار د

 

ا ت  ا ٓت  د یکھیں ہم ر یم کی مپ
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megahertz (MHz), refers to how much data 
can move across the bus simultaneously. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 لیے ا ہم ہیں۔ ا ی ک بس سپیڈ، ا ی ک کلاک سپیڈ۔

  پر ا و پر لکھی ہوتی ہیں۔ ا و ر  ر یم کی یہ د و نون چیزیں پیش آت

 

ر
 س
ن

 یوا 

 

 ر کھیں۔کچھ د

 ست  کی بس سپیڈ 

 

 ا ن

 

ٹ
ق
کچھ کی ی ا ئی ا و س سے پتہ چلتی ہیں۔ ر یم ، پرو سیسر لگاتے و 

ر ق پڑھے 
ف
ضرو ر  پیش آت ر کھیں۔ و ر ہ ا ٓت  کے کمپیوٹر کی سپیڈ ا و ر  پرفار منس پر 

  ا و ر  کلاک سپیڈ 166سٹم کی بس سپیڈ P2گا۔

 

ز

 

پ
 ر 
ہ
بی ہے۔  ا یم 121سے  04میگا 

  ا و ر  کلا سپیڈ  133سے  166کی ر یم کی بس سپیڈ P3ا سی طرج 

 

ز

 

پ
 ر 
ہ
سے  121میگا 

  سے ا گٓے ا ینڈ  133سٹم کی بس سپیڈ  P4ا یم بی ہے۔ ا س طرج  250

 

ز

 

پ
 ر 
ہ
میگا 

 ی ڈ 

 

ر
ک
ا  چاہیے۔ا سی طرج ا ٓگے 

 

ل ہوی
 پ 
پ

 ا 

 

 ی ت
می
ک

 ست  کو 

 

 ۔یعنی ا ن

 

Assembling 

PC System: 
Lec-13& 14 

 
 Guidelines for Building Your Own PC 
Pervious, we have covered the 
fundamentals of the components used in 
today's PCs, discussed some of the 
important aspects of hardware 
configuration, now further we will explain 
how to assemble a standard PC. 
First, let's take a look at the various steps 
to putting together a PC. 

 

 

 

Opening the empty case.  
Preparing to fit the components.  
Fitting the motherboard. 
Fitting the RAM, processor, and cooler. 
Installing the graphics card and sound 
card.  
Fitting the hard disk and floppy drive. 
Installing the floppy and CD-ROM 
drives.  
Connecting the ribbon cables. 
Powering the drives and motherboard.  
Connecting the cables for the case 
front panel.  
Final check. 

 کی مدد  سے ا ٓت  

 

 تمام مرا حل کو فالو کرتے ہوئے سٹم کو ا سمبل کریں۔ا ن

 

ا ن

 تیار  کرسکیں گے۔ بھی PCکسی بھی طرج کا 
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LECTURE – 15 
Computer BIOS & BIOS Extension ROM 

 

BIOS are software that controls all the H.W 
in the computer. Work in booting processor 
in the computer and check that how many 
devices are attaches with the computer and 
how they have to work. 
 In computing, the Basic Input/Output 
System (BIOS), also known as the System 
BIOS. The BIOS is boot firmware, designed 
to be the first code run by a PC when 
powered on. 
 The initial function of the BIOS is to 
identify, test, and initialize system devices 
such as the video display card, hard disk, 
and floppy disk and other hardware. This is 
to prepare the machine into a known state, 
so that software stored on compatible 
media can be loaded, executed, and given 
control of the PC. This process is known as 
booting, or booting up, which is short for 
boots trapping. BIOS programs are stored 
on a chip and are built to work with various 
devices that make up the complementary 
chipset of the system. They provide a small 
library of basic input/output functions that 
can be called to operate and control the 
peripherals such as the keyboard, text 
display functions and so forth. In the IBM 
PC and AT, certain peripheral cards such 
as hard-drive controllers and video display 
adapters carried their own.  
 

 

BIOS extension ROM,  
This provides additional functionality. Operating 
systems and executive  
Software, designed to supersede this basic 
firmware functionality, will provide  
Replacement software interfaces to applications. 

 ھ ر ہے ہیں ۔ ا ت  ا ٓت  کمپیو

 

ز
پ 
 می مرا حل کی طرف 

 

  و ئیر پر  ٹر ا ت  ہم بہت لار

 

ہار د

 مرا حل پر جن کی مدد  سے ا تٓ  کو پتہ چلے گا 

 

کنٹرو ل بھی حاصل کریں گے یعنی ا ن

 یوا 

 

ا  ہے کسیکیسے کیسے ، کہان چل ر ہی ہے ا س کو ئسکونسی د

 

 چیز کو ا ین  کنٹرو ل کری

ل 
 پ 
پ

 س ا 

 

ل ی ا  د
 پ 
پ

ا  ہے۔ کیسےا 

 

 کری

ی ا ئی ا و س کی تعریف سا منے لکھی ہوئی ہے ا س کے مطابق ا ٓت  کا یکچر  ہو گا ۔ ہم 

   P3  ،4نوعیت کے پی سیز، مختلف

 

ر
م

 

شی
س

  کے ی ا ئی ا و س مختلف ا و ر  ج ڈ ی ڈ  ترین 

 

 ر

 

ڈ

 

ز ا ی
پ 

 یوا 

 

ل کریں گے ا و ر  کسی د
ی ک

 

ی کی

ا  سیکھیں Detectکو  ئسپر پر

 

 پلگ کری

 

  گے۔ا و ر  ا ن

 یوا ا و ہ پہلا س و سی ا ئی ا 

 

 ر  د
ہ
ر  ی ا  پرو گرا م ہے جس نے کمپیوٹر میں لگی 

 

ی ی
 کو یہ ئسٹ  و 

ا  ہے کہ ا ٓگے چل کر ا س نے کیا کام 

 

ا  ہے۔تو سمجھ لیں یہ تنا  ا ہم ہے۔کیسےبتای

 

 کری

کمپیوٹر میں بہت سا ر ے مسائل صرف ی ا ئی ا و س کی سیٹنگ سے حل ہو جاتے ہیں 

 و ر  ا س کو سمجھیں۔ا س لیے ا س پر خاص توجہ د یں ا 
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LECTURE – 16 
 

Introduction to SET UP or BIOS of computer. 
Using Dell P2, Non Branded P3,P4 and Dual Core. 

 

LECTURE – 17 
Concept of Software 

Software is a single collection of programs that performs a particular task. 
System software and application software are two main components of software. 
Do you remember that a set of instruction is called program, so a set of program can be 
software (that is system & application).  
 
Types of software: 
System software: 
System software used to control, monitor or facilitate the use of the computer.  
Example of system software is OS. 
 
Introduction to Operating System (OS) 
An operating system is system software that provides an interface for the user to communicate 
with the computer in well defines manner. And to find suitable solutions. The purpose of the OS 
is to organize and control hardware and software in a link. 
Types of OS are 
Command Line OS i.e. DOS 
GUI (Graphical User Interface) OS i.e. Windows 
 
Command Line OS i.e. DOS 
Introduction to MS DOS. 
Dos (Disc Operating System): 
Dos is a ready made program that is used to operate the computer, it is also used for handling 
hard disc & other data storage devices. 
It is also called command prompt, because in this we operate with specific commands. 
 
DOS files are BATCH files, command files & executable files. These are identifying by their 
extensions which are .bat, .com, .exe. Respectively 
1. Batch Files: 
One are more commands are grouped together. The name of the batch file acts as a command 
for the DOS. When the name of fils is given to DOS on command prompt the command written 
in the batch file are executed sequentially without involving user to type every command on 
command prompt. 
2. Executable Files: 
These are ready to run on the computer. These files contain instructions in machine language. 
3. Command Files:  
contain DOS commands. 
 
There are two types of commands used in dos. 
1. Internal commands.    
2. External commands. 
Infernal commands:  
The internal commands are loaded into memory when Dos is loaded these are available only 
sometime. And used with in command .com program only. The prompt of “command .com” is 
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“C>” some commands are time, ver, dir, exit, date etc. 
Command .com is specific directory which exist in the program. In which we can add or delete 
commands.  
 
External commands:  
Are used for handling hard disk and other data storage devices. These are some fixed 
commands some of them can not be used in internal commands (tell that can not be included in 
the command .com) the prompt of these commands is c :\> and some commands are format, 
CHKDSK, path, DELTREE, XCOP etc. 

LECTURE – 18 
Working in Ms. Dos (Using Commands) 

  

  

  

  

  

  

  

  

 

  و ئیر میں یہ بہت ا ہم

 

 ہیں  لیکن ہار د

 

 ا س کی ا ت  ا فٓس و ر ک ی ا  کسی ا و ر  حوا لے سے تو کوئی خاص ضرو ر ت

 

 ل شوٹنگ  ا یم ا یس د
ی
ہے ا و ر  کسی بھی کمپیوٹر میں ٹر

ا  ضرو ر ی ہے۔

 

  کا ا ٓی

 

 ر

 

ڈ

 

 ا س کی کچھ مخصوص کمای

 

 کے حوا لے سے ا تٓ  کو د

 کی پریکٹس کریں ا و ر  ا س کو سمجھیں۔

 

  سا منے د ی ہوئی ہیں ا ن

 

 ر

 

ڈ

 

 کچھ کمای

 کی  پریکٹس کر یں ۔

 

  لکھی گئی ہیں ا ن

 

 ر

 

ڈ

 

 نیچے بہت سا ر ی کمای

In DOS secondary storage of the computer are logical drives and each is recognized by letter 
followed by a colon. i.e. 
A: for floppy drive B: Zip drive (not used  
 C: Drive and similarly D:, E: , F: so one up to CD ROM drive. 
 (About making these drives we will learn next) using DOS and Win XP. 
 
Using current OS: 
Go to run & type command. 
C:\> 
Using Commands: 
CD: 
C:\> CD.. (This command used to change the working directory) 
C:\>PICS~1\user>CD.. 
C:\>PICS> 
MD: (Make directory) 
Is used to make a directory of folder in a specific drive 
C:\>md Prime 
RD:(remove directory): 
C:\>rd PICS 
DIR: show directory 
Used to display a list of files and subdirectories that are in the specific drive. 
C:\>DIR 



132 

 
Using Wild Cards with DIR: 
When we want to search for some specific files we use wild cards or this purpose. That is * 
and?. 
* is used to denote any number of characters. 
? is used to denote exactly one missing character. 
C:\> dir PI*.dat 
This will show all files having names starting with the character PI and then extension .DAT. 
C:\>dir ??X*.* 
In short 
When we forget the name or spelling of our file then we use wild cards to find it two types of wild 
cards are 
* Asteris &? Question Mark 
 
 
There are three methods of loading Ms DOS. 
Using current OS: 
Booting with CD ROM: 
Using F8 Command in booting 
Lec-19 
Adding switches with DIR 
C>dir/s/p 
Ctrl + c to end current action.  
Alt +enter maximize program 
ClS clear screen 
Exit close dos 
Dir/p: shows files & directories page wise 
Dir/w: shows files & directories Width wise 
Dir/l: shows files & directories in a lower case 
Dir/B: shows files & directories in a bare format 
Dir/s: searches files & directories 
F3: undo in DOS 
 
“O” switches for ascending & descending orders 
Dir/ON: shows files & directories in ascending order 
Dir/o-n: show dir in descending order of file & dir name 
Dir/OE: show dir in ascending order of file extensions 
Dir/O-E: show dir in Descending order of file extension 
Dir/Os: show dir in ascending order of file size 
Dir/O-S: show dir in descending order of file size 
Dir/OD: show dir in ascending order of date & time 
Dir/O-D: show dir in descending order of date & Time 
Dir/OG: show sub dir before files 
Dir/o-G: show sub dir after files 
 
Attributes switches 
Dir/AD: show only directory names & show hiding directories 
Dir/A-d: show all files only other than sub dir & show hiding files 
Dir/Ar: read only files 
Dir/a-r: other than read only files 
Dir/Ah: hidden files(enter) 
Dir/a-h: other than hidden files 
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Dir/As: system files 
Dir/a-s: other than system files 
C:\>tree shows the files in a tree diagram 
C :> path 
Del to delete a file or dir 
C:\>del a.bat 
Copy is used to copy files from one place to another 
C :> copy Prime.doc C:\Prime.doc 
DISKCOPY is used to copy one disk to another. 
A :> disk copy a: a: 
C:\chkdsk this command is used to check your hard drive. 
Making file in dos. 
C:\chkdsk/f: fix problem in a current drive. 
C:\scandisk 
C:\ edit 
D: go to second drive 
Save file ALT+FS 
Exit ALT+FX 
 
Tree: structure of directory 
C:\>tree 
Prompt: Used to make prompt like this 
C:\>prompt 
PICS:\> then 
Type prompt PICS 
PICS: prompt $p$g 
 
Copy commands: 
From C to A 
C:\> copy . A: (enter) 
Form A to C 
A:\>copy . C: (enter) 
Or 
C:\copy PICS.DOC A: (enter) 
 
Deleting files from drives 
From A 
A:\>Del PICS.DOC (enter)  Ie 
Any file extension doc, presentation etc. 
 
Format: use to create a new boot directory and file allocation table for the disk, it also check bad 
areas on the disk. This command will delete all the previous data from your drive. So be careful 
with using this command. 
C:\>Foramt A: 
FDISK: 
Use for partition procedure using WIN 98. 
C:\> FDISK: 
SCAN DISK: 
For clearing bad sectors from your HDD 
C:\>scandisk. 

LECTURE – 20 
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Test 

LECTURE – 21 
Complete Procedure of installing OS 98 

  

 

 و ر

 

ڈ

 

ا ل کر ر ہے ہیں حالانکہ ا س کا د و ر  بہت عرصہ پہلے ختم ہو چکا  31ہم و ی

 

شپ

 

ن
 ہے ا و ر  ا ت  ہ ا ٓفس ا و ر  ہ ہی گھریلو ا ستعمال میں ہے۔کیون ا 

  

 

 و ر

 

ڈ

 

 یہ ہے کہ و ی

 

 ا س بیس س 31ا صل ی ا ت

 

  و ئیر ا ا ی ک مکمل د

 

 ا س بیس ہے۔ ا و ر  کسی بھی ہار د

 

 می ا و ر  بنیاد ی طریقہ کار  د

 

ا لیشن، کا لار

 

شپ

 

ن
ر  ہے یعنی ا س کی ا 

 

ی ی
ٹ  و 

 ی ا د ہ ا ٓپشن ہونے چا

 

نجاننے و ا لے کے ی ا س ا ی ک سے ر
 
 ہی
ہ

 ا ی ک ہیں  تو د و سرا ۔  

 ا س ہی کرے گا ۔ ی ا قی کوئی وفٹ  و ئیر ہیں ۔

 

 میں ہم ا تنا پھنس جائیں گے تو ا ٓت  د یکھیں کےہمار ی مدد  صرف د

 

 ا و ر  بعض معاملا ت

 

لاہ و ہ ا ی ک ی ا ت
ا س کے ع

  

 

 و ر

 

ڈ

 

  و ئیر ہیں  جانتے ۔ 31مشہور  ہے کہ جو لوگ و ی

 

ا  ہیں  جاتنے و ہ کمپیوٹر ہار د

 

 کری

Main Steps of installing OS win98 

1. Booting with CD Rom 
2. Loading Ms Dos 
3. Making Partitions.(if needed) 
4. Copying 98’s files in hard drive )Backup) 
5. Starting setup of win98 

 

To start we begin with step 1 
1. Booting with CD Rom 

Insert win98 CD in your CD ROM 
Go to set up of your computer and change your boot device i.e. your first boot device must be 
CD ROM. Save your changes. 
And restart your computer or Press CTRL+ALT+DEL. 

2. Loading Ms DOS: 
There will be two options  

1. Boot from hard disc 
2. Boot from CD ROM 

Enter choice 2. 
Again there will be three options 
1. Start win98 setup from CD ROM 
2. Start win98 setup with CD ROM  
3. Start win98 setup without CD ROM  

 
Choose the 2nd one start computer with CD ROM supprot in order to go in partition 
procedure a fresh win. 
When PCI bus scan completed 
 
The prompt will appear A :\> 
A:\ 
Step 4 of installing OS 98: 
4. Partition Procedure 

ل ہے ا س کو ہم پرفار م کریں گے
ی ک

 

ی کی

ا  ل کرتے ہیں ۔ ا س کا سا ر  ا  کام پر

 

شپ

 

ن
  ا 

 

  و ر

 

ڈ

 

 کو فالو کرتے ہوئے ہم و ی

 

 ۔ا و پر د یے ہوئے تمام ا قدا مات

 کو فالو 

 

ا  ہے۔ا ی ک ا ی ک سٹیپ لکھ د ی ا  گیا ہے ، ا س لیے ا ن

 

 کری
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 ی ا نچ ہیں جو لکھے گے ہیں ا گٓے ہم ا نہی کو لیتے ہوئے چلیں گے ۔

 

 ا و پر میں ا قدا مات

Win 98 total space=300 MB 
Win Xp=1.59 GB 
Win Visita=4GB + 
Seven original=10GB+ 
 
Hard Disk Partition Table: 
(20 GB)(for XP) 
C=5050MB(6GB) 
(40GB) (for XP) 
C=6000 or 8000GB 
(80GB) (for XP) 
C= 10000MB to 15000MB(15GB) 
 
 

 می سٹیپ کی ، و ہ ہے 

 

 ا ٓ گئی بہت لار

 

:ی ا ر ٹیشن ا ت  ی ا ت  

ا  سے مرا  د  

 

 سک کے مختلف حصے بنای

 

  د

 

ہے ہار د  

ا  شرو ع کرتے ہیں ح ت  ا ٓت  ا س مرحلے پر ا ٓئیں گے تو ا ٓت  نے کچھ فیصلے کرنے ہوتے

 

ا ل کری

 

شپ

 

ن
  ا 

 

 و ر

 

ڈ

 

 کیا ا ٓت  و ی

 

ر ص
ف

  ہیں و ہ یہ ہیں۔

 سک

 

  د

 

 کتنی ہے ۔ Total Storage Capictyکی  ا ٓت  کی ہار د

ا  ہیں۔

 

  یعنی حصے بنای

 

 ر ا یور

 

 ا ٓت  نے ا س کی کتنی د

 سک 

 

  د

 

 کیا ا ٓت  کے کمپیوٹر کی ہار د

 

ر ص
ف
 بتا د و ن بعض لوگ یہ   20GBتو 

 

ت  بنانی ہے۔ ہاںن پر ا ہم ی ا ت
 ر ا یو مناس

 

 ر ا یو یعنی پرا ئمری د

 

ہے تو ا تٓ  نے ا س کی سی د

 ر ا یو جس کی بنا  یعنی Cکرتے ہیں کہ 

 

 ی ا د ء ا ٓت  کی پرا ئمری د

 

ہیں   ہپر ا ٓت  کا پور ا  ا پٓریٹنگ سٹم چلے گا ا س کو کم سے کم سٹور یج سپیس د یتے ہیں ۔ تو ا ٓت  نے بہت ر

 سا  ت   ا ی ک مناس لیکن

 

پ
  ضرو ر  د ینا ہے ہاںن پر میں 

 

  تنا  سپیسا و پر  ز

 

 و ر

 

ڈ

 

ن بھی کہ کونسی و ی

 ش
پ ی
س

  کا 

 

 و ر

 

ڈ

 

لے گی ا و ر  ا س کے  ا ی ک ٹیبل د ے ر ہا ہون ا و ر  سا تھ و ی

 مطابق ا تٓ  ا س کی ی ا ر ٹیشن بنائیں۔

  کے لیے ی ا ر ٹیشن سپیس بھی بتا  نے  ا س کے علاو ہ میں

 

ز
سک
 

 

  د

 

د یے ہیں ۔ا تٓ  کو مختلف ہار د  

 کے مطابق تیار  کر

 

  کو ا ٓت  ا پنی ضرو ر ت

 

 ر ا یور

 

 کر ر ہا ہون ی ا قی د

 

ن

 

ش

 

پ ی
م

 ر ا یو کو 

 

یں گے۔میں ا س میں سی د  

 

LECTURE – 22 
Deleting/ Creating Partitions (if needed) 

D:\>cd win98 
Ds win98:\ >FDISK  
There will be 4 choices i.e. 
1. Create DOS partitions or logical 

dos drive. 
2. Set active partition. 
3. Delete partition or logical dos 

drive. 
4. Partitions information(total space) 

  

 

 و ر

 

ڈ

 

 ا س ا و ر  و ی

 

ا  د یکھتے ہیں۔ 31ا ت  ہم د

 

 یلیٹ کری

 

سا منے و ا لی کی مدد  سے ی ا ر ٹیشن د

  لکھیں جو

 

 ر

 

ڈ

 

 میں ا سی ترتیب سے کمای

 

 سا منے موجود  ہیں ۔ پرا مت

 ا س کو فالو کریںا س کا طریقہ کار  سا منے موجود   ہے۔

 میں ا ٓت  کو معلوم ہی ہے کہ 

 

ا  کیونکہ ا ن

 

 یلیٹ ہیں  کری

 

 ر  د عہ  ی ا ر ٹیشنز د
ہ
چونکہ ہمیں 

 ر یو کو فار میٹ 

 

 یٹا پڑا  ہوا  ہے ۔ ا س لیے بعض صور تون میں ہم صرف سی د

 

ا ٓت  کا سا ر ا  د

  کر د یتے ہیں

 

 و ر

 

ڈ

 

  میں کچھ تبدیلی ہیں  ہوتی ۔کرتے ہیں ا و ر  نیو و ی

 

 ر ا یور

 

  ی ا قی د
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To delete partitions enter choice 3. 
 
There will be four options. 
1. Delete primary dos partition 
2. Delete extended dos partition. 
3. Delete logical dos partition. 
4. Delete none Partitions system 
At first you have to delete extended 
Dos partition. And than the primary 
one. 
So enter choice 2 
And if you have only one drive i.e. no 
partitions then you have to enter 
choice 1. 

 
Creating partitions  
Now for creating partition enter choice 
1 of first menu. 
There will be three options 
1 Create primary dos partition 
2. Create secondary dos partition 
3. Create logical drive space. 
Enter choice1 
Create partition according to your disc 
space I.e.2.50GB (total 6 GB) 
After making drive C then than make this 
drive active. Press esc and return to first 
menu and enter choice 2.than enter 
choice 2. 
After this you can make the secondary 
drive D, E, F……….. 
Enter choice after making partitions you 
have to restart you machine press 
CTRL+ALT+DEL. 

 

 

ا  ہے یعنی  31ی ا د  ر کھیں 

 

ا  ہوی

 

 نے کے لیے نیچے سے ا و پر کام کری

 

  میں ی ا ر ٹیشنز تور

 

 و ر

 

ڈ

 

و ی

ا  ہے ۔ا س کے علاہ ا یسی Extendedپھر  logicalپہلے 

 

 ی

 

  تور

 

 ر ا یور

 

ا و ر  پھر پرا ئمری د

عقلہ ہے تو ا س کو  XPی ا ر ٹیشن جو 

 

می
 نے کے لیے ی ا  کسی د و سرے فائل سٹم سے 

 

تور

 ا خٓری ا ٓپشن یعنی 

Delete none Dos Partition  ر ا یو کو 

 

لا ا گر ا ٓت  نے کسی د

 

میں XPلینا ہے ۔مپ

  ر ہے ہیں ا و ر  ا س کا فائل سٹم  31بنا ی ا  تھا ا ت  ا ٓت  ا س کو 

 

ہے تو ا ٓت   NTFSمیں تور

  ا گر ا ٓت  کو 

 

 ر ا یور

 

ا  ہے ۔ ا س کے علاو ہ بعض د

 

  کری

 

 میں تنگ کر ر ہی XPنے یہ ا ٓپشن یور

 نیلی سی سکرین د ے 

 

ہیں ی ا  ہیں  بن ر ہی ، فار میٹ ہیں  ہو ر ہی ی ا  بنانے کے د و ر ا ن

 کو 

 

 کے لیے ہم  31د یتی ہیں تو بھی ا ن

 

 پ ک کریں ی ا  پھر ا ن
ح
لیں گے جو ا ٓگے  DMمیں 

 ہو گا ۔

 

 بیان

ا  ہے پہلے پرا ئمری ، پھر 

 

پھر  Extendedی ا ر ٹیشن بنانے کے لیے ا و پر سے نیچے ا ٓی

logical ا  ہے

 

 ر ا یو کو  بنا ی

 

ی یعنی سی د

 ہل
ن

ا  ہ بھولیں ۔جو پہلے ا پٓشنز میں  Activeا و ر  

 

کری

 پر ا کٓر ا ٓت  نے ضرو ر   31موجود  ہے ۔ی ا ر ٹیشنز 

 

ن

 

 ش
کی

میں بنانے کے بعد ا ی ک خاص لو

Restart ا  ہے ۔

 

 کری

 
LECTURE – 23 

Copying and Starting Setup of Windows 98 

After partitions you have to format your local drive C 
A:\>E: 
E:\ CD win98> 
E :\> win98 :\> format c: 
E :\> win98 :\> format D: 
Then go to C drive or other where you have to install an OS 
And make a directory 
C:\>md win98 
Then check it type 
C:\>dir 
Then go to CD ROM drive again 
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C:\>E: 
E:\ win98> 
Now you have to copy all the files in your c drive or where you have made a directory 
E:\>copy win98 C:\win98 or 
E:\win98>copy *.* c:\win98 
All the files will be copy in your drive 
Then go to c drive 
E:\>C: 
C:\>setup 
 
This will start your win98 s’ setup: then you have to respond as the OS required. 

 
Now you have to wait while windows install in your system. 

  ا ٓپنے بیک  ا گر

 

  ر

 

ڈ

 

لای ا  جا سکتا ہے ا س کے لیے ا ٓت  نے ا و پر سے د و  تین کمای
 ا ت  ج 

 

  کا سی ت

 

 و ر

 

ڈ

 

 ی سے بھی و ی

 

ا  ہیں ۔  skipا ت  ہیں  بنای ا  تو سی د

 

 کری

 

LECTURE – 24 
Installing Operating System Windows XP 

Before installing xp in your pc your system must have this capability i.e. 
Processor of 400+….. And 96+….. MB RAM.  
Making Partitions (If needed) 
After some process your system asks you this type of question. 
To install win in your system press Enter. 
You must press Enter. 
Then the partition process will start. Now do the same things as the system requires. 
Installing new device (VGA, Modem, Capture Card etc.) in system. 
(Installing drivers) & detecting double IDE or CD ROM/writer. 

ا  ۔یہ 

 

ا ل کری

 

شپ

 

ن
  ا یکس پی ا 

 

 و ر

 

ڈ

 

 کو فالو کریں۔ 31ا ت  ہم د یکھتے ہیں و ی

 

 سا منے د ی گئی ہیں ا ن

 

 ہے۔ا س کے لیے کچھ ہدا ی ا ت

 

 ہے ا س کو سمجھنا نسبتاً ا ٓسا ن

 

 سے ا ٓسا ن

 ہے۔ا صل میں ا س میں سا ر ے ا پٓشنز سا منے ا س میں ی ا ر ٹیشنز و غیرہ کا سا ر ا  طریقہ کار  

 

 ا ٓسا ن

 

 ٹ
پ
لا۔نہا

 

 لکھے ہوئے ا تٓے ہیں ۔ مپ

 و  

 

ڈ

 

 کرو ا ئیں ۔ ا و ر  و ی

 

 ی ر و م سے بوت

 

 میں ا ٓت  XPا سی طرج کمپیوٹر کو سی د

 

 ہونے کی صور ت

 

 ی ر ا م د ر ست

 

 ی، سی د

 

 کریں سی د

 

 ا ل د یں ر ی سٹار ت

 

 ی د

 

کی سی د

 کے سا منے یہ ا ٓپشن ا ٓ ئے گا ۔

Press any key to start from CD/DVD…. ا  ہے بس س

 

 ا پٓنے ا نٹر کر ی

 

ا  ہے ا س د و ر ا ن

 

 ا ت  شرو ع ا ٓگے سا ر ا  کام سکرین کو فالو کرتے ہوئے کری

 

 ی ت

ا  ہے تو 

 

 ی

 

 ر ا یو کو تور

 

ٹ  بھی ست  کچھ سا منے لکھا ہوا  ملے گا ۔ ا ٓت  نے کسی د

 

پ
ت  ی ا ر ٹیشنز کی ی ا ر  ی ا ٓئے گی 

  یعنی  Dح 

 

ڈ

 

 تے  Dکریں پھر ا سی ترتیب میں ا سی کمای

 

سے تور

 جائیں ۔

 سک کو مد آت ر کھتے ہوئے ی ا ر ٹیشنز بنائیں ۔پھر ا س میں فار میٹنگ کے لیے کریں  Cی ا ر ٹیشنز بنانے کے لیے لکھا ہے کہ 

 

  د

 

 & FATا سی طرج سپیس ا و ر  ہار د

NTFS (QUICK & STRONG)  کریں ا لبتہ  

 

 ہیں جو  NTFSکوئی بھی ا ٓپشن یو ر

 

 ر  ہے ہیں  ہیں  FATکو ترجیح د یں چونکہ ا س میں کچھ خصوصیا ت
ہ
ا 

 

میں ط

  جو سا منے لکھی

 

ر

 

س
ک

 ہو گا ۔ ۔ا س کے بعد ا نسٹر

 

لائیں ا س کے بعد ا ٓت  کا کمپیوٹر خود  بخود  ر ی سٹار ت
 ا ٓت  ا ٓگے ج 

 

  ا تٓی ہیں فالو کرتے ہوئے سی ت

 ا ت  ا ٓگے چلے گا ۔ تقریبا ح ت  Press any key to start from CDا لبتہ پھر و ہی ا پٓشن کہ 

 

  بخود  سی ت

 

ا  ۔ خود

 

نٹ   33ا ٓئے گا ا ت  ا پنے کچھ بھی ہیں   کری

ا ل ہو گی ا و ر  ا ٓت  کار ہتے ہون گے تو ا ٓت  

 

شپ

 

ن
 و  ا 

 

ڈ

 

 مانگے گا جو ا ٓت  نے و ہان د ینی ہیں ۔ کیز و غیرہ بھی ۔ ا س کے بعد خود  بخود  کمپیوٹر میں و ی

 

کمپیوٹر  سے کچھ معلومات

 ہو گا ۔ تقریباً 

 

 ا ت  د و ی ا ر ہ چلے گا ۔ 16ر ی سٹار ت

 

 میں صرف سی ت

 

ے ہیں ۔ بجلی جانے کی  صور ت

 

سکی
 ی نکال 

 

 نٹ  ر ہتے ہون تو ا ٓت  سی د
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LECTURE - 25 

Installing os winxp 
(when system has suffered from virus) 

ا ل کرنے کی مختلف نوعیتیں د یکھیں گے۔ ست  سے ا ہم ہے کہ ح ت  ا تٓ  کے کمپیوٹر میں

 

شپ

 

ن
  کو ا 

 

 و ر

 

ڈ

 

ا  ا ٓت  سیکھ چکے ہیں ا ت  ہم و ی

 

ا ل کری

 

شپ

 

ن
  ا 

 

 و ر

 

ڈ

 

ز س ا ٓ جائے گا و ی

 

پ
 و ا 

ا  ہے

 

 ا س کا طریقہ کار  ا ٓت  سیکھیں گے۔ تو پھر ا ٓت  نے کمپیوٹر کیسے ہینڈل کری

ز س ا ٓ گیا تو ا س کو ا ت  ہینڈل کیسے

 

پ
 یٹا بھی ا و ر  یہ بہت ا ہم چیز ہے جو کور س ہی میں سیکھ ی ا ئیں گے ۔ ا ی ک خاص طریقہ کار  ہے کہ ح ت  کمپیوٹر میں و ا 

 

 کریں ۔ چونکہ د

ے ۔و غیرہ۔

 

سکی
  بھی ہیں  

 

  تور

 

 ر ا یور

 

ا  ہے د

 

 ضرو ر ی ہے ا س کو بھی بچای

LECTURE - 26 

Installing OS using Ghost 

  میں یہ بہت کام کا ۔ا س میں ا ُٓٓت  ا ی ک خاص ٹیکنیک سیکھیں گے جس کی مدد  سے ا تٓ  ا پنا ا پٓریٹنگ سٹم بہت جلدی ر ی کور  کر لیں گے

 

 ر
پ ی
ل

ا س کے علاہ ا فٓس ا و ر  

 س ٹرت  ہ ہو۔ 

 

ی و ا لی سیٹنگ و ا پس لے لیں ا و ر  کام د

 ہل
ن

  جلد ا پنی 

 

ا کہ ا ٓت  جلد ا ر

 

 ٹول ہے ی

 
Practice 

LECTURE - 27 
Data Recovery Using Software & HDD Tools 

  د ی ی ا  فا

 

 یٹا ر ی کور  کریں گے۔ چاہے ا ٓت  نے ی ا ر ٹیشن تود

 

کیہ بھی ا ی ک ا ہم ٹیکنیک ہے جس کی مدد  سے ا تٓ  کھوی ا  ہوا  د

 

 یٹا کافی حد ی

 

 ر میٹ کر د ی پھر بھی ا ٓت  کا د

ا س کے علاہ یو ا یس بی سے بھی ر ی کور  کریں گے۔ ر ی کور  ہو سکتا ہے ۔   

ا  ، ی ا ر ٹیشن کے مسائل

 

  کو ٹھیک کری

 

 ی ا یم کی مدد  سے ہار د

 

 ی ڈ  چیزیں د یکھیں گے جس میں د

 

ر
ک
ا ، ی ا ر ٹیشن ینیجر  کا ا ستعمال و غیرہ۔ جوکو ا س کے بعد ا ٓت  کچھ 

 

 حل کری

 سک کی خرا بیون کی نوعیت ہے جس کو ہمہے  د لچسپبہت 

 

  د

 

ک ہینڈل کر ا س کے علاہ ہار د

 

 ی ا یم کی مد د  سے کافی حد ی

 

ے ہیں ۔ د

 

سکی
  

 
LECTURE - 28 

Test 

 

LECTURE - 29 
Computer Virusand Anti virus 

ز س 

 

پ
  کو 1312ی ا   1313کچھ کتابون میں یہ لکھا گیا ہے کہ پہلا و ا 

 

ر د
ف
پ کہ  تفصیل کے علاو ہ ا ٓت  کو یہ ا سنےبنای ا ۔(Fred Cohen)ئنمیں 

گ
 :بھی ملے 

“In the mid-1980s two brothers in Pakistan discovered that people were pirating their software. 
They responded by writing the first computer virus, a program that would put a copy of itself and 
a copyright message on any floppy disk copies their customers made. From these simple 
beginnings, an entire virus counter-culture has emerged.Today new viruses sweep the planet in 
minutes and can corrupt data, slowNetworks down, or harm your reputation.” 

 د ی جار ہی ہیں ا س سے 

 

ز س سے تعلق  بہت سا ر ی معلومات

 

پ
  Syllabusنیچے ا ٓت  کو و ا 

 

 کو ضرو ر  پڑیں  ۔معلومات

 

ے ہیں ا ن

 

سکی
و ا لے لو گ بہت فائدہ ا ٹھا 

ا  چاہیے ۔

 

ز س کا پتہ ہوی

 

پ
 ر  کو و ا 

 

 ر  یور
ہ
 کے لیے 
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What is a virus? 
"A virus or worm is a computer program 
that can spread across computers and 
networks by making copies of itself, 
usually without the user’s knowledge. 
Viruses can have harmful effects. These 
can range from displaying irritating 
messages to stealing data or giving other 
users control over your computer." 

Or 
“A virus is a program (software) that 
attaches itself with other executable files 
by modifying them so that the virus is 
also loaded and executed with the 
execution of these programs. Virus has 
this ability that makes copies of similar 
forms.” 
 

 
How does a virus infect computers? 
A virus program has to be run before it can infect 
your computer. Viruses have ways of making sure 
that this happens. They can attach themselves to 
other programs or hide in code that is run 
automatically when you open certain types of file. 
Sometimes they can exploit security flaws in your 
computer’s operating system to run and to spread 
them automatically. You might receive an infected 
file in an email attachment, in a download from the 
internet, or on a disk. As soon as the file is 
launched, the virus code runs. Then the virus can 
copy itself to other files 

 
There are five recognized types of viruses: 
File infector viruses: 
File infector viruses infect program files. These virusesnormally infect executable code, such as 
.com and .exe files. The can infect other files when an infected program is run from floppy, hard 
drive, or from the network. Many of these viruses are memory resident.  
After memory becomes infected, any non-infected executable that runs becomes infected.  
Examples of known file infector viruses include Jerusalem and Cascade.  
Master boot record viruses:  
Master boot record viruses are memory resident viruses that infect disks in the same manner as 
boot sector viruses. The difference between these two virus types is where the viral code is 
located. Master boot record infectors normally save a legitimate copy of the master boot record 
in an different location. 
Macro viruses:  
These types of viruses infect data files. They are the most common and have cost corporations 
the most money and time trying to repair. With the advent of Visual Basic in Microsoft's Office 
97, a macro virus can be written that not only infects data files, but also can infect other files as 
well. Macro viruses infect Microsoft Office Word, Excel, PowerPoint and Access files. Newer 
strains are now turning up in other programs as well. All of these viruses use another program's 
internal programming language, which was created to allow users to automate certain tasks 
within that program. Because of the ease with which these viruses can be created, there are 
now thousands of them in circulation.  
Examples of macro viruses include W97M.Melissa, WM. NiceDay and 97M.Groov. 
Boot sector viruses:  
Boot sector viruses infect the system area of a disk--that is, the boot record on floppy disks and 
hard disks. All floppy disks and hard disks (including disks containing only data) contain a small 
program in the boot record that is run when the computer starts up. Boot sector viruses attach 
themselves to this part of the disk and activate when the user attempts to start up from the 
infected disk. These viruses are always memory resident in nature. 
Multi-partite viruses:  
Multi-partite (also known as polypeptide) viruses infect both boot records and program files. 
These are particularly difficult to repair. If the boot area is cleaned, but the files are not, the boot 
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area will be reinvested. The same holds true for cleaning infected files. If the virus is not 
removed from the boot area, any files that you have cleaned will be reinvested.  
Examples of multi-partite viruses include One Half, Emperor, Anthrax and Tequila 

What can viruses do? 
Slow down email.  
Steal confidential data. 
Use your computer to attack websites. 
Let other users hijack your computer.  
Corrupt data. 
Delete data.  
Disable hardware.  
Play pranks. 
Display messages.  
Damage your credibility. 
Cause you embarrassment. 
Where are the virus risks? 
CDs and floppies 
Programs and documents 
Email 
The internet 
Networks 
Removable Storage 
Un Registered software etc. 

LECTURE - 30 
Anti-virus software 

Anti-virus software can detect viruses, 
prevent access to infected files and often 
eliminate the infection. 
The program which is used to clean & 
Delete the viruses is called anti virus 
program in computer  

 

 ر  سے کوئی کام ہی ہ کریں ۔ 

 

ز  س کے د

 

پ
 ر  گز یہ مطلب ہیں  کہ ہم و ا 

ہ
ا ت  ا س کا 

ا  ا و ر  بعد  ہمار ے ی ا س ا س کا حل

 

ا ل کری

 

شپ

 

ن
 موجود  ہے و ہ ہے ا پٓریٹنگ سٹم پرا پرلی ا 

 ر کھنا بھی بہت ضرو ر ی 

 

 ٹ
پ
 

 

ا  ا و ر  ا س کو ا ت  د

 

ا ل کری

 

شپ

 

ن
ز س بھی پرا پرلی ا 

 

پ
میں ا ینٹی و ا 

 ہے ۔یہ طریقہ کار  ا ٓت  نےکلاس میں سیکھا ہے ا سی کے مطابق ہینڈل کریں۔

 

LECTURE - 31 
 

Preventing viruses 
How we can protect? 
 

 Make users aware of the risks 

 Install anti-virus software and update it regularly 

 Use software patches to close security loopholes 

 Use firewalls 

 Keep backups of all your data 
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LECTURE –32 

Tips about VIRUS Attack: 
Virus Signs: 

 
1. Drives are auto play: 
Serious virus attack, reinstall your OS 
properly scanned your drives then, go to 
tools menu show hidden files & folders & 
delete the auto run file in your every HDD 
drive. 
2. Low speed: 
There are many factors are there but be 
sure that this time is virus. 
3. Task manager progress: 
Many processes are running on without 
opening any applications. 
4. Hanging, low speed while restarting 
& shutting down. 
5. Hidden files & folders cannot be 
shown: 
6. “Application can not be run on win 
32 bit OS format "Message: 
7. MS DOS will not run more then 5 
mins. 
 
8. Task manger will not work, HDD 
light will be more often on. 
9. Your applications will not work also. 
10. System will take long time while 
logging on & off. 
11. After reinstalling OS some drives 
are not opening/formatting. 
Sol (11): Use Disk management to 
change your drive address otherwise use 
MS DOS mode to Format your current 
Drive. 
12. Program will automatically close. 
Sol: Open your HDD and detect it to 
another system in which upgrade 
antivirus is working well scanned it and 
return it to your system if your find some 
errors while booting then your OS will be 
corrupt Reinstall your OS properly.  

OR 
Reinstall your OS properly and use fresh 
up graded antivirus for scanning your 
HDD drives 

 مل سکتی ہیں۔ا ی ک ا و ر  

 

ز س ا ٓ جائے گا تو ا تٓ  کو یہ یہ علامات

 

پ
ح ت  ا ٓت  کے کمپیوٹر میں و ا 

 ل شوٹنگ میں تفصیل سے پڑیں  گے و ہ یہ کہ ہو سکتا ہے کہ کچھ 
ی
 جو ہم ٹر

 

ا ہم ی ا ت

 یوا یس میں ا ر یر

 

  و ئیر جاننے و ا لے مسائل کسی ا و ر  د

 

ر  کی و جہ سے ہون ا س لیے ہار د

 پ ک کرتے ہیں۔
ح
 ر  چیز کو 

ہ
  میں 

 

 ے محتاظ ا ندا ر

 

ز
پ 

 

 ۔سپیڈ سلو ہو جائے گی۔1

 ی د یر کے بعد خود  بند ہو 2

 

ا سک ینیجر  و ر ک ہیں  کرے گا ی ا  ا گر چلے گا تو تھور

 

۔ا ٓت  کا ی

ا سک ینیجر  چل ر ہا ہے تو ا ٓت  د یکھیں گے

 

 Idleکہ سٹم کا جائے گا۔ ا س کے علاو ہ ا گر ی

Process  46   ا  ہے۔ 36یہ   عام طور پر سے بھی کم ہو گا لیکن 56ی ا

 

 ی ا د ہ ہوی

 

یہ سے ر

و  س کا د ا ی ا ن کلک کرنے پر ا ٓئے 

 

ن
ا سک ی ا ر  پر ما

 

ا سک ینیجر  میں ملے گا  جو نیچے ی

 

ا ٓت  کو ی

 میں ی ا  تو یہ ا ٓپشن 

 

ز س ہونے کی صور ت

 

پ
 ہیں  ہوگا یہ  پھر کھلتے Highlightگا ۔بہت و ا 

 ہی  بند ہو جائے گا۔ 

ا ئم لگائے گا۔3

 

 ہونے میں بہت ی

 

 ۔پھر ا ٓت  کا کمپیوٹر بند ہونے ا و ر  سٹار ت

 پر 4

 

 فائل بنا د یتے ہیں ، ح ت  ا ٓت  ا ن

 

  میں ا ی ک ا ٹٓو ر ن

 

 ر ا یور

 

ز س ا ٓت  کی د

 

پ
۔ بعض و ا 

  ہون گی۔ ا س 

 

کلک کریں گے تو پہلا ا ٓپشن ا ٓٹو پلے ہو گا جس سے و ہ ی ا ر  ی ا ر    ا یگزی کیوت

 لے سے ھلے گی۔کے  علا

 

 تے د

 

 و  میں تھور

 

ڈ

 

 ر ا یو ا ی ک ا لگ و ی

 

 ر  د
ہ
 و ہ ا ٓت  کی 

  آت ہیں  ا ٓئیں گے ا گر ا ٓئیں گے  Hidden Files۔ ا و ل تو ا ٓت  کی تمام 5

 

ا و ر  فولڈر ر

  بھی بن چکے ہیں۔

 

 تو ا ٓت  د یکھیں کہ بہت سا ر ی غیر ضرو ر ی فائلز ا و ر  فولڈر ر

  خود  بخود  بھی بند ہو

 

ر
ک
ے ہیں۔ا س کے علاو ہ ا ٓت  کے کچھ پرو گرا 

 

سکی
 

 ر  گز کلک ہ 1
ہ
ا م سے فائل بھی بن سکتی ہے ا س پر 

 

  می کے ی

 

۔ا ٓت  کے کمپیوٹر میں ر ی ڈ

 ل کلک کم سے کم ا ستعمال کریں۔
ی
 

 

 میں د

 

ز س ہونے کی صور ت

 

پ
 کریں ۔و ا 

  بھی خود  بخود  لگ سکتا ہے ۔

 

لاہ ا ٓت  کے کمپیوٹر پر ی ا س و ر د
 ا س کے ع

 یٹا ضائع ہو سکتا ہے۔

 

 ۔۔۔And so onا ٓت  کا د

 بھی ہیں جن کو ا ٓت  کور س کے ا و پر 

 

 کے علاو ہ ا و ر  بہت سی علامات

 

 تمام ہدا ی ا ت

 

ئ

گ

د ی 

 سیکھیںد 

 

 کو ہینڈل بھی کریں گے ۔ ا س کا  و ر ا ن

 

ہم ا و پر لے چکے ہیں  حل گےا و ر  ہم ا ن

ز س ا نٓے کے بعد نیا ا پٓریٹنگ سٹم کیسے  نے  کہ ہم

 

پ
ا  ہے۔Properlyو ا 

 

ا ل کری

 

شپ

 

ن
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LECTURE –33 

Handling Troubleshooting 

 

  و 

 

  ہے ی ا  یون کہہ لیں کہ ا تٓ  نے جس و جہ سے ہار د

 

ے جا ر ہے ہیں و ہ ا ٓت  کے تما م کور س کا نچور

 

ھی
 کور س کیا ۔ا س سے پہلے ا ٓپنے کور س میں ئیرا ت  جو چیز ہم پڑ

 بہت کچھ سیکھا ا ت  ا س کی بنیاد  پر ا ٓت  ا پنے کمپیوٹر کے مسائل کو حل کریں گے۔

 کا ی ا  ا ٓت  کا ح ت  ا ٓت  کسی کمپیوٹر کے کو

 

ا  شرو ع کریں چاہے ا ٓت  کا ہو ی ا  د و ست

 

 یل ا مور  کا خیا ل ر کھیں۔ یہ ٹھیک کری

 

 د

 

 کار  و ی ا ر  ہے۔ د ر ج

 س پلے ہونے کی۱

 

سا  کمپیوٹر ہے ا گر و ہ ہیں  جانتا تو د

 

ن
 لیں کہ یہ کو

 

 ر  سے ا س کی معلومات

 

پ ک  ۔ ح ت  بھی کمپیوٹر لیں تو ا س سے پہلے ا س کے یور  
ح
 میں خود  

 

صور ت

 ا سکو بتا د یں۔کریں ا و ر  

 ر  سے پوچھیں کہ کیا ہوا  ہے کب ہوا  ہے ا و ر  کیسے ؟ ا س سے ا ٓت  کو مسلے کو حل کرنےمیں ا ٓسا نی۲

 

ملے گی۔یہ بہت  ۔ کمپیوٹر سے تعلقہ  مسلے کے ی ا ر ے میں یور

 ر  گز ہ بھولیں۔
ہ
 ضرو ر ی ا مر ہے ا س کو 

 ہن میں ا ی ک خاکہ تیار  کر۳

 

 ملنے پرا پنے د

 

ا  ہے و ہ یہ کہ پرا بلم کا ا ٓت  نے کہان  یں کہ۔ معلومات

 

ا  ہے ۔ یعنی ست  سے پہلا کام جو ا ٓت  نے کری

 

سے کام شرو ع کری

ا  بہت ضرو ر ی ہے۔

 

ا  توا  س سے پہلے مسلے کا پتہ ج لای

 

 کری

 

لاس

 

 حل ی

ت  کچھ ہ کھولیں ۔ بلکہ ا ٓپنے کور س کے حوا لے سے ی ا  ا پنے تجربہ میں ۴
 کریں ۔ ا ی ک ہی د عہ  س

 

 کوجو سیکھا ہے ا س ۔ ا س کے بعد حل کے لیے مر حلہ و ا ر  ا قدا مات

 ہن میں لاتے ہو

 

 ا س مسلے کے حل کے لیے ا ی ک ا ی ک  ئےد

 

 پ ک کریں ۔ئسیوا د
ح
  کو 

  و  ر کھیں ۔ ی ا د  ۵

 

 کم ہوتی ہے ا س لیے پور ی توجہ سے کام لیں ا و ر  ا س کو سرا نجام د یں ا ٓت  کی لطی  کی و جہ سے کمپیوٹر ہمیشہ کے  بہتئش میں لطی  کی نجائیرہار د

ا کار ہ ہو سکتا ہے۔

 

 لیے ی

 ر  گز ہ کریں ۶
ہ
 میں تجربے 

 

 ۔و غیرہ۔پرا بلم سمجھ ہ ا نٓے کی صور ت

 سے مسا

 

 کون

 

 ی ا د ہ ی ا ئلا ت  ہم پڑھتے ہیں کہ کون

 

 کو لیتے ہیں ی ا قی ا ٓت  خود   جاتے ہیں ۔ ئے کمپیوٹر میں ر

 

 می ا ن

 

ے ہیں لیکن ہم لار

 

سکی
ا س کے علاو ہ بھی بہت ہو 

 کریں گے۔

 

 ر ہ ا تٓ  کور س کے د و ر ا ن
ہ
 سیکھ گے۔ا س کا عملی مظا

 مہ د ا ر ی بھی 

 

ا  بہت ا ہم کام ہے ا و ر  ا ی ک د

 

  مسائل کو حل کری

 

ت

 

 ھ جائیں گے ۔ تو ست  سے پہلے مسئلے کی شناح

 

ز
پ 
 میں مسائل 

 

کریں پھر  کیونکہ لطی  کی صور  ت

 چھیڑیں ی ا  پھر ا پنے ٹیچر سے ی ا  کسی تجربہ کار   بندے سے ر ا بطہ کر لیں

 

  کو مت

 

ر

 

پ ی

 

ش
م

 کریں ۔ بغیر وفچے سمجھے 

 

 پھر ا س کے ا س کے لیے ترتیب سے ا قدا مات

 د ینا ہے ۔ Awarenessمطابق عمل کریں ۔یہ کتات  لکھنے کا مقصد بھی لوگون کو 

 میں 

 

ر  کے سا تھ نیچے جو بھی مسائل لکھے گے ہیں ا ن

 

کی
لکھا گیا ہے ا س کا مطلب یہ ہے کہ یہ مسئلہ کسی ا و ر و جہ سے بھی ہو سکتا ہے جو ہم ا گٓے  Optionalا 

 د یکھیں گے۔

Practical Work 
 
The first thing about handling troubles/problems in your computer you have initialize that what 
kind of problem computer has. And in my little concern this is the most important aspect of 
solving problems. 
Mainly there are two types of troubles can by find in the pc. 

 Error in OS (System software) or Application software. 

 Error in Hardware 
Also there are some problems about your application software but in this course we are talking 
about two main problems . 

Error in OS (software) 
1. Corrupt OS 
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 کا علق  جو 

 

 کی جا ر ہی ہیں ا ن

 

 بیان

 

 ھنا ہے ۔   Corrupt OSعلامات

 

ز
پ 
 میں ا ٓت  نے نیچے د یے ہوئے حل کی طرف 

 

 کی صور ت

 

 علامات

 

کے سا تھ ہے۔یعنی ا ن

  بعض علا

 

 کیا جائے گا ا سی لیے ا تٓ  کو بتا ی ا  گیا ہے کہ ہار   Optionalمات

 

  و ئیر کی و جہ سے بھی ہو سکتا ہے جو ا ٓگے بیان

 

  و ئیر ہیں یعنی ا س طرج کا پرا بلم بعض ہار د

 

د

ا  ہے ۔ ا س لیے ا ٓت  کو مکمل 

 

ا  ہوی

 

 ی سے پیچیدہ ہے کیونکہ ہمیں بہت سا ر ی چیزو ن کو مدآت ر کتھے ہوئے حل کری

 

عبور  حاصل ہو ا س کے لیے ا ٓت  کی فیلڈ تھور

 محنت ا و ر  مسلسل و ر ک د ر کار  ہے۔ 

Signs: 
1.  Low speed and send error reports or low speed while opening programs etc. 
2. NTLDR is missing message. (optional) 
3. Replace disk and press any key message. (Optional). 
4. Missing OS message. (optional) 
5. OS not found. (optional) 
6. Media test failure check cable and reboot message. (optional) 
7. Restarting at OS’s 1st start up screen again & again. (optional) 
8. Start windows normally message and restarting it again. (optional) 
9. Restarting at windows welcome screen. .(optional again) 
10. System 32/windows files missing error message. 
11. Windows media player is not working. 
12. Hanging again and again .(optional) 
13. System represent blue type screen after booting and restart it again. 
14. Application software is running very slowly. 
15. System cannot detects some devices automatically, and you to restart your PC for this 

special purpose again & again. 
16. Folder option is hide. 
17. Task manger is not working. 
18. Restarting system while working on heavy application. 
19. System represents file missing message while working on. 
20. Not showing hidden files & folders. Etc 

 
All these problems belong to corrupt OS, now the question is that Why the OS is corrupt? It is 
very difficult answer directly about all these. We will handle it one by one during our course. As a 
summary I can only say that some of these problems belong to VIRUS & some of others to your 
method of using computer& some of these belong to wrong handling to your OS or Hardware. 
Etc we will discuss it during Lecture. 
 
Arguments: 

1. These are some main signs of your corrupt OS and there are also many things that why 
your OS is corrupt? One thing is sure in these days is the Virus. Because virus can 
destroy your data and OS for sure. So always use the best and upgrade anti virus for 
protecting virus attack and longevity of your OS. 

2. The other thing about your corrupt OS is your attitudes toward your PC. i.e. how your 
handling your computer. Many people don’t have the right idea of switching off the PC. It 
must be on the spot. Otherwise you are about to corrupt your OS himself. 

3. Light factor is also there. Fluctuating light is harmful for your hardware and software 
both. 

4. Using harmful web sites on the internet is also dangerous for your OS. Because these 
are containing some Virus. 

5. Unregistered software also not good for your system software/OS. 
6. If your HDD is damage then your OS will not run any longer and speed will also be 

down. 
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7. Another thing that must be kept in mind that if your OS is running along nicely and you 

have installed a new software or Hardware then you find your OS giving these kind of 
messages “Start windows normally” every time while rebooting your computer. Then 
you’re not allowed to use current software/Hardware. Be remember that these are some 
other matters are also there for giving these kinds of messages that is turning off your 
computer while application is still going on. And light factor. 
 

We will discuss these in our lectures briefly. 
Solution: 
Decide about the right idea that what is factor of corrupting your OS. Then reinstall your OS and 
use the same method of installing your new OS that your have learned during course. 

 

LECTURE –34 

Error in Hardware 
 
1. Replace disk and press any key option: 
Sol. Check your data bus then HDD (is it connected or not) and then reboot your 
system other wise reinstall your OS also load BIOS defaults. 

 ر ا یو   یہ پیغام ا ٓت  کو 

 

  د

 

 کیا ہار د

 

ی ی ا ت

 ہل
ن

  ہیں ۔ 

 

 ہے ۔ یعنی ا ٓت    Detectبوٹنگ پرا سس میں ملے گا ۔ ا س میں بہت سا ر ے فیکٹرر

Setup  ا ل کر 

 

 ی د

 

  کی سی د

 

 و ر

 

ڈ

 

 یوا ئس بدلیں ا و ر  و ی

 

 د

 

  شو ہور  ہی ہے ۔ ا گر ا و  کے تو پھر ا ٓت  ا پنی بوت

 

  کو د یکھیں کہ کیا و ہان ہار د

 

 ا ت  ج لا د یں ۔ میں جا کر ہار د

 

 سی ت

  

 

ی ہیں کہ ٹھیک ہیں ی ا  ہیں  ا و  Detectا و ر  ا گر ہار د

 

ھی
ی ک

  د 

 

ز
 پ ل
کی

 یٹا 

 

 ر  ہے ا تٓ  نے سٹم کو کھولنا ہے ا و ر  د
ہ
ا 

 

ا  پڑے گا  BIOSر  ی ا ر  ی ا ر  ا ٓت  کو ہیں  ہے تو ط

 

میں جای

  کی سیٹنگ یعنی   BIOSپھر ا سی 

 

ر
س

 

ن

 یوا 

 

   Detect or Un detectمیں ا ٓت  کی سٹور یج د

 

ز
 پ ل
کی

  میں پڑھ چکے ہیں ۔ ا گر 

 

 کو ہم پہلے یکچر ر

 

ا پٓشنز بھی ہوتے ہیں ا ن

ا  

 

 سک کے ی ا ر ے میں کوئی ر ا ئے قائم کری

 

  د

 

 ہے ۔و غیرہ ٹھیک ہیں تو ا ٓت  نے پھر ا پنی ہار د

  ا گر  

 

ہی ہیں  ہو ر ہی تو پھر ا س کا حل سا ٹ  و ئیر سے  Detectسے ا س کا حل ممکن ہے لیکن ا گر  DMہو ر ہی ہے تو سا ٹ  و ئیر یعنی  Detectی ا د  ر کھیں ہار د

 

 

  جو ہار د

 

 ر ا یو خرا ت  ہے ا ت   ا تٓ  ا س کا کار د

 

  د

 

کی بیک سا ئیڈ پر لگا ہو ا  ہے ا س کو د یکھیں کہ کیا  کیسے ہو گا ۔ پھر ا س کا حل کیا ہو گا تو مکمل طور  پر سمجھنے کے بعد کہ ہار د

ے ہیں ۔ 

 

سکی
  لے کر ا ٓت  ا س کو بدل 

 

 کوئی ا ٓئی سی تو ہیں  ج لا ہوا  ا سی طرج کا کار د

 

2. Blue screen during installation of OS: 
Sol. Check your CMOS battery otherwise change it if problem exist erase your RAM and use 
blur to provide a service to your PC. Otherwise reinstall your OS. Or press F7 while installation 
of your OS Xp during set up. 

 کسی خاص جگہ پر ا ٓت  کا کمپیوٹر ا ی ک نیلی سی سکرین ا ی ک خاص پیغا یہ 

 

ا لیشن، کے د و ر ا ن

 

شپ

 

ن
  ا 

 

 و ر

 

ڈ

 

 و ی

 

ر  د یکھنے میں ا ٓی ا  ہے کہ بعض ا و قات

 

کی
ا  مسئلہ ا 

 

م کے سا تھ د کھای

ا  ہے ۔ تو ا س کا حل بہت سا ر ے مرا حل پر بنی  ہے پہلے تو یہ کہ کس سٹیج پر ا ٓ  hangہے ی ا  و ہیں 

 

 ہو جای

 

لًا ی ا  پھر ر ی سٹار ت

 

 ی ا   ہے ۔ مپ

ا  ہے تو ا س کے د و  تین حل ہیں ۔1

 

 ا ت  ا یکس پی میں ا ٓی

 

  کے سی ت

 

 و ر

 

ڈ

 

 ۔ ا گر شرو ع میں و ی

  

 

 و ر

 

ڈ

 

 کرو ا  کر ا س کی ی ا ر ٹیشن  31*۔ ا ٓت  و ی

 

 ی سے کمپیوٹر کو بوت

 

 ا س میں ۔  FDISKکی سی د

 

 میں بنائیں یعنی د

 

 

   ا ت   *۔ ی ا  پھر شرو ع ہی میں سی ت

 

 ا ی ک خاص جگہ پر ا ٓت  کی بور د

 

 کی پریس کر د یں۔ F7سے کے د و ر ا ن

 یٹا کیبل بھی تبدیل کر کہ د یکھ لیں۔

 

 *۔ د

 ر  کریں۔ CMOS*۔ 
ی

 

کلپ
 

  پرا سیسر کی بس سپیڈ   Commpaitable*۔ ا گرر یم 

 

ٹ  بھی ہو سکتا ہے یعنی ا گر ر یم کی ا و ر  بور د

 

پ
ہیں  ہے تو ا ٓت  نے ر یم کو  commpaitableہیں  ہے تو 
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 بدل کر د یکھنا ہے ۔

 یم و غیرہ۔*۔ کمپیوٹر میں کوئی نیا

 

  ی ا  مود

 

  کار د

 

ڈ

 

لا سا و ی

 

  و ئیر بھی خرا ت  ہو سکتا ہے مپ

 

  ہار د

   کے ی ا ر ے میں ر ا ئے قائم کریں ۔ ا و ر  ا س کا حل ا ٓت  

 

ر ا ر  ہے تو ا خٓر میں ا ٓت  ا پنی ہار د
ق
ز  
پ 
  میں پڑھا ہے۔ DM*۔ مسئلہ ا گر 

 

ے ہیں جو ہم نےپچھلے یکچر ر

 

سکی
 سے کر 

 

3.Very low progress during installation: 
Sol. Check CMOS and CD Rom otherwise RAM & HDD. 

ا  ہے ۔ 

 

ا  ہوی

 

 میں بہت سا ر ی چیزو ن کو فالو کری

 

ٹ
ق
  و ئیر ا ی ک پیچیدہ مگر ا نٹرسٹنگ فیلڈ ہے ہمیں ا ی ک و 

 

ا ت  یہ جو مسئلہ ہے کہ میں نے پہلے ا ٓت  کو بتای ا  کہ ہار د

 ی ا و  ر  سی

 

 تو سی د

 

 سپیڈ بہت کم ہے تو پہلے ی ا ت

 

ا لیشن، کے د و ر ا ن

 

شپ

 

ن
   ا 

 

لًا ر یم ہے ، ہار د

 

  کو د یکھیں مپ

 

 و ئیر ر

 

 ر  کر لیں کہ ا و کے ہیں پھر ا ٓت  د و سرے ہار د
ی

 

کلپ
 ی ر و م کو 

 

د

 ر ا یو ا و ر  بعض د عہ  ی ا ر ٹیشن کا مسئلہ بھی ہو سکتا ہے ا س کے لیےا تٓ  صرف 

 

  کے  Cد

 

  ا و ر  بور د

 

  کر پھر بنا لیں ۔ تما م ا پٓشنز د یکھنے کے بعد ا خٓر میں ہار د

 

 ر ا یو کو تور

 

د

  کو کھولی ا ر ے میں ر ا ئے

 

 پ ک کریں ی ا  پھر بور د
ح
 سک کو کھول کری ا  کسی د و سرے سٹم کے سا تھ لگا کر 

 

  د

 

 میں ہے ا س کے لیے ا ٓت  ہار د

 

  قائم کریں کہ مسئلہ ا ن

  بہت گندہ تو ہیں  یعنی ا س پر 

 

 ہ خرا ت  تو ہیں  ی ا  پھر بور د

 

 پ ک کریں کہ کوئی پرر
ح
 ی ا د ہ ہے تو ا س کو د ھو Dustکر صاف کریں ا و ر  

 

 کر خشک کر لیں و غیرہ ا گر بہت ر

 ر تے ہیں تو پھر پیٹرو ل ی ا  کسی ا و ر  ا س طرج کے 

 

 بتا ۔ سے د ھو کر خشک کرلیں ا و ر  پھر لگا لیں  Liquidا و ر  پھر د و ی ا ر ہ ٹ  کرلیں ا گر د ھونے سے د

 

 ے کی ی ا ت

 

ر
ک

  کو صاف کر لینے حل  سےہوجاتے ہیں ۔

 

 د و ن کہ بعض د عہ  بہت سا ر ے مسائل صرف بور د

5. Virtual memory low message: 
Sol. Installation must be carrying on. But while working on restart you system. 

 

ا لیشن، جار ی ر کھیں ، لیکن ا گر ا ٓ ت  کمپیو

 

شپ

 

ن
 کریںا 

 

 ۔یہ پرا بلم حل ہو جائے گا۔ٹر پر کام کر ر ہے ہیں ا و ر  یہ پیغام ا ٓ ر ہا ہے تو کمپیوٹر کو ر ی سٹار ت

4. No power display. 
Sol: Check power cable, processor &RAM is rightly connected or not, Power supply and 
motherboard. And power on off switches is rightly connected on the motherboard. Clear your 
CMOS and then try again.Power supply is main factor in this problem. 

 

 ہیں  ی ا س ہو ر ہا ۔ تو د یکھیں ا س صو

 

ٹ

 

پ
 ہی ہیں  ہو ر ہا د و سرے معنی میں کر

 

 س پلے ہیں  ہے مرا د  یہ کہ سٹم ا ٓن

 

 حال میں کچھ ا ہم  پوا ئنٹ ہے کہ ی ا و ر  د

 

ر  ت

 کو ا ٓت  ضرو ر  د یکھیں گے ا و پر لکھی ہوئی ہیں پھر ا ٓت  میں پرا بلم جو ہو سکتا ہے ا س کی طرف  Understoodچیزیں تو 

 

پ لائی  ہیں کہ ا ن
س
 ر  ہے ی ا و ر  

ہ
ا 

 

ا ٓئیں گے تو ط

  

 

پ لائی پر ہے ا س کو د یکھ لیں پھر ہو سکتا ہے کہ ا ٓت  کا بور د
س
 ہوا  ہے جو مکمل ی ا و ر  

 

جل گیا ہو ا س کو بھی د یکھ لیں کو ضرو ر  د یکھ لیں ا س کے لیے ا و پر ا ی ک یکچر  بیان

 میں ہمار ے ی ا س ا خٓری حل پور 

 

  بدلنا پڑے گا کچھ معاملا ت

 

 ا و ر  بیسٹ بھی ہےو ر ہ ا ٓت  کو بور د

 

ا  ہے ا و ر  ست  سے ا ٓسا ن

 

 یوا ئس کو ہی بدلنا ہوی

 

 ۔ی د

 
1. Error booting from CD Rom: 
Sol. Check your CD & CD Rom then reboot your PC otherwise change your CD/ROM. 

  میں پڑھا ۔ کہ  یہ ا ی ک عام مشین

 

  کے ی ا ر ے میں ا ٓت  نے پہلے یکچر  ر

 

ر
س

 

ن

 یوا 

 

 د

 

 ی کمپیوٹر میں بوت

 

ا ت  میں تین ہوتی ہیں ۔ ا ی ک ا ٓ گئی سی د

 

 یعنی پی سی میں ی ا  لیپ ی

 ر  

 

  ہوتی ہیں جن کا ا ستعمال عام یور

 

 ی ا د ہ تر د و  یور

 

ا مل ہے ۔ لیکن ہمار ے ہان ر

 

 ر ا یو ا و ر  پھر ا ی ک یو ا یس بی بھی س

 

  د

 

جانتے بھی ہیں ۔ تو د یکھیں ح ت  ر و م ا و ر  د و سرا  ہا ر د

ا ل 

 

شپ

 

ن
 یوا ئس بدلیں گےبھی ا ٓت  کوئی نیا ا پٓریٹنگ سٹم ا 

 

 د

 

ا  چاہتے ہیں تو ا ٓت  ا پنی بوت

 

ا  چاہیے۔ تو ا گر  First Boot Deviceیعنی ا ٓت  کی  کری

 

 ی ر و م ہوی

 

سی د

 ہیں  ہو ر ہا تو 

 

 ی ر و م د و نون کو د یکھ لیں کہ ا و کے ہیں ۔  Setupپہلے ا ٓت   Obviosulyا ٓت  کا کمپیوٹر بوت

 

 ی ا و ر  سی د

 

 کرنے کےبعد سی د

 

 یوا ئس سی ت

 

 د

 

سے بوت

 ت  ا س کو حل کریں گے۔یہیں سے ا ٓ

0. Error Copying files from CD: 
Sol. Check your CD then CD Rom then checks your CMOS, RAM and erase it then capacitor on 
Motherboard may be the problem. 
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8. Error during formatting of HDD: 
Sol: Check your HDD otherwise change it. or break your partition & make it again. Or Use DM 
for creating/deleting partition or fix your problem using low level formatting of DM. 

  کر د یکھ لیں لیکن

 

 سک فار میٹنگ میں پرا بلم کر ر ہی ہے تو پہلے ا تٓ  ا سکی ی ا ر ٹیشنز تو ر

 

  د

 

 ا ٓت  کی ہار د

 

ا لیشن، کے د و ر ا ن

 

شپ

 

ن
  ا 

 

 و  ر

 

ڈ

 

 یٹا کا بیک ا ت  ضرو ر  کر ا گر و ی

 

 پہلے د

 سک کو    DMلیں ا گر مسئلہ حل ہیں  ہو ر ہا تو 

 

  د

 

 کر د یں۔ Low Level Formatسے ا س ہار د

9. BIOS patch error: 
Sol: CPU bus speed must be managed. 

 کر لیں ی ا  پھر  BIOSیہ پیغام ا ٓت  کو بوٹنگ پرا سس میں ملے گا ہو کے  تو ا ٓت  ا پنا 

 

 ٹ
پ
 

 

 کر لیں۔ BIOSا ت  د

 

 میں جا کر پرا سیسر کی کلاک سپیڈ و غیرہ سی ت

17. No VGA display 
Sol: Check your VGA cable/card clear 
CMOS, RAM (erase it otherwise change it), any change in hardware , data buses,CPU 
otherwise your board is damage. 

 تو ہو

 

 س پلے سے مرا د  ہے کہ سٹم ا ٓن

 

 سری  مائل ہو جاتی ہے، یہ ا ی ک بہت حساس مسئلہ ا س د

 

ی ت

 

 یٹا ی ا  گنل  ہیں  ا ٓ ر ر ہا و ر  مانیٹر کی لاپ

 

 ر ہا ہے لیکن مانیٹر پر د

  ا و ر  بجلی کنفرم کریں پھر ا ٓت  ا و پر بتائے ہوئے ا پٓشنز کو ی ا ر ی ی ا ر ی د یکھیں

 

ز
 پ ل
کی

 س پلے 

 

ا  ہے پہلے تو ا تٓ  ا پنی د

 

 .ہوی

 

ز ا ہ ر ا ست
پ 
 س پلے کا 

 

 یہ کہ د

 

علق  ا ہم ی ا ت

ا ر نے پر ا ٓت  کا کمپیوٹر 

 

  پر فوکس کریں۔ ا گر ر یم ا ی

 

ر
س

 

ن

 یوا 

 

 د

 

  پر منحصر ہے ۔ا س لیے ا ن

 

 ہے  Beepر یم، پرا سیسر، ا و ر  بور د

 

د یتا ہے تو سمجھ لیں کا ا ٓت  کا پرا سیسر د ر ست

 کو بھی د یکھ لیں کہ ا لٹی تو ہیں  لگی ہوئی ۔ ا پنی ر یم کو

 

ر
 س
ن

 یٹا 

 

 چھیڑیں۔ پھر ا پنی د

 

 صاف کر کہ لگائیں ی ا  پھر ہو کے  تو بدل کر ۔ ا خٓر میں ا س لیے ا س کے سا تھ مت

 حال میں 

 

  کو د یکھیں ا س صور  ت

 

 پر  CMOSبور د

 

 ی ا ن

 

 ا ٓ ر ہے ہیں ی ا  ہیں  ا س کو نکال کر ر

 

ج

ی 

 

لی

ا  چاہیے ۔مطلب کہ ا س میں و و 

 

ضرو ر  کلیر کر لیں ا و ر  یہ ٹھیک ہوی

 ی ا د ہ تر ر یم سے مناست  لگائیں ا گر جلن ہوتی ہے تو ٹھیک ہے و ر ہ ا تٓ  ا س کو بدل لیں کیونکہ

 

 ا س سے بعض د عہ  کئی مسائل حل ہو جاتے ہیں ۔ا س مسئلے کو ر

 د ی جاتی ہے۔کہ ر یم خرا ت  ہے۔

LECTURE –35 

 
11. Low speed  
Sol. Check any change in Ram then OS, CD ROM, HDD or virus attack. Any hardware change, 
otherwise make a service to your PC and then clear your CMOS 
12. Error in detection of HDD or CD Rom 

Sol. Check your Setup HDD is connected or not then jumper settings then data buses. 

BIOS  یوا ئس کی 

 

 ر  د
ہ
ت  سے پہلے ی ا ئی ا و س میں د یکھیں Dectectionپر ا ٓت  کا مکمل عبور  ہو ا و ر  

 کے حوا لے سے تمام ا پٓشنز س

 

 پھر ا ٓگے چلیں ا س مسئلے کی صور  ت

لًا 

 

 د یکھیں۔ Jumpersمیں بھی پہلے ی ا ئی ا و س کو د یکھیں ا و ر  پھر د و سرے بتائے ہوئے ا پٓشنز مپ

13. System booting error from CD ROM or file copying error: 
Sol. Check CD then CD ROM & RAM. 
20. Restarting during Formatting of HDD drive: 
Sol. HDD contains Bad sector, so use Disk manager tools to get recovered this problem. 
15. Starting set up again & again: 
Sol. HDD error use disk manager, RAM error then clean it. Light factor. 
14. File copying error where CD & CD ROM are absolutely true. 
Sol. RAM is the problem check your Ram erases it and confirms it that the BUS speed is similar 
to CPU, Board and other RAM. 

 کی بس سپیڈ میچ کر لیں ۔

 

 ی ا د ہ ر یم ہوتی ہیں ا ن

 

 ا ی ک سے ر

 

 حال میں ر یم کی بس سپیڈ د یکھ لیں ی ا  پھر بعض ا و قات

 

 ا س صور ت

11. Restarting when loading heavy program Video or Game: 
Sol: Light is big factor, check your power supply, RAM, VGA card otherwise use extra FAN or 
heat skink for your CPU also use cool magic while assembling your CPU on Board. 

 ر یم ا و ر  پرا سیسر  ہے عام طور  

 

ت  سے ا ہم ی ا ت
ے س

 

سکی
ا  ہے ہو کے  تو ا س کو بدل د یں ی ا  بعض د عہ  د و  فین لگانے پڑھ 

 

پر پرا سیسر کے ا و پر لگا ہوا  فین بھی مسئلہ کری
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 ہیں۔

10. Hanging after inserting new VGA/RAM/Sound etc. 
Sol. Check you card and then Board slot otherwise use other slot. If problem exist then either 
your card is not functioning well. 
18. Long Beep but display. 
Sol. Check Keyboard/mouse, keys stuck, any thing on board 
19. Light beep no display. 
Sol. Check your Data buses & Ram 
27. New sound/VGA card is not working: 
Sol. Go to setup and disable your default sound/VGA (built in). & install your card. 
 

LECTURE – 36 

 
21. I have increase my CPU, but every time it gives an error in BIOS (install BIOS patch to 
upgrade your CPU) or alike. 
Sol. Load your setup defaults, then check your board that how much CPU clock speed and bus 
speed it supports if you find option buttons then establish it and compare it to your current CPU 
clock speed, if problem exists then don’t use this CPU for this particular board. 
 
22. Blue screen while making partition/formatting drive. 
Sol. HDD error. Use Disk manager tools.(DM) 
 
23. Scanned disk every time on rebooting. 
Sol. HDD error.  Make fresh partition after backing up your data  or Use Disk manager tools. 
 
25. “OS not found” message: 
Sol. Got to setup and check that HDD is properly connected or not, check your Master/slave 
settings of HDD. If all the settings are ok then same message exist, you must reinstall your OS. 

 

 

پ
 ا 

 

ا  ہے کہ کیا کہہ ر ہا ہے لیکن ا ٓت  د

 

 ر  ہے کہ پیغام د یکھتے ہی پتہ چل جای
ہ
ا 

 

لائیں بلکہ پہلے ا ٓت  ی ا ئی یہ پیغام ا ٓت  کو بوٹنگ پرا سس میں ملے گا ۔ ط
 ا ت  ہ ج 

 

ز یکٹ سی ت

  

 

 میں بھی یہ پیغام ا ٓ سکتا ہے  Detectا و س میں جا کر د یکھ لیں کہ ہار د

 

  ہ ہونے کی صور ت

 

 ۔ہے ی ا  ہیں  پھر ا ٓگے فیصلہ کریں ۔چونکہ بعض د عہ  ہار د
24. Low speed and gives messages of “a dialogue of send error report” don’t send” again 
& again: 
Sol. Corrupt OS, reinstall your OS. or bad operating. 
 
21. Date & time check some error again again/invalid date & time. 
Sol. Change your CMOS battery. 
 
20. Low progress while installing new OS: 
Sol. Check CD/ROM, RAM, HDD, CMOS CPU FAN and CPU. Otherwise board capacitors. 
 
28. HDD Master/ slave problem. 
Sol. Use corrects jumper’s settings, proper data buses. Etc 
 
29. A:\> after booting process: 
Sol. Check you HDD and data cables then reinstall your OS. 

 پرا سس میں 

 

۔ملے گا پیغام  یہ بھی بوت  

37. Scandisk every time when system reboot. 
Sol. Either your OS is corrupt otherwise there is error in you HDD, you can recover it using Your 
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OS recover bad sectors option or using DM tools. 
 
31. Drives shows 0 bytes: 
Sol. Format your drive again or change your file system and format it again. 
 
 
32: Dim prompt light of system: 
Sol. Check your power light then clear your CMOS otherwise check your power supply & Board. 
 
33. BIOS password is not enabling: 
Sol. Check your PSW (Jumper) on board is right on the spot or not 
 
35.Blue Screen While Partitions 
Sol. Use DM tool to creat these partitions or your HDD is damage 
 

LECTURE – 37 

34. Beep sound 
Sol. Check your cables i.e. keyboard/mouse then keyboard stuck keys, RAM is big factor for 
giving Beep sound, other thing is if your board generating a sound then your CPU is running 
along well so don’t disturbed your CPU.VGA card is also factor if your system is not displaying 
and giving Beep sounds. Mainly VGA and RAM must be checked. 
 
31. No sound 
Sol. Check your speaker’s input then sound drivers, then any bad problem in your sound card. 
 
30. NTLDR missing 
Sol. Restart your system load default settings of your pc. If problem exists then reinstall your 
OS. 

ا  ہے ا صل میں ا ی ک فائل

 

ا  پڑی

 

ر  نیا ا پٓریٹنگ سٹم ہی کری

 

کی
 یلیٹ ا 

 

 ی ا  د

 

 ٹ
پ
ا م ہے جو کر

 

 ۔ہو جاتی ہے کا ی

38. Low progress in installation of OS: 
Sol. Ram and CMOS then processor Fan or sink. 
 
39. Error during partition procedure: 
Sol. HDD media error use disk manager to fix this problem. Otherwise make only one partition 
that is C and leave all the other space. When your OS is installed then make your partition using 
my computer’s manage option. 
 
57. Low speed while opening drives: 
Sol. HDD error use disk manager and then use this kind of HDD as a slave. Virus also a factor. 
 
51. USB keyboard is not functioning in BIOS: 
Sol: Go to setup & enable your USB keyboard support in BIOS. 
 
 
52. Input sound is running but out sound is not running well. 
Sol. Sound card input port error. Replace your sound card. 
 
53. Long Beep, then option for Setup: 
Sol. Go to setup and load your defaults, check your CMOS. 
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55. Long beep No display. 
Sol. VGA/RAM and board. 
 
54. System has been automatically turned off. 
Sol. Confirm it that there is no virus problem. If you confirm it then do these things. 
Provide service to your PC, erase your RAM, clear CMOS (checks it),Use heavy Heat sink and 
cream, check your Power supply (checks its FAN, otherwise provide an extra Fan for it), provide 
an extra FAN for CPU. The light is also be a factor. 
 
51. System is Restating again and again. 
Sol. Heat is big factor also where you put your system there will be minimum 15 & maximum 49 
degree (for Intel chipset). 
 
50. Blue screen while installing new OS. 
Sol. Clear your CMOS and RAM. Press F3 during installation of OS. 
 
 
58. Blue screen after inserting new card. 
Sol. Change your slot other wise card. 
 
49. Blue screen after booting process and then restarts. 
Sol. Install a new OS. 

LECTURE – 38 

 
 

47. Some applications are not running like windows media player:. 
Sol. Reinstall your OS properly. & install a good antivirus. 
 
 
41: HDD prompt red light is completely on and then system Halt: 
Sol. HDD error, use Disk manager if HDD is detecting. 
 
42. System is absolutely power off and no power effect. 
Sol. Power cable and power supply, if your system bear a shock then might be your power 
supply is burnt, then open it and check its Fuse and capacitors otherwise change it. 
After inserting new power supply cleat it that your board is healthy. 
 
43. HDD is not taking any power and not detecting. 
Sol. Check your power cable of HDD, use another one, and otherwise change your HDD card. 
 
45. Hanging during setup of Win XP: 
Sol. Check your CD & CD ROM other wise break your C drive and make it again. 

لاصہ:

 

 ج

  و ئیر کے کچھ

 

 سا منے ا ٓ ر ہی ہیں۔ ا س لیے یہ ممکن ہیں  کہ صرف چند صفحا ہار د

 

 نئی ا یجاد ا ت

 

ٹ

 

پ
 ٹیکنالوجی بدل ر ہی ہے ا و ر  

 

 بدن

 

 کیے ہیں ، د ن

 

 مسائل ا و پر بیان

 

ت

ا  سمجھ جاتے ہیں تو ا ٓت  کے سا منے فیلڈ ا و پن ہے ا ت  ا تٓ  ی ا قی 

 

 مسائل کو حل کری

 

 تمام مسائل کا ا حاطہ کریں ۔ لیکن ا گر ا ٓت  ا ن

 

 کے حل معامیں ہم ا ن

 

ملات

 کےلیے خود  سے فیصلہ بھی کر سکیں گے۔
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CHAPTER 9   INFORMATIVE SECTION  

LECTURE – 39 

Concept of Networking 
“A network is way to connect computers together so that they can communicate, exchange 
information and pool their resources amongst each other.” 
Practical work. 
Extra devices for networking: 
LAN card, WAN Card, MAN (Metropolitan Network), Net working switch (HUB), Networking 
Cables, Connectors. Etc. 
There are three types of networking Modals: 
1. Client/Server Networks: 
This network involves a server. Which is a main computer having whole of information. It can 
hold several HDDs. Where It can share info. To others using internet or small network. The main 
advantage of this king of network is security. Because administrator that belongs to main server 
has total command on this kind of network. He can protect files & data from being sharing. 
II) Peer to Peer Networks: 
In this network all the computer has an equal status. And no one has any control on others. So 
they have equal status and right to others. And you can easily share all the devices and data.. 
But this network has lack of security and speed. But it is an one of easy way to connect 
computers to others. This networks only supports 10 to 15 computers. 
III) Hybrid Networks: 
This networks is power full in all, It is the combination of both above. 
Networks Topologies: 
Network topology is “shape or map” of the network. Before being able to connect. 
Types of Topologies: 
BUS, RING, STAR, TREE, MESH. 

Practical will be in lectures 

LECTURE – 04 

Password Unlocking& Security 

ز ی ک 
پ 
  

 

 ر

 

ا  بتای ا  جائے گا ا و  ر  مختلف ی ا س و ر د

 

  لگای

 

  سے تعلقہ  کچھ خاص ٹپس پڑیں  گے۔ جس میں ا ُٓٓ ت  کو سکیور  ی ا س و ر د

 

ا  بھی  ا ٓت  ی ا س و ر د

 

 پڑھای ا  جائے گا۔ کری

 و ر کنگ کے حوا لے سے ا ٓت  کو ا ی ک لیب ی ا  ا ٓفس میں 

 

ی ت

 

ا  بتا ی ا  جائے گا پھر ا س میں 15سے  16پ

 

 و ر ک بنا ی

 

ی ت

 

   سٹم کا ا ی ک پ

 

 ر ا یور

 

ا  ا و ر  د

 

 ج لای

 

ی ت

 

  پر پ

 

ر
م

 

شی
س

تمام 

ا  ی ا  پرنٹر و غیرہ۔  Share کو 

 

 کرا ی

 ا س کو لیں گے۔

 

 سا ر  ا  کام لیب میں ہی ہو گا ۔ تو یکچر  کے د و ر ا ن

LECTURE – 04 

Hardware Application 

 کیا سیکھا کیون سیکھا ا س کو کہان ا ستعمال کریں گے؟

  و غیرہ۔ 

 

 ا تٓ  کے وفا لات

Lec-42 

Summary 
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Do you know? 

 ز س

 

پ
 ی ا د ہ پھیلنے میں و ا لا کمپیوٹر و ا 

 

ز س یکم مئی  ‘I Love You’ د نیا کا ست  سے ر

 

پ
ز س ہے۔ یہوا 

 

پ
ا می و ا 

 

 ہین تھا  2666ی

 

ک د

 

کو سا منے آ ی ا ۔یہ ا س حد ی

 ر یس پر ا پنی 

 

 ر  ا ی میل ا ی ڈ
ہ
 ر یس ی ک میں موجود  

 

ا ا س کی ا ی ڈ

 

 و ٹر بھی ا س سے متاثر کہ جس کمپیوٹر کو متاثرکری
 ی
می
ہ ک

ا ی ک کاپی بھیج د یتا۔ ا س طرج و 

  و غیرہ فلپائن کی 

 

 جیسے ی ا س و ر د

 

 میں موجود  معلومات

 

ا  تھا بلکہ ا ن

 

 یں یہ ہ صرف کمپیوٹر کی د و سری فائلون کومتاثر کری

 

 ہوجاتے۔ علاو ہ ا ر

 

ٹ

 

پ
 سا 
ا ی ک و ی ی

ز س کے سا منے آ نے کے 

 

پ
ا  تھا۔ ا س و ا 

 

ھپ
ک

 بھی ر 

 

ک ا س کے تقریباً  0کو ا ر سا ل کرنے کی صلاحی ت

 

بھی  (Variants) د و سرے بہرو ت   56ماہ بعدی

 سا منے آ ئے۔

ز س نے د نیابھر میں 

 

پ
 بھی 3.1ا س و ا 

 

ٹ
ق
  ہے۔ ی ا د  ر ہے کہ ا س و 

 

  کو متاثر کیا جو ا ی ک ر یکار د

 

ز سز د نیا میں موجود   50,000 ملین کمپیوٹرر

 

پ
کمپیوٹر و ا 

 

 

 ر  د ن
ہ
  کومتاثر کرتے ہیں۔ 16ہیں ا و ر  

 

ز س کمپیوٹرر

 

پ
 نئے و ا 

 نیو یکسیکو  کا وممی پرندہ ا ی ک کوئل ما  پرندہ ہے سے ا مریکہ 

 

 ر نر’ کی نوبت  غرببی ر ی ا ست

 

ا  تو ہے ہی، ‘ ر و د

 

 ی

 

ا  ہے۔ا س کی و جۂ تسمیہ یہ ہے کہ یہ ا ر

 

کہا جای

 میں ا ی ک ا یسا کمپیوٹر نصب کیا جا ر ہا ہے سے ا سی پر

 

ا ۔ا س ر ی ا ست

 

ھپ
ک

ا نی ہیں  ر 

 

 نے میں بھی ا پنا ی

 

 مین پر تیز د و ر

 

 سا تھ ہی سا تھ ر

 

ندے کی مناسی ت

  ر نر’سے 

 

  د ی ا  گیا۔‘ر و د

 

ا م د ی ا  گیا ہے۔ ا س کمپیوٹر کے ا بتدا ئی ٹیسٹ کیے گئے جن کے بعدا سے ی ا ضابطہ طور  پر د نیا کا تیز ترین کمپیوٹر کا ا عزا ر

 

 کا ی

  ر نر میں  

 

 کل نئے کمپیوٹرو ن میں د و  پرو سیسر لگے ہوتے ہیں۔ ا س کے مقابلے پر ر و د

 

و سیسر نصب ہیں، جن کی پر110,046آ ت  نے سنا ہو گاکہ آ ج

 کا

 

ٹ
ق
ا  ہے۔ ا س کی طا 

 

ھپ
ک

 ر 

 

  کرنے کی صلاحی ت

 

ر

 

ی

 

 س
لی

 و 
پ لکی
ک

  ر نر ا ی ک سیکنڈ میں د س لاکھ ا ر ت  

 

 ہ یون لگائیے کہ ا گر د نیا کے تمام چھہ   مدد  سے ر و د

 

ا ندا ر

 و لیٹر لے کر حسات  کریں تو ا نھیں و ہ وفا ل حل کرنے میں پونے ی ا نچ گھنٹے لگیں گے جو
پ لکی
ک

 ا ی ک ا ی ک 

 

سا ن

 

ن
  ر نر ا ی ک ہی سیکنڈ میں حل کر  ا ر ت  ا 

 

ر و د

 لے گا۔ 

   

 

 نیوی ا ر ک میں تیار  کیا ہے، جہان سے ا سے نیو  26ا س سپر کمپیوٹر کی قیمت ا ی ک کرو ر

 

 ا ر  ہے، ا سے آ ئی بی ا یم کمپنی نے مشرقی ا مریکی ر ی ا ست

 

لاکھ د

 کے حوا لے کر د ی ا  جائے گا۔

 

     یکسیکو  لے جاکر ا مریکی فوج

  کوو یسے تو ا س کمپیوٹر کا بنیاد 

 

ٹ
ق
 طا 

 

ز د ست
پ 
 

 

ا  ہے لیکن ا س کی ر

 

 پر تحقیق کری

 

ر یضہ ا مریکی د فاعی معاملات
ف
 بین کے لیے بھی   ی 

 

سا ئنسی مسائل کی ھان

 حصون کے ی ا ر ے میں تحقیق کی جائے

 

 کے ا ن

 

سا نی د ماع

 

ن
  کی و یکسین بنانے ا و ر  ا 

 

 ر

 

  ر نر کی مدد  سے ا ی ڈ

 

ا ل کے طور  پرر و د

 

 گی جو ا ستعمال کیا جائے گا۔ مپ

 سے تعلق 

 

ا ئی پیدا  کرنے کے طریقے   ہیں۔ بصار ت

 

 ر یعے صاف ستھری توا ی

 

 کے د

 

 ن

 

 مے د و سرے کامون میں ا یٹمی فیور

 

ا س سپر کمپیوٹر کے د

ا  ا و ر  

 

ا مل ہیں۔سا ئنس د ا نون کو توقع ہے کہ جو مسائل حل کرنے میں   د ر ی ا فت کری

 

ا  س

 

 ل بنای

 

 پیش گوئیان کرنے کے ماد

 

 کی د ر ست

 

موسمیات

  ر نر کی ب بجاتے ہی حل کر د ے گا۔ا سد و سرے کمپیوٹر سا لہا سا ل لگا د یتے تھے

 

 سپر کمپیوٹر ، و ہ ر و د

 

ز د ست
پ 
 

 

   ر

 

 ن

 

 221ٹن ہے ا و ر  ا سے  236کا و ر

 کر تعجب ہو کہ ا س

 

ا ی ڈ  آ ت  کو یہ جان

 

 نیو یکسیکو  لے جای ا  جائے گا۔لیکن س

 

تمام  ٹرکون پر لاد  کر نیوی ا ر ک سے ا مریکہ کے د و سرے سرے یعنی ر ی ا ست

  ٹر کیتر د یو ہیکل پن کے ی ا و جود  ا س کمپیو

 

 کے د ماع

 

سا ن

 

ن
 ا ی ک عام ا 

 

ٹ

 

پ
 ہا

 

ا  کم ہے۔کمپیوٹر کے خالق کہتے ہیں کہ ا یسا کمپیوٹر  56 کے مقابلے میں د

 

گپ

ز  ہو۔
پ 
ز ا 
پ 
 کے 

 

سا ن

 

ن
 ا 

 

ٹ

 

پ
 ہا

 

ز س لگیں گے جس کی د
پ 
 ی ڈ  کئی 

 

ر
ک
 بنانے میں ا بھی 

Tricks: 

   پیڈ میں جا کر 

 

  Q33Nا ٓت  نوت

 

 ی

 

پ
 ا 

 

ٹ

 

پ
 کرنے کے بعد ا س کا سا    Wingdingsٹ  کریں ا و ر  ا س کا فا

 

پ
  

 

 تو ا ٓت  کو و ر لڈ ٹری ڈ  نٹر  کی کر کہ د یکھیں 72ز

 ۔ملے گا نقشہتباہی کا 

  میں کہیں بھی  

 

 و ر

 

ڈ

 

ا م سے فولڈر  ہیں  بنای ا  جا سکتا ۔ conو ی

 

 کے ی

  جاننے کے لیے 

 

  ا ستعمال کریں۔ RUN- "DXDIAG"کمپیوٹر کی معلومات

 

ڈ

 

 کمای
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 My Computer   کی پرا پرٹیز جاننے کے لیےWin logo + Pause/Print   کی   

 

ڈ

 

 لیں۔کمای

  میں 

 

 لیں ۔ Alt+ Arrow Keyسکرین ا لٹی ہونی کی صور ت

  میں  

 

کے  266،33پیجز بنے ہوئے مل جائیں گے ا س طرج ا ٓت   556لکھ کر ا نٹر کریں تو ا ٓت  کو تقریباً rand(200,99)=ا یم ا یس و ر د

ے ہیں ۔

 

سکی
 بجائے کوئی ا و ر  ہندسے بھی ر کھ 

 ٹ  کریں ا و ر  ا س کو نیچے د ی ا  ہوا  کو

 

پ
ا 

 

  پیڈ میں ی

 

  و ر د

 

ا  ہے  bat extension.د

 

 میں سیو کرنے کے بعد ج لائیں تو د یکھیں کیا ہوی

shutdown -s -t 80 -c "Message A gift for you" 

 

 س پلے ہوگا ۔ ا س کو ختم کرنے کے لیے

 

ٹ  کر د یں و ہ د

 

پ
ا 

 

  میں لکھا ہوا  ہے و ہان پر ا ٓت  کوئی بھی پیغام ی

 

 ل کامار
ی
 

 

  جہان پر د

 

ڈ

 

 start –run ا ٓت  نیچے د ی ہوئی کمای

ا ئم 

 

ز س ہے ا گر ا ٓت  ا س کا ی

 

پ
ٹ  کریں۔یہ ا ی ک و ا 

 

پ
ا 

 

  ہوتے ہی د و ی ا ر ہ بند کر start upہے  16ر کھ کر جہان پر  5-2میں جا کر ی

 

  کو لود

 

 و ر

 

ڈ

 

میں سیو کرد یں تو یہ و ی

 کریں ۔)

 

 کو ا ی میل کر کہ ا س کو ضرو ر  حیرا ن

 

 (Just for Funد ے گا ۔ ا پنے کسی د و ست

To cancel this mesage 

type shutdown -a 

 
Useful key shortcuts for WinXp 

 

 

 

 

 

 

 

 

 

 

DEFINITIONS 

Shows the desktop 
minimizes all open windows 
maximizes whole open windows 
 

Runs Windows Explorer 
shows the RUN dialog 
shows Search window 
shows System Properties box 
Go taskbar applications 
Display the System Properties dialog 
box 
Unlatched Lift Executive 
Cycle through opened applications  
 
 
Exhibition the Inauguration menu 
 View the properties for the selected 
item 
 

Windows key + D 
Windows key + M 
Windows key + Shift + M 
 
Windows key + E 
Windows key + R 
Windows key + F 
Windows key + Break 
Windows key + TAB 
Windows key + PAUSE 
 
Windows key + U 
ALT + TAB 
Hold down CTRL while dragging an 
item to Copy it 
CTRL + ESC 
ALT + ENTER 
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Application: 

A program that helps the user accomplishes a specific task. i.e Using MS Word or Ms 

excel etc. 

 

Address Bus: 

It is the part of system bus. It carries the addresses of various memory locations to 

perform read or write operation. 

 

ALU: 

It is one of the major part of CPU. Solves & perform arithmetic logical operations. 

 

Amplitude: 

It is the height of wave within a given period of time. 

 

Analog Signal: 

These are signals which are in wave form. 

 
Antivirus Software: 
It is software which is used to detect & remove a virus software from computer. 
 
ASCII: 
American standard code for information interchange, 7 bit coding scheme. 
 
Bandwidth: 
It is a measure of the transmission rate of communication channel. 
 
BCD: 
Binary code decimal. 4 bit coding scheme. 
 
BIT: 
Unit of computer, the smallest unit of data representation. 
Broadband: 
It is a technique of transmitting a large amount of date (voice or Video) over a long distances 
simultaneously by modulation each signal onto a different frequency. 
 
Bitmap: 
In bitmap graphics an image is displayed in the screen as a collection of tiny squares pixels, 
which together form a pattern. 
 
Boolean: 
In computer and digital electronics this term means an expression with two possible values “true” 
& “false”. The common operations are AND, OR, NOT, IF etc. 
 
Browser: 
A program that allows users to read hypertext documents on the World Wide Web. 
 
CRT: 
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Cathode ray tube – It is a vacuum tube used as a display screen in a computer or video display 
terminal. 
 
Custom Built software: 
This software is developed for a particular customer. 
 
Cache: 
Read as “Kash” a temporary storage area for frequently accessed or recently accessed data. 
There are two kinds of cache internal and external. Internal cache is built into the processor and 
external cache is on the motherboard. 
 
Clipboard: 
An area of temporary memory which is used to transfer text and graphics within a document 
being edited. 
 
Cache 
In computer science, a cache (pronounced /kæ&#643;/) is a collection of data  duplicating original 
values stored elsewhere or computed earlier, where the  original data is expensive to fetch (owing 
to longer access time) or to compute, compared to the cost of reading the cache. In other words, 
a cache is a temporary storage area where frequently accessed data can be stored for rapid  
access. Once the data is stored in the cache, future use can be made by  accessing the 
cachedcopy rather than re-fetching or recomputing the original  data, so that the average access 
time is shorter 
 
Decoder: 
It converts the encoded signal to digital form. 
 
Digital Signal : 
It uses on – off electronic pulses in discontinues & discreet form. 
 
Domain Name: 
All servers on the Internet also have human readable names. 
 
DSL: 
Digital Subscriber Line. 
 
Database: 
A large collection of data organized for rapid search and retrieval. 
 
Desktop: 
The whole computer screen which represents different shortcut icons in graphical interface. 
 
Domain name: 
An internet address in alphabetic form (Intel, .com, www) domain names must have at least two 
names. 
Some domains are 
.com commercial site   .edu educational institution 
.gov governmental    .mil military 
.net network    .org non profit organization 
 
Download: Getting some data from Internet and saving in your PC is Downloadingprocess. 



155 

 
 
DISK Defrag met: 
A program which you can find in your accessories, It is tool which arrange your files and folders in 
respectable order so that computer can search these easily and provide you quick results. 
 
E-Mail: 
It is the process of sending messages electronically over the internet. 
 
E –Mail Client: 
It is software used to create, send & receive. 
 
Ethernet: 
It is LAN protocol. 
 
Extended Partition: 
The partition refers to a portion of Hard disk that can contain other partitions. 
 
Frequency: 
It is the number of times a wave repeats during a specific time interval. 
FTP: 
File Transfer Protocol. It is a protocol to transfer files from one computer to other on a computer 
network. 
 
GIF: (Graphical Interchange Format): 
An object format in which you can save your object in a picture format.So that you can view these 
in a direct picture browser directly. 
 
Hardcopy: 
It is refers to printed output. 
 
Hyperlink: 
A word or icon or object that follow another location while clicking on it. 
 
Hub:  
Also known as a dumb hub. Hubs are general repeaters that share bandwidth between other 
devices connected to it. If you have a 100Mb hub and 4 ports, and 4 devices connected to the 
hub, each device is using the same 100Mb bandwidth. So, if PC1 is pushing a large amount of 
files, that will slow down the other devices connected to that hub. PC1 is using 1/2 of the 
resources the hub is designed for, so, the rest of the machines share the remaining resources. 
This results in poor performance which can result in data collisions. Another down side to a hub is 
that it broadcasts to each PC since it's not smart enough to remember where each device is. 
 
Internet: 
It is huge network of computer in which millions of computer are connected together, can share & 
transfer data from one to another. It is also called network of networks. 
 
ISP : 
A company which provides internet services. 
 
Internet: Internet is huge network of different computers in which you can share your data from 
one computer to another 
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JPEG Bitmap (Joint Photographic Expert Group): 
Another picture format in which you can view your pictures directly in picture browser. 
 
Multiprocessing: 
We mean having more than one processor in a single computer. 
 
 
Multitasking: 
The ability of loading different applications (software) at the same time & after processing 
providing you the results. 
 
Multiuser OS: 
It allow multiple users to work on a single computer (capable) at the same time. 
 
Network: 
A group of computers which are joined together to exchange information and pool their resources 
to each other. 
 
Operating System: 
An OS s collection of operative programs that provide an interface for the user to interact with the 
computer. 
 
Partition: 
The process of making different drives of your HDD. 
Primary Partition: 
It is used for system partitioning. 
 
Program: 
A set of instruction is called program & a set of program is called software. 
 
Pixel: 
Short for picture element, one spot from thousands of dots to form a complete picture. 
 
Protocol: 
It is refers to rule & procedure that defines how computer receive and transmit data over the 
network. 

Router:  
There are different types of routers, what will be explained are home routers. A router is a 
switch that acts as a DHCP (Dynamic Host Configuration Protocol), and sometimes a NAT 
server. All that means is that it can assign any device connected to it an IP, Subnet, Gateway 
and DNS servers automatically. Usually NAT will function as a firewall between your PC's and 
your internet connection. This will make sharing an internet connection and file sharing easier 
for home users who do not have a dedicated server to function as the "router". 

Switch:  
There are two types of switches, managed and unmanaged switches. Unmanaged switches are 
more common in homes and SOHO settings. Switches are Collision detection and prevention 
and each port is allocated 100Mb.  
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SVGA(Supper Video Graphic Adaptor) 
XGA (Extended Graphic Array) Supported 16.7 millions Colors. 
 
Sample ATM (Auto Mated Travel Machine) card. 
PIN(personal identification number). 
 
An ATM card (also known as a bank card, client card, key card or 
cash card) is an ISO 7810 card issued by a bank, credit union or 
building society. It can be used at an ATM for deposits, withdrawals, 
account information, and other types of transactions, often through 
interbank networks Some ATM cards can also be used: at a branch, 
as identification for in-person transactions at merchants, for EFTPOS 
(point of sale) purchases Unlike a debit card, in-store purchases or 
refunds with an ATM card can generally be made in person only, as 
they require authentication through a personal identification number or 
PIN. In other words, ATM cards cannot be used at merchants that only 
accept credit cards. However, other types of transactions through 
telephone or online banking may be  
performed with an ATM card without in-person authentication. This includes  
account balance inquiries, electronic bill payments or in some cases, online  purchases (see 
Interac Online). 
In some countries, the two functions of ATM cards and debit cards are combined  into a single 
card called a debit card or also commonly called a bank card.  These are able to perform banking 
tasks at ATM's and also make point-of-sale transactions, both functions using a PIN. Canada's 
Interac and Europe's Maestro  are examples of networks that link bank accounts with point-of-
sale equipment. ATM Cleaning Cards are the primary means of cleaning ATM machines to 
ensure that the machine stays functioning properly. 
 
What is Unicode? 
Unicode provides a unique number for every character, no matter 
what the platform, no matter what the language. Fundamentally, 
computers just deal with numbers. They store letters and other 
characters by assigning a number for each one. Before Unicode was 
invented, there were hundreds of different encoding systems for 
assigning these numbers. No single encoding could contain enough 
characters: for example, the European  Union alone requires several 
different encodings to cover all its languages.  
Even for a single language like English no single encoding was 
adequate for all  the letters, punctuation, and technical symbols in common use. These encoding 
systems also conflict with one another. That is, two encodings  can use the same number for two 
different characters, or use different numbers for the same character. Any given computer 
(especially servers) needs to support many different encodings; yet whenever data is passed 
between different encodings or platforms, that data always runs the risk of corruption. Unicode is 
changing all that! 
Unicode provides a unique number for every character, no matter what the platform, no matter 
what the program, no matter what the language. The Unicode Standard has been adopted by 
such industry leaders as Apple, HP, IBM, Just Systems, Microsoft, Oracle, SAP, Sun, Sybase, 
Unisys and many others. Unicode is required by modern standards such as XML, Java, ECMA 
Script (JavaScript), LDAP, CORBA 3.0, WML, etc., and is the official way to implement ISO/IEC 
10646. It is supported in many operating systems, all modern browsers, and many other 
products. The emergence of the Unicode Standard, and the availability of tools supporting it, is 
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among the most significant recent global software technology trends. Incorporating Unicode into 
client-server or multi-tiered applications and websites offers significant cost savings over the use 
of legacy character sets.  Unicode enables a single software product or a single website to be 
targeted across multiple platforms, languages and countries without re-engineering. It allows data 
to be transported through many different systems without corruption. 
 
Color depths and what they mean? 
Here's a general break down of the different color depths:  
Color Depth Guide 32-bit 16.7+million colors plus an 8-bit (256-level) grayscale mask.  
24-bit 16.7 million colors    16-bit 65.5 thousand colors  
15-bit 32.8 thousand colors    8-bit 256 colors  
7-bit 128 colors      6-bit 64 colors     
5-bit 32 colors      4-bit 16 colors  
3-bit 8 colors      2-bit 4 colors  
1-bit 2 colors  
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CHAPTER 10:   SELF TEST 
 

This test belongs to your previous course; you can judge him that what you learned during 
course, if you are satisfied then you will never loose any other test. I will ensure you. 

1. What is computer; write down the components of your PC? 
2. What do you mean by digital computers? 
3. Write down the first 4 generations of computers and some main model computers? 
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4. How many keys are there on your keyboard? Also write type of keys. 
5. What is booting process of computer? 
6. What is BIOS? 
7. What is an OS? How many types of OS are there in these days? 
8. What do you mean by Desktop? 
9. Write down the function of DXDIAG command? 
10. What is MS Office? Which versions of MS office do you like &why? 
11. Write down some characteristics of MS Word 2007? 
12. What is format of MS Word office 2007? 
13. Name the Different toolbars of MS office 2007? Explain interface also? 
14. Write down the short keys of New, Open, Save, save as, Cut, Copy, Paste, undo, redo, 

Hyperlink, zoom, increasing & decreasing text size, centre Alignment, change case, print, 
print preview, exit, drop cap, spelling check ect. 

15. What is function of paste special? 
16. Write down the properties of page setup? 
17. What is task pane & Header & footer? 
18. What is Auto Text? 
19. Why are symbols important? 
20. What is object? How can you insert MS equation editor? 
21. Explain some main tools of reference menu? 
22. What is Drop cap & change case? 
23. What is the function of text Box? 
24. What is Clip Art? 
25. What is Printed Watermark? 
26. What is Mail merge & Macros? 
27. Define difference between protect & security of document? 
28. How can you draw a table of 8 x 9? 
29. How can you insert a table of 7x 7? 
30. What is merge cell? 
31. What is inpage? What is format of inpage 2.4? 
32. What is the short key of increasing Text size in inpage? 
33. What is name of standard layout of inpage? 
34. What is place, import & export in inpage program? 
35. What is story editor? Write its short key? 
36. Write down short key of inserting new page in inpage & deleting it? 
37. What is style sheet in format menu of inpage? 
38. Write down the properties of document button in format menu of inpage? 
39. Insert a table of 9x 6 in inpage & format it? 
40. Write down short keys of symbol menu in inpage? 
41. What is short key for changing language in inpage? 
42. What is master page in inpage? 
43. How can you send data form inpage to Ms Office Word?  
44. What is format of Power point presentation? Also write its second name? 
45. How many parts are there in slide of MS PP 2007? 
46. What is short key of new slide? 
47. Why power point is important? 
48. How can you save your slide as picture using JPEG or Gif format? 
49. How can you paste Urdu data from inpage to powerpoint? 
50. What difference is between save & save as? 
51. Discuss the properties of Movies & sound buttons of insert menu in PP? 
52. How you can Open Ms word document in powerpoint? 
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53. Briefly discuss slide show menu in power point? 
54. How can you start your show directly? 
55.  What is format of Ms Excel? 
56. How many sheets are there in a work book of Ms Excel 2007? 
57. What is cell address? 
58. What is Sort in Ms Excel? 
59. Write down the properties of page setup in Ms Excel? 
60. How can you use office clipboard for traveling data from excel to Word? 
61. How can you insert new sheet, new row, new column?  
62. What do mean by name button of insert menu in Ms excel? 
63. Write down the functions of these? sum, max, date, time, median, mode, average, square 

root, multiplying, dividing, subtracting? 
64. How can you find the grades of students using data? 
65. How can you use name function for using formula easily? 
66. Write down the properties of cells menu in format of MS excel? 
67. What is goal seek? 
68. Why are filters important?  
69. How can you use validation Rules in your sheet? 
70. How can you protect your folder? 
71. What is format of Corel Draw? 
72. What are Accessories? Discuss according to your concept? 
73. What are partitions? 
74. How can you paly a CD & copy it to your own Disk drive? 
75. What is unit of computer write its complete chart? 
76. How can you insert a password on your OS using User Account? 
77. What is procedure of installing a software i.e. Ms office, inpage, corel, etc in your 

computer? 
78. How can you add are remove your program? 
79. What is Recycle Bin? 
80. How can you change your desktop’s properties? 
81. What is method of inserting a new folder & copying your files in it? 
82. How can you hide your folder & showing it again? 
83. How can you power off your computer also write its short key? 
84. What is difference between log off & power off? 
85. How can you change your computer’s time & date? 

 
Assignments: 

1. Write down the application for Job in English Also print it? 
2. Compose you CV & print it? 
3. Compose your experience certificate & print it out? 
4. Make a Date sheet & print it on landscape page? 
5. Compose your urdu application in inpage & insert it in MS Word? 
6. Prepare your Matric’s marks sheet using table’s commands? 
7. Write down a letter to your father for money & print it? 
8. Compose an application in inpage Urdu & print it? 
9. Insert a table of 8x 6 in inpage using sutiable data also print it? 
10. Prepare a presentation of 5 districts of AJK with audio Video effects & launch it directly 

using save as ‘s suitable format? 
11. Find out the grades of following data using logical tests of Ms Excel also find there 

remarks? 555, 250, 360, 701, 364, 200, 245. 
12. What is formula of finding monthly payment of your loan? 
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13. Make a graph of the data also print it? 
X= Districts= MZD, Mirpur, Kotli, Bamber, Neelum, Poonch, Bagh, Mirpur. 
Male=      5        ,  6         ,  7,        4,         6,            3,             2,         9 (Lakhs) 
Female=        7,          3,             6,       2,           4,          1,            5,           5( Lakhs) 
Total=          
14. Make a database of your monthly expenditures also apply some validation rules? 
15. How will your proceed for traveling your excel‘s data into Ms Word? 
16. Prepare your personal visiting Card & insert it in MS word? 
17. Prepare the Icon given below? 

 
 
 
 
 
 
 
 
 

18. Make a title page of any book in corel draw in Urdu & print it? 
19. What is function of Fit text to path in corel draw? 
20. How can you proceed for creating your Own CD? 
21. Use data traveler for copying your data from one computer to another? 
 

^^^^^^^^^^^^^^^^^^^ 
 

Self Test for Hardware: 
1. What is difference software & Hardware? 
2. Prove with the help of diagram that how computer proceed & saves data? 
3. Write down the components of Motherboard? 
4. What is CMOS? 
5. How can you proceed for breaking your BIOS password? 
6. Why Hardware is important? 
7. What is the main purpose of as OS? 
8. What is BIOS, write some standard key for hitting PC’s BIOS setup? 
9. Define different types of memories in computer? 
10. What is Chipset, write some chipset’s from Intel? 
11. What is DOS, How many commands are used in DOS? 
12. Write some main steps for installing OS 98 in your PC? 
13. How many types of partitions are there in PC? 
14. What is HDD & CD ROM? 
15. What is RAM & ROM? 
16. What is difference between DDR & SDR RAM? 
17. Write down procedure for installing OS XP? 
18. Can you enable your Urdu language in OS XP? 
19. What is assembling? Also assemble a tower PC? also write stepwise procedure? 
20. Write down the names of HDD technologies? 
21. What is GHOST? 
22. Your system is attacked by the VIRUS how will you proceed? 
23. What is computer Virus, how they can destroy your data? 
24. How can you protect your PC form Virus? 
25. What is NOD 32? 
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26. What is program? Write down the names of some basic languages of computer? 
27. Your computer is making a noise, what is first thing about this problem? 
28. What is data bus, Bus speed, clock speed, Unit of computer, FAT, NTFS? 
29. Write down the ports of a PC? 
30. You have install a new OS XP but your sound & VGA is not working what is solution? 
31. What is VAG card? How many slots are there in intel 845 chipset board? 
32. What is CPU write its parts & their functions? 
33. What is power supply? 
34. Write all the components of a motherboard? 
35. What is LAN & WAN? 
36. Apply these DOS commands, Dir, CHKDSK, copy, DIR/p, dir/a-h, label, FDISK, tree, 

type, path, edit, exit, CD, MD? 
37. What is troubleshooting?  
 
Solve these problems 
38. Your computer not showing display, what is problem? 
39. Your PC showing dem light with no display? 
40. Restarts at welcome screen? 
41. Every time showing starts windows normally? 
42. Computer not showing hidden files & folders? 
43. Three beeps & no display? 
44. Continuous Beep & no display? 
45. Replace disk & press any key message? 
46.  Very low speed? 
47. Send error reports again & again? 
48. VGA, SOUND, or any other card is not detected? 
49. If your built in sound is not working, how you can install your PCI Sound card? 
50. HDD is not detected? 
51.  Invalid date & time message? 
52. NTLDR is missing message? 
53. CD ROM is not detected? 
54. You are in procedure to use tow HDD in your PC how will you proceed? 
55. How can you copy your data from one HDD to another directly? 
56. System Hang at first point? 
57. Showing little “-“& halt? 
58. My drives are auto play? 
59. System restarts during formatting of HDD? 
60. File copying error? 
61. System 32/ is corrupted message? 
62. Bootable CD not exist message? 
63. System showing Blue screen & restarts? 
64. Very low speed during working? 
65. No power display? 
66. System is halted every time when I starts video? 
67. My game is not running? 
68. My pc is setup is not highlights password options? 
69. Very heavy sound from system? 
70. How can I increase my PC’s speed using simple techniques? 
71. How you will install Printer, Scanner, and Web camera? 
72. My data is lost how can I recovered it? 
73. My HDD is giving sound & very low speed how can I recovered it? 
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74. I want to break my user password? 
75. What is best password for keeping system secure? 
76. What is networking? Write down some IP address? 

 

 

 

ے ہیں کسی بھی وفا ل کے حل کے لیے ہم سے ر ا بطہ کر

 

سکی
۔  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ہیں؟ ۔ کیا ا ٓت  ا پنے کیے گے کور س سے مطمئن 1 

 ا ۔ کیا ا ٓت  کمپیوٹر س

 

  و یر د و نون کے ی ا ر ے میں معلومات

 

ہیں؟ ر کھتےٹ  و  ہار د 2 

ا  جانتے ہیں؟

 

 پیج ( و غیرہ میں کام کری

 

ل، ی ا و ر  پوا ینٹ، کور ل، ا ن
س
ی ک

 ، ا 

 

 3۔ کیا ا ٓت  ا یم ا یس ا ٓفس )و ر د

4  ئل۔ کیا ا ٓت  ا پنے کمپیوٹر میں پیدا  ہونے و ا لے چھوٹے مسا

 

ڈ

 

 ،)و ی

 

ا  و ر

 

شپ

 

ن
ا لیشن،، ا ٓفس ا 

 

شپ

 

ن
 یوا یس جیسےا 

 

ی د  
ی

 

پ

 یم لیشن، ،

 

 ، مود

 

 ، و ی جی ا ے، ٹی و ی کار د

 

ڈ

 

 پرنٹر، سا و ی

 و غیرہ کو حل کر لیں گے؟
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5   کو تو ا ئیی   ئے۔ کیا ا ٓت  کمپیوٹر میں لگے ہو

 

 ر  ی ا س و ر د

 

 ا و س ی ا  یور

 

لیں گے؟ ر  

 ی ا یم، ا یکس پی د و نون کے حوا لے سے کر لیں گے؟۶

 

 ا س، د

 

 سک کی ی ا ر ٹیشن ، د

 

  د

 

 ۔ کیا ا ٓت  ا پنی ہار د

   ۔ ا ٓت  کی۷

 

 سک ہار د

 

 میں بیڈ سیکٹر ہو تو کیا ا تٓ  ا س کو ٹھیک کر لیں گے؟ د

ے ہیں؟۸

 

سکی
 یٹا و ا پس لا 

 

  ی ا  یو ا یس بی کا د

 

 ۔ کیا ا ٓت  کسی فار میٹ شدہ ہار د

ے ہیں؟۹

 

سکی
 و ر کنگ کر 

 

ی ت

 

 ۔ کیا ا ٓت  پ

  کو حل کر لیں گے؟ئلمسا 56۔ کیا ا ٓت  کمپیوٹر میں ا نٓے و ا لے تقریباً ۱۱

گ میں ٹ  کر لیں گے؟۔کیا ا ٓت  کمپیوٹر کو ۱۱

 

شپ
کی 

ے ہیں ی ا  نیا کمپیوٹر نیو 

 

سکی
  

 

 کھول کر د و ی ا ر ہ جور

 تمام کامون کے ی ا ر ے میں ا پنے ا تٓ  کو ہان کہتے ہیں تو ا تٓ  کا کور س کامیات  ر ہا

 

 ۔ا گر ا تٓ  ا ن

 

 

 

 

 

CHAPTER 11:       INTERNET 

 
LECTRUE-1 

  ا  ہے؟۔

 

 کیا ہے؟ ا و ر  کیسے کام کری

 

ی ت

 

 ا نٹرپ

 FTP, Client & Server Networks, Peer to Peer Networks etc. 

 ر ا ہم کرنے و ا لی کمپنیون کا تعار ف۔
ف
 کی سرو س 

 

ی ت

 

 ا نٹرپ

  کے فوا 

 

ی ت

 

۔ئدا نٹرپ

 

ا ت

 

  ا و ر  قصانی



165 

 

 ا ۔

 

 کنکشن بنای

 

ی ت

 

ا  ا و ر  ا نٹر پ

 

ا ل کری

 

شپ

 

ن
 یم ا 

 

 مود

 WWW ر   کیا ہے ؟ 

 

ز ا و ر
پ 
 کا ا ستعمال۔  و یب 

 

 ہ ا و ر  ا ن

 

  کا تعار ف، موا ر

 

ر

 

ج ی

 

ن

 ا 

 

و ر  کا تعار ف ۔ سرج
پ ل
ش
ی ک

 ا 

 

ی ت

 

 ا و ر  ا نٹرپ

  ، ر یس 

 

و ر  کے چند ٹولز ۔ و یب ا ی ڈ
پ ل
ش
ی ک

 ا 

 

ی ت

 

 Searching  URLs ٖٔ  ا و ر  ا س کے سا تھ ا نٹرپ

 ا  و یب ہیلپ ا و ر  ا نفو

 

 کری

 

ا ، ہوم پیج سی ت

 

 کری

 

ٹ

 

پ
ا  ی ا  پر

 

 ا کونٹ  کو سیو کری

 

 د

  

 

لاس

 

 میں کسی کو ی

 

ا ۔کسی یونیور سٹی ی ا  لای ا کستان

 

  کری
پ ی

 

پ

 و غیرہ۔

 

لاس

 

ا ۔ر یری کی ی

 

 کری

 

لاس

 

 ا نجن کی مدد  سے تصاو یر ، سا یٹس  ی

 

 سرج

 www.youtube.com ا ۔ی  کی مد د  سے و

 

 کری

 

لاس

 

 یو ی

 

 ڈ

  ا ی میل سے تعار ف ۔ جس میںG-Mail, Yahoo, Hotmail ٓ ا  ۔ ئیا

 

 ی بنای

 

 د

   ا

 

ا ، ر ی ی لا( Yahoo Messenger، )خصوصاً میل پرو گرا م ج لای

 

 یلیٹ کری

 

ا ، میل بھیجنا، جوا ت  د ینا، د

 

  کری

 

ا ، ا س  ئےمیل فار و د

 

ا ، میل کو فار میٹ کری

 

کری

 کا ا ستعمال۔  Outlook & Ms Wordکے لیے 

 ر ا د  کو سینڈئلزا ی میل کے سا تھ فا
ف
 ی ا د ہ ا 

 

ا ( ا ی ک سے ر

 

  )تصاو یر و غیرہ ا یچ  کری

 

 کری

 

 ر یس محفوظ

 

ا ۔ ا ی میل ا ی ڈ

 

ا  ،  کری

 

 کری

 

لاس

 

 ر یس ی

 

 ا ی میل ا ی ڈ

 

ی ت

 

ا ۔ا نٹرپ

Address Book 

  میل پرو گرا م سے ی ا  
ہ

ا 

 

کلپ

 

ن
ا ۔ ئیا پنی ا ٓ ، ر  

 

کلپ

 

ن
 ر  
ہ
 ی سے ی ا 

 

 د

 سے تعار ف۔ 

 

ی ت  ر یلے ح 

 

ی ت

 

 ا نٹرپ

 IRC  یو ، و 

 

گ، ا ٓد

 

پ

 

پ ی  
ح
ا  ہے، تفریح، 

 

 یو )و یب کیمرہ( ۔ی  پرو گرا م کیسے کام کری

 

 ڈ

 ا ، سئلزفا

 

  کری

 

 لود

 

 ا و ن

 

ر ٹ  و ا  د

 

ی ی
ز  ، ا ینٹی و ا 

 

پ
 

 

پ ڈ
م
 یٹس۔س، ملٹی 

 

 ، ا ت  د

 

ر
ک
 ی ا  پرو گرا 

  کس ہمچند ا
 

لپ

((URLsر ی سرو سز۔
ف
 

 

ی ت

 

 ہ ا و ر  ٹرکس، ا نٹرپ

 

ز

 

پ
 ا و ر جا

ا  ہے؟

 

 کیا ہے؟ ا و ر  کیسے کام کری

 

ی ت

 

پ
 ا ۔ا نٹر

 ی ا د ہ پر ا سٓا 

 

 ا پنے ا ٓت  کو ست  سے ر

 

سا ن

 

ن
 کیں ۔ چونکہ ا 

 

 نی ا یجاد ا ت

 

ٹ

 

پ
 نے د نیا میں ا پنی ا ٓسا نی کی خاطر 

 

سا ن

 

ن
 کے سا تھ سا تھ ا 

 

ٹ
ق
:و   ر کھنا چاہتا ہے ۔ جو ئشجوا ت 

 یہ ہے کہ ا ٓت  ست  جانتے ہیں کہ 

 

ت  سے ا ہم ی ا ت
ک ممکن ہیں  بھی۔ خیر ۔ ا س وفا  ل کے جوا ت  میں س

 

ز ی ا   کمپیوٹرکسی حد ی
پ 
لات  
ق

 

ن
 ا  ا 

 

ز
پ 
کی ا یجاد  نے د نیا میں بہت 

ک ا للہ نے چاہا ترقی ہوتی ر ہے گی۔ جس میں ہم ا و ر  ا ٓت  

 

ک جار ی ہے۔ ا و ر  ا س میں ح ت  ی

 

 ی

 

 ا لنا ہے۔ کمپیوٹر کی تعریف ا و ر  ا س کے کیا  جو ا ٓج

 

نے بھی ا پنا ا پنا حصہ د

ی  

 

 ا ٓت  نے ا س سے پہلے کور س میں ا چھی طر ج سمجھ لیے ہیں۔ ہاںن پر ا ٓت  جس کور س کی طرف جا ر ہے ہیں و ہ ہے ا نٹر پ

 

 تعلقہ  بہت سا ر ے تصوا ر ت

 

۔ ا جٓ

 

ت

 سے کے 

 

 پر ا ٓت  یہٹیکنالوجی کے لحاظ

 

 ی ا ن

 

 ر  شخص کی ر
ہ
 ہن ترقی ی ا فتہ د و ر  میں 

 

 می ا ٓت  کے د

 

ے ر ہتے ہیں۔ جس سے لار

 

ی

 

سی
 

 

 لفظ ا و ر  ا س سے تعلق  کچھ ا و ر  تصور ا ت

 ست  کا جوا ت  ا ٓت  کو ا س کور س کی مدد  سے ملے گا۔

 

 میں بھی بہت سا ر ے وفا ل جنم لیتے ہیں۔ ا ن

 خود   ا صل میں ہ تو کوئی س

 

 ا ت

 

 ی ڈ

 

ی ت

 

  و ا  ا نٹرپ

 

ا م ہے۔ ا و ر  ا س علق ، نک   کمپیوٹرو ن مختلف۔ بلکہ یہ ئیرٹ  و یر ہے ا و ر  ہ ہی مکمل ہار د

 

کے ا ی ک د و سرے سے نک  کا ی

ے ہیں ا و ر  ر سیو 

 

سکی
 بھیج 

 

ا مل ہو جائے تو ا ٓت  بھی د و سرو ن سے منسلک کمپیوٹرو ن پر ا پنی معلومات

 

ے ہیں ۔ جس میں ی ا  ر ا بطہ میں ا ٓت  کا کمپیوٹر بھی ا گر س

 

سکی
بھی کر 

ا مل ہے۔ جس کو سینڈ ی ا  ر سیو کر

 

 ی ا  و غیرہ س

 

پ ڈ
م
 سیکھیں گےٹیکسٹ، تصاو یر، 

 

ا  ا ٓت  کور س کے د و ر ا ن

 

 ۔ی

The Internet:  

http://www.youtube.com/
http://www.youtube.com/
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The internet is huge network of computers in which we can share our information, can send 
emails, have very quick results of connecting with each other and can research and make your 
information available to each other. Find targets, to get entertainment and more useful results. 

  ست  سے پہلے ا مریکہ کے محکمہ د فاع نے ی ا قا

 

 کا ا غٓار

 

ی ت

 

شرو ع کیا۔ یہ ARPA NET (Advanced Research Project Agency Network)عدہ ا نٹرپ

 ہے۔ا و ر   1312سے  1306

 

 کو تیزی سے ا ی ک جگہ  1312کی ی ا ت

 

 و ر ک بنا لیا تھا جس کا مقصد معلومات

 

ی ت

 

و ن نے چالیس کمپیوٹرو ن پر مشتمل ا ی ک پ
ہ

 

ن
ک ا 

 

ی

 کنٹرو لسے د و 

 

ن

 

 ش
می
س

 

ن

و ن نے ا س میں ا ی ک نیوٹیکنالوجی متعار ف کرو ا ئی ا و ر  و ہ تھا  ٹی سی پی )ٹرا 
ہ

 

ن
ا  تھا۔ ا س کے کچھ عرصہ بعد ا 

 

پرٹو کول( یہ ا ی ک  سری جگہ پہنچای

ا  ہے۔

 

 کری

 

مت
س

 

ن

ا  سا  ٹکڑا  ٹرا 

 

 کا ا ی ک چھوی

 

 میں معلومات

 

ٹ
ق
 پرو ٹو کول ہے جو ا ی ک و 

 FTP, Client & Server Networks, Peer to Peer Networks etc. 

 و ر ک کی

 

ی ت

 

 بنیاد ی طور  پر ا سی پ

 

ٹ
ل
 کی سہو

 

ی ت

 

 و ر ک۔ ی ا د  ر کھیں ا نٹرپ

 

ی ت

 

 می چیز لیتے ہیں و ہ ہے پ

 

 کی تعریف کے سا تھ ا ی ک بہت لار

 

ی ت

 

 مل ر ہی  ہم ا نٹرپ

 

ٹ
ل
بدو 

 و ر ک ی ا  د ا 

 

ی ت

 

ا  ہے تو ا ٓت  ا ی ک پ

 

 ہو جای

 

کت

 

 سے کپ

 

ی ت

 

 ہے یعنی ا ٓت  کا کمپیوٹر ح ت  پ

 

پ
 و ر ک لینڈ لاین ہو ی ا  و ا ز ے میں ا ٓ جاتے ہیں و ہ ا لگ

 

ی ت

 

 ہے کہ پ

 

  ی ا ت

 

پ
ز  لیس 

 د و نون ممکن ہیں۔

ا  ہے۔ ا و ر  ا 

 

ا م د ی ا  جای

 

 ر  کمپیوٹر کو ا ی ک ا نفرا د ی ی
ہ
 ر یعے جڑے ہوتے ہیں۔ ا و ر  

 

ا ر و ن کے د

 

 و ر ک میں عموما کمپیوٹر ی

 

ی ت

 

 ا ی ک پ

 

ا ر و ن سے نک  کمپیوٹرو ن کے  ن

 

ی

 ا ی ک سے د و سرے کمپیوٹر 

 

ز قی لہرو ن کی مدد  سے معلومات
پ 
 ر یعے 

 

 کو د ی جاتی ہیں۔ د

 یں، فالز  ا و ر  پرو گرا م

 

ڈ

 

 ، کمای

 

 د و نون سے معلومات

 

 تے ہیں تو ا ت  ا ٓت  ا ن

 

 ر یعے جور

 

 نک  کے د

 

ن

 

 ش
پ کی

 

پ

دوسرے سے  ای ک  ح ت  ا ٓت  د و  کمپیوٹرو ن کو کسی کمیو

لًا۔

 

ے ہیں۔ مپ

 

سکی
 کو ٹرا نسفر کر 

 و ر ک بنا ر ہے ہیں۔  

 

ی ت

 

ا مل کر د یں تو ا ٓت  ا ی ک پ

 

 ا گر ا ٓت  ا س کے سا تھ ا ی ک ا و ر  کمپیوٹر س

 ی ڈ ۔

 

ر
ک
 ا و ر  ا سی طرج 

 و ر ک سے ر ا بطہ

 

ی ت

 

ے۔ بلکہ ا س مقصد کے لیے ا ٓت  کو ا ی ک پ

 

سکی
 کے سا تھ منسلک ہیں  ہو 

 

ی ت

 

 و ر ک ا س ا نٹر پ

 

ی ت

 

 کہ ا ٓت  خود  ا س پ

 

کرتے ہیں جو  ا ی ک ا و ر  ا ہم ی ا ت

 

 

و مت
جک
ما لک میں 

ک
ر ا ہم کرنے کے لیے د نیا کے تما م 

ف
ا  ہے۔ یہ سرو س 

 

ا مل کرنے کا کام کری

 

 و ر ک کے سا تھ س

 

ی ت

 

  کو پ

 

کے سا تھ سا تھ د و سری  د نیا میں کمپیوٹرر

ر ا ہم کرتی ہیں  
ف
 

 

ٹ
ل
 کی سہو

 

ی ت

 

 کمپنیون ی ا  ا د ا ر و ن کو جو ا نٹرپ

 

ا  ہے۔ ISP(Internet service provider)کمپنیان بھی کام کرتی ہیں۔ ا ن

 

 کہا جای

 

 

 

 

 

 

س

 کو

 

 معلومات

 

پ
ا  ہے ا س کو 

 

 ر  کرنے کے لیے جو پرو ٹو کول ا ستعمال ہوی
ی

TCP/IP ا  ہے۔ یہ کچھ خاص قسم

 

 پر کہا جای

 

ی ت

 

 ر  کمپیوٹر کی ا نٹرپ
ہ
  ہیں جو 

 

  و ر د

 

 ر یس  ی ا  کود

 

 کے ا ی ڈ

ا  ہے ا س کو ا ٓت  سر

 

ر ا ہم کر ر ہا ہوی
ف
 

 

ٹ
ل
 کی سہو

 

ی ت

 

 و ہ یہ کہ و ہ کمپیوٹر جو بنیاد ی طور  پر ا ٓت  کو ا نٹرپ

 

 کرتےہیں۔ ا ی ک ا و ر  ا ہم ی ا ت

 

ت

 

و ر  کہتے ہیں ا و ر  ا س سے شناح

 میں ئنٹ ۔یعنی کلائنٹمنسلک د و سرے کلا

 

 ر  صور  ت
ہ
 کے حوا لے سے (۔ سرو ر  کا 

 

ی ت

 

 ہے۔)ا نٹرپ

 

 محتاج

FTPٹول ہے جو کمپیوٹرو ن کے مابین فائل:فا 

 

ی ت

 

ا  ہے۔ئلیں ٹرا نسفر پرو ٹو کول ا ی ک ا نٹر پ

 

  کرنے کے ا ستعمال ہوی

 

 لود

 

 ا و ن

 

  ا ت  ا و ر  د

 

 

 

<><><><><><> 
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LECTRUE-2 

 

  ر ا ہم کرنے و ا لی کمپنیون کا
ف
 کی سرو س 

 

ی ت

 

پ
 تعار ف۔ا نٹر

Brain Net, Comsats, MSNEt, NEXLINX,PTCL, SCOM, UFONE, WARID, JAZZ, Telenor etc. 

 کے فا 

 

ی ت

 

پ
:۔ئدا نٹر

 

ا ت

 

 ے ا و ر  قصانی

 

 

 کو ا ن

 

سا ن

 

ن
 و  تعالی  نے نیکی ا و ر  شر د و  چیزیں پیدا  کیں ہیں۔ ا و ر  ا 

 

 کے ا ندر  ا للہ سبحان

 

 ست  لوگ ا چھی طرج جانتے ہیں کہ کائنات

 

ا نتخات  د و نون میں سے یہ ی ا ت

 میں یہ چیز سا منے ہے کہ

 

ا  ہے کہ ہم کس طرف جاتے ہیں۔ ا سی طرج ٹیکنالوجی ا و ر  سا ئنس۔ ر یسرج

 

 پینڈ کری

 

بہت سا ر ی  کرنے کا ا ٓپشن د ی ا  ہے۔ ا ت  ہم پر د
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 کے فائدے ا و ر  قصانی

 

ی ت

 

 بھی ہیں۔ ا س حوا لے سے ا نٹرپ

 

ا ت

 

 چیزو ن کہ ا گر بہت سا ر ے فائدے ہیں تو و ہان پر کچھ  قصانی

 

ہے  منحصرموجود  ہیں ۔ لیکن ہم پر ا ت

 ۔کہ ہم کس کو ترجیح د یتے ہیں

:۔

 

 کے میریٹس ی ا  خصوصیات

 

ی ت

 

پ
 ا نٹر

ر ا ہم۱
ف
 

 

ٹ
ل
 یو کو د یکھنے کی گھر میں ی ا  سفر د و نون صور تون میں سہو

 

  ا و ر  پور ی د نیا سے تعلق  خبرو ن کو ٹیکسٹ ا و ر  و ی ڈ

 

 ا ٓت  کو نیور

 

ی ت

 

ا  ہے۔۔ ا نٹرپ

 

  کری

 کی مدد  سے گھر2

 

ی ت

 

ے ہیں۔ ۔ ا ٓت  ا نٹر پ

 

سکی
  یٹھے  پور ی د نیا سے ر ا بطہ میں ر ہ 

ا  ہے ۔ جس کی مدد  سے ا ٓت  کسی بھی ملک میں ا پنے ر شتہ د ا ر و ن، د و ستون و غیرہ 3

 

ر ا ہم کری
ف
 

 

ٹ
ل
 ا ٓت  کو ا ی میل کی سہو

 

ی ت

 

ے  سے خط۔ ا نٹرپ

 

سکی
 کر 

 

 ٹ
پ
و کتا

 د یکھتے 

 

ز ا ہ ر ا ست
پ 
 کو 

 

ے ہیں ا و ر  ا ن

 

سکی
ت  کر 

 

ٹ  س
گ
 سے

 

ے ہیںا  ہوئےہیں۔ ا س کے علاو ہ ا ٓت  ا ن

 

سکی
 کر 

 

ی ت  سے  ح 

 

 .ن

 گور نمنٹ ی ا  سیمی گور نمنٹ ی ا  پرا 4

 

ے ہیں۔ ئیو۔ بہت سا ر ے ا د ا ر و ن کی و یب سا یٹس کی مدد  سے ا تٓ  ا ن

 

سکی
 ہ کر 

 

 کی سرو سز کا موا ر

 

 ا د ا ر و ن سے تعلقہ  ی ا  ا ن

 

 ٹ
پ

  ا و ر  

 

ر
ک
 بھی ممکن ہے۔ ا س کے علاو ہ محکماہ فار 

 

 ٹ
پ
 سے خط و  کتا

 

 ا و ر  ا ن

 

 لاین ممکن پیپرر

 

 بچ جاتے ہیں۔  و غیرہ بھی ا ٓن

 

ہیں۔ جس سے ا ٓت  کے بہت سا ر ے ا خرا جات

ے ہیں۔

 

سکی
 حاصل کر 

 

 کی مدد  سے گھر میں یہ تما م سہولیات

 

ی ت

 

 ا و ر  ا ٓت  ا نٹرپ

 لا5

 

ے ہیں ، ا س کے علاو ہ بجلیئن۔ا ٓن

 

سکی
 لے 

 

 سے تعلقہ  تمام معلومات

 

ٹ

 

پ
 کی مد د سے ا ٓت  ا پنے ا کاو 

 

ی ت

 

 ل، کے   ینک  سٹم کے ی ا ر ے میں ا ٓت  نے سنا ہو گا۔ پ
ی

ے ہیں۔ جو ا ٓت  کے لیے بہت موی ا ئل بلز،

 

سکی
 لاین سٹم کی مدد  سے گھر یٹھے  حاصل کر 

 

   ا و ر  ا س کے علاو ہ ا پنے مرضی کی چیزیں ا س ا ٓن

 

ا پنگ، موی ا یل کار د

 

 لی س

 بخش ہے۔

 کی مدد  سے 0

 

ی ت

 

  ا نٹر پ

 

  ا و ر  یکچر ر

 

ر
ک
 ا یگرا 

 

، نوٹس، د

 

س سے تعلقہ  کسی بھی طرج کی نیو ر یسرج

پ لی 
س

 جانتا ہے۔ ا ٓت  ا پنے 

 

ٹ

 

پ
 

 

ے ہیں۔ جو ا ی ک سٹود

 

سکی
 کہ حاصل کر 

 کتنی ا ہم ہیں۔

 ا 1

 

 ی ا  کے تما م ا پس ا ینڈ د

 

پ ڈ
م
، سا ئنس، ا رٓ ٹس، 

 

، شمار ی ا ت

 

، معاشیات

 

 ا یونٹس، کھیل، سیاست

 

ٹ

 

پ
 ا ٓت  کو پور ی د نیا میں ہونے و ا لے کر

 

ی ت

 

 کی ی ا لکل ۔ ا نٹرپ

 

و ن

 د یتا ہے۔

 

ر یش معلومات
ف

 

لا۔ کھیل1

 

ے ہیں۔۔ ا پنی پسندی ڈ ہ کسی بھی شخصیت مپ

 

سکی
 ا ٓت  لے 

 

ا ر یخ سے تعلق  کوئی بھی معلومات

 

 ی ا  ی

 

 ر ا مہ ی ا  سیاست

 

  ی ا  م ڈ د

3 

 

سکی
 کر 

 

 شہرو ن کی تصاو یر ا پنے کمپیوٹر میں محفوظ

 

ے ہیں۔ ا س کے علاو ہ ا ن

 

سکی
 کر 

 

 ت

 

 کی مدد  سے پور ی د نیا کے کسی بھی ملک کو و ر

 

ی ت

 

 ے ہیں۔۔ ا ٓت  پ

  ۔ کسی بھی قسم کا سا ٹ  و 16
ی ی

 سے 

 

ی ت

 

ا مل ہیں۔ر  ا ٓت  کو پ

 

ز س س

 

پ
 ، ا ینٹی و ا 

 

 ، سا ٹ  و یرر

 

 ر ا یور ر

 

ا  ہے۔ جس میں د

 

 ا ٓسا نی سے مل جای

ے ہیں۔11

 

سکی
 کا ا ظہار  پور ی د نیا سے کر 

 

 ی ا  تصور ا ت

 

 یعنی ا پنے خیالات

 

 ٹ
پ
 ۔ ا تٓ  ا پنی بنائی ہوئی کوئی و یب سا 

ے ہیں۔ ا و ر  ا 12

 

سکی
 بنا 

 

ما لک میں ا پنے د و ست
ک
 کی مدد  سے ا تٓ  مختلف 

 

ٹ
ل
 کی سہو

 

ی ت  ح 

 

ی ت

 

 کو ا پنے  ۔ ا نٹر پ

 

ے ہیں۔  Visionن

 

سکی
 بتا 

 لا نسٹیٹیوٹس۔ ا س کے علاو ہ بہت سا ر ے ا 13

 

ے ہیں۔ ئنا و ر  یونیوسٹیان ا ٓن

 

سکی
 گری ا ن بھی کرو ا  ر ہی ہیں۔ جن سے ا ٓت  گھر یٹھے  تعلیم حاصل کر 

 

  کور سز ا و ر  د

 کی مدد  سے بہت سا ر ی کمپنیون سے ا پنی فیلڈ سے14

 

ی ت

 

  کام لے تعلقہ ۔ ا س کے علاو ہ ا تٓ  ا نٹرپ

 

ا ، ا رٓ ت

 

ا ، ا شتہار  تیار  کری

 

  بنای

 

ر
ک
ے ہیں۔ جس میں کمرشل پرو گرا 

 

سکی

ے ہیں۔و غیرہ۔

 

سکی
 ا ین کا کام ی ا  ا پنی کوئی ا و ر  بنائی ہوئی چیز متعار ف کرو ا  کر پیسے بھی کما 

 

ز
پ 
 

 

 ا و ر  د

 :۔

 

ا ت

 

 کے قصانی

 

ی ت

 

پ
 ا نٹر 

 کمپیوٹر پر گزر ے گا جس سے ہو سکتا ہے۱

 

ٹ
ق
 کی و جہ سے ا ٓت  کا بہت سا ر ا  و 

 

ی ت

 

ا  ۔ ا نٹرپ

 

 ی کو پور ا  ی

 

ڈ

 

  ا پنی سپ

 

ٹ

 

پ
 

 

 گے۔ ئیں ہیں  د ے ی ا ئم کہ سٹود

 لا2

 

 فاتو  ی ا تون میں گزر  سکتا ہے۔ ئن۔ ا ٓن

 

ٹ
ق
گ میں بھی ا تٓ  کا بہت سا ر ا  و 

 

پ

 

پ ی  
ح
  

 ندگی 3

 

 ا ل سکتی ہیں۔جن کے ا ستعمال سے ا ٓت  ا پنی ر

 

 د

 

 پر ا یسی سا یٹس بھی موجود  ہیں جو ا ٓت  کی شخصیت پر منفی ا ثرا ت

 

ی ت

 

کے کسی ا ہم مقصد ۔ ا س کے علاو ہ ا نٹرپ

ے ہیں۔

 

سکی
 س ٹرت  ہو 

 

ے ہیں۔ا و ر  د

 

سکی
 سے د و سرے کی طرف ر ا ب ہو 

 پر کرا 4

 

ی ت

 

 ہیں  ر ہتا۔  Hackingیعنی ئمز۔ ا نٹر پ

 

 بھی محفوظ

 

ٹ

 

پ
 لاین ا کاو 

 

 چور ی ہو سکتی ہیں۔ ا س کے علاو ہ ا ٓت  کا ا نٓ

 

 سے ا تٓ  کی بہت سا ر ی معلومات
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ز ۔ و 5

 

پ
 ی تیزی ا س سا 

 

ز
پ 
 ر یعے 

 

 کے د

 

ی ت

 

  بھی پ

 

ا  ہے۔ٹ  و ئیرر

 

 سے ا ی ک کمپیوٹر سے د و سرے میں منتقل ہو جای

 و غیرہ۔ جن کو 0

 

 ا  د و ر  بھی کر سکتا ہے یعنی ا ٓت  کے ر شتے د ا ر  ، ا و ر  د و ست

 

ر یب کی د نیا سے تھور
ق
 ی ا د ہ ا ستعمال ا ٓت  کو ا پنی 

 

 کا بہت ر

 

ی ت

 

 کو ہو ۔ پ

 

ا ٓت  کی ا و ر  ا ٓت  کی ا ن

 ہے۔

 

 ی ا د ہ ضرو ر ت

 

 سکتا ہے ر

 ی ا د ہ 1

 

 یپریشن کا بھی شکار  ہو جاتے ہیں ۔ یعنی بہت ر

 

 کی و جہ سے کچھ خاص قسم کے د

 

ی ت

 

سے   Luxuries۔ ا س کے علاہ بہت سا ر ے لوگ میں نے د یکھا ہے کہ پ

 ندگی میں بھی ر ہنا شرو  ع کر د یتے ہیں۔

 

ے ہیں ا و ر  خیالون کی عجیب سے ر

 

سکی
 کر 

 

ر ا مو س
ف
س 

 

گی

ا ر 

 

 ندگی کے بہت سا ر ے ی

 

 متاثر ہو کر و ہ ر

 س ٹرت  ہو سکتا ہے۔    Glamour, Fashion۔ 1

 

لا کر سکتی ہیں جس سے و ہ د

 

 پ
می
 سے تعلقہ  بہت سا ر ی سا یٹس بھی بعض د عہ  کسی کو ا حساس کمتری میں 

3 

 

 کو حقار  ت

 

ت

 

 ا و ر  شناح

 

ا  ہے جس سے ہو سکتا ہے کہ ہم ا پنی و حدت

 

ما لک کی تہذیب ا و ر  ثقافت د کھای
ک
 ی ا د ہ تر ترقی ی ا فتہ 

 

 ا ٓت  کو ر

 

ی ت

 

سے د یکھنا شرو  ع کر ۔ ا نٹرپ

ا  پڑے۔و غیرہ۔

 

 ا ٹھای

 

 ند گی میں قصانن

 

 د یں ۔ جس سے ہمیں ا ٓیندہ ر

 بھی ہوتے ہیں ۔ و غیرہ ۔16

 

ا ت

 

ا  ہے۔ جس سے قصانی

 

ل جای
پ 
 ھ
ن

 بعض د عہ  کوئی جھوٹی خبر ا و ر  و ا قعہ بھی ا س سے تیزی سے لوگون میں 

 

LECTRUE-3 

: 

 

ر
 س
ن

 یوا 

 

 کے لیے ضرو ر ی د

 

ی ت

 

پ
 ا نٹر 

PC, MODEM, PHONE LINE or Wireless connection of internet. 

 و ر ک کا حصہ ہیں

 

ی ت

 

ز  لیں پ

 

پ
 د ے ر ہی ہیں جو و ا 

 

ٹ
ل
 کی سہو

 

ی ت

 

 د نون بہت سا ر ی موی ا ئل کمپنیان بھی ا نٹر پ

 

  EVO PTCL۔یسا ا ن

 

  ا

 

 کنکشن بنای

 

ی ت

 

پ
ا  ا و ر  ا نٹر 

 

ا ل کری

 

پ
ش

 

ن
 یم ا 

 

 ۔مود

 کے لیے ا ُٓٓ ت  یہ سیکھیں  گے  میںا ت  ہم ا تٓے ہیں ا پنے ا صل کور س کی طرف جس 

 

ٹ
ل
 کی سہو

 

ی ت

 

 یوا یس کیا ہے ۔ کمپیوٹر میں پ

 

 ج لانے و ا لی د

 

ی ت

 

کہ کمپیوٹر میں ا نٹر پ

 ٹرنل ا و ر  و ا 

 

ز
ی ک
 یم ہے ۔ یہ ا نٹرنل ، ا 

 

ا م مود

 

 یوا یس چاہیے ہوتی ہے جس کا ی

 

ز ا ٓت  کو ا ی ک ا یکسٹرا  د

 

پ
ا 

 

 لیس ی

 

پ
 ی ا د ہ ا ستعما ل 

 

  کے لیے ا نٹرنل ر

 

ا  ہے ۔ گھریلو یور

 

ٹ  کا ہوی

 ٹرنل

 

ز
ی ک
ا  ہے۔ ا ٓت  ا 

 

 کل ہوی

 

 کر د یتا ہے۔ا ٓج

 

کت

 

 سے کپ

 

ی ت

 

ا  ہے جو ا ٓت  کو پ

 

 یم ہوی

 

 ی ا د ہ تر و ا یر لیس مود

 

ا ت  میں ر

 

ے ہیں ۔ ا س کے علاہ لیپ ی

 

سکی
 مختلف بھی لے 

ے ہیں۔  MODEM USB کمپنیان

 

سکی
 ا ستعمال کر 

 

ی ت

 

ا ل ہے۔ جس کی مدد  سے ا ٓ ت  جہان ح ت  چاہیں پ

 

 یم کی ا ی ک مپ

 

 د ے ر ہی ہے یہ بھی و ا یر لیس مود

 

ٹ
ل
 کی سہو

 

 

ل کر و ا  ی ا  جامود
ی ک

 

ی کی

 پر

 

ا  ا ٓت  کو کلاس کے د و ر ا ن

 

ا  ا و ر  کنکشن بنای

 

ا ل کری

 

شپ

 

ن
 گا۔ ئےیم ا 

 WWW کا ا ستعمال۔ 

 

 ہ ا و ر  ا ن

 

  کا تعار ف، موا ر

 

ر

 

ج ی

 

ن

 ا 

 

و ر  کا تعار ف ۔ سرج
پ ل
ش
ی ک

 ا 

 

ی ت

 

پ
 ر   ا و ر  ا نٹر

 

ز ا و ر
پ 
 کیا ہے ؟و یب 

WWW or W3 پر 

 

ی ت

 

 ہے ا س کی مدد  سے ا ٓت  کے پیج کی پ

 

ت

 

 کی ا ی ک شناح

 

ی ت

 

 ممکن نتی  ہے۔ا صل میں ا نٹر پ

 

ت

 

  شناح

URLsر یس 

 

 :و یب ا ی ڈ

ر  د 

 

کی
ر  ا د ا ر ے ا پنے ا شتہار  میں یہ یکھتے  ا ٓت  ا 

 

کی
 ی ا   لکھتے  ہیں کہ ا 

 

 ٹ
پ
 کا جو ا ٓت  کا Urlہیں کہ ہمار ی و یب سا 

 

 کریں۔ یونیفار م ر یسور س لوکیٹر یہ ا س معلومات

 

 ت

 

پر و ر

  ہو گا۔ 

 

ز ا و ر
پ 
 ر یس ہے جس کی بنا پر ا ٓت  کا پیچ 

 

 ا ی ڈ

 

ا ر ت

 

 و  کھولے گا ا ی ک س

 

ز ا و ر
پ 
 .HTTP(hyper text transfer protocol)کے پیچھے  wwwو یب 

   HTTPہے ا و ر  ا س 

 

ت

 

 ہے۔ .URL (uniform recourse locator)کی شناح

The format of all URL is  
Type://address/Path/file.ext 
 
 
What is WWW or W3? 
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It is a map of text images, and other linked base files, that is use to show data and effects on the 
internet. 
And the language of www is html (will be discussed in web course) 
Law of World Wide Web (WWW) is HTTP (hyper text transfer protocol). 
And the code of HTTP is URL (uniform recourse locator). 
The format of all URL is  
Type://address/Path/file.ext 

ا  ا ٓ

 

 کیا جای

 

ت

 

 ر ی شکل ا ٓت  کے سا منے   HTTPہے جو ت  سمجھ گے ہیں کہ کسی بھی و یب پیج کو مین سرو ر  پر ا ی ک خاص فار میٹ میں شناح
ہ
ا 

 

 WWWہے ا و ر  ا س کی ط

  

 

 ہے۔ جیسے   URLجس کو کھولنے کا کود

www.ptv.comwww.yahoo.com,  www.ajk.gov.pk,    ت  یو ا رٓ  ا یل ہیں جن کی مدد  سے ا ٓت  ا ی ک و یب پیج کو کھول سکیں گے۔ی ا د  ر کھیں
یہ س

 ر یس ی ا ر  میں ا س کو 

 

ا ۔ ا ی ڈ

 

 ر  گز ہیں  ہوی
ہ
ٹ  ا س میں سپیس ی ا  کاما کا ا ستعمال 

 

پ
ا 

 

 کریں ا و ر  ا نٹر پریس کریں۔ی ا  کسی بھی سر ی

 

ا نجن کو کھولیں ا و ر  ا س میں ا پنی مطلوبہ  ج

 ر یس د یں ی ا  کچھ ا لفا

 

 کا ا ی ڈ

 

 ٹ
پ
۔سا 

 

 ظ

 

LECTRUE- 4 

س پر مشتمل ا ی ک فا

ک

 

لپ

  کر تے ہیں ا  کے  ا ندر  بہت سا ر ے ئلو یب پیج ا صل میں بہت سا ر ے ہاپر 

 

ز ا و ر
پ 
س   bookmarks ہے جس کو ا ٓت  

ک

 

لپ

ا و ر  ا س کے علاو ہ 

 ی  

 

ر
ک
 نک  پر ح ت  ا ٓت  ماو س پوا ینٹر لے کے جا ڈ ہوتے ہیں جن کو ا ٓت  کلک کرنے پر 

 

س ی ا  ا ٓپشن ی ا تے ہیں ا ن

ک

 

لپ

 ر  کرتے ہیں جن کو ا ٓ ت  ئنیہ ہاتھ کا سا  تو ئیں
ہ
ا 

 

 ط

  نک  ہیں۔ئپرکھولیں گے ۔یہ ہا

ز 
پ 
 ر ا ٓت  کے و یب پیج کو کھولنے و ا لا پرو گرا م و یب 

 

و ر ۔ ا و ر
پ ل
ش
ی ک

 ا 

 

ی ت

 

 ہے ، یعنی کھولنے و ا لا، جیسے ا نٹرپ

 کا ا ستعمال۔

 

 ہ ا و ر  ا ن

 

  کا تعار ف، موا ر

 

ر

 

ج ی

 

ن

 ا 

 

 سرج

 کرنے 

 

لاس

 

 ی

 

  ا صل میں کوئی بھی معلومات

 

ر

 

ج ی

 

ن

 ا 

 

ے سرج

 

سکی
 کر 

 

 میں کوئی چیز سرج

 

 کی مدد  سے ا ٓت  بغیر فل یو ا رٓ  ا یل د یے ا پنے ا لفاظ

 

 ر یعہ ہیں ا ن

 

 د

 

کے لیے ا ٓسا ن

 کر سکیں گے۔

 

 ت

 

س د یتے ہیں جن کو ا ٓت  و ر

ک

 

لپ

 ی ا د ہ 

 

  ا تٓ  کو ا ٓت  کی مطلوبہ چیز کے تعلق  ا ی ک سے ر

 

ر

 

ج ی

 

ن

 ا 

 

 ہیں۔ ا س کے علاو ہ سرج

 ی ا د ہ ا ستعما ل ہونے 

 

 کل ہمار ے ہان ست  سے ر

 

 ا نجن ا ٓج

 

و ر  کھولیں ا و ر  ا پنا ہوم پیج    Googleو لا سرج
پ ل
ش
ی ک

 ا 

 

ی ت

 

ہے ۔ یعنی ا ٓت  ا پنا ا نٹرپ

www.google.comیں۔ا ت  ا تٓ  کے سا منے  ا و پن کرGoogle  ا ٓپشن موجود  ہے ا س کو ا ستعمال کریں 

 

 .سرج

ے ہیں۔ ا س کا  Yahooد و سرے نمبر پر  

 

سکی
گ کے لیے ا ستعمال کر 

 

ے ہیں ا و ر  سرح پ

 

سکی
 ا نجن ہے ا س کو بھی ہوم پیج بنا 

 

 ر یس سرج

 

 ہے۔ www.yahoo.comا ی ڈ

 ا نجن ہے ۔ یہ بھی ا ستعما ا  و  سئیکرہے یہ ما www.msn.comپھر 

 

 ل کیا جا سکتا ہے۔ٹ  کا ا پنا سرج

  

 

ر

 

ج ی

 

ن

 ا 

 

 بھی د یتے ہیں  E.Mailا و پر د یے گے تمام سرج

 

ٹ
ل
 ی کی سہو

 

 ۔ا ٓئی د

 

LECTRUE-5 

 

 کریں۔ جس میں۔

 

 ت

 

  کی مد د  سے  و ر

 

ر

 

ج ی

 

ن

 ا 

 

ر ج
س
ش

 

ی ی

س:۔ مختلف ا د ا ر و ن کی و یب سا 

 

ی

 

مپ

 

ی

 

پ

 ا سا 

BBC, Karachiupdates, AJKgov, PTV, GEO News, Mouhsaib news, Nwai Waqt 
news, Muzafffarabad PICS,AJK university, PND AJK, Muzafffarabad ak.com, etc.  

 

<>><><<><>><<><> 

LECTRUE-6 

http://www.ptv.com/
http://www.ptv.com/
http://www.yahoo.com/
http://www.ajk.gov.pk/
http://www.google.com/
http://www.google.com/
http://www.yahoo.com/
http://www.msn.com/


171 

 

 ر یس 

 

و ر  کے چند ٹولز ۔ و یب ا ی ڈ
پ ل
ش
ی ک

 ا 

 

ی ت

 

پ
 Searching۔URLs ا نٹر

 Searching: 

  پر 

 

ی ت

 

پ
ا  ا نٹر

 

 کری

 

لاس

 

 :لوگون کو ی

 ا نجن میں جا کہ 

 

 ا نجن کی  Who is or Who is in Pakistanا س مقصد  کے لیے ا ٓت  گوگل سرج

 

لاو ہ ا ٓت  گوگل ی ا  کسی ا و ر  سرج
ے ہیں۔ ا س کے ع

 

سکی
 کر 

 

سرج

 کر سکیں گے۔

 

 مدد  سے بھی مختلف سا یٹس پر جا کر سرج

 

 

لاس

 

  کو ی

 

ا  ، مختلف سٹار ر

 

 کری

 

لاس

 

 ر یری ا ن ی ا  کتابیں  ی
پ ی

 

پ

 کے ا ند ر   لا

 

ا ، ی ا کستان

 

 و غیرہ۔  NGOs, Organizations, Federationsمختلفکری

 

LECTRUE-7 

  ا ی میل سے تعار ف ۔ جس میںG-Mail, Yahoo, Hotmail ا  ۔

 

 ی بنای

 

 ا ئٓی د

لاقے سے د و سرے ی ا 
 ر یعہ ہے ۔ ا س کی مدد  سے ا تٓ  بہت جلد ا ی ک ع

 

ا ی ک ملک سے د و سرے ملک میں ا پنا  ا ی میل کسی کو لیٹر ی ا  کوئی پیغام بھیجنے کا ا ی ک طا قتور  د

 پیغام سینڈ

 

 ا ک کا پرا ی

 

 کی و جہ سے خط ی ا  د

 

ٹ
ل
 یو بھی۔ یعنی ا ی میل کی سہو

 

 یو و د

 

ے ہیں ۔ ا و ر  ا س کے سا تھ کوئی ا یکسٹرا  ٹیکسٹ، ا ج، ، ی ا  ا ٓد

 

سکی
ا  سٹم کافی سست لگتا  کر 

ا  ہے۔

 

 ی ا د ہ تر یہی ٹول ا ستعمال ہوی

 

 کہ ا س د و ر  میں ر

 

 ہے۔ یہی و جہ ہے کہ ا ٓج

ا  ہو گا ۔ا 

 

 بنا ی

 

ٹ

 

پ
 س کے لیے ست  سے پہلے ا ٓت  کو ا پنا ا کاو 

 

LECTRUE-8, 9 

 

  ا ، )خصوصاً ا ی

 

ا ،ا ی ( Yahoo Messengerمیل پرو گرا م ج لای

 

  کری

 

ا ،  ا یمیل فار و د

 

ا ، ر ی ی للائے کری

 

 یلیٹ کری

 

میل کو ا ی میل بھیجنا، جوا ت  د ینا، د

ا ، ا س کے لیے

 

 Hot mail Alsoکا ا ستعمال۔ Outlook & Ms Word فار میٹ کری

  ر  میل پرو گرا م سے ی ا ا ی 
ہ

ا ۔

 

پ
کل

 

ن
 ر  
ہ
 ی سے ی ا 

 

ا ، ا پنی ا یٓ د

 

پ
کل

 

ن
 

LECTRUE-10,11 

 سے تعار ف۔ 

 

ی ت  ر یلے ح 

 

ی ت

 

 ا نٹرپ

 IRC یو )و یب کیمرہ( ۔ 

 

 یو ، و د

 

گ، ا دٓ

 

پ

 

پ ی  
ح

ا  ہے، تفریح، 

 

 پرو گرا م کیسے کام کری

LECTRUE-12,13 

 ا ، سئلزفا

 

  کری

 

 لود

 

 ا و ن

 

 ی ا  ئیرٹ  و  ا  د

 

پ ڈ
م
ز س، ملٹی 

 

پ
 یٹس۔، ا ینٹی و ا 

 

 ، ا ت  د

 

ر
ک
 پرو گرا 

 (س

ک

 

پ
ل

ر ی سرو سز۔URLs)چند ا ہم 
ف
 

 

ی ت

 

 ا و ر  ٹرکس، ا نٹرپ

LECTRUE-14,15 
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 جا 
 

پ
 ہ

 

  Practiceز

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

CHAPTER 21 :   WEB DEVELOPMENT & DESIGN 

 
LECTRUE-1 

 لا

 

 ۔ئنکور س ا وٓ ت

  

 

 .تعار ف ا و ر  و یب سے تعلق  معلومات

  ،و یب پیج& DHTML HTML ،گ

 

 ی

 

 ، کود

   ،فار میٹنگlinking ،س،جاو ا  سکرپٹس

 

پ ی

 

س

 ، سٹائل 

 Browser, Front page 2002 & Adobe Dream Weaver Cs5 

  ا ۔

 

 پیج میں خالی پیجز پر کام کری

 

ٹ

 

پ
ر 
ف
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 ا ۔

 

 پیج میں ٹیکسٹ پر کام کری

 

ٹ

 

پ
ر 
ف

 

 Hyperlinks پیج میں 

 

ٹ

 

پ
ر 
ف

 ا کونٹ  کو .

 

  پرو سیسر میں د

 

ا  HTMLا یم ا یس و ر د

 

ا ۔ا و ر  نک  بنای

 

 فار میٹ میں سیو کری

 Bookmarks پیج میں 

 

ٹ

 

پ
ر 
ف

. 

 پیج کے 

 

ٹ

 

پ
ر 
ف

  سے تعلقہ  مختلف ٹولز جو ہمیں و یب میں چاہیں۔ مختلف

 

  ا و ر  ی ا ر ر

 

س۔ جس میں مینور

 

پ ی

 

پ

 کمپو

 ا ۔

 

 ٹیبلز پر کام کری

 ا و ر  کاملز ٹیبل پرا پرٹیز۔ ، 

 

 سلز، ر و ر

 ا ۔

 

  پر کا م کری

 

ر
ک
 فار 

 :  

 

ر
ک
 & Photo Impact 12, Gif Animator, Swish Max2, Cool 3D production Studioو یب سپور ٹنگ پرو گرا 

other web related tools  

  ا ینگ۔ 

 

ز
پ 
 

 

گ ا ینڈ د

 

پ

 

 ی ی

 

ا  ا ی ڈ

 

 ا ج،  پر کام کری

 

 پ کت
می
 
ن

 فوٹو ا 

 ا ۔ و غیرہ

 

 ا ین کری

 

ز
پ 
  

 

 د

 

 کا لے ا وٓ ت

 

 ٹ
پ
ا  ا و ر  و یب سا 

 

 بنای

 

ن

 

 ش
می

 

پ ی

 میں ا 

 

 پ کت
می
 
ن

 فوٹو ا 

   ر ا 

 

ا  12کور ل د

 

 .میں کام کری

 Gif Animation ا ۔

 

ا یٹل بنای

 

 ا و ر  ٹیکسٹ ی

 

ن

 

 ش
می

 

پ ی

 میں ا 

 Swish Max   

 

ن

 

 ش
می

 

پ ی

 .میں ا 

 Cool 3D production  

 

ن

 

 ش
می

 

پ ی

 میں ا 

 ا ۔

 

س بنای

پ ی 
م

 ا ج،  

 ا ۔

 

ر یم پیجز بنای
ف

 

  معا ل۔ ہوئےبنے

 

سی
 پیجز کا ا 

 ک ر سا ئی لینا۔

 

 سرو ر  ی

  ا

 

 کری

 

س

 پ ل
پ

ر ی ا و ر  پیڈ سرو ر  پر 
ف
 کو 

 

 ٹ
پ
 .ا و ر  و یب سا 

 و یب پیج کیا ہے؟

Web page is source of displaying text, images, and media & to use for sharing knowledge & 
creative work to the whole world. And you know that internet is main source for this purpose. 

ا  ہے؟ا ٓ و یب پیج کن 

 

 یٹمز پر مشتمل ہوی

گ  

 

 ی

 

 ی ا  کود

 

و ج
گ

 

 پ
لی

و  HTML(Hyper Text Markup Language)ی ا د  ر کھیں و یب پیج کی ا صل 
گ

 

 پ
لی

 ہے جس کی مدد  سے مین سرو ر  ا ٓت  کے پیج کو یججو ا ی ک 

  

 

ڈ

 

ا  ہے ۔ ا تٓ  جانتے ہیں کہ کمپیوٹر کے بیک گرا و ی

 

  کری

 

و  مختلفر ی ڈ
گ

 

 پ
لی

 

 

ز
ج 
 
ی

 

پ

ا  ہے ۔لیکن ا ٓت  جانتے  

 

  کو حل کری

 

ر

 

س
ک

و ر ک کرتی ہیں ا نہی کی بنیاد  پر کمپیوٹر ا تٓ  کی ا نسٹر
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ا  ہے ۔ ا س کا 

 

گ کری

 

 ی

 

و یج سیکھنی ہو گی۔ ہیں  کیون کہ ا یسے ہیں کہ کمپیوٹر کے ا ندر  ست  سے پیچیدہ کام کود
گ

 

 پ
لی

مطلب یہ ہوا  کہ ہمیں و یب پیج بنانے کے لیے یہی 

  موجود  ہیں جن کی مدد  سے ا تٓ    ئیربہت سا ر ے سا ٹ  و 

 

ا  کہ ہم  Visual Programmingر

 

گ ا ینڈ و یول ی

 

 ی

 

ے ہیں ہم د و نون سیکھیں گے۔ یعنی کود

 

سکی
کر 

ز  بن سکیں۔
 پ ل
پ

 و 

 

 پرو فیشنل و یب د

  کرتے ہیں تو ا ٓت  نے د یکھا ہوگا کہ ا ٓت  ا ی ک   ا یٓٹم ی ا  بٹن پر کلک کرتے ہیںد و سری ا ہم ی ا 

 

 یور

 

ی ت

 

ا  ہے تو ا ٓت  پ

 

 س پلے کیا کری

 

 کہ ا ٓت  کا و یب پیج د

 

 ی   ت

 

ر
ک
 ڈ  تو ا س کے 

 لیتے ہیں۔ 

 

 ا پٓشنز ی ا  بٹن کھلتے ہیں جن کی مدد  سے ا ٓت  تعلقہ  معلومات

So simply we can say that web page consists of different links (hyperlinks), horizontal & Vertical 
Bars, Menus, Banners & text (Animated & none animated 

 

گ و یب:

 

 پ
ی لی
  س 

 

 وفر س ا ٓف د

Internet, LAN, WAN, Servers. 

 و یب پیج کی ا قسام کیا ہیں؟

 ,Personal, corporate, institutional, informationalو پ ی ت  پیج مختلف مقاصد کے لیے بنائے جاتے ہیں۔ جن میں

entertainment etc. 

LECTRUE-2 

 کیا ہے؟

 

 ٹ
پ
 ا و ر  ا فاد 

 

 و یب پیج کی ضرو ر ی ا ت

ر ا د  کا  
ف
 د و  حوا لے سے ہے۔ و یب میں د و  ا 

 

 ٹ
پ
 ا و ر  ا فاد 

 

ا  ہے۔  point of Viewو یب کی ضرو ر ت

 

 د یکھنا ہوی

 ا ینر کا پوا ینٹ ا فٓ و یو۔( و یب ۲    (۔ د یکھنے و ا لے کا پوا ینٹ ا ٓف و یو۔۱

 

ز
پ 
 

 

 د

 

 (۔ د یکھنے و ا لے کا پوا ینٹ ا فٓ و یو۔:۱

لًا۔  

 

س
م
 ر ا ئع سے ملیں۔ 

 

 د

 

 جو ا س کو کسی ا ٓسا ن

 

  ر  چاہتا ہے معلومات

 

سا یٹس  مختلفا و ر  ا س میں  . News paper sites, TV, Radio, commercialیور

 

 

 ر  کو مختلف مقاصد کے لیے سا یٹس ا ٓیود

 

ا  کہ یور

 

ا  پڑتی  ہیں ی

 

 پہنچا سکیں۔ جن میںی لت  کری

 

 ۔سا نی سے معلومات

Education: Universities, Colleges, & online web sites. 
Entertainment: Games, sports, Music & Movies. 
Communication: Buying & selling products etc. 

 

 ا ینر کا پوا ینٹ ا فٓ و یو۔۲

 

ز
پ 
 

 

 :( و یب د

 پہنچا

 

ا  کہ معلومات

 

 یپار ٹمنٹ کی، تعلیمی جن میں ئیںجا ئیی

 

 ا و ر   ئےد ا ر و ن، مذہبی و  سماجی و غیرہ۔ ا و ر  ا پنی ر ا  ا  کسی خاص شخصیت سے تعلقہ ، کسی د

 

ا پنے خیالات

ا مل ہے

 

ا  بھی ا س میں س

 

ک پہنچای

 

 .کام کو د و سرو ن ی

 

 ا ینر کا وفر  س ا فٓ ا نفار میشن ا نٹر چینج:۔ 

 

ز
پ 
 

 

 د یکھنے و ا لےا و ر و یب د

 ر ا 

 

 سے د

 

 ہیں جن کی مدد  سے یہ د و نون ا شخاص یہ کام سرا نجام د یتے ہیں۔ ئعیعنی و ہ کون

 ہ کرتے ہیں

 

 د یکھنے و ا لے تو موا ر
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 ٘Media, TV, Newspaper, Maps, Books VS Websites, Area & ranges, time of View. 

 ا ینز کا وفر  س ہے :

 

ز
پ 
 

 

 و یب د

HTML Software   ا  ہے جس میں و ہ ا پنی ا و ر

 

ک پہنچای

 

 ر  ی

 

  جو ا ی ک د و سرے سے نک  ہیں کو ا ی ک یور

 

 ر
ج ی
پ ی 

 پر بنی  مختلف 

 

جن کی مدد  سے و ہ بہت سا ر ی خصوصیات

ا  ہے۔

 

 کی عکاسی کری

 

 ی ا ت

 

 د یکھنے و ا لے د و نون کے ج ڈ

HTML سے تعار ف:۔ 

The language used to develop web pages is called hyper text markup language. HTML is 
interpreted by the browser. You can see internet explorer open your page in totally different mode 
after saving your code in html format.  

 

: 

 

ز
پ گ

 

پ

 “<”, “>” 

و یج مختلف
گ

 

 پ
لی

  ہے ۔ یہ ہمیشہ  یہ 

 

  پر بنی  ا ی ک وفر س کود

 

 ر

 

 سا  <>کود

 

 لکھی جاتی ہے۔ئنزا ن

 

  کے د ر میان

First HTML Assignment: 

 ہم ا پنے و یب پیج کو ی ا قاعدہ 

 

ی ت  کریں۔ نیچے HTMLا ٓج

 

ا پ

 

  ی

 

 ر

 

 پیڈ کو ا و پن کریں ا و ر  ا س میں جا کر یہ کود

 

ا  شرو ع کریں گے۔ ست  سے پہلے ا تٓ  نوت

 

کی مدد  سے بنای

ا  ہون گے۔شرو ع میں ا ٓت  کو یہ 

 

ا مل کری

 

 ر  پیج میں یہ س
ہ
  کسی بھی و یب پیج کا ا ہم حصہ ہیں ا و ر  ا ٓت  کو 

 

ی ت  کیے گے کود

 

ا پ

 

 ر  و یب  مشکلی
ہ
لگے گا لیکن ہم نے ا ی ک ما

 
 
پ

 و 

 

 د

 

 ٹ
پ
 پیج میں تو و یب سا 

 

ٹ

 

پ
ر 
ف
ر  لوگ کہتے ہیں کہ و ہ 

 

کی
ا  چاہیے۔ ا 

 

ا  ا ٓی

 

گ ا و ر   د و نون طریقون سے و یب پیج بنا ی

 

 ی

 

ز  بنا ہے ا س لیے ہمیں کود
پ ل

 تو  

 

بنا لیتے ہیں ی ا ت

  ا و ر  

 

ا ا للہ کود

 

س

 

ن
  کی مدد  سے کر کہ د کھائیں ہم ا 

 

 ر

 

ٹ  ہے کہ و ہ کود

 

پ
Visual  ر 

ہ
 ا ینر کے لیے ضرو ر ی بھی ہے  د و نون طریقون سے بنائیں گے۔ ا و ر  یہ ا ی ک ما

 

ز
پ 
 

 

و یب د

 ا 

 

ز
پ 
 

 

ا  ہےہ کہ د

 

 ر  کہا جای
ی لی
 و 

 

ر  جگہ ی ا قاعدہ و یب د

 

کی
 ۔ئیر۔ا و ر  جات  کے لیے تو ا 

HTML is set of codes determining what a page will look like in a web browser; HTML files must 
have a HTM or HTML extension. HTML is the language that tells the browsers how to display a 
webpage on computer screen.   
<html> 
<head> 
<title>mcsit</title> 
<body> 
</head></body></html> 

 
Must Be Save With .html Extension 

 کو  ٖٓت  غور  کریں ا ٓا

 

گ ئنسا   ”/“خر میں ہم نے ا ن

 

 ی

 

  کیا ہے ا س کو لوزر

 

ا  ہے۔ ا س کو ح ت  سیو کریں گے تو ہمیشہ  ٹیگ سے لوزر

 

فار میٹ میں  abc.htmlکہا جای

 لیتے ہیں۔

 

ا  ہے۔ ہم سٹار ت

 

 سیو کری

ا 

 

  ی

 

 یہ کود

 

پ
 ٹ  کریں۔ا س میں ہم بہت سا ر ی فار میٹنگ بھی سیکھیں گے۔ 

<html> 
<head> 
<title>my first web page</title> 
<body bgcolor= black text= white> 
</html> 
</head> 
</body> 

ے ہیں۔

 

 ھی
چ
س

  کو 

 

ز
پ گ

 

پ

 

 

ا  ہو گا۔ ا س لیے ہم ا ن

 

  لینا ہو گی ا و ر  ا س کو بھی ٹیگ کی مدد  سے کنٹرو ل کری

 

ڈ

 

 ر  کام کے لیےا ی ک خاص کمای
ہ
 ا ت  ہمیں 
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HEAD…..</head> 

 ے کسی بھی کیس میں

 

ز
پ 
گ بھی۔ا ٓت  ا س کو چھوٹے 

 

 ی

 

ا  مسٹ ہے ا و ر  لوزر

 

ے ۔ ا س حصہ میں ہم نے کچھ ہیں  لکھنا لیکن ا س ٹیگ کا ہوی

 

سکی
 لکھ 

<title>…..</title> 

ا ل د یکھیں گے۔

 

ا یٹل ی ا ر  میں آتا ٓئے گا ا ٓگے ا س کی مپ

 

ا م ی

 

 ا س کی مد د  سے ا ٓت  کے و یب پیج کا ی

<body>…</body> 

 ی ڈ  

 

ر
ک
ا  ہے۔ا س کے ا ٓگے 

 

ا  ہوی

 

لًا ہیں یعنی ا یسے ا ٓپشن جو ا س ٹیگ کی Attributesیہ بہت ا ہم حصہ ا صل میں ہم نے تما م کام ا سی حصہ میں کری

 

  پرا پرٹیز ہیں ۔مپ

 

<html> 
<head> 
<title>My home page</title> 
<body bgcolor=black text=white> 
Naveed here…………..Hi! 
<body background= “image.gif” text=red> 
</html></head></body> 

 د یکھیں۔HTMLا س کو ا تٓ  

 

ٹ
ل
 

 

 ر  میں ا س کا ر ر

 

ز ا و ر
پ 
 فار میٹ میں سیو کریں ا و ر  

 

<><><><><><><><><><><> 

 

 

LECTRUE-3 

 

 فار میٹنگ:

<B>…..</B><i>….</i><U>….</u><p>…..</p> 

لًا 

 

گ کے لیے ا ستعمال ہوتے ہیں۔جو ٹیگ کے ا ندر  لکھے گے ٹیکسٹ کو و ہ فار میٹ د ے د یتے ہیں۔ جو ا ٓت  بتائیں۔مپ

 

 پ
می
  ٹیکسٹ فار 

 

ز
پ گ

 

پ

 ر  یہ تمام 

 

ڈ

 

پ ک، ا ی
ل

 

ی
بولڈ، ا 

گ کے لیے  P ا و ر  پیرا گرا ف کے لیے ئنلا

 

گ سٹا0ا سی طرج ہیڈی

 

ک ہیڈی

 

  ہیں جن کے لیے ا ٓت  ئللیول ی

<h1>…..</h1> ,<h2>……</h2>, <h3>…ا ستعمال کریں گے۔  

<BR>…</BR> and <hr>…</hr> 

  کو سمجھیں۔کلاس کے د و ر 

 

ز
پ گ

 

پ

   پر کام کریں ا و ر  تمام 

 

 ر ا  کرنے کے لیے ا ستعمال ہوتے ہیں۔ا س کود

 

ز ی ک ا و ر  سیدھی لائن د
پ 
 ا تٓ  کو تفصیلی بتا ی ا  جائے یہ ٹیگ پیج 

 

ا ن

 گا۔

 
<html> 
<head> 
<title>My Web page</title> 
<meta name=“keywords” content =“text, formatting, bold, paragraph”> 
</head> 
<body bgcolor=black text=white> 
<h2>Welcome to my page</h2> 
<p>Here is the beginning of the paragraph. Notice there is no automatic indentation.</p> 
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<hr> 
<h2>Whats up</h2> 
<h4>Good evening</h4> 
<p align =center>In this paragraph you‘ ll apply some formatting such as  
<b>bold</b><i>Italics</i><u>underline</u<S>Strike</s><blink>Blink</blink>and so on</p 
<h3 align=left>My Kahsmir</h3> 
</body> 
</html> 

 ا س کی بھرپور  پریکٹس کریں۔ 

 

س پر کام کریں ا و ر  کلاس کے د و ر ا ن

 

پ لی
 م
ی

 

پ

 ا س طرج کے مختلف 

<><><><><><><><><> 

LECTRUE-4 
Other Text Effetcs: 

<center>…………..</center> ,  

ا مل کریں گے۔تو ا و پر د ی ا  گیا ٹیگ

 

 پیڈ میں س

 

 کو نوت

 

  ہیں  لکھون گا ۔ لیکن ا ٓت  ہمیشہ ا ن

 

 ر

 

 می کود

 

  میں ، میں لار

 

 ر

 

 کسی بھی ٹیکسٹ کو ا س کے بعد ا نٓے و ا لے کود

 میں کر د ے گا۔ 

 

 د ر میان

Font faces: 

<font face= “time new Roman” size=12 color=red>Welcome to Muzaffarabad The city 

of Mountains</font> 

 ،  می د ے گا۔ ا س کے علاو ہ پیچھے تمام ٹیگ ا سی ترتیب میں ا ستعمال ہون گے جیسے ا ٓ ت  ا گرا

 

ز
پ 
 ، سا 

 

ٹ

 

پ
ا  چاہیں تو و پر د ی ا  گیا ٹیگ کسی بھی ٹیکسٹ کا فا

 

 ا س کو بولڈ کری

 

 

 کر د یں۔کلاس کے د و ر ا ن

 

ن

 

ش

 

پ ی
م

 کا ٹیگ ختم ہو ر ہا ہے و ہان پر د و سرا  ٹیگ 

 

ٹ

 

پ
 کو ملا کر جہان پر فا

 

  کے سا تھ ا ن

 

ز
پ گ

 

پ

ا س کی پریکٹس کریں۔ا و ر  ا و پر د یے گے تما م 

 ا ستعمال کریں۔

Lists 

 کی تین ا قسام ہیں۔

 

 یہ بھی بہت ا ہم ہیں ا ن

Unordered List 

Ordered Lists 

Definition Lists 

 کا ا ستعمال سیکھتے ہیں۔

 

 ہم ا ن

Unordered List 

لًا۔ا س کی مد د  سے ا ٓت  کسی بھی لکھے گے ٹیکسٹ 

 

س د یں گے۔مپ

 

ی لی

 کو 

<ul type=square> 

<li type=circle> 

 ر  ا یٓٹم کے سا تھ<Ul>ا س میں ا تٓ  ست  سے پہلے 
ہ
لًا۔ <li>ٹیگ د یں گے ا و ر  سا تھ ا س کو سٹائل یعنی کس طرج کی بلٹ د یں گے۔پھر ا ٓگے 

 

 ٹیگ د یں گے۔مپ

 

<ul> 
<li>Lions 
<li>Tigers 
<li>Bears 
</ul> 
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Ordered Lists(OL) 

<ol Type=A/I/i> 

<ol Start=10> 

<li type=i value=7> 

 ر  ہے یہ کسی بھی ٹیکسٹ کو ترتیب میں نمبر د ے گا۔ 
ہ
ا 

 

ا م سے ط

 

 یسا کے ی

 

  کی پریکٹس کریں

 

 ۔ا س کود

<OL Type=I> 
<LI>Top Level Item 
<LI>another Top Level Item 
<OL Type=A> 
<LI>A second Level item 
<LI>Another second level Item 
<OL Type=1> 
<LI>A third Level item 
</OL> 
<LI>Another second level item 
</OL> 
<LI>A top level item 
</OL> 

 پھر ا ٓ جاتی ہیں :

 

 کے

 

لًا ا ی ک ا یٓٹم لکھا ا و ر   یہ لسٹیں تعریفات

 

ا  چاہتے ہیں تو یہ لسٹ ا ستعمال کریں گےلیے مپ

 

 ی ڈ  تشریح کری

 

ر
ک
 .ا س کی 

LECTRUE-5 

 

 

ا ت  ہم د یکھتے ہیں کہ کسی و یب پیج میں تصاو یر کے لیے کون

 سے ٹیگ ہوتے ہیں۔

<IMG> 

پرا پرٹیز بھی ہیں جن کو سا تھ ا ستعمال ا س ٹیگ کے سا تھ ا س کی 

ا  ہے۔

 

ا  ہوی

 

 کری

<IMG align=center border=1 height=50 hspace=0 
src= “img.jpg” width=400> 

ا م 

 

ا و پر د ی ا  گیا ٹیگ کسی بھی و یب پیج میں ا ج،  کی جگہ تصویر کا ی

 س پلے کر د ے گا ، و ہ ا ج،  ا ٓت  کے ا سی فولڈر  میں 

 

لکھیں تو و ہ د

<html> 
<head> 
<title>Displaying Images</title> 

<dl> 
<dt>term1 
<dd>Description of term1 
<dt>term2 
<dd>Description of term2 

</dl> 

<ol> 
<li>First ITEM 
<li>Second ITEM 
<li>Third ITEM 
</ol> 
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ا  چاہیے جہا

 

ن پر ا ٓت  ا پنا و یب پیج سیو کر ر ہے ا س کے لیے ہوی

  کا ا ی ک فولڈر  بنا لیں ا و ر  تمام تصاو یر جو ا ٓت  

 

ز
ج 
 
می

ا ٓت  ا لگ سے ا 

 پیڈ کی 

 

ا  چاہتے ہیں و ہان پر ر کھ د یں بعد میں نوت

 

پیج پر د کھای

 ر یس د یں گے تو و ہ د ی گئی پرا پرٹیز کے 

 

فائل میں صرف ا س کا ا ی ڈ

 س پلے ہو جائے گا۔

 

 مطابق د

<body background= “image.jpg”> 
<B>See here my PICS</b> 
<IMG src= “image.gif”><br> 
<img border=3 src= “image.gif”> 
</body> 
</html></head> 

  کو ا 

 

 لائی کریں۔ی  ا و پر د یے گے کود

 ر و ن 
ھی
 

 

فار میٹس ہیں تصاو یر کے فار میٹس۔ یون تو تصاو یر کے د

لًا 

 

 مپ

.bmp, .jpg,.jpeg, .gif, .png,  

 ر  کی مناست  سے کچھ خاص فار میٹس کی 

 

ز ا و ر
پ 
لیکن و یب پیج پر 

ً ہلکے فار میٹس میں ہون  ا 

 

پ

 

ی ی
س

 

ن
تصاو یر ہی ر کھائی جا سکتی ہیں جو 

ا ئم ہ لگے۔ ا س لیے ا ٓت  صرف 

 

 ی ا د ہ ی

 

 ر

 

ٹ
ق
  ہوتے و 

 

ا و ر  پیج کو لود

.jpg,..gif, .png ا م کے ہی ا ستعمال کریں، ا

 

 ر  تصو یر کے ی
ہ
و ر  

 کریں۔

 

ن

 

ش

 

پ ی
م

 تصو یر کے بجائے ئنکا سا  altبعد ا س کو ضرو ر  

 د ے گا۔

 

 ا س کی معلومات

<IMG src= “Roomi.jpg”> 
<img alt= “the PICS” src= “image.gif”> 
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ے ہیں ہا
ھ

 

ی کی

 ہیں۔ ئپرا ت  ہم د 

 

ا  جو و یب پیج کی ا صل پہچان

 

س بنای

ک

 

لپ

 

<a href=“nextpage.html”> this is a link</a> 
Blue & Underlined 
href  hypertext reference 
Not only documents, image file, video, audio and many others 
<ahref=“http://www.msn.com/products.html”> click</a> 

 

 ٹیگ کی مدد  سے ا ٓت  ہائپر نک <a>ا و پر ا ٓت  د یکھ ر ہے ہیں کہ 

ے ہیں۔ ا س میں سا تھ 

 

سکی
 ل کوٹس میں و ہ hrefبنا 

ی
 

 

ا و ر  پھر د

 ر  

 

ز ا و ر
پ 
وفر س فایل جس کو کھولنا ہے و ہ د یں گے پھر و ہ بٹن و ہ 

لًا۔

 

 میں آت ا ٓئے گا مپ

نے د و  مختلف پیج بنا د یے ہیں ا ت  ا ٓت  ا ی ک ہی پیج پر ا س کو ا س 

 یل کو فالو کریں۔

 

 د

 

ا  چاہتے ہیں تو د ر ج

 

 نک  کری

جس پیج پر کھولنا ہے و ہ ا ٓت  کا abc.htmlا ٓت  کا پہلا پیج ہے 

index.html  یکس پیج پر پہلے پیج کو نک 

 

ڈ

 

پیج ہے ۔ ا ت  ا ٓت  ا ی

گ کریں گے۔ا س میں مائی پیج 

 

 ی

 

کرنے کے لیے سا منے و ا لی کود

ا م ہے جس پر کلک کرنے سے ا ٓت  کا پیج ھلے گا 

 

ا ٓت  کے نک  کا ی

 
 
 
 
<a href= “abc.thml”>My page</a> 
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ہم پیجز بنا کر ا س کی پریکٹس کریں۔یہ بہت ا  مختلفا ت  ا ٓت  

 ہے۔

ا :یعنی ا ٓت  

 

پر  ا ج، کے بجائے کسی بٹن ی ا   ٹیکسٹتصویر کا نک  بنای

  گئے یےکلک کریں تو و ہ پیج کھل جائے۔تو د یکھیں۔سا منے د 

 

ز
پ گ

 

پ

 کو ا ستعمال کریں ۔

<a href ="interests.html"><img width=120 height=30 
src="images/b1.jpg"></a><br><br> 

<a href = "education.html" ><img width=120 
height=30 src="images/b2.jpg"></a><br> 

ا کہ ا ٓت  کسی بٹن پر کلک کریں تو تعلقہ  ا ی میل کمپو

 

گ ی

 

 ی

 

ر

 پرو گرا م خود  بخود  کھل جائے۔

E-mail Link: 
<b>Click Here to send your feed back: <h3> 
<ahref="mailto:njustgue@yahoo.com"> 
1.njustgue@yahoo.com</a><br></b></h3> 
<b><h3> 
<a href="mailto:naveed58@hotmail.com"> 
2.naveed58@hotmail.com</a></b></h3> 

 تو یہ ہے کہ ہم ٹیبل کو ا س لیے ا ستعمال 

 

ی ی ا ت

 ہل
ن

: 

 

ر
ک
ٹیبلز ا و ر  فار 

  کو ئی بھی چیز ا س کی ا لاین  ٹیکسٹکرتے ہیں کہ ہمار  

 

ز
ج 
 
می

ی ا  ا 

ا  نٹ  ٹھیک

 

 کری

 

 ر ہے۔ و ر ہ ہمیں کسی بھی ا و بجیکٹ کو سی ت

ا  ہے۔

 

 ا  مشکل ہو جای

 

ز
پ 
 بعض د عہ  

LEC-7 
 

<Table> 

 ی ڈ  

 

ر
ک
ٹیبل کے لیے د یکھیں سا منے۔ ا س کے علاو ہ ا س کے سا تھ 

  کو 

 

ز
پ گ

 

پ

 تمام 

 

پرا پرٹیز ٹولز بھی د یے گے ہیں جو سا منے ہیں۔ا ن

لًا۔

 

 ا ٓت  کو سمجھای ا  جائے گا مپ

 

 کلاس کے د و ر ن

<TR> کوئی بھی ر و  لینے کے لیے۔ٹیگ 

<TH>گ کے لیے۔

 

  ی ا  ہیڈی

 

 پہلے فیلڈر

<TD>کے لیے۔  

 

ر
م
ل

 ی ڈ  کا

 

ر
ک

 

 <TR>ا س طرج ا تٓ  

 

  لیتے جائیں ا و ر  ا ن

 

ٹیگ  کی مدد  سے ر و ر

<TD>  لیں ا و ر  

 

ر
م
ل

 ر   ٹیکسٹکی مدد  سے کا
ہ
 ا لتے جائیں۔ا و ر  

 

د

گ ٹیگ ضرو ر  لیں۔

 

 ی

 

 ا ی ک سا تھ ا س کا لوزر

 

 

<<center><table border=thin bordercolor=solid 
bgcolor=silver></center> 

<<tr> 
<th>S#</th> 
<th>Name of the position 
</th><th>Organization</th><th>Period</th> 
<tr > 
<td>1</td><td><I>Data Entry operator 
+Translator</td> 
<td>International Organization UNICEF</td> 

td>6 months</td>> 
<<tr > 

<td>2</td><td><i>Office Assistant/computer 
operator</td> 
<td>National Institute of Computer Research 

NICR</td><td>5 Months</td></i>> 
<<tr align=center><td>3</td><td><i>Computer 

Instructor*</td><td>Prime Institute of Computer 
Sciences (PICS)</td><td>4 years Continuous 

</td></i>> 
<<tr align=center><td>4</td><td><i>Security 

Officer*</td><td>Inter Services Intelligence  
(ISI)</td><td>Continuous </td> 

<tr align=center> 
<td>5</td><td><i>Computer Instructor*</td><td>Al 
Furqan Welfare Association</td><td>Continuous 

</td>> 
/<table> 
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FORMS 
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<html> 
<head> 
<title>Feed Back</title> 
<body background="images/ba.jpg" > 
<img align=left height=100 width=150 src="images\3.jpg"><h3>Feed Back</h3> 
<hr align=center size=6 color=black></center><br> 
<i><marquee scrollamount="4" behavior="scroll"><font face="sirif" color=white>This is not 
important taht you make thousand friends in a year important is to make a friend for thousand 
years...<br></marquee></font></i> 
 
<form method="post" action=""> 
Name <input type="text" size="24"> 
Address <input type="text" size="30" > 
Country 
<select> 
name="Country"><option>Select</option><option>Pakistan</option><option>India</option><opti
on>USA</option><option>UAE</option><option>UK</option><option>Other</option> 
</select><br><br> 
Location 
<select> 
name="Country"><option>Select</option><option>Muzaffarabad</option><option>Islamabad</o
ption><option>Lahore</option><option>Karachi</option><option>not in 
Pak</option><option>Other</option> 
</select> 
&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbspOccuption 
<select> 
name="Occuption"><option>Select</option><option>Study</option><option>Govt.Job</option><
option>Business</option><option>Professional</option><option>Teacher</option><option>Othe
r</option> 
</select> 
&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbspDate Of Birth  
<select name="date of Birth"><option>Select</option><option>1960-70</option><option>1970-
80</option><option>1980-90</option><option>1990-95</option> 
</select> 
<br><br>Your Hobbies 
<input type="radio" name="Hobbies" value="Books Reading">Books 
<input type="radio" name="Hobbies" value="Traveling">Traveling 
<input type="radio"  name="Hobbies" value="Sports events">Sports Events 
<input type="radio" name="hobbies" value="Software Games">Software Games 
<input type="radio" name="hobbies" value="Others">Others<br><br> 
What is your opnion about my website 
<input type="checkbox" name="Province" value="Excellent">Excellent 
<input type="checkbox" name="province" value="Good">Good 
<input type="checkbox" name="Province" value="Better">Better 
<input type="checkbox" name="Province" value="Best">Best 
<input type="checkbox" name="Province" value="Don't know">Don't know<br><br> 
Would you like to say something? <br> 
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<center><textarea rows="6" cols="28" wrap="physical" name="comments"> 
Enter Comments Here 
</textarea><br><br> 
<input type="submit" value="submit"> 
<input type="reset" value="reset"> 
</form> 
<text area rows="5" cols="20" wrap="physical" name="comments"></form> 
 

<><><><><><><> 

LECTRUE-9 
Cascading Style Sheet (CSS) 

 

 

ہم نے و یب کے کافی سا ر ے ٹولز کو سمجھا ۔ ا ی ک ا ہم ی ا ت

ا  

 

 ر  جگہ ا لگ ا لگ فار میٹس بتای
ہ
کہ ہمیں فار میٹنگ کے لیے 

 

 

 ت

 

  و یب پیج و ر

 

پڑتے  ہیں لیکن ا گر ا ٓت  ا ی ک سٹینڈر د

کریں تو ا ٓت  د یکھیں گے کہ ا س کے ا ندر  تما م کی تمام 

  و غیرہ ا ی ک ہی طرج 

 

ز
پ 
 ، سا 

 

ٹ

 

پ
ا  ہے فار میٹنگ یعنی فا

 

کا ہوی

 ہے ۔ ا س کے لیے ہمار ے ی ا س ا ی ک 

 

جو ا ی ک بہتر ا پرو ج

 ا ٓپشن موجود  ہے ا و ر  و ہ ہے سی ا یس ا یس:

 

ز د ست
پ 
 

 

 بہت ر

 می ن
ہ
 مختلفپشن د یتا ہے کہ ہم نے ا ٓا صل میں یہ 

کو ا ی ک خاص ترتیب میں بنا کرا ی ک جگہ  سٹائلزفامیٹنگ 

ر کھ د ی ا  ا لگ سے فائل بنا د یں ی ا  ا ی ک ہی کو بنا کر جہان 

 پڑے ا س کو کاپی پیسٹ کر لیں۔ تو ا س سے ا ی ک ضرو 

 

ر ت

ا  پڑے گی د و سرا  پور ے 

 

تو ہمیں ی ا ر  ی ا ر  فار میٹنگ ہیں  کری

 پیج پر ہم ا ی ک طرج کی فار میٹنگ کر سکیں گے۔

 CSSs provide the means to control and change 
presentation of HTML documents 

 CSS is not technically HTML, but can be embedded in 
HTML documents 

 Style sheets allow you to impose a standard style on a 
whole document, or even a whole collection of 
documents 

 Style is specified for a tag by the values of its 
properties  

 
Types of CSS: 

 Inline - specified for a specific occurrence of a tag 
and apply only to that tag 

 This is fine-grain style, which defeats the 
purpose of style sheets - uniform style 

 Internal style sheet - apply to the whole document in 
which they appear 

 External style sheets - can be applied to any number 
of documents 

 

 میں پہلا کوئی خاص ہیں  ہے ۔

 

 یہ تین طرج کی ہیں جو سا منے آت ا ٓ ر ہے ہیں ا ن

ر  پیجز میں یہ ا ستعمال ہوتے ہیں۔

 

کی
 مگر د و سرا  ا و ر  تیسرا  د و نون بہت ا ہم ہیں ا و ر  ا 

 

  کو پڑھئلسا منے د ی ا  گیا سٹا

 

ز
پ گ

 

پ

سا  ٹیگ کس مقصد کے لیے ا ستعمال ہو گا ۔جیسے  کو چکے ہیں ا و ر  ا ت  ا ٓت    کیا کرے گا ۔پہلے ا ٓت  تمام 

 

ن
ا  چاہیے کہ کو

 

 ,H1پتہ ہوی

font, P, و غیرہ۔ 

ا ل میں ہم نے 

 

 ، ا و ر  سا MCSIT د ے د ی ا ۔یعنی ئلکو سٹاH1ا ت  ا و پر مپ

 

ٹ

 

پ
گ ہے تو ہم نے ا س کو فا

 

 ،  می د ے د ی ا  ہمار ی ہیڈی

 

ز

 

پ
 لا

 

  ئل سٹائنا ن

 

 ا تنا یور

 

ی ت

 

 س

ا  ۔

 

 ہیں  ہوی

Inline Styles: 

<H1 STYLE=“color: blue; font-size: 20pt;”>MCSIT 

</H1> 
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 ا کونٹ  ا نٹرنل سے مرا د  جو 

 

 کیا گیا ،  د

 

ن

 

ش

 

پ ی
م

کے ا ندر  ہی 

 ئلنل میں ہم ا لگ سے فاجبکہ ا یکسٹر

 

 بنا د یں گے۔ ا ن

 لگے ا سی کو ا ستعمال 

 

د و نون میں سے ا ٓت  کو جو ا ٓسا ن

 کریں۔

 تو سا منے ہے ا نٹرنل:

کا ٹیگ لینا ہو گا ا و ر  ا کے  <style>ا س کے لیے ا ٓت  کو 

ا 

 

  ی

 

 ا ٓگے د ی ا  گیا کود

 

پ
ٹ  کرد یں۔ا س میں کاما، سیمی کولن ، ا و ر  

ز یکٹ کا خاص خیال ر کھیں ۔
پ 

 

 کر ئلہم ا پنی پیج کے ا ندر  ا س سٹا

 

ن

 

ش

 

پ ی
م

 کی مدد  سے یہ 

ا س کی فار میٹنگ یہ ہو یسا ا و پر H3ر ہے ہیں کہ جہان پر 

، سا  می د ی ا  گیا ہے ا س کے

 

ٹ

 

پ
  علاو ہ ا ٓت  فا

 

پ
 ، بولڈ و غیرہ 

 

ز

ے ہیں۔ا س طرج ا ٓت  نے ا گر پیج میں د و سری 

 

سکی
د ے 

کوئی بھی لی ہیں تو ا س کے لیے ا لگ H4ی ا   H2ہیڈز ک یعنی 

 فار میٹنگ بتا د یں۔

یعنی پیرا گرا ف ہے تو ا س کی ا لگ Pپھر ا سی طرج جہان پر 

 سے فار میٹنگ کر لیں۔

Internal Style Sheet 
 
 
<HTML> 
<HEAD> 
<TITLE>Stylesheet</TITLE> 
<STYLE TYPE=“text/css”> 
h3{font-family:ariel,helvetica; color:black} 

 
P {font-family: calibri; font style:italic;font size:14pt; font 
style:italic; color:cyan;border-style:groove;border-
width:medium; border-color:voilet} 

 
</style> 
</HEAD> 
</HTML> 
 

 میں ئلا س میں ہم نے و ہی فار میٹنگ ا ی ک ا لگ سے فا

ا  ہے css. کو ئلسیو کی ا س فا

 

ا یکسٹینشن کے سا تھ سیو کری

بعد میں ہم ا س کو سا منے د یے گے ٹیگ کے سا تھ کال 

  سا منے د ی ا  گیا ہے جبکہ جو فائل ا و پر بنائی گئی کریں گے۔

 

کود

  ہے ا س میں ا و ر  کوئی ٹیگ ہیں  

 

ز
پ گ

 

پ

د ینا صرف فار میٹنگ 

ا  ہے سا منے 

 

 کو کال کری

 

د ینا ہیں ۔ ا و ر  د و سری فائل میں ا ن

  کال کرنے کے لیے ۔

 

 د یکھیں  کود

 
 

LECTRUE-10 
External  
h3{font-family:ariel,helvetica; color:black} 

 
P {font-family: calibri; font style:italic;font size:14pt; font 
style:italic; color:cyan;border-style:groove;border-
width:medium; border-color:voilet} 
 
<HEAD> 
<LINK REL=stylesheet” TYPE=“text/css”  
HREF=“ mystyles.css”> 
</HEAD> 
 

ر  ا ٓخر میں ا س کو ہم پرو کٹ   کی شکل د ے سا تھ سا تھ ہم ا ی ک و یب پیج بناتے ہوئے چلیں گے ا و ر  ا س پر یہ تما م ٹولز جو ہم پڑھ ر ہے ہیں ا ستعمال کریں گے ا و 

 د یں گے۔

 

س کو ا ستعمال کریں گے۔

 

پ لی
 م
ی

 

پ

ا س ہم مختلف بنے ہوئے 

 Advanceا و ر  کچھ  Baisc Syntaxکے علاو ہ جاو ا  کا 

Applications ا ٓت  کو پڑھائی جائیں گی۔ 

LECTRUE-11 

Java Scripts 

 ا ی ک و یب سا 

 

ٹ

 

پ
 

 

 ر  سٹود
ہ

 

 

پ
 بنائے گا جس کو ہم لانچ بھی 

 

ٹ

Final Project Through Coding 
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 کریں گے۔

A  complete website “Your Choice” 

  میں 

 

ر

 

ی

 

س
پ ک
س

ر یمز کی مدد  سے ا ُٓٓ ت  ا ی ک ہی پیج کو مختلف 
ف

 کرتے ہوئے د و سرے پیجز کو ا لگ ا لگ ا ی ک ہی 

 

کنور ت

ے ہیں۔

 

سکی
 سکرین پر کھو ل 
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Frames: 

ر یمز
ف
  ا ُٓٓت  کی سکرین کو 

 

 ر میں کنو سا منے د ی ا  گیا کود

 

ت

 ر  میں 

 

ز ا و ر
پ 
  کو ا ی لائی کریں۔ا و ر  

 

کرد ے گا ۔ ا س کو کود

ر یم میں جو پیج کھولنا 
ف
د یکھیں۔ا  س میں سا تھ ہم نے جس 

 ی  

 

ر
ک
 کیا ہے ۔ ا س کی 

 

ن

 

ش

 

پ ی
م

پرا پرٹیز ہم  ڈ ہے ا س کو بھی 

 د یکھیں گے۔ یہ بھی 

 

 کلاس کے د و ر ا ن

 

ہن میں ر کھیں د

 ی کا ٹیگ ختم 

 

ر یم ا ستعما ل کیا تو ی ا د
ف
ہو گیا چونکہ ح ت  ہم نے 

 ی کا 

 

 ی کے ٹیگ کی جگہ ا گٓیا ا ت  ی ا د

 

 کا ٹیگ ی ا د

 

ر یم سی ت
ف

  ہیں  ہو گا۔

 

 ٹیگ یور

<HTML> 
<HEAD> 
<title>Index</title> 
 
<FRAMESET ROWS="15%,80%" > 
<FRAME SRC="name.html" > 
<frameset cols="15%,78%"> 
<frame src="links.html" name=frame1 scrolling=no> 
<frame src="page2.html" name=frame2> 
<frameset> 
</farmeset> 
</html> 
</head> 

  کو ا ستعمال کریں۔

 

 ا س کود

<frameset rows = "150, 200, 300"> 
<frameset rows = "25%, 50%, 25%"> 
<frameset rows = "50%, 20%, *" > 
<frameset rows = "50%, 25%, 25%" cols = "40%, *"> 

 

  د یکھیں۔فار میٹنگ 

 

ز
پ گ

 

پ

 ی ڈ  

 

ر
ک
 میں 

Formatting frames 
FRAMEBORDER=n or  
Border=n 
NORESIZE 
Scrolling=“  “ 
Yes/no/auto 
MARGINHEIGHT=n 
MARGINWIDTH=n 
BORDERCOLOR=“  “ 
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Web Development through Visual 
 (Front page and other web supported software) 

 
 Introduction to Front page: 
Front page allow user to create, edit, maintain a single webpage as well as complete web project 
with out HTML coding. Because this program has its ability to developed your visual actions into 
HTML himself. 

ر WYSIWYG ا ٓت  ا س پرو گرا م کی مدد  سے
ف
 کی مدد  سے کام کریں گے یعنی 

 

ٹ

 

پ
 ر یم و یور  پیج 

 

  کی مدد   (Dreamwever Cs5)، د

 

ر
ک
عقہ پرو گرا 

ل

 

ا و ر  د و سرے مپ

 ہے Dynamicمیں کام کرتے ہوئے ا ی ک بہت   User Friendly Interfaceسے ا ٓت  

 

گ سے نسبتاً ا ٓسا ن

 

 ی

 

 ۔و یب پیج بنائیں گے جو کود

Starting MS Front page 2002 
File – New – page or web – Empty web: This will create your web folder. 
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 کے لیے کوئی پرا بلم ہی ہیں  ا و ر  جنہون نے

 

 ہے کیونکہ جن لوگون نے ا ٓفس کیا ہوا  ہے ا ن

 

 ا ٓسا ن

 

 ٹ
پ
ہیں  تو و ہ بھی ا س کو  ا س پرو گرا م کے ا نٹر فیس کو سمجھنا نہا

 ا ٓسا نی سے سمجھ لیں گے۔پرو گرا 

 

ا ت  پہ:کور س کے د و ر ا ن

 

 م میں ست  سے ی

Tile bar, Menu Bar, Standard text Bar, Formatting text bar, ہیں۔ 

ٹ  

 

پ
ا  ہے۔ جو ا ٓت  سکرین پر د یکھ سکیں گے۔ View barا س طرج ی ا ئیں جا

 

 میں ا ٓت  کا مین پیج ہے جس پر ا ٓت  نے کام کری

 

 ا و ر  د ر میان

طریقے کے مطابق فایل کی مدد  سے ا ٓت  پہلے ا ی ک نیا و یب فولڈر  لیں ا و ر  ا س کے بعد ا س کے ا ندر  ا ٓت  نئے  ئےہو ئےتو ست  سے پہلے ا ٓت  ا ی ک نیا پیج لیں ۔ ا و پر بتا

ے ہیں ا و ر  

 

سکی
  ٹول ی ا ر  کی مدد  سے بھی یہ کام کر 

 

ا  ہے۔  ا س کے علاو ہ ا تٓ  سٹینڈر  ر

 

سے بھی۔ی ا د    Ctlr +N پیجز لیتے جائیں گے ۔ جن کو بعد میں ہم نے نک  کری

 ہو گا۔د ا   extension .html کے سا تھ ہی ا س کی ر کھیں نیو پیج لینے

 

 ر  ہ کلاس کے د و ر ا ن
ہ
ٹ  و یو ی ا ر  کو لیتے ہیںئیںلینی ہے۔جس کا عملی مظا

 

پ
 ۔ جا
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View Bar 
Page 
Folder 
Reports 
Navigation 
Hyperlinks 
Tasks 

 بنی  ہے۔ جن کو ہم ی ا ر  ی ا ر  ا ستعما ل کریں گے۔ پر 

  لیں گے ا و ر  مطوبہ فائل پر کلک کریں گے۔ Ctlr +Oپیج کو کھولنے کے لیے ا ٓت  جانتے ہیں کہ ہم ا و پن کی ی ا   ہوئےبنے 

 

ڈ

 

 کی کمای

  ہیں جو ا ٓت  نیچے کی طرف ملاظہ  کریں گے۔

 

 کام کرنے کے تین ماد

Normal: For Working 
HTML: For Coding 
View: for view 

 
Working With text & Hyperlinks in web page: 
Standard & formatting tool bars front page: 
Hyperlinks: 

صیت ہے یہ و یب کے لیے بہت ا ہم ٹول ہے ا س کی مدد  سے ا ٓت  ا ی ک ٹیکسٹ ی ا  ا ج،  کا علق  د و سرے کے سا تھ بنائیں گے ۔ جو ا صل میں و یب پیج کی ا ی ک خصو

س خود  بخود  کھلیں

ک

 

لپ

س ی ا  ست  

ک

 

لپ

  گے۔کہ ا ی ک بٹن پر کلک کرنے سے د و سرے 

 کر کہ ا و ر  د و سرے 

 

پ کت
پ ل
س

س د یتا ہے۔ ا ی ک تو ٹیکسٹ کو 

ک

 

لپ

 پیج د و  قسم کے 

 

ٹ

 

پ
ر 
ف

Hot spot   س بنا سکیں گے۔تو د یکھیں۔

ک

 

لپ

کی مدد  سے بھی ا ٓت  تصاو یر کے سا تھ 

 :ح ت  ا ٓت  ہاپر نک  بنائیں گے تو

 

Internal Hyperlink = One page to another 
External Hyperlink = Outside web page  
E-Mail Links. 

 کی ۱

 

ا ر ت

 

  ٹول ی ا ر  میں ٹول بھی ہے۔ ا و ر  ا س کے علاو ہ ا س کی س

 

 د

 

ا : ا س کے لیے سٹینڈر د

 

 کر کہ نک  بنای

 

پ کت
پ ل
س

 ہے۔   Ctrl+K۔ کسی لفظ کو 

 موجود  ہے۔  Insert۔ ۲

 

ٹ
ل
 میں بھی ہائپر نک  کی سہو
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 ۔ ماو س د ا ئیں کلک میں بھی ہائپر نک  پر کلک کیا جاسکتا ہے۔۳

Assignments: 

ا :

 

 کسی ا ی ک لفظ سے د و سرے فائل کا نک  بنای

 کسی ا ی ک بٹن ی ا  لفظ سے د و سرے پیج کا نک  د ینا ۔

 Mail Me, Feed Back, E-Mail گ پرو گرا م سے نک  د ینا۔

 

 ی

 

 سے تعلقہ  میل کمپور

Outsider Web page Links: 

 سے نک  د ینا۔  URLکو کسی د و سرے   URLکسی ٹیکسٹ ی ا  

 پر کلک کر د یں۔  remove Linkہاپر نک  کو ختم کرنے کے لیے ا س لفظ پر کلک کرنے کے بعد ہاپر نک  میں جا کر 

:

 

 کسی ہائپر نک  کی پہچان

 ۔ ماو س لے جانے پر ہاتھ کا سا ئن۔۱

ا  ہے۔۲

 

 ۔ ٹیکسٹ کا  می بدل جای

 
ف
 

 

ٹ
گ
ا ر 

 

 ر  ی ا  ی

 

ڈ

 

س بنا سکیں گے جو ہاپر نک  کے کھلنے و ا لے ی ا کس میں ا ٓت  کو مختلف ا پٓشنز بھی ملیں گے جیسے نیو و ی

ک

 

لپ

 ر یم و غیرہ۔ ا سی طرج ا تٓ  ہاپر 

Insert – Hyperlink – Target Frame – New Window or else. 

 کا  ہوئےپھر و یو ی ا ر  کا ا ستعمال کرتے 

 

س کو د یکھنا کہ ا ن

ک

 

لپ

ا  ہے۔ہاءپر 

 

 و ر ک کیسے بنا ہوی

 

ی ت

 

 پ

 ی ک مار کس:

ا یٹل کو نک  د ے سکیں گے۔ پیج کےا ندر ۔

 

 کی مدد  سے ا ٓت  کسی لفظ کو ی ا  ی

 

 ا ن

 کریں ا و ر  

 

پ کت
پ ل
س

 Insert – Bookmarks – Heading text – Okلفظ کو 

ے ہیں۔

 

سکی
 پھر ا ٓت  کسی ی ک مار ک کو بھی نک  کر 

 ٖInsert – hyperlinks – bookmarks – Ok 

 .Insert – Bookmark – clearر ک کو ختم کرنے کے لیے کسی ی ک ما

 کلک میں بھی ۔ د ا ئیںماو س کے 

ا ۔

 

 ا س طرج کسی د و سرے پیج کے سا تھ ی ک مار ک کری

Align the Bookmark on next page & link it with Back page. 
Address Are (link the word) 
Next page name :#bookmark word. 

<><><><><><><><><> 
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 پیج کے

 

ٹ

 

پ
ر 
ف

Components  : 

Hover Buttons: Shows effects on mouse over (active x must be installed) 

 مینو میں ملیں گے۔

 

 یہ ٹولز ا ٓپکو ا نسرت

Insert – web components – dynamic effects – Hover Button – Finish – H.B Properties etc. 

 طریقہ کار :
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 ر  کوئی 

 

ز ا و ر
پ 
ٹ  کریں ا و ر  ا س کو فار میٹ کر لیں۔ ا س ٹیکسٹ کی مدد  سے ا ٓت  د و سرے پیج کو نک  کر د یں یسا ا ٓت  کو بتا ی ا  گیا ہے۔ ا ت  

 

پ
ا 

 

میں د یکھیں تو ٹیکسٹ ی

  تبدیل ہو گا۔ئلماو س لے جانے پر ا س بٹن کا  می ی ا  سٹا

Hit Counter: 

 کو 

 

 ٹ
پ
 کیا ہے۔ا س کی مدد  سے ا ٓت  د یکھ سکیں گے کہ ا تٓ  کی و یب سا 

 

 ت

 

 کتنے لوگون نے و ر

  ٖInsert – web components – Hit Counter – Finish – Properties etc 

Horizontal Line  ے ہیں

 

سکی
ا مل کر 

 

 ۔بھی س

Marquee: 

ا  ۔ Animationمار کی

 

  Insert – web component – Dynamic effects – Marquee – Finish – Propertiesپر کا م کری

Inline Frame : 
Page into page for giving full details & serving the space of front page. 
Insert – inline frame 

 ا ئی ، مار جنز ا و ر  ا لائن نٹ ۔

 

، چور

 

 ٹ
پ
 ، ہا

 

ز
پ 
ر یم کا سا 

ف
ا م بدلنا ، 

 

 پھر ا س پیج کا ی

Date & Time: 

Insert – Date & time  
Change the date & time format  
Last modifying on page time. 
Page properties: 
Format – background  
Right click on page area – Page properties box. 
DHTML Effects on text: 
Format – DHTML effects. 
Views tool bars – HTML bar – on 

 کرنے کے بعد ا س پر 

 

پ کت
پ ل
س

 کا ا ستعمال۔ DHTMLکسی لفظ کو 

 

پ کت
ن ف
 ا 

 
Page Transition: 
Format – page transition 
Formats – paragraph, bullets & numbering, Borders & shading. 

 کا بیسک سڑکچر بنا یں گے ا س کے تمام ٹولز کو ہم کلا س د و ر 

 

 ٹ
پ
 پیج میں ا پنی سا 

 

ٹ

 

پ
ر 
ف
 می ہے ا س کی مدد  سے ا ٓت  

 

ا  بہت لار

 

 پڑیں  گےٹیبل پر کام کری

 

 ۔ا ن

 کے کچھ ٹولز د یکھیں گے۔ Dream Weaver Cs 5ا س کے ہم 

 

LECTRUE 

16,17,18,19, 

EDITING  IMAGES 

Photo Impact 12 

  ہے ۔ ا س میں ہم مختلف 

 

ڈ

 

 یہ کہ و یب سپور ی

 

 ا و  ر  ی ا و ر  فل پرو گرا م ہے ا ہم ی ا ت

 

ز د ست
پ 
 

 

 یٹنگ کے لیے ا ی ک بہت ر

 

گ ا و ر  ا ج،  ا ی ڈ

 

 پ
ی

 

ی
 ا 

 

ز
پ 
 

 

بینزر  بنائیں گے یہ ا ی ک د

 ا ین کر سکیں گے۔  Animationا س کے علاو ہ

 

ز
پ 
 

 

س پر کام کریں گے۔ا س پرو گرا م میں ا ٓت  و یب کا پور ا  سٹرکچر بھی د

 

پ کی
ن ف

 you will surelyا و ر  تصاو یر کے ا 

enjoy these moments 

 GIF, JPEGتصاو یر کے لیے د و ا ہم فار میٹس پر کام ہو گا 
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Crop می ہے۔ ا س کے علاو ہ ا و ر  ا ہم ٹولز جو ہمیں چاہیے ہو 

 

ا مل ہے۔ٹول پر کام بہت لار

 

ا  س

 

 پر کام کری

 

 ا س پرو گرا م کی ن گے ا ن

 

 ٹ
پ
ا س کے علاہ ا ٓت  پور ی و یب سا 

 مدد  سے بنا سکیں گے۔

 

Gif Animator: 

 تیار  کرسکیں گے۔

 

ن

 

 ش
می

 

پ ی

ی ف ا 
گ
ا  سا  پرو گرا م ہے لیکن ا ٓت  ا س میں بھی 

 

 یہ ا ی ک چھوی

 

 

LECTRUE 

20,21,22,23 

Corel Draw 12 

ے ہیں ۔ کور ل کو ا ہم پہلے  

 

سکی
 ا ینگ کر 

 

ز
پ 
 

 

 Asمیں پڑھ چکے ہیں ۔ و یب کے لیے ا ٓت  کوئی بھی سا ٹ  و ئیر  Chapterا س پرو گرا م کی مدد  سے ہم و یب کے لیے د

a Tool  لًا

 

جتنے سا ٹ   Corel Draw, Photoimapct, Swish, Gif Animator, Photo Express, Photshop, etcا ستعمال کر تے ہیں۔ مپ

 سا  کام  بہتر کس سا ٹ  و ئیر میں ہو سکتا ہے ۔ ا س لیے ہم بعض د عہ  ا ی ک سا ٹ  و ئیر کوو 

 

ا   کہ کون

 

  ا ٓت  جانتے ہیں تو ا ٓت  کو پتہ ہوی

 

د سرے پر ترجیح د یتے ہیں  ئیر ر

  Bannersیہ جانتے ہوئےکہ یہ کام ا س میں ا ٓسا نی  ا و ر  جلدی سے ہو جائے گا ۔ ا ٓت  

 

ے ہیں ، ا س کے علاو ہ چونکہ ا ر د و   بنانے کے لیے ا س سا ٹ  و ئیر کو یور

 

سکی
کر 

ا  ہے ۔ و یب 

 

 پو ر ی کری

 

 ا ینر کی ضرو ر ی ا ت

 

ز
پ 
 

 

کے لیے ا ہم ٹولز ٹیکس بھی کور ل میں ا ٓسا نی سے ہینڈل ہو سکتا ہے ا س لیے میں یہ سمجھتا ہون کہ کور ل ا ی ک و یب د

  کے د و ر ا  Chapterکے  12ا ٓت  کور ل 

 

ل سمجھای ا  جائے گا ۔سے سیکھ لیں ا و ر  و یب میں ا ستعمال کریں ۔ یکچر  ر
ی ک

 

ی کی

 کا پر

 

 ا ٓت  کو ا ن

 

 ن

 

LECTRUE-24,25,26 

Swish Max 2 

 ی ا  سا ٹ  و ئیر ہے جس میں

 

پ ڈ
م
  ، ٹیکسٹ ا و ر  تصاو یر پر بنی  و یب پیج بنائیں گے ا س کے علاو ہ یہ ا ی ک ملٹی 

 

  بینرر

 

ڈ

 

 پ
 می
ی

 

ی ی

  پر ا س کی مدد  سے ا ٓت  ا 

 

 یور

 

 ا ٓت  کمرلز  ا و ر  و د

 ۔کیبل پر ج لانے کے ا شتہار  بھی سیکھیں گےبنی  ا شتہار  بنا سکیں گے ۔ ا و ر  

LECTRUE- 27,28 

 
Cool 3D Production Studio(if Needed) 

 ی  3یہ بھی 

 

 بنانے کے لیے ا ستعمال کریں گے۔Animationد

 

LECTRUE - 9,30,31,32 

Creating your personal web page :( Full Practice) 

 بنانے جا ر ہے ہیں ا س میںا تٓ  

 

 ٹ
پ
 کو فالو کریں۔ ا پنی و یب سا 

 

س میں بتا ر ہا ہون ا ن

 

ی

 

ہ پ

ا  ہے ا س کے 

 

 ا ٓت  کو کیا کیا کیسے کری

 کا کسی کاغذ پر ا ی ک خاکہ سا   بنا لیں ۔۱

 

 ٹ
پ
 ۔ ست  سے پہلے ا پنی و یب سا 

 ا ئن طریقہ کے مطابق بنا۲

 

ز
پ 
 

 

  کے لیے ا ی ک د

 

ڈ

 

 یٹنگ پرو گرا م میں جا کر بیک گرا و ی

 

عقہ فوٹو ا ی ڈ
ل

 

 کے لیے مپ

 

 ٹ
پ
  لیں۔۔ ا س کے بعد ا پنی و یب سا 

 یکس پیج لیں ا و ر  ا س کو  ۳

 

ڈ

 

ا م سے سیو کر لیں۔   Index.html۔ ا ت  ا ٓت  نیا پیج یعنی ا ی

 

 کےی

 ر ا  کر لیں ا و ر  ا س کو ا لاین کر لیں۔۴

 

 کے مطابق ٹیبل د

 

 ۔ ا ت  ا تٓ  ا پنی ضرو ر ت

ا ت  میں تیا ر  کیا ہے تو ا س ۴

 

 ی ا  فوٹو س

 

 پ کت
 می
ن

 کو تصویر کے طور  پر ہاںن پر کھول لیں۔۔ یہ پیج لینے کے بعد ا گر ا ٓت  نے و یب کا سٹرکچر فوٹو ا 
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 کو ۵

 

 میں ر کھیں ا و ر  ا ن

 

ا م چھوٹے ا لفاظ

 

 ر  پیج کا ی
ہ
  کے مطابق د و سرے پیج بھی لے لیں ا و ر  

 

ر

 

ی

 

 پ
پ

 فار میٹ میں سیو کریں۔  html۔ ا ت  ا ٓت  بنے ہوئے 

 سپاٹس کا ا ستعما ل کرتے ۶

 

 کو نک  کرلیں۔ ہوئے۔ا ت  ا ٓت  ہات

 

 ا ن

  لگا۷

 

ا ت  پر ا ٓت  نے بینرر

 

 ی ا  ۔پیج کو ی

 

 پ کت
 می
ن

   Swish Maxنے ہیں و ہ ا ٓت  کور ل ی ا  فوٹو ا 

 

ن

 

 ش
 می
ی

 

ی ی

میں بنا لیں ا و ر  ا س کو ہاںن پر کھول لیں۔ ا گرا تٓ  نے کسی ا 

 ر  میں ا سی طرج چلے گا ۔

 

ز ا و ر
پ 
ی ف و غیرہ میں سیو کیا ہے تو و ہ 

گ
لا 

 

 فار میٹ مپ

 پیج کے مختلف ا پٓشنز جو ا ٓت  کو بتا ء گے ہیں ا پنی و یب میں ا ستعمال کر لیں جن میں ۸

 

ٹ

 

پ
ر 
ف
 , Marquee, page Transition, DHTML Effects۔ ا ت  ا ٓت  

Web components etc. 

  ہ لیں ا و ر  پھر ا س کو فائنل کریں۔۹

 

ز
پ 
 ۔ تیار  کرنے کے بعد ا س کا بغور  جا

ر ی سرو ر  پر ۱۱
ف
 کو 

 

 ٹ
پ
 ہے لانچ کر د یں۔ ا پنی و یب سا 

 

 ۔ی ا  پیڈ جو ا ٓت  کی ضرو ر ت

<><>><><><><> 

LECTRUE-33,34,35 
Publishing Web site 

 
Doamin name: 

 کا 

 

ٹ

 

پ
 ر  ا  URLا ٓت  کی و یب سا 

 

 ر یس جس کی بنا ء پر یور

 

  کرے گا ا س کوی ا  ا ی ڈ

 

ز ا و ر
پ 
 و مین نیم کہیں گے جیسے  س کو سرو ر  سے 

 

تو ح ت  ا ٓت  ا ت   www.majk.comد

 یٹا بیس میں ا ٓت  کا د ی ا  گیا 

 

 ا ٓت  لے ر ہے ہیں ا پنی د

 

ٹ
ل
  کرتے ہیں تو کوئی بھی سرو ر  جس کی سہو

 

 د ے گا کیا یہ  URLلود

 

 پ ک کرے گا ا و ر  ا تٓ  کو معلومات
ح
 و مین نیم 

 

ی ا  د

 ر یس ا ٓت  کو مل سکتا ہے ی ا  ہیں  کیونکہ ہو سکتا ہے کہ و ہ پہلے سے موجود  ہو  ا س طر

 

 ج ا تٓ  ا ٓگے پرو سیڈ کریں گے۔ا ی ڈ

 ر  ہے کہ یہ تو فی ا لحال ا تٓ  کے ا پنی کمپیو
ہ
ا 

 

 تیار  کر لی تو ط

 

ٹ

 

پ
ٹر پر ہے ، حالانکہ ا س کا مقصد ا ت  ح ت  کہ ا ٓت  نے و یب پیج کے تمام ٹولز سیکھ لیے ا و ر  ا ی ک مکمل و یب سا 

ا  ہے۔ تو

 

ک پہنچای

 

 جو کسی بھی فیلڈ سے تعلق  ہو سکتیں ہیں د و سرو ن ی

 

 ہن میں  یہ معلو مات

 

 بتا ر ہا ہون جو ا ٓت  نے د

 

ا س کے لیے میں ا ٓت  کو نیچے کچھ ا ہم نکات

 ر ھنے  ہیں۔

 ہے چونکہ:۱

 

 و ر ک کا محتاج

 

ی ت

 

 کر چکے ہیں بنیاد ی طو ر پر پ

 

 جس پر ہم پہلے ی ا ت

 

ی ت

 

 ۔ ا نٹرپ

 "Netwrok of the Networks is called Internet" 

ا  ہے ۔ 

 

  پر مشتمل ہوی

 

ر
م

 

شی
س

 تو یہ د و  ا ہم 

1. Server(Physcial Domain) 
2. Client (Virtual Domain) 
1. Servers 

Make the Internet possible.The machines that provide services to other machines are servers 
2. Clients 

The machines that are used to connect to those services are clients. 
 
When you connect to http://www.msn.comyou are a user sitting at a client‘s machine. 
You are accessing the msn Web server. 
The server machine finds the page you requested and sends it to you. 
Most popular software which the Servers run to allow responding to client is Internet Information 
Server (I.I.S), Apache Web Server, Microsoft Personal Web Server. 
 
Clients run special software that allows them to  

 Locate the required Server. 

 Query the Server for Information. 

http://www.majk.com/
http://www.msn.com/
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 Most popular software that the Clients run are Netscape Communicator, Internet 

Explorer, Mozilla Firefox, Opera. 
Clients direct their requests to a specific software server running on the server machine. 
For example, if you are running a Web browser on your machine, it will want to talk to the Web 
server on the server machine, not the e-mail server.  
 
Communicating on the Internet: 
TCP/IP used to send data all over the network. 
TCP 
Set of communication protocols. 
IP 
A unique address 
Every computer that is connected to the Internet is part of a network, even the one in your home. 
Every machine on the Internet has a unique identifying number, called an IP Address. 
 
InterNIC (Network Interface Controler) 
An international governing body who is responsible for registering and assigning IP addresses to 
organizations wishing to manage networks.  

 

 ہم سرو ر  پر کیسے سیو کریں گے ا س عمل

 

ٹ

 

پ
ے ہیں ۔ ا ت  ا ٓت  کی و یب سا 

 

سکی
 کر 

 

 پر ر یسرج

 

ی ت

 

کہا  Uploadingکو  یہ تو تھیں کچھ جنرل ا نفار میشن ا س کے علاہ بھی پ

ا  ہے۔ ا س کے لیے ا ٓت  کے ی ا س د و  ا ٓپشن ہیں ا ی ک تو یہ ا ٓت  

 

 تو  Free Hosting Serversجای

 

ٹ

 

پ
ی و یب سا 

 ہل
ن

فعا د ہ کریں ۔ بلکہ ا ٓت  ا پنی 

 

سی
 سے ا 

 

ٹ
ل
کی سہو

 پر جائیں ا و ر 

 

ٹ

 

پ
ا  کہ ا ٓ ت  کو ا س کا تجربہ ہو جائے ۔ ا س کا طریقہ کار  یہ ہے کہ ا ٓت  مطلوبہ سرو ر  کی و یب سا 

 

  کریں ی

 

 سے ا ت  لود

 

ٹ
ل
ا س میں مطلوبہ ا ٓپشن پر  ا س سہو

 ر  کلک کریں ا س کے بعد ا ٓت  کو ا 

 

ل کریں ا س کے بعد ا ٓگے پرو سیڈ کریں ۔ ا ٓت  کو ا ٓت  کی د ی گئی ا ی میل پر ا ی ک یور
ف 
ا  ہو گا ا س میں تما م ا نفار میشن 

 

ُٓز  کری

پ 
ی ک فار م 

  موصول ہو گا ا و ر  ہو سکتا ہے سا تھ کچھ 

 

 کو بھی پڑھ لیں ۔ Terms & conditionsنیم ا و ر  ی ا س و ر د

 

 بھی ہون ا ن

 ر  نیم ، ی ا س

 

 کہ یور

 

ے ہیں ا گر ا س  ا ی ک ا و ر  ا ہم ی ا ت

 

سکی
  کر 

 

 کے پیجز ا ت  لود

 

ٹ

 

پ
ز یکٹ بھی ا پنی و یب سا 

 

پ
 ا 

 

 سے د

 

ٹ

 

پ
  لینے کے بعد ا ٓت  ا س سرو ر  کی مطلوبہ سا 

 

و ر د

 
َ
لا

 

گ سا ٹ  و ئیر مپ

 

 ی

 

 پر یہ ا ٓپشن ہے و ر ہ ا ٓت  کوئی ا ت  لود

 

ٹ

 

پ
ے ہیں۔ی ا  پھر بعض فائلز کے لیے ہمیں Cute FTPسا 

 

سکی
بھی  MS Front Pageبھی ا ستعمال کر 

 

 

 ر یم و یور  ا و ر  ا ستعما ل کری

 

ٹ  ۔ا س کے علاہ د

 

پ
 پیج میں بنائی ہے 

 

ٹ

 

پ
ر 
ف
 

 

ٹ

 

پ
ا  ہے۔ ا گر ا ٓت  نے و یب سا 

 

 بنائی ہے تو  HTMLا  ہوی

 

ٹ

 

پ
گ کی مدد  سے ا گر و یب سا 

 

 ی

 

کود

 ہیں ۔

 

  کرنے کی کوئی ضرو ر ت

 

 پیج سے ا ٓ کر د و ی ا ر ہ ا ت  لود

 

ٹ

 

پ
ر 
ف
 پھر ا ٓت  کو 

  کرنے کے بعد ہمیں ا سی یو

 

 ر  سے ا ت  لود
ہ
   و غیرہ ی ا 

 

ر
ک
  کے سا تھ چونکہ کچھ فار 

 

 ر  نیم ا و ر  ی ا س و ر د

 

ٹ  جا کر ا ٓت   Front Pageر

 

پ
ا  پڑتے ہیں 

 

  کری

 

سے د و ی ا ر ہ ا ت  لود

  ہو سکیں گے ۔

 

 کے تما م پیجز ا ت  لود

 بھی کریں گے تو ا ٓت  ا پنے پیجز میں ح ت  چاہیں جنتی بھی

 

 ٹ
پ
 

 

 ر  ہے ا ٓت  بعد میں ا س کو ا ت  د
ہ
ا 

 

  کر د ی تو ط

 

 ا ت  لود

 

ٹ

 

پ
 تبدلیاںن ح ت  ا ٓت  نے ا ی ک د عہ  و یب سا 

ا  ہے جس طرج ا ٓت  نے پہلے کیا ہے۔کر

 

  کری

 

  کے سا تھ صرف د و ی ا ر ہ ا ت  لود

 

 ر  نیم ی ا س و ر د

 

ے ہیں ا س کے بعد ا تٓ  کو پھر ا سی یور

 

سکی
 یں کر 

 

Paid Hosting: 

ا  ہے ا س کے لیے ا تٓ  Inter NICا نٹر ا ین ا ٓئی سی)

 

 و مین نیم ا سا ئن کری

 

ے ہیں یہ www.internic.comا ی ک ا نٹرنیشنل ا د ا ر ہ ہے جس کا کام د

 

سکی
 کر 

 

 ت

 

پر و ر

 پر جائیں ا و ر  ا س میں مطلوبہ ا ٓپشن پر کلک کریں ا ی ک فا

 

ٹ

 

پ
ا  ہے ۔ ا س کے لیے ا ٓت  ا س کی و یب سا 

 

 و مین نیم ا سا ئن کرنے کا کام کری

 

ا  ہو گا ا س ا د ا ر  ہ د

 

ر م ا ٓت  کو پر کری

 میں مختلف 

 

ٹ

 

پ
 و مین نیم ی ا   Packagesکے بعد ا ٓت  کو ا سی و یب سا 

 

   URlبھی ملیں گے جس پر ا ٓت  د

 

 و مین نیم ر جسٹرد

 

لےسکیں گے ۔ یہ تقر یبا ً د و  سا ل کے لیے د

ا  ہوتی ہے۔

 

ا  ہوتی ہے ا و ر  ا سکی فیس بھی جمع کرا ی

 

ا  ہے ا س کے بعد ا ٓت  کو نیو ر جسٹریشن کرا ی

 

گھنٹے کے ا ند ر  ا ندر  ا ٓت  کو ا ی ک ا ی میل ا ٓ جاتی ہے ا س میں  24تقریباً کری

ا  ہے ا س کو پڑھ لیں ۔سا ر  ا  پر

 

 و یجر  ہوی

http://www.internic.com/
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ک کے لیے پے پینٹ کے 

 

ر یشن کنفرم ہو جاتی ہے  د و  سا  ل ی

 

ج ی
 ی لا ک ہو جائے گی بعد ا تٓ  کی ر 

 

ٹ

 

پ
۔ ا س ا گر ا تٓ  نے فیس جمع کرو ا  د ی ہے و ر ہ ا ٓت  کی و یب سا 

 و مین نیم ا گر پہلے سے موجود  ہو تو ا ٓت  کو 

 

ا  ہے تو Error Messageمیں ا ٓت  کا د ی ا  گیا د

 

ٹ  ہی ا ٓت  ا گٓے ا ٓ جای

 

پ
 و مین نیم ی ا  یو ا رٓ  ا یل بدل د یں تو 

 

 ا س کے لیے ا ٓت  ا پنا د

  کرسکیں گے۔ بعد

 

 ا ت  لود

 

ٹ

 

پ
  ملے گا ا و ر  ا ٓت  ا پنی و یب سا 

 

 ر  نیم ی ا س و ر د

 

 ر  نیم ا و ر  ی ا س  میں  چل سکیں گے ۔ ا و ر  ا ٓت  کو یور

 

گ کے لیے ا ٓت  کو یہی یور

 

 ی

 

 ر  د عہ  ا ت  لود
ہ

  چاہیے ہو گا ۔

 

 پیج کے کچھ کمپوو ر د

 

ٹ

 

پ
ر 
ف

ا  ہو گا جو 

 

گ کری

 

 ی

 

 پیج میں جا کر پھر ا ت  لود

 

ٹ

 

پ
ر 
ف
س کے لیے ا ٓت  کو 

 

ی

 

 پ
ی

 

ی

File-Publish on Web کے ٹولز سے ہو کے  گا ۔ 
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Some Product Keys:  
MS Windows Service Pack 2:  
QW4HD-DQCRG-HM64M-6GJRK-8K83T. 
XP Crystal  Service Pack 2:  
RHKG3-8YW4W -4RHJG-83M4Y-7X9GW. 
MS Windows Service Pack 1:  
FCKGW -RHQQ2-YXRKT-8TG6W -2B7Q8. 
Ms Windows 98:  
HQ6K2-QPC42-3HWDM-BF4KJ-W4XWJ 
Windows VISITA CD Version:  
MPH7K-PPYPT-GMG2V-HDJG7-43X2H. 
Ms Office 2003 .  
GWH28-DGCMP-P6RC4-6J4MT-3HFDY.  
Ms office 2007 VISITA Edition .  
HCFPT-K86VV-DCKH3-87CCR-FM6HW. 
FM9FY-TMF7Q-KCKCT-V9T29-TBBBG. 
Ms Office 2006 .  
FM9FY-TMF7Q-KCKCT-V9T29-TBBBG. 
Corel Draw 11.  
DR11CRD-0012082-DGW. 
Corel Draw 12. 
DR12WEF-5646037-WEC 
Photoshop - 9 
1045-1042-1053-5499-5707-8118. 
1045-1209-6738-4668-7696-2783. 
Nero Burning .  
1A23-0009-5030-2275-0470-9781 
Adobe Acrobat Reader5:  
KWW500R7150122-128 
Macro Media Flash8 .  
PFD800-55549-16648-41238 
Recover My File:  
0JV3X5-FEE9XD-6TXZU0-JH7PJM-BB61RQ-4ZVJEK-E4ZW3H 
-KR7N4N 
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IMPORTANT ABBREVIATIONS 

 A  
ALU Arithmetic Logic Unit 

ASCII American Standard Code of information 
ALGOL Alphabetic Language 

ALU Arithmetic Logic Unit 
AGP Accelerated Graphic Port 
ANSI American National Standards Institute 
ASCII American Standard code for information interchange 

B 
BIT Binary digits 

BASIC Beginner’s all purpose symbolic instruction code 
BCD Binary coded decimal 

C 
CAD Computer aided design 
CAM Computer aided Manufacture 
CD Compact Disc/ change directory 

CD ROM Compact disc read only memory 
CMOS Complementary metal oxide semiconductor 
CLS Clear screen 

COBOL Common business oriented language 
CPU Central processing unit 
CRT Cathode ray tube 
CU Control unit 

D 
DBMS Data base management system 

DM Disc Manager 
DDR Double data Ram 
DVD Digital Video Disc 
DDC Date description language 

DRAM Dynamic Random Access Memory 
DEL Delete 

DIMM Dual in line memory module 
E 

EDC Electronic Digital Computer 
EDP Electronic data processing 

EDVAC Electronic discrete variable automatic calculator 
ENIAC Electrical Numerical Integrator and Calculator 
EOF End of file 
EIDE Enhanced Integrated Device Electronic 
EMF Enhanced  Metafile Format 
EOF End of File 
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F 
FAT File allocation table 
FDD Floppy disc drive 
FIFD First in first out 

FORTRAN Formula translation 
G 

GUI Graphical User interface 
GB Gaga byte 
GIF Graphical Interchange Format 

JPEG Joint Photographic Expert Group 
H 

HDD Hard disc 
HZ Hertz (Unit of frequency) 

HTML Hyper text markup language 
HTTP Hyper text transfer Protocol 

HP Hewlett Pickard 
I 

I/O Input/output 
IC Integrated circuit 

IDE Integrated Device Electronic 
IBM International business machine 
ISA Industrial Standard architecture 
ISO International standard org. 
IC Integrated Circuit 

ISP Internet service provider 
IE Internet Explorer 
IT Information technology 

K 
KB Kilo byte 

L 
LAN Local area network 
LED Light Emitted Diode 

 M 
MB Mega Byte 
MS Microsoft Cor. 
MD Make directory 

MHZ Mega Hertz 
 N 

NTFS New technology File system 
O 

OS Operating system 
 P 
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Good Luck for your future  
Do remember me in your prayers. 

 

 

 

 

 

PBM Public data network 
PDA Personal data assistant 
PCI Peripheral component interconnect 

PSTN Public switched telephone network 
R 

RD Remove directory 
RGB Red green blue 

 S 
SIMM Single memory in line single in line Memory Module 

W 
WAN Wide area network 
WWW Wide Area Network 

 U 
USB Universal Serial Bus 
URL Uniform resource locator 

V 
VB Visual Basic 

WWW World wide web 
WAN Wide area network 

Z 
ZD Zone digit 


